IP : Protocolos de roteamento IP

Ajuste a distância administrativa para a seleção de rota no exemplo de configuração do Roteadores do Cisco IOS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como mudar o valor de distância administrativa do protocolo de roteamento a fim influenciar a seleção de rota nos roteadores Cisco.

A distância administrativa é a característica que o Roteadores usa a fim selecionar o melhor caminho quando há rotas dois ou mais diferentes ao mesmo destino de dois protocolos de roteamento diferentes. A distância administrativa define a confiança de um protocolo de roteamento. Menor o valor de distância administrativa, mais seguro o protocolo.

Nota: Quando você muda as distâncias padrão, pode conduzir aos loop de roteamento na rede. Mude a distância administrativa com cuidado e somente depois você tenha o pensamento com o que você quer conseguir.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As configurações neste documento são baseadas no Cisco 3700 Series Router no Cisco IOS Software Release 12.4 (15)T 13.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Aqui o r1 do roteador e o R2 são conectados através das linhas serial paralela. O r1 do Roteadores e o R2 são configurados com BGP e OSPF. A distância administrativa padrão de OSPF é 110 quando aquele do eBGP for 20. Com o comando distance, nós mudamos o valor AD do BGP a 190. Antes deste comando, o roteador R2 preferiu as rotas de BGP sobre o OSPF desde que tiveram os valores do padrão AD configurados. Depois que o valor AD do BGP mudou, as rotas de OSPF tomam a precedência.

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-routed-protocols/113153-adjust-ad-01.gif

Configurações

Este documento usa este a configuração

Configuração do r1
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface Loopback10
 ip address 10.10.10.10 255.255.255.255
 !
!
interface Loopback20
 ip address 20.20.20.20 255.255.255.255
 !
!
interface Loopback30
 ip address 30.30.30.30 255.255.255.255
 !
!
interface Serial1/0
 ip address 100.100.100.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
interface Serial1/1
 ip address 192.168.12.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.10.10 0.0.0.0 area 0
 network 20.20.20.20 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 10.10.10.10 mask 255.255.255.255
 network 20.20.20.20 mask 255.255.255.255
 network 30.30.30.30 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 ebgp-multihop 5
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!

Configuração R2
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
!
interface Serial1/0
 ip address 100.100.100.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
interface Serial1/1
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !

!
router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 100.100.100.2 0.0.0.0 area 0
!
router bgp 100
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 123
 neighbor 1.1.1.1 ebgp-multihop 5
 neighbor 1.1.1.1 update-source Loopback0
 distance 190 1.1.1.1 0.0.0.0 

Changed the AD value of BGP as 190!

 no auto-summary
!

Verificar

Use os comandos descritos nesta seção a fim verificar a configuração.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

No roteador R2

Quando o comando distance não for aplicado no roteador R2

Show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      10.0.0.0/32 is subnetted, 1 subnets
B        10.10.10.10 [20/0] via 1.1.1.1, 00:00:03        

 BGP Router Preffered Over OSPF

      20.0.0.0/32 is subnetted, 1 subnets
B        20.20.20.20 [20/0] via 1.1.1.1, 00:00:03
 
 BGP Router Preffered Over OSPF

      30.0.0.0/32 is subnetted, 1 subnets
B        30.30.30.30 [20/0] via 1.1.1.1, 00:00:03
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.100.100.0/24 is directly connected, Serial1/0
L        100.100.100.2/32 is directly connected, Serial1/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Serial1/1
L        192.168.12.2/32 is directly connected, Serial1/1

Quando o comando distance for aplicado no roteador R2

Show ip route
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      10.0.0.0/32 is subnetted, 1 subnets
O        10.10.10.10 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
           
By increasing the AD of External BGP, OSPF takes precedence

      20.0.0.0/32 is subnetted, 1 subnets
O        20.20.20.20 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
           
By increasing the AD of External BGP, OSPF takes precedence

      30.0.0.0/32 is subnetted, 1 subnets
B        30.30.30.30 [190/0] via 1.1.1.1, 00:00:03
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.100.100.0/24 is directly connected, Serial1/0
L        100.100.100.2/32 is directly connected, Serial1/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Serial1/1
L        192.168.12.2/32 is directly connected, Serial1/1


Informações Relacionadas


Document ID: 113153