IP : Border Gateway Protocol (BGP)

Compreendendo o atributo BGP MED

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A finalidade deste documento é fornecer uma compreensão melhor do atributo do Multi Exit Discriminator do Border Gateway Protocol (BGP) (MED) ao cruzar-se sobre um limite do sistema autônomo executando o em encenações diferentes.

O MED fornece uma maneira dinâmica influenciar outra COMO na maneira de alcançar uma determinada rota quando há uns pontos de entrada múltipla para aquele COMO. O BGP segue um procedimento sistemático para escolher o melhor caminho. Há outros atributos importantes tais como o peso, preferência local, origina a rota, e COMO o trajeto que são recolhidos para explicar antes de considerar o atributo MED. Assim, se qualquens um critérios combinam, o atributo MED não será considerado.

Nota: Quando todos fatores restantes são iguais, o ponto de saída com o mais baixo MED está preferido.

Pré-requisitos

Requisitos

Cisco recomenda que você tem o conhecimento básico do BGP.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas. As encenações discutidas neste documento usam este a versão de hardware e software:

  • Cenário 1: Cisco 2600 Router no Software Release 12.4 ou Mais Recente do ½ do ¿  de Cisco IOSïÂ

  • Cenário 2: Cisco 2600 Router no Cisco IOS Software Release 12.4 ou Mais Recente

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Casos Práticos

Cenário 1

Quando um auto-falante de BGP aprende uma rota de um par, o MED da rota está passado a outros pares interiores BGP (iBGP), mas não a BGP exterior (eBGP) espreita.

Considere esta instalação de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-01.gif

Aqui, o r1 do roteador e o roteador R2 são considerados no mesmos COMO, por exemplo AS#100, e o roteador R3 pertencem a AS#101. Para a convenção fácil, os endereços IP de Um ou Mais Servidores Cisco ICM NT no bloco de /24 são usados.

O r1 do Roteadores e o R2 são configurados como segue:

Roteador 1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 10.10.10.10
(Config-router)#bgp log-neighbor-changes
(Config-router)#network 10.10.10.10 mask 255.255.255.255 route-map ATTACH_MED
(Config-router)#neighbor 192.1.12.2 remote-as 100
(Config-router)#no auto-summary
(Config)#access-list 10 permit 10.10.10.10
(Config)#route-map ATTACH_MED permit 10
(Config)#match ip address 10
(Config)#set metric 100

Roteador 2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.12.1 remote-as 100
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#no auto-summary

A configuração do roteador R3 é dada aqui:

Roteador 3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)#no synchronization
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

Nesta instalação, o r1 e o R2 têm ser executado do iBGP. Consequentemente, quando uma atualização entra no COMO com uma determinada métrica, essa métrica é usada para fazer decisões dentro do COMO. O comando show ip bgp quando verificado da mostra R2 o o valor de métrica para ver se há 10.10.10.10, que é inclinado através do vizinho iBGP 192.1.12.1 e terá um valor med de 100.

A saída do R2 é mostrada aqui:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-02.gif

corridas do eBGP entre o R2 e o R3 porque estes estão em um diferente COMO. Quando a mesma atualização passar a um terço COMO, por exemplo AS#101, retornos dessa métrica a 0. O comando show ip bgp quando verificado do R3 terá sua métrica removida, porque 10.10.10.10 cruza COMO boundary(101).

A saída do R3 é mostrada aqui:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-03.gif

Desta encenação é evidente que o atributo MED pode influenciar o tráfego de entrada dos sistemas autônomo vizinhos. O atributo MED não pode influenciar as decisões de roteamento de sistemas autônomo mais-remotos. Quando um auto-falante de BGP aprende uma rota de um par, pode passar o MED da rota a todos os pares do iBGP, mas não ao eBGP espreita. Em consequência, o MED tem a importância somente entre sistemas autônomo vizinhos.

Cenário 2

Se a rota injetada no BGP (usando a rede ou o comando redistribute) vem de um IGP (RASGO ou EIGRP ou OSPF), o MED está derivado da métrica IGP e a rota é anunciada a um vizinho de ebgp com este MED.

Esta encenação usa esta instalação de rede:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-04.gif

Nesta rede, o r1 é configurado para ser executado em uma rede do RASGO. Corrida R2 e R3 BGP do Roteadores, onde o R2 está configurado com AS100 quando o R3 for com COMO os 101.

O r1 do roteador é configurado como segue:

R1 do roteador
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router rip
(Config-router)#network 10.0.0.0
(Config-router)#network 192.1.12.0
(Config-router)#no auto-summary

O Roteadores R2 e R3 é configurado para o BGP, onde a redistribução é feita no R2 a fim injetar as redes do RASGO a um BGP.

Roteador R2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router rip
(Config-router)# network 192.1.12.0
(Config-router)#no auto-summary
(Config-router)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#redistribute rip metric 1
 Config-router)#no auto-summary

Roteador R3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)# no synchronization
(Config-router)#bgp router-id 33.33.33.33
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

RASGO e BGP executado no R2. Se você verifica usando o comando show ip bgp, você pode ver que a rede de 10.0.0.0 do prefixo está mostrada com uma métrica de 1, que é derivado do RASGO.

A saída do R2 é mostrada aqui:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-05.gif

Contudo, no R3 que é executado no eBGP, a rede é anunciada considerando o valor med derivado do IGP. Neste caso é RASGO. O prefixo 10.0.0.0 é anunciado com o valor med IGP, que é a métrica 1. do RIP.

Isto pode visto nesta saída:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-06.gif

Desta encenação o comportamento do MED, no caso das redes que estão sendo injetadas ao BGP Router através da rede ou do comando redistribute, é considerado claramente onde o valor med real está sendo substituído com o aquele da métrica IGP. Agora, dado que este atributo é uma sugestão aos vizinhos externos sobre a preferência do trajeto no COMO. Como indicado mais cedo, não se considera sempre se há outros mais atributos importantes para determinar a melhor ruta. A fim ter o mesmo efeito com um atributo mais determinística, use o comando set as-path prepend sob o mapa de rota. Se você prepend PORQUE as rotas do trajeto com certeza, ele continuarão a ser vistas por outro COMO. Para obter mais informações sobre do uso do as-path prepend, refira o uso do grupo-aspath prepend o comando.


Informações Relacionadas


Document ID: 112965