Cisco Interfaces and Modules : Cisco Catalyst 6500 Series Multilayer Switch Feature Card

Catalyst 6500 EIGRP sobre o exemplo de configuração de VRF-Lite

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar o EIGRP sobre a transmissão da rota virtual (VRF) - lite em um Cisco Catalyst 6500 Series Switch. A rota estática é configurada no Switches e redistribuída através do EIGRP entre o Switches.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Conhecimento básico do EIGRP

  • Conhecimento básico da configuração do Catalyst 6500

Componentes Utilizados

A informação neste documento é baseada nos Catalyst 6500 Series Switch que executam a versão de software 12.2(33).SXH6.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

VRF-lite permite que um provedor de serviços apoie dois ou mais VPN com um endereço IP de Um ou Mais Servidores Cisco ICM NT de sobreposição usando uma relação. VRF-lite é denominado igualmente dispositivo do edge de cliente CE ou multi-VRF multi-VRF. No passado, VRF-lite foi apoiado somente com RASGO, OSPF, e BGP. Mas nas versões recentes, VRF-lite é apoiado igualmente com EIGRP. Este documento fornece um exemplo de um EIGRP sobre a configuração de CLI de VRF-lite onde as rotas estáticas VRF são redistribuídas através do EIGRP ao outro Switches.

Configurar VRF-Lite sobre o Catalyst 6500

Estas são as diretrizes para configurar VRF-lite sobre o Catalyst 6500:

  • Um interruptor com VRF-lite é compartilhado por clientes múltiplos, e todos os clientes têm suas próprias tabelas de roteamento.

  • Porque os clientes usam tabelas diferentes VRF, os mesmos endereços IP de Um ou Mais Servidores Cisco ICM NT podem ser reutilizados. Os endereços IP de Um ou Mais Servidores Cisco ICM NT sobrepostos são permitidos em VPN diferentes.

  • VRF-lite deixa clientes múltiplos compartilhar do mesmo enlace físico entre o PE e o CE. As portas de tronco com vlan múltiplos separam pacotes entre clientes. Todos os clientes têm seus próprios VLAN.

  • Para o roteador de PE, não há nenhuma diferença entre a utilização de VRF-lite ou a utilização de CE múltiplos.

  • Um cliente pode usar vlan múltiplos enquanto não sobrepõem com os aqueles de outros clientes. Os VLAN de um cliente são traçados a uma tabela de roteamento específica ID que seja usada para identificar as tabelas de roteamento apropriadas armazenadas no interruptor.

  • VRF-lite não afeta a taxa do packet switching.

Configuração de CLI

Esta seção mostra a configuração de CLI:

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

Pesquise defeitos o EIGRP

Um problema comum considerado com EIGRP é o roteador local não estabelece um relacionamento do vizinho EIGRP com roteadores vizinho.

Rota estática não Redistriubted ao EIGRP

  1. Use o valor métrico padrão para as rotas estáticas no comando redistribute static.

  2. Remova e adicionar o comando redistribute static no roteador; as mostras da rota estática 10.0.0.0/8 sob a topologia EIGRP.


Informações Relacionadas


Document ID: 112245