IP : IP Versão 6 (IPv6)

Roteamento baseado em política com o exemplo de configuração do IPv6

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O roteamento baseado em política fornece um mecanismo expressando e executando a transmissão/roteamento dos pacotes de dados baseados nas políticas definidas pelos administradores de rede. O roteamento baseado em política é aplicado aos pacotes recebidos e usa mapas de rota para definir as políticas. Baseado nos critérios definidos nos mapas de rota, os pacotes são enviados/distribuídos ao salto seguinte apropriado. Este documento fornece uma configuração de exemplo para o roteamento baseado em política com o IPv6.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Nota: Refira limitações para o IPv6 PBR para obter mais informações sobre das limitações.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Neste cenário de configuração, o Policy-Based Routing (PBR) é configurado em um WAN Router e o roteamento de política é aplicado na relação fa1/0. Conforme o tráfego da configuração da rede, 6001:66:66:66::6 são reorientados ao roteador intermediário. Isto é conseguido com o roteamento baseado em política. Este exemplo de configuração ajusta o salto seguinte a 2001:10:10:10::2. Se o origem de tráfego é 6001:66:66:66::6, a seguir o tráfego está reorientado ao roteador intermediário onde alcança então o roteador de Internet.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/112218/policy-based-routing-ipv6-configex-1.gif

Configurações

Este documento utiliza as seguintes configurações:

Configuração do WAN Router
WAN_Router#
!
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed 100
 ipv6 address 1001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed 100
 ipv6 address 2001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet1/0
 no ip address
 speed 100
 full-duplex
 ipv6 address 3001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
 ipv6 policy route-map ipv6
!
ipv6 router eigrp 55
 router-id 3.3.3.3
 no shutdown
!
route-map ipv6 permit 10
 match ipv6 address ALLOW_INTERNAL_NETWORK
 set ipv6 next-hop 2001:10:10:10::2
!
ipv6 access-list ALLOW_INTERNAL_NETWORK
 permit ipv6 6001:66:66:66::/64 any

!--- Creates IPv6 access-list ALLOW_INTERNAL_NETWORK 
!--- and permits any ipv6 address in the network 6001:66:66:66::/64

!

Configuração do roteador intermediário
Intermediate_Router#
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed 100
 ipv6 address 2001:10:10:10::2/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed 100
 ipv6 address 4001:10:10:10::2/64
 ipv6 enable
 ipv6 eigrp 55
!
ipv6 router eigrp 55
 router-id 2.2.2.2
 no shutdown
!

Configuração do roteador de Internet
Internet_Router#
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address 5001:55:55:55::5/64
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed 100
 ipv6 address 1001:10:10:10::2/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed 100
 ipv6 address 4001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
!

ipv6 route ::/64 Loopback10
ipv6 router eigrp 55
 router-id 1.1.1.1
 no shutdown
 redistribute connected
!

Configuração de roteador local
Local_Router#
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address 6001:66:66:66::6/64
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
 ipv6 address 3001:10:10:10::2/64
 ipv6 enable
!
!
ipv6 route ::/64 FastEthernet0/0

!--- Static route is configured in the local router.

!

Verificar

Emita o comando ping de Local_Router a fim verificar o roteamento baseado em política:

Local_Router#ping ipv6 5001:55:55:55::5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5001:55:55:55::5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/40/76 ms

Permita este comando debug em WAN_Router a fim ver se o roteamento baseado em política está funcionando corretamente ou não:

Wan_Router#
debug ipv6 policy

IPv6 policy-based routing debugging is on

Wan_Router#
*Mar  1 04:10:43.846: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:43.846: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1
*Mar  1 04:10:46.826: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:46.826: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1
*Mar  1 04:10:49.834: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:49.834: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1
*Mar  1 04:10:52.838: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:52.838: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1

Troubleshooting

Exemplo de uma configuração incorreta

O IPv4 e o IPv6 PBR não podem coexistir em uma relação enquanto estas saídas de exemplo mostram:

route-map BGP-NLGP-MSP-I2RandE-ALLOW permit 10
 description For allowing BGP sessions and setting next hops
 match ipv6 address BGP-NLGP-MSP-I2RandE-IPV6-ALLOW		
!
route-map BGP-NLGP-MSP-I2RandE-ALLOW permit 20
 match ip address BGP-NLGP-MSP-I2RandE-IPV4-ALLOW	
!
route-map BGP-NLGP-MSP-I2RandE-ALLOW permit 30
 set ip next-hop 192.168.48.41
 set ipv6 next-hop 2620:32:0:1000::2
!

Exemplo de uma configuração correta

A fim aplicar o IPv4 e o IPv6, você tem que usar dois mapas de rotas separados para o IPv4 e o IPv6 e então aplicá-los em uma relação. Este exemplo de saída fornece um exemplo:

route-map IPv6 permit 10
 match ipv6 address BGP-NLGP-MSP-I2RandE-IPV6-ALLOW
 set ipv6 next-hop 2620:32:0:1000::2
route-map IPV4 permit 10
 match ip address BGP-NLGP-MSP-I2RandE-IPV4-ALLOW
 set ip next-hop 192.168.48.41
Router#show run interface e0/0
Building configuration...

Current configuration : 163 bytes
!
interface Ethernet0/0
 ip address 10.57.253.109 255.255.255.252
 ip policy route-map IPV4
 ipv6 address 2001:468:1900:70::1/64
 ipv6 policy route-map IPv6
end

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 112218