IP : Protocolos de roteamento IP

Configuração do IPv6 da amostra para o BGP com os dois provedores de serviços diferentes (hospedagem múltipla)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O Border Gateway Protocol (BGP) é um dos protocolos-chave usado para obter a redundância da conexão com a Internet. Quando sua rede é conectada a dois provedores de Internet (ISP) diferentes, isso é chamado de multihoming. O multihoming fornece redundância e otimização de rede. Seleciona o ISP que oferece o melhor caminho para um recurso. Quando você executa o BGP com o mais de um provedor de serviços, você corre o risco que seu sistema autônomo se transformará um trânsito COMO. Isso faz com que o tráfego da Internet passe pelo seu AS e potencialmente consuma toda a largura de banda e os recursos da CPU de seu roteador. Este documento endereça esta edição e fornece exemplos de configuração apropriados.

Pré-requisitos

Requisitos

Refira este documento antes que você continue:

Configuração de exemplo para o BGP com dois provedores de serviço diferentes (multilocal)

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2800 Series Router com Software Release 12.4(13r)T do½ do¿Â do Cisco IOSïÂ

  • Cisco 3800 Series Router com Cisco IOS Software Release 12.4(13r)T

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/112228/bgp2isp-01.gif

Neste roteador de rede A conecta a dois provedores de serviços diferentes SP-Um e SP-B que formam o hospedagem múltipla por onde 1010:1010::/64 e 2020:2020::/64 são anunciados COMO 101 à parte externa e à rede 1212:1212::/64 é recebido de dois diferentes COMO, COMO 202 e COMO 303.

Nota: Aqui está um link a um vídeo (disponível na comunidade do apoio de Ciscoleavingcisco.com ) que fornece a vista geral do hospedagem múltipla BGP e dá o conselho em como pesquisar defeitos problemas comuns BGP como espreitar e alta utilização da CPU.

Multi-direção BGP: Projeto e Troubleshooting - Vídeo de Webcast vivo leavingcisco.com

Configurações

Este documento utiliza as seguintes configurações:

Roteador-A
Router-A#
ipv6 unicast-routing

!---Enables the forwarding of IPv6 packets.

ipv6 cef
interface Serial3/0
 description CONNECTED TO SP-A
 ip address 192.168.10.1 255.255.255.0
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
 clock rate 64000
!
interface Serial3/1
 description CONNECTED TO SP-B
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 clock rate 64000
!
 router bgp 101
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 remote-as 202

!--- Configures SP-A as neighbor.

 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 ebgp-multihop 2
 neighbor 2303:ABCD::21B:54FF:FE54:FB10 remote-as 303

!--- Configures SP-B as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21B:54FF:FEA9:24B0 activate
  neighbor 2303:ABCD::21B:54FF:FE54:FB10 activate
  network 1010:1010::/64
  network 2020:2020::/64
 exit-address-family
!

Preste serviços de manutenção a ProviderA
SP-A#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
!
router bgp 202
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configuers Router A as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

Preste serviços de manutenção a ProviderB
SP-B#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 no fair-queue
!
router bgp 303
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 2303:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configures as Router A as neighbor.

 neighbor 2303:ABCD::21C:58FF:FEED:3E90 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 2303:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • Roteador A que espreita com dois ISP

    Router-A#
    show bgp ipv6 unicast summary
    
    BGP router identifier 1.1.1.1, local AS number 101
    BGP table version is 6, main routing table version 6
    3 network entries using 447 bytes of memory
    4 path entries using 304 bytes of memory
    4/2 BGP path/bestpath attribute entries using 496 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 1295 total bytes of memory
    BGP activity 3/0 prefixes, 14/10 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    1202:ABCD::21B:54FF:FEA9:24B0   4   202   108     119   6    0    0 00:31:41   1
    2303:ABCD::21B:54FF:FE54:FB10   4   303   108     121   6    0    0 00:25:1    1
    
    !--- Indicates that Router A is peering with both the ISP SP-A and SP-B
    
    
  • Rotas aprendidas do Roteador-A do SP-Um e do SP-B

    Router-A#show bgp ipv6 unicast
    BGP table version is 6, local router ID is 1.1.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   ::                       0                          32768 i
    *  1212:1212::/64   2303:ABCD::21B:54FF:FE54:FB10 0  0 303 i
    *>                              1202:ABCD::21B:54FF:FEA9:24B0 0  0 202 i
    *> 2020:2020::/64   ::                       0                         32768 i
  • No SP-Um:

    SP-A#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 2.2.2.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
    *> 1212:1212::/64   ::                       0            32768              i
    *> 2020:2020::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
  • Em SP-B:

    SP-B#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 3.3.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i
    *  1212:1212::/64   2303:ABCD::21C:58FF:FEED:3E90  0                 101 202 i
    *>                  ::                       0         32768 i
    *> 2020:2020::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i

Troubleshooting

Use o comando update do IPv6 BGP debugar a fim indicar a informação sobre debugging nas atualizações para ajudar a determinar o estado de espreitar.


Informações Relacionadas


Document ID: 112228