IP : IP Versão 6 (IPv6)

Multiprotocol BGP para o exemplo de configuração do IPv6

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo de Multiprotocol Border Gateway Protocol (MBGP) para o IPv6. O BGP é um Exterior Gateway Protocol (EGP) usado principalmente para conectar domínios de roteamento com políticas de roteamento independentes (sistemas autônomos). O BGP é de uso geral conectar a um provedor de serviços para o acesso ao Internet. O BGP pode igualmente ser usado dentro de um sistema autônomo, e esta variação é referida como o Internal BGP (iBGP). O Multiprotocol BGP é um BGP aumentado que leve a informação de roteamento para a família do endereço das famílias do endereço do protocolo de camada da rede múltipla, tais como, do IPv6 e para rotas do Protocolo IP multicast. Todos os comandos e recursos da política de roteamento do BGP podem ser usados com o Multiprotocol BGP.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nesta topologia, o R0 do Roteadores e o r1 formam um relacionamento EBGP: O R0 está no número de sistema autônomo 1 (AS1) e o r1 está no AS2. O R0 do roteador está anunciando duas redes do IPv6: 2010:AB8:2::/48 e 2010:AB8:3::/48.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/112135/ipv6-bgp-01.gif

Configurações

Esta é a configuração de exemplo do Multiprotocol BGP do IPv6 para o Roteadores mostrado no diagrama:

R0 do roteador

ipv6 unicast-routing

!--- Enables forwarding of IPv6 packets.

ipv6 cef

interface Loopback10
 no ip address
 ipv6 address 2010:AB8:2::/48
 ipv6 enable
!
interface Loopback20
 no ip address
 ipv6 address 2010:AB8:3::/48
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 1
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring ""no bgp default ipv4-unicast"" only IPv4 will be 

!--- advertised

 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C601:10FF:FE58:0 remote-as 2
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C601:10FF:FE58:0 activate
  network 2010:AB8:2::/48
  network 2010:AB8:3::/48
 exit-address-family
!

R1 do roteador
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 2
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C600:10FF:FE58:0 remote-as 1
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C600:10FF:FE58:0 activate
 exit-address-family
!

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

show ipv6 route

Este comando indica o a tabela de roteamento do IPv6.

R1#
show ipv6 route

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2010:AB8:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   2010:AB8:0:2:C601:10FF:FE58:0/128 [0/0]
     via ::, FastEthernet0/0
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

BGP do show ipv6 route

Quando você especificar um protocolo, simplesmente as rotas para esse protocolo de roteamento particular estão mostradas. Este exemplo de saída é do comando show ipv6 route quando entrado com a palavra-chave BGP:

R1#
show ipv6 route bgp

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0

sumário do unicast do show bgp ipv6

Este comando fornece a saída similar ao comando show ip bgp summary, a não ser que seja IPv6-specific.

R1#
show bgp ipv6 unicast summary

BGP router identifier 2.2.2.2, local AS number 2
BGP table version is 3, main routing table version 3
2 network entries using 304 bytes of memory
2 path entries using 152 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2010:AB8:0:2:C600:10FF:FE58:0
                4     1      15      14        3    0    0 00:11:52        2

Informações Relacionadas


Document ID: 112135