Voz e comunicações unificadas : Cisco Unified Border Element

Elemento unificado da beira (CUBO) com exemplo unificado da configuração de IVR da Videoconferência (CUVC)

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A adoção de comunicações de vídeo com base em IP dentro da empresa é bem corrente. No ambiente, no vídeo econômicos de hoje do uso dos clientes mais frequentemente como uma ferramenta para comunicações intra-empresa com os maiores benefícios desta adoção que é ganhos na produtividade do funcionário e em eficiências operacionais.

A maioria de redes de comunicações de vídeo com base em IP da empresa são hoje como ilhas relativo a outras tais redes de empreendimento interconectadas usando uma tecnologia mais velha do Integrated Services Digital Network (ISDN). O ISDN é muito de uso geral para toda a extra-empresa ou comunicação do extra-terreno com outros setor e, em alguns casos, mesmo com os filiais remotas dentro da empresa próprios. Os benefícios de grande envergadura de comunicações de vídeo com base em IP podem verdadeiramente ser realizados com conectividade IP fim-a-fim dentro ou entre das organizações para facilitar comunicações interempresariais (de B2B). Isto exige uma transição do ISDN às soluções com base em IP que atravessam o Internet em vez do PSTN, permitindo uma opção convirgida menos cara para comunicações intra-empresa e de B2B.

A transição por atacado dos circuitos de ISDN às conexões IP através do Internet não é um empreendimento trivial. Os circuitos de ISDN, e os gateways video que amarram o ISDN no comunicações de vídeo com base em IP mundo, são umas soluções extensamente distribuídas, tempo-provadas e confiadas. Apesar das limitações em serviços de comunicações de vídeo obsequiosos da próxima geração, o ISDN ainda ajusta o padrão contra que as soluções novas são medidas ao tomar na Segurança, na privacidade, no faturamento, e na delimitação da consideração. As soluções novas devem oferecer acreditações similares do serviço-nível para que empresas e os provedores de serviços considerem-nos como uma alternativa viável. As empresas precisam assim uma maneira de manter todos os benefícios associados com o ISDN ao explorar as eficiências de estender comunicações de vídeo com base em IP além da empresa.

Este exemplo de configuração destaca as características do Cisco Unified Border Element (CUBO) e ilustra especificamente como o CUBO apoia a capacidade para um valor-limite que resida em algum lugar no Internet para discar através de um endereço IP de Um ou Mais Servidores Cisco ICM NT a uma unidade de controle multiponto (MCU) ou ao valor-limite que sejam atrás de um firewall corporativa. Esta funcionalidade apresenta a característica da ultrapassagem do nulo-chamar-número disponível na liberação 12.4(22)YB do CUBO 1.3 e a funcionalidade de IVR disponível na liberação 5.6 da Videoconferência unificada Cisco (CUVC) MCU. Este documento contém recomendações de configuração e pontos de início possíveis para as empresas que embarcam nesta evolução.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento básico de como configurar e usar a Voz do Cisco IOS (tal como dial peer)

  • Conhecimento básico de como configurar e usar o CUBO

  • Compreensão básica de como os Firewall trabalham

Componentes Utilizados

A informação neste documento é baseada sobre:

  • Cisco Unified Border Element e Gatekeeper que é executado em um Cisco 2800 Router e usa o Cisco IOS Release 12.4.22(YB) ou o Cisco IOS Release 15.0.1M

  • Solução da vídeo conferência 3545 IP de Cisco que executa a versão de software 5.6 ou mais atrasado

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este diagrama mostra a CUBO os valores-limite externos que discam firmemente na rede cliente através de um endereço IP de Um ou Mais Servidores Cisco ICM NT interno do valor-limite.

/image/gif/paws/111313/cube-cuvc-01.gif

Fluxo de chamadas do diagrama

  1. Um valor-limite externo no Internet disca um endereço IP público do CUBO (192.168.1.2) para juntar-se a uma videoconferência que resida em uma unidade de controle multiponto interna de Cisco (MCU). Os mensagens de configuração de chamada de H.323 chegam no CUBO em virtude de um furo de pino inicial para a porta TCP 1720 configurada na ferramenta de segurança adaptável de Cisco (ASA) que é o Firewall que fornece o limite da Segurança para a rede. Neste exemplo, o CUBO tem um endereço IP privado assim que publicamente o endereço roteável visado pelo valor-limite exterior é o resultado de um NAT estático (tradução de endereço de rede) executado pelo ASA.

    Nota: Para fins ilustrativos, Cisco usa somente espaços de endereço IP privado na documentação.

  2. Desde que o mensagem de configuração recebida não inclui os dígitos discados usuais por que o CUBO visaria normalmente o pé seguinte do atendimento, o CUBO usa os dígitos (1234567890) configurados pelo comando configuration da ultrapassagem do nulo-chamar-número. Usando este endereço, os mensagens de configuração de chamada continuam para a rede do cliente interno.

  3. O ASA tem dois furo de pino para apoiar esta fase do atendimento: um para permitir o CUBO olhe acima o endereço desejado através da característica interna do porteiro CUVC-M e um para permitir que o mensagem setup resultante do CUBO consiga a CUVC-M estabelecer o atendimento ao MCU baseado no endereço E.164 configurado no dial peer no CUBO. Usando a característica da inspeção de H.323 no ASA, a sinalização e os media restantes fluem TCP e conexões de UDP são abertos dinamicamente de acordo com a informação inferida da sinalização da configuração de chamada.

  4. O porteiro interno CUVC-M distribui o atendimento ao IPVC-MCU que inclui uma característica nova do vídeo IVR que apresente um menu de opções gráfico ao usuário externo. Este menu é navegado incorporando toms DMTF através da almofada do seletor ou do controle remoto do valor-limite de chamada. O utilizador final seleciona simplesmente o ID de conferência da opção de menu da conferência da junta e incorpora então a senha necessária se configurado.

  5. O ponto final de vídeo interno junta-se à conferência discando o mesmo ID de conferência que o valor-limite externo.

Configurações

Este documento utiliza as seguintes configurações:

Configuração do CUBO
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname cube1
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9_ivs-mz.124-22.YB.bin
boot-end-marker
!
ip source-route
!
!
multilink bundle-name authenticated
!
!
!
voice service voip
  allow-connections h323 to h323
  h323
  emptycapability
  null-called-number override 1234567890
  h225 start-h245 on-connect
  call start slow 
  h245 passthru all
!
!
!
voice class h323 10
!
!
voice-card 0
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.1.100 255.255.255.0
 ip route-cache same-interface
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip id vgk1 ipaddr 172.16.1.100 1719 priority 1 

!--- vgk1 defines zone the cube to register with the local Gatekeeper service
 
 h323-gateway voip h323-id cube1

!--- Defines the ID of CUBE
 
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 172.16.1.100
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip http server
no ip http secure-server
!
!
!
!
dial-peer voice 1 voip
destination-pattern .T

!--- To match outbound call leg to send to GK process

session target ras
incoming called-number .

!--- For inbound call leg

codec transparent



!
!
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
zone local vgk1 cisco.com 
zone remote CUVCM cisco.com 10.1.1.26 invia vgk1 outvia vgk1
enable-intrazone
zone prefix CUVCM 1234567890
gw-type-prefix 1#* default-technology
no use-proxy GK1 default inbound-to terminal
no use-proxy GK1 default outbound-from terminal
bandwidth interzone default 1000000
no shutdown
!

end

Configuração ASA
ASA Version 8.2(1)
! 

!--- This is only a portion of the ASA config.
!--- In a typical production scenario, these commands would
!--- be in addition to the current security policies configured.

!
interface Ethernet0/0
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/0.2
 vlan 2
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.255.255.0 
!
interface Ethernet0/0.12
 vlan 12
 nameif dmz
 security-level 50
 ip address 172.16.1.1 255.255.255.0 
!
interface Ethernet0/0.500
 vlan 500
 nameif outside
 security-level 0
 ip address 192.168.1.2 255.255.255.0 
!
boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone CDT -6
access-list dmz-in extended permit icmp any any 
access-list dmz-in extended permit udp host 172.16.1.100any eq 1719 
access-list dmz-in extended permit tcp host 172.16.1.100any eq h323

!--- The access list allows CUBE address lookups and call
!--- signaling respectively to get to the interior of the network.

!
access-list outside_access_in extended permit icmp any any 
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq h323 
access-list outside_access_in extended permit udp any host 192.168.1.2 eq 1719

!--- The access list allows exterior call setups and address
!--- look ups respectively to get to the CUBE.

!  
! 
access-list inside-to-DMZ-exemption extended permit ip 10.0.0.0 255.0.0.0 10.150
.150.0 255.255.255.0

!--- This access list prevents the global NAT translation intended
!--- for the outside interface from being used on the conversations
!--- between internal endpoints and CUBE.

!
mtu inside 1500
mtu dmz 1500
mtu outside 1500
nat-control
global (outside) 1 192.168.1.5-192.168.1.100 netmask 255.255.255.0

!--- Note that the general NAT pool should not overlap the
!--- ASA interface nor the static NAT used for CUBE.

!
nat (inside) 0 access-list inside-to-DMZ-exemption
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 1 172.168.1.0 255.255.255.0
static (dmz,outside) 192.168.1.2 172.16.1.100 netmask 255.255.255.255

!--- The previous statement is what establishes the publicly
!--- routed address for CUBE on the outside interface.

! 
access-group dmz-in in interface dmz
access-group outside_access_in in interface outside
route inside 10.0.0.0 255.255.255.0 10.1.1.2 1
route outside 0.0.0.0 0.0.0.0 192.168.1.254 1

!--- These two static route statements assume the existence of
!--- a next hop router on both inside and outside interfaces.

!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:10:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:10:00 h225 1:00:00 mgcp 0:10:00 mgcp-pat 0:10:00

!--- Note: It is a good idea to increase the H.225 timeout. Not all endpoints
!--- send enough traffic on this connection to keep it alive. The H.225 command
!--- includes the H.245 attributes.

!
policy-map global_policy
 class inspection_default
  inspect h323 h225 
  inspect h323 ras

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

Esta imagem mostra o Gatekeeper que está sendo adicionado ao Cisco Unified Videoconferencing Manager. O modelo do Gatekeeper é selecionado na lista de drop-down.

cube-cuvc-02.gif

Esta imagem mostra que a verificação dentro da seção de gerência de recursos de Cisco unificou o gerente da vídeo conferência que o Gatekeeper esteve adicionado com sucesso. Aqui você pode ver o porteiro de H.323 do Cisco IOS alistado com o endereço IP de Um ou Mais Servidores Cisco ICM NT de 172.16.1.100.

cube-cuvc-03.gif

Esta imagem mostra a configuração do atendimento automático na vídeo conferência unificada Cisco que indica o endereço e.164 (1234567890) que correspondem ao número chamado nulo configurado no CUBO.

cube-cuvc-04.gif

Este as imagens mostram o que o vídeo IVR de Cisco IPVC enviará para trás ao ponto final de vídeo de chamada. Usando o controle do controle remoto ou do teclado numérico do ponto final de vídeo, o usuário escolhe uma reunião video através do DTMF (em-faixa) que é hospedado no CUVC MCU e junta-se à reunião video apropriada.

/image/gif/paws/111313/cube-cuvc-05.gif

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 111313