Switches : Switches Cisco Catalyst 3750 Series

Exemplo de Configuração de Catalyst Switches da Camada 3 para Oferecer Suporte ao Wake-On-LAN Através de VLANs

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (20 Setembro 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Informações de Apoio
      Wake-On-LAN
      Advertência - Broadcasts Direcionados
Configuração
      Diagrama de Rede
      Configurações do Switch
      Configuração do PC Cliente
      Configuração do PC Servidor
Verificação
Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento fornece um exemplo de configuração para oferecer suporte ao Wake-On-LAN (WOL) através de VLANs com um Catalyst Switch da Camada 3.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento básico destes tópicos antes de tentar esta configuração:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Catalyst 3750 Series Switch com Cisco IOS® System Software Release 12.2(25r)SEC

  • Catalyst 2950 Series Switches com Cisco IOS System Software Release 12.1(19)EA1a

  • PCs com o sistema operacional Microsoft Windows 2000

  • Utilitário Wake-On-LAN freeware da SolarWinds leavingcisco.com

    Nota: A Cisco não recomenda nenhum utilitário Wake-On-LAN.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Wake-On-LAN

O Wake-On-LAN (WOL) é uma combinação de tecnologias de hardware e de software que é usada para despertar sistemas adormecidos. O WOL envia pacotes de rede especialmente codificados, chamados de pacotes mágicos, para sistemas equipados e habilitados para responder a esses pacotes. Essa funcionalidade adicional permite que os administradores façam a manutenção nos sistemas mesmo que os usuários os tenham desligado. O recurso WOL permite que um administrador ligue remotamente todos os computadores adormecidos de forma que eles possam receber atualizações. O WOL se baseia no princípio que, quando o PC é desligado, a NIC ainda se mantém energizada e continua a escutar a rede para aguardar a chegada de um pacote mágico. Esse pacote mágico pode ser enviado por uma variedade de protocolos sem conexão (UDP, IPX), mas o UDP é o mais usado.

Se você enviar pacotes WOL a partir de redes remotas, os roteadores deverão estar configurados para permitir broadcasts direcionados. Isso deve ser feito por duas razões:

  • Como o PC está adormecido, ele não terá um endereço IP e não responderá a solicitações de Address Resolution Protocols (ARP) do roteador. Assim, somente um pacote de broadcast de uma sub-rede IP local pode ser transmitido no segmento sem o ARP.

  • Se houver um switch da Camada 2 entre o roteador e o PC, o que é comum em muitas redes hoje em dia, o switch não saberá em que porta o PC está fisicamente conectado. Somente um broadcast da Camada 2 ou um frame unicast desconhecido é enviado a todas as portas do switch. Todos os pacotes de broadcast de IP são endereçados ao endereço MAC de broadcast.

Advertência - Broadcasts Direcionados

Os broadcasts direcionados de IP são utilizados nos comuns e populares ataques smurf de negação de serviços, podendo também ser usados em ataques relacionados.

Um broadcast direcionado de IP é um datagrama enviado para o endereço de broadcast de uma sub-rede à qual o computador que o enviou não está diretamente conectado. O broadcast direcionado é roteado através da rede como um pacote unicast até chegar na sub-rede de destino, onde é convertido em um broadcast da camada de enlace. Devido à natureza da arquitetura do endereçamento IP, apenas o último roteador da cadeia, aquele que está diretamente conectado à sub-rede de destino, pode identificar conclusivamente um broadcast direcionado. Às vezes, os broadcasts direcionados são usados para fins legítimos, mas tal utilização não é comum fora do mercado financeiro.

Em um ataque de smurf, o invasor envia solicitações de eco de ICMP a partir de um endereço de origem falsificado para um endereço de broadcast direcionado. Isso faz com que todos os hosts na sub-rede de destino enviem respostas para a origem falsificada. Ao enviar um fluxo contínuo dessas solicitações, o invasor consegue criar um fluxo muito maior de respostas. Isso pode inundar completamente o host cujo endereço é falsificado.

Se uma interface Cisco for configurada com o comando no ip directed-broadcast, os broadcasts direcionados que seriam transformados em broadcasts da camada de enlace na interface serão descartados. Isso significa que o comando no ip directed-broadcast deve ser configurado em todas as interfaces de todos os roteadores conectados à sub-rede de destino. Não é suficiente configurá-lo apenas nos roteadores de firewall. O comando no ip directed-broadcast é o padrão no Cisco IOS Software Release 12.0 ou posterior. Nas versões anteriores, o comando devia ser aplicado a todas as interfaces de LAN que não eram conhecidas por encaminhar broadcasts direcionados legítimos.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento usa esta configuração de rede:

catl3-wol-vlans1.gif

Estes são os detalhes dessa configuração de rede:

  • Os PCs 1, 2 e 3 são os PCs clientes que precisam ser acordados.

  • PC 4 é o servidor de WOL, bem como o servidor DHCP.

  • PC 4 está configurado com um endereço IP estático 172.16.3.2/24.

  • Os PCs clientes estão configurados para obter o endereço IP de um servidor DHCP.

  • O servidor DHCP (PC 4) está configurado com três escopos de IP para clientes que se conectem às VLANs 2, 3 e 4.

  • SW-1 e SW-2 (Catalyst 2950) são utilizados como switches da Camada 2 e L3 (Catalyst 3750) é utilizado como switch da Camada 3.

  • Os PCs 1 e 4 estão conectados na mesma VLAN (VLAN 3).

  • Os PCs 2 e 3 estão conectados nas VLANs 2 e 4, respectivamente.

Configurações do Switch

Este documento utiliza as seguintes configurações de switch:

  • Switch da Camada 3 - L3

  • Switches da Camada 2 - SW-1 e SW-2

L3

Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname L3
L3(config)#ip routing
L3(config)#vtp mode server
Device mode already VTP SERVER.
L3(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
L3(config)#vlan 2
L3(config-vlan)#vlan 3
L3(config-vlan)#vlan 4
L3(config)#interface gigabitEthernet 2/0/1
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#interface gigabitEthernet 2/0/2
L3(config-if)#switchport trunk encapsulation dot1q
L3(config-if)#switchport mode trunk
L3(config-if)#exit
L3(config)#access-list 101 permit udp host 172.16.3.2 any eq 7

!--- Aceita broadcasts direcionados somente de PC 4.

L3(config)#ip forward-protocol udp 7

!--- Especifica o protocolo e a porta que será encaminhada.
!--- Capture o pacote de WOL com qualquer sniffer de rede para determinar a porta de UDP
!--- que deverá ser usada neste comando. O número da porta varia em função do utilitário de WOL usado.

L3(config-if)#interface vlan 2
L3(config-if)#ip address 172.16.2.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Habilita o encaminhamento do broadcast de BOOTP para o servidor DHCP.

L3(config-if)#ip directed-broadcast 101

!--- Habilita a tradução de um broadcast direcionado para broadcasts físicos.

L3(config-if)#interface vlan 3
L3(config-if)#ip address 172.16.3.1 255.255.255.0
L3(config-if)#interface vlan 4
L3(config-if)#ip address 172.16.4.1 255.255.255.0
L3(config-if)#ip helper-address 172.16.3.2

!--- Habilita o encaminhamento do broadcast de BOOTP para o servidor DHCP.

L3(config-if)#ip directed-broadcast 101

!--- Habilita a tradução de um broadcast direcionado para broadcasts físicos.

L3(config)#^Z
L3#wr
Building configuration...
[OK]
L3#

SW-1

Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-1
SW-1(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-1(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-1(config)#interface fastEthernet 0/1
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 4
SW-1(config-if)#interface fastEthernet 0/2
SW-1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 3
SW-1(config-if)#interface gigabitethernet 0/1
SW-1(config-if)#switchport mode trunk
SW-1(config-if)#^Z
SW-1#wr
Building configuration...
[OK]
SW-1#

SW-2

Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SW-2
SW-2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW-2(config)#vtp domain cisco
Changing VTP domain name from NULL to cisco
SW-2(config)#interface fastEthernet 0/1
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/1 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 3
SW-2(config-if)#interface fastEthernet 0/2
SW-2(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast has been configured on FastEthernet0/2 but will only
 have effect when the interface is in a non-trunking mode.
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 2
SW-2(config)#interface gigabitethernet 0/1
SW-2(config-if)#switchport mode trunk
SW-2(config-if)#^Z
SW-2#wr
Building configuration...
[OK]
SW-2#

Configuração do PC Cliente

A maioria das placas-mãe hoje em dia possuem uma NIC incorporada e são compatíveis com a funcionalidade WOL. Alguns computadores possuem o WOL desabilitado por padrão. Para habilitá-lo, é necessário acessar as opções de configuração do Basic Input Output System (BIOS). Este é o procedimento para habilitar o WOL em um PC cliente:

  1. Entre na tela de configuração do BIOS durante o Power On Self Test (POST) do computador.

    Nota: Geralmente a tecla F10 ou Delete deve ser pressionada para acessar as configurações do BIOS.

  2. Na tela do BIOS, navegue para as configurações Advanced e, em seguida, Device Options.

  3. Nessa tela, procure as configurações relacionadas ao Wake-On-LAN e habilite-as.

  4. Salve e saia das configurações do BIOS.

    Nota: O procedimento exato e as opções disponíveis no BIOS para a habilitação do WOL são diferentes para cada fabricante de computadores. Consulte o manual da placa-mãe fornecido com cada computador para obter mais informações sobre as configurações do BIOS.

  5. Verifique as propriedades avançadas da sua placa de rede para garantir que a funcionalidade de WOL esteja habilitada.

    1. Selecione Start > Settings > Network and Dial-up Connections e clique com o botão direito do mouse em Local Area Connection.

    2. Clique em Properties e selecione Configure.

    3. Vá para a guia Advanced. Defina a propriedade Wake Up Capabilities como Both e WOL Speed como Auto.

      catl3-wol-vlans2.gif

    4. Clique na guia Power Management e marque a caixa que indica Allow this device to bring the computer out of standby.

      catl3-wol-vlans3.gif

      Nota: Em computadores com o Microsoft Windows XP, há mais uma opção: Only allow management stations to bring the computer out of standby. Essa última opção liga o computador somente se um pacote mágico de WOL for recebido. Sem essa opção marcada, qualquer tráfego enviado à placa de rede ligará o PC.

Execute estes passos para que o cliente obtenha um endereço IP a partir do servidor DHCP:

  1. Selecione Start > Settings > Network and Dial-up Connections, clique com o botão direito do mouse em Local Area Connection e selecione Properties.

  2. Na guia General, clique em Internet Protocol (TCP/IP) e, em seguida, em Properties.

  3. Selecione Obtain an IP address automatically.

    catl3-wol-vlans4.gif

Configuração do PC Servidor

Execute estes passos para configurar o servidor de WOL:

  1. Baixe e instale o utilitário de Wake-On-LAN.

  2. Configure o PC com um endereço IP estático 172.16.3.2/24.

  3. Configure o PC como um servidor DHCP.

  4. Crie três escopos com estes detalhes:

    Escopo

    Intervalo de IPs

    Intervalo de IPs excluídos

    VLAN 2

    172.16.2.1 - 172.16.2.254

    Máscara - 255.255.255.0

    172.16.2.1

    VLAN 3

    172.16.3.1 - 172.16.3.254

    Máscara - 255.255.255.0

    172.16.3.1 e 172.16.3.2

    VLAN 4

    172.16.4.1 - 172.16.4.254

    Máscara - 255.255.255.0

    172.16.4.1

    Consulte Como Instalar e Configurar um Servidor DHCP em um Grupo de Trabalho no Windows Server 2003 leavingcisco.com para obter mais informações sobre a configuração do servidor DHCP.

Verificação

Utilize esta seção para confirmar se a sua configuração está funcionando corretamente.

Execute estes passos:

  1. Ligue os PCs e conecte-os aos respectivos switches conforme mostrado no Diagrama de Rede.

  2. Faça login em cada PC e tome nota dos endereços MAC e IP.

    Nota: Abra o prompt de comandos e digite o comando ipconfig /all para descobrir os endereços MAC e IP.

  3. Use o comando ping para verificar a conectividade entre os PCs.

  4. Desligue todos os PCs clientes (PC 1, PC 2 e PC 3) após verificar suas conectividades.

  5. Inicie o utilitário de WOL no PC servidor (PC 4).

  6. Insira os endereços MAC e IP do PC que você deseja "despertar" conforme mostrado aqui:

    catl3-wol-vlans5.gif

    Nota: O endereço IP pode ser qualquer um (até mesmo um broadcast de sub-rede) no intervalo da sub-rede da VLAN onde o PC cliente está conectado. Apenas o endereço MAC do PC cliente precisa corresponder.

  7. Clique no ícone Wake UP PC para enviar uma série de pacotes mágicos para o PC de destino em uma tentativa de ligar o dispositivo.

    catl3-wol-vlans6.gif

  8. Quando o dispositivo remoto receber a mensagem de despertar e se ligar, esta mensagem será exibida:

    catl3-wol-vlans7.gif

    O PC cliente está agora ligado.

Troubleshooting

No momento, não existem informações específicas disponíveis sobre troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 91672