Cisco Interfaces and Modules : Módulos da Cisco Services

Troubleshooting e Configuração Inicial do Wireless Services Module (WiSM)

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (1 Agosto 2013) | Inglês (4 Agosto 2008) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Informações de Apoio
Configuração da Comunicação entre o Supervisor 720 e o Cisco WiSM
Passos de Verificação
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento discute os comandos utilizados na verificação e no troubleshooting da configuração inicial do WiSM. Este documento também cobre os passos básicos necessários para configurar o Catalyst 6500 Supervisor Engine 720 (Sup720) para se comunicar com o módulo WiSM que é instalado nele.

Pré-requisitos

Requisitos

Certifique-se de ter algum conhecimento básico sobre as controladoras de LAN sem fio e suas configurações, bem como conhecimento básico sobre os Cisco Catalyst 6500 Switches que executam o Supervisor 720 e sobre recursos como o EtherChannel Link Aggregation (LAG). Além desses, não existem requisitos específicos para este documento.

Componentes Utilizados

As informações deste documento são baseadas no módulo Cisco WiSM instalado em um Catalyst 6500 Supervisor Engine 720 com Cisco IOS® Software Release 12.2(18)SXF2 nativo. No entanto, os comandos se aplicam a todas as versões do IOS compatíveis com o Supervisor 720 e a placa WiSM.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

O Cisco WiSM é um membro da família Cisco Wireless LAN Controller. Ele trabalha em conjunto com os pontos de acesso Cisco Aironet Lightweight, o Cisco WCS e o Cisco Wireless Location Appliance para fornecer uma solução de rede sem fio segura e unificada compatível com aplicativos de dados, voz e vídeo.

O Cisco WiSM se integra totalmente ao Cisco Catalyst 6500 Series Switch e a um Cisco Catalyst 6500 Supervisor Engine 720. Há suporte a todas as versões do Supervisor Engine 720. O WiSM também é compatível com os Cisco 7600 Routers que executam somente o Cisco IOS® Software Release 12.2(18)SXF5.

Esta tabela lista os slots compatíveis no Cisco Catalyst 6500 para o Cisco WiSM:

Slot

6503-E

6504-E

6506

6509

6513

1-3

X

X

X

X

 

4

 

X

X

X

 

5-6

   

X

X

 

7-8

     

X

 

9

     

X

X

10-13

       

X

Nota: O chassi do Catalyst 6500 Series Switch pode comportar até cinco Cisco WiSMs sem qualquer outro módulo de serviço instalado. Caso um ou mais módulos de serviço estejam instalados, o chassi poderá comportar até um máximo de quatro módulos de serviço, incluindo o WiSMs.

O Cisco WiSM consiste em duas Cisco 4404 Controllers. Assim, a equipe de TI deve estar ciente de que existem duas controladoras separadas em um único módulo. A primeira controladora é considerada como a placa WiSM-A, enquanto a segunda é considerada como a placa WiSM-B. As interfaces e o endereçamento IP devem ser considerados independentemente em cada placa. WiSM-A gerencia 150 pontos de acesso, enquanto WiSM-B gerencia um lote em separado de mais 150 pontos de acesso. Essas controladoras podem ser agrupadas em um grupo de mobilidade que forma um cluster.

Há diversos tipos de interfaces em cada controladora do Cisco WiSM; três delas são de tipos predefinidos que devem estar presentes e ajustadas no momento da configuração:

  • Interface de gerenciamento (predefinida e obrigatória)

  • Interface do gerenciador do AP (predefinida e obrigatória)

  • Interface virtual (predefinida e obrigatória)

  • Interface definida pelo operador (definida pelo usuário)

  • Interface de porta de serviço (predefinida e obrigatória)

Consulte Configurando um Cisco Wireless Services Module e um Sistema de Controle sem Fio para obter mais detalhes sobre cada tipo de interface.

No WiSM, a porta de serviço é utilizada para sincronizar o Supervisor Engine e o WiSM.

Configuração da Comunicação entre o Supervisor 720 e o Cisco WiSM

Após a controladora Cisco WiSM ser instalada em um slot e detectada pelo Supervisor, estas configurações são feitas no Supervisor Engine para que ele se comunique com o WiSM.

  1. Crie um escopo de DHCP para a porta de serviço do WiSM do Catalyst.

    ip dhcp excluded-address 192.168.10.1 192.168.10.2
    
    !
    ip dhcp pool wism-service-port
    
    network 192.168.10.0 255.255.255.0
    
    default-router 192.168.10.1
    
    

    De forma alternativa, você também pode abrir uma sessão (session slot X proc 1 ou 2) ou conectar diretamente o console do WiSM e definir endereços IP estáticos (config Interface Address Service-Port).

    Certifique-se de que o endereço IP da porta de serviço não seja um endereço IP roteável dentro da sua rede, pois ele só é utilizado para a comunicação entre o Sup 720 e o WiSM.

    Nota: O VLSM é aceito em todas as portas, inclusive a porta de serviço.

  2. Crie o gateway de porta de serviço do WiSM e atribua o endereço IP.

    Crie uma VLAN no Supervisor 720. Essa VLAN é local ao chassi e é utilizada para a comunicação entre o Cisco WiSM e o Catalyst Supervisor 720 sobre uma interface Gigabit do Supervisor e uma porta de serviço do Cisco WiSM.

    interface Vlan192
    
    Description WiSM Service Port Gateway or Management Interface on CAT6K
    ip address 192.168.10.1 255.255.255.0
    
    

    Nota: Já deve haver uma interface de VLAN de gerenciamento de rede para acessar o Cat6k.

  3. Atribua as portas de serviço do WiSM à VLAN.

    Configure este comando para utilizar a VLAN 192 para se comunicar com a porta de serviço.

    wism service-vlan 192
    
    
  4. Crie a interface do gateway gerenciamento do WiSM/gerente de AP no Cat6k.

    Esta é uma configuração de exemplo:

    interface vlan40
    
    Description WiSM Management/AP-Manager Interface Gateway
    ip address 40.1.1.1
    
    

    Nota: O software release 12.2(18)SXF5 introduz novos comandos do WiSM para utilização com as portas auto-LAG (no intervalo acima de 200). Esses comandos podem ser utilizados ao invés dos passos 5 e 6. Repita os dois comandos para a controladora 1 e para a controladora 2 no módulo WiSM.

    wism module <module/slot no>controller 1 native-vlan 40

    wism module <module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc...

  5. Crie duas interfaces porta-canal no Cat6k com sinalização de tronco dot1q, trust dscp e VLAN nativa, o que permite pacotes sem marcação na porta de gerenciamento.

    Crie duas interfaces porta-canal para as duas controladoras independentes no Cisco WiSM e atribua a VLAN 40 como interface nativa.

    interface Port-channel X
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
    
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    

    De forma similar, crie outra interface porta-canal para a outra controladora no WiSM.

  6. Configure as interfaces 1 e 2 da controladora do WiSM.

    Assim que a controladora do Cisco WiSM for detectada pelo Supervisor no início, oito interfaces Gigabit serão criadas no intervalo de Gig<número do slot onde o módulo está instalado>/1 a Gig<número do slot>/8.

    Configure essas interfaces Gigabit como portas de tronco com a VLAN 40 como VLAN nativa. Certifique-se de que a VLAN nativa não esteja marcada enquanto faz a configuração do Cisco WiSM. Este é um exemplo de configuração:

    router(config)# interface range gigabitEthernet
    <slot>/1 – 4 
    or
    router(config)# interface range gigabitEthernet
    <slot>/5 – 8
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
    
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    channel-group <port-channel no> mode on
    

Passos de Verificação

Esta seção descreve os comandos utilizados na verificação da configuração do WiSM.

  1. Para verificar a versão do CAT IOS em execução, execute o comando

    show version.

    Router#show version
    Cisco Internetwork Operating System Software
    IOS (tm) s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Sat 08-Jul-06 02:54 by kellythw
    Image text-base: 0x40101040, data-base: 0x42D88000
    
    ROM: System Bootstrap, Version 12.2(14r)S1, RELEASE SOFTWARE (fc1)
    BOOTLDR: s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    
    ... skip ...
    
    cisco WS-C6503-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.
    Processor board ID FOX0920047A
    SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
    Last reset from power-on
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    X.25 software, Version 3.0.0.
    Bridging software.
    TN3270 Emulation software.
    3 Virtual Ethernet/IEEE 802.3 interfaces
    20 Gigabit Ethernet/IEEE 802.3 interfaces
    1917K bytes of non-volatile configuration memory.
    8192K bytes of packet buffer memory.
    
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102

    Nota: O WiSM necessita de um Supervisor 720 que execute IOS nativo versão 12.2(18)SXF2 ou posterior.

  2. Para verificar se o Cat6k possui um Supervisor 720 e uma placa WiSM, use o comando show module

    Router#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      1    2  Supervisor Engine 720 (Active)         WS-SUP720-BASE     SAD0717003H
      3   10  WiSM WLAN Service Module               WS-SVC-WISM-1-K9   SAD09280AZU
    
    
    Mod MAC addresses                       Hw    Fw           Sw           Status
    --- ---------------------------------- ------ ------------ ------------ -------
      1  000c.ce63.eb0c to 000c.ce63.eb0f   2.1   7.7(1)       12.2(18)SXF5 Ok
      3  0030.f274.ae36 to 0030.f274.ae45   0.3   12.2(14r)S5  12.2(18)SXF5 Ok
    
    
    Mod  Sub-Module                  Model              Serial       Hw     Status
    ---- --------------------------- ------------------ ----------- ------- -------
      1  Policy Feature Card 3       WS-F6K-PFC3A       SAD071902DP  1.1    Ok
      1  MSFC3 Daughterboard         WS-SUP720          SAD071700L3  1.2    Ok
      3  Centralized Forwarding Card FARFEL             SAD0929038U  0.3    Ok
    
    Mod  Online Diag Status
    ---- -------------------
      1  Pass
      3  Pass

    Nota: A saída do comando show module no switch mostra o WiSM com 10 portas. Entretanto, somente 8 portas são utilizadas para a configuração porta-canal, port-channel1 e port-channel2. As outras duas portas são utilizadas como portas de serviço.

  3. Para verificar o slot no qual o WiSM está instalado, execute o comando

    show wism status.

    Este é um exemplo de saída do comando:

    Router#sh wism status
    Service Vlan : 158, Service IP Subnet : 172.16.158.131/255.255.255.128
    WLAN
    Slot Controller Service IP Management IP SW Version Status
    ----+-----------+----------------+----------------+-----------+---------
    3 1 172.16.158.142 140.1.3.10 3.2.116.21 Oper-Up
    3 2 172.16.158.143 140.1.3.11 3.2.116.21 Oper-Up
    

    No 6503-E, somente os slots de 1 a 3 funcionam. Do 6504 ao 6506, somente os slots de 1 a 4 funcionam. No 6509, somente os slots de 1 a 9 funcionam. No 6913 é exatamente o contrário; somente os slots de 9 a 13 funcionam. Para obter informações detalhadas, consulte o Perguntas mais Frequentes de Troubleshooting do WiSM

  4. Para verificar o status do WiSM no lado do Cat6k, execute o comando

    show wism module X controller Y status

    e procure Oper-Up and the LAG port in use (Verify LAG port).

    Para verificar se não há um endereço IP de serviço, verifique a configuração do DHCP na VLAN de serviço. Alternativamente, abra uma sessão (session slot x proc 1 ou 2) no módulo ou conecte diretamente via console ao WiSM para verificar os endereços IP estáticos.

    Router#show wism module 3 controller 1 status
    
    WiSM Controller 1 in Slot 3
    Operational Status of the Controller : Oper-Up
    Service VLAN                         : 250
    Service Port                         : 9
    Service Port Mac Address             : 0014.a9bd.d9a2
    Service IP Address                   : 172.16.158.142
    Management IP Address                : 140.1.3.10
    Software Version                     : 3.2.116.21
    Port Channel Number                  : 285
    Allowed vlan list                    : 5,10,15,25,35,45,55
    Native VLAN ID                       : 5
    WCP Keep Alive Missed                : 0
    
  5. Para verificar se o tronco até o WiSM e as VLANs está definido, execute o comando

    show interface trunk.

    Este é um exemplo de saída do comando:

    Router#show interface trunk
             Port  Mode   Encapsulation Status Native vlan
             Po1   on     802.1q trunking 140
             Po2   on     802.1q trunking 140
  6. Para verificar o algoritmo de balanceamento de carga correto (config #port-channel load-balance src-dst-ip), execute o comando

    show etherchannel load-balance.

    Este é um exemplo de saída do comando:

    Router#show etherchannel load balance
    EtherChannel Load-Balancing Configuration:
                       src-dst-ip
    

    Para verificar as portas corretas no EtherChannel, execute o comando

    show etherchannel load-balance.

    Este é um exemplo de saída:

    Router#show etherchannel summary
    Group Port-channel Protocol Ports
    ------+-------------+-----------+-----------------------------------------
    1     Po1(SU)        -      Gi3/1(P) Gi3/2(P) Gi3/3(P) Gi3/4(P)
    2     Po2(SU)        -      Gi3/5(P) Gi3/6(P) Gi3/7(P) Gi3/8(P)
  7. Para verificar o status no lado do WiSM, abra uma sessão (session slot x proc 1 ou 2) ou conecte diretamente via console ao WiSM e verifique o status do LAG em show interface summary (ou em Controller -> Interfaces - > edit (management interface). Em Physical Information, podemos observar “The interface is attached to a LAG.”

    Exemplo:

    (WiSM-slot3-1) >show interface
    		  summary
    Interface Name     Port  Vlan Id   IP Address   Type   Ap Mgr
    --------------------------------   ----      -------   -------- -------
             ap-manager         LAG  untagged   192.168.3.9   Static   Yes
             management         LAG  untagged   192.168.3.10  Static    No

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 91473