Switches : Switches Cisco Catalyst 6500 Series

Exemplo de Configuração para a Migração da Spanning Tree de PVST+ para MST

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (13 Dezembro 2006) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Informações de Apoio
Configuração
      Diagrama de Rede
      Configurações
      Configuração do PVST+
      Migração do MST
Verificação
Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento fornece um exemplo de configuração de migração do modo de spanning tree PVST+ para o Multiple Spanning Tree (MST) na rede de um campus.

Pré-requisitos

Requisitos

Consulte Entendendo o Protocolo Multiple Spanning Tree (802.1s) antes de configurar o MST.

Esta tabela mostra o suporte ao MST em Catalyst Switches e o software mínimo necessário para esse suporte.

Plataforma Catalyst

MST com RSTP

Catalyst 2900 XL e 3500 XL

Não disponível

Catalyst 2950 e 3550

Cisco IOS® 12.1(9)EA1

Catalyst 3560

Cisco IOS 12.1(9)EA1

Catalyst 3750

Cisco IOS 12.1(14)EA1

Catalyst 2955

Todas as versões do Cisco IOS

Catalyst 2948G-L3 e 4908G-L3

Não disponível

Catalyst 4000, 2948G e 2980G (Catalyst OS (CatOS))

7.1

Catalyst 4000 e 4500 (Cisco IOS)

12.1(12c)EW

Catalyst 5000 e 5500

Não disponível

Catalyst 6000 e 6500 (CatOS)

7.1

Catalyst 6000 e 6500 (Cisco IOS)

12.1(11b)EX, 12.1(13)E, 12.2(14)SX

Catalyst 8500

Não disponível

  • Catalyst 3550/3560/3750: A implementação do MST no Cisco IOS Release 12.2(25)SEC é baseada no padrão IEEE 802.1s. As implementações do MST nos releases mais antigos do Cisco IOS são anteriores ao padrão.

  • Catalyst 6500 (IOS): A implementação do MST no Cisco IOS Release 12.2(18)SXF é baseada no padrão IEEE 802.1s. As implementações do MST nos releases mais antigos do Cisco IOS são anteriores ao padrão.

Componentes Utilizados

Este documento foi criado com as versões de software IOS 12.2(25) e CatOS 8.5(8), mas a configuração se aplica às versões mínimas do IOS mencionadas na tabela.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

O recurso MST é o IEEE 802.1s e é uma emenda ao 802.1Q. O MST estende o algoritmo Rapid Spanning Tree (RST) 802.1w a spanning trees múltiplas. Essa extensão fornece convergência rápida e balanceamento de carga em um ambiente de VLAN. O PVST+ e o Rapid-PVST+ executam uma instância de spanning tree para cada VLAN. No MST, você pode agrupar as VLANs em uma única instância. Ele usa a Bridge Protocol Data Unit (BPDU) versão 3, a qual é compatível com o STP 802.1D (que usa a BPDU versão 0).

Configuração do MSTP: A configuração inclui o nome da região, o número da revisão e o mapa de atribuições de VLAN para instância do MST. Você deve configurar o switch para uma região com o comando de configuração global spanning-tree mst configuration.

Região do MST: Uma região de MST consiste em bridges interconectadas que possuem a mesma configuração de MST. Não há limite para o número de regiões de MST na rede.

Instâncias de spanning-tree dentro da região de MST: Uma instância nada mais é do que um grupo de VLANs mapeadas pelo comando spanning-tree mst configuration. Por padrão, todas as VLANs são agrupadas em IST0, o qual é chamado de Internal Spanning Tree (IST). Você pode criar instâncias manualmente, numeradas de 1 a 4094, e elas serão rotuladas como MSTn (n =1 a 4094). No entanto, a região suporta apenas até 65 instâncias. Alguns releases suportam apenas 16 instâncias. Consulte o guia de configuração de software da plataforma do seu switch.

IST/CST/CIST: A IST é a única instância que pode enviar e receber BPDUs na rede MST. Uma instância de MSTn é local à região. As ISTs nas diferentes regiões são interconectadas por meio da Common Spanning Tree (CST). A coleção de ISTs em cada região de MST e a CST que conecta as ISTs são chamadas de Common and Internal Spanning Tree (CIST).

Compatibilidade com versões anteriores: O MST é compatível com o PVST+, o Rapid-PVST+ e o Prestandard MST (MISTP). O switch MST se conecta aos outros switches STP (PVST+ e Rapid-PVST+) pela Common Spanning Tree (CST). Outros switches STP (PVST+ e Rapid-PVST+) veem a região de MST inteira como um único switch. Quando você conecta um switch MST anterior ao padrão com um switch MST padrão, você precisa configurar spanning-tree mst pre-standard na interface do switch MST padrão.

Configuração

Este exemplo contém duas seções. A primeira seção mostra a configuração atual do PVST+. A segunda seção mostra a configuração para a migração do PVST+ para o MST.

Nota:  Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento usa esta configuração de rede:

O diagrama contém os seguintes switches:

  • Distribution1 e Distribution2 na camada de distribuição.

  • Dois switches da camada de acesso chamados Access1 (IOS) e Access2 (CatOS).

  • Dois switches de agregação de servidores chamados Services1 e Services2.

As VLANs 10, 30 e 100 transportam tráfego de dados. As VLANs 20, 40 e 200 transportam tráfego de voz.

MST-1.gif

Configurações

Este documento utiliza estas configurações:

Configuração do PVST+

Os switches são configurados no PVST+ para transportar os tráfegos de dados e voz de acordo com o diagrama de rede. Um pequeno resumo da configuração é:

  • O switch Distribution1 é configurado para se tornar uma bridge raiz primária para as VLANs de dados 10, 30 e 100 com o comando Distribution1(config)# spanning-tree vlan 10,30,100 root primary e a bridge raiz secundária para as VLANs de voz 20, 40 e 200 usa o comando Distribution1(config)# spanning-tree vlan 20,40,200 root secondary.

  • O switch Distribution2 é configurado para se tornar uma bridge raiz primária para as VLANs de voz 20, 40 e 200 com o comando Distribution2(config)# spanning-tree vlan 20,40,200 root primary e a bridge raiz secundária para as VLANs de dados 10, 30 e 100 usa o comando Distribution2(config)# spanning-tree vlan 10,30,100 root secondary.

  • O comando spanning-tree backbonefast é configurado em todos os switches para convergir o STP mais rápido no caso de falha indireta do link na rede.

  • O comando spanning-tree uplinkfast é configurado nos switches da camada de acesso para convergir o STP mais rápido no caso de direta do uplink.

Distribution1

Distribution1#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Podemos ver que a porta Fa1/0/24 é configurada com o comando spanning-tree vlan 20,40,200 port-priority 64. Distribution2 é configurado como raiz para as VLANs 20, 40 e 200. Distribution2 possui dois links para Distribution1: Fa1/0/23 e Fa1/0/24. Ambas as portas são portas designadas para as VLANs 20, 40 e 200 porque Distribution2 é a raiz para essas VLANs. Ambas as portas possuem a mesma prioridade 128 (padrão). Além disso, esses dois links possuem o mesmo custo de Distribution1: fa1/0/23 e fa1/0/24. Distribution1 seleciona o menor número de porta entre as duas portas para defini-la no estado de encaminhamento. O menor número de porta é Fa1/0/23. No entanto, de acordo com o diagrama de rede, as VLANs de voz 20, 40 e 200 devem fluir por Fa1/0/24. Isso pode ser feito com os seguintes métodos:

  1. Diminua o custo da porta em Distribution1: Fa1/0/24.

  2. Diminua a prioridade da porta em Distribution2: Fa1/0/24.

Neste exemplo, a prioridade da porta é diminuída para encaminhar as VLANs 20, 40 e 200 via fa1/0/24.

Distribution2

Distribution2#show running-config
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Podemos observar que a porta Fa0/5 em Services1 e ambas as portas Fa0/6 e Fa0/48 em Services2 possuem custo de porta e configuração de prioridade de porta de spanning tree. Aqui o STP é ajustado para que as VLANs 100 e 200 de Services1 e Services2 passem pelos links de tronco entre elas. Se essa configuração não for aplicada, Services1 e Services2 não transmitirão o tráfego pelos links de tronco entre eles. Em vez disso, o caminho através de Distribution1 e Distribution2 será escolhido.

Services2 vê dois caminhos de custo semelhante até a raiz da VLAN 100 (Distribution1): um por Services1 e o segundo por Distribution2. O STP escolhe o melhor caminho (porta raiz) nesta ordem:

  1. O custo do caminho

  2. O ID da bridge do switch de encaminhamento

  3. A menor prioridade de porta

  4. O menor número de porta interna

Neste exemplo, ambos os caminhos têm o mesmo custo, mas Distribution2 (24576) tem uma prioridade menor do que Services1 (32768) para a VLAN 100, e então Services2 escolhe Distribution2. Neste exemplo, o custo da porta em Services1: fa0/5 é definido como menor para que Services2 escolha Services1. O custo do caminho tem precedência sobre o número de prioridade do switch de encaminhamento.

Services1

Services1#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

O mesmo conceito é aplicado para Services1 escolher Services2 para encaminhar tráfego da VLAN 200. Após a redução do custo da VLAN 200 em Services2 - fa0/6, Services1 escolhe fa0/47 para encaminhar a VLAN 200. No entanto, o requisito aqui é encaminhar a VLAN 200 via fa0/48. Isso pode ser feito com estes dois métodos:

  1. Reduzir o custo da porta em Services1: Fa0/48.

  2. Reduzir a prioridade da porta em Services2: Fa0/48.

Neste exemplo, a prioridade da porta em Services2 é diminuída para encaminhar a VLAN 200 via fa0/48.

Services2

Services2#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1

Access1#show running-config
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2

Access2> (enable)show config all

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

Migração do MST

É difícil converter todos os switches na rede corporativa ao mesmo tempo para o MST. Devido à compatibilidade com versões anteriores, é possível converter uma fase de cada vez. Recomenda-se implementar as alterações na janela de manutenção programada porque a reconfiguração da spanning tree pode interromper o fluxo de tráfego. Quando você ativa o MST, ele também ativa o RSTP. Os recursos uplinkfast e backbonefast da spanning tree são recursos do PVST+, e ele é desativado quando você ativa o MST porque esses recursos são incorporados ao RSTP, e o MST depende do RSTP. Com a migração, você poderá remover esses comandos no IOS. No backbonefast e no uplinkfast do CatOS, os comandos são automaticamente limpos da configuração, mas a configuração de recursos tais como o PortFast, o bpduguard, o bpdufilter, o root guard e o loopguard também são aplicáveis no modo MST. O uso desses recursos é o mesmo que no modo PVST+. Se você já tiver habilitado esses recursos no modo PVST+, eles permanecerão ativos após a migração para o modo MST. Ao configurar o MST, siga estas orientações e restrições:

  • O primeiro passo na migração para o 802.1s/w é identificar adequadamente as portas ponto-a-ponto e de borda. Certifique-se de que todos os links switch-a-switch, onde são desejadas transições rápidas, sejam full-duplex. As portas de borda são definidas pelo recurso PortFast.

  • Escolha um nome para a configuração e um número de revisão que sejam comuns a todos os switches da rede. A Cisco recomenda que você posicione tantos switches quanto possível em uma única região; não é vantajoso segmentar uma rede em regiões separadas.

  • Decida cuidadosamente quantas instâncias são necessárias na rede comutada, e tenha em mente que uma instância é traduzida por uma topologia lógica. Evite mapear qualquer VLAN na instância 0. Decida que VLANs mapear nessas instâncias e selecione cuidadosamente uma raiz e uma raiz de backup para cada instância.

  • Certifique-se de que os troncos transportem todas as VLANs mapeadas em uma instância ou não transportem nenhuma VLAN para essa instância.

  • O MST pode interagir com bridges antigas que executam o PVST+ baseado em portas, portanto não é problema misturar ambos os tipos de bridges se as interações forem claramente compreendidas. Sempre tente manter a raiz da CST e a IST dentro da região. Se você interagir com uma bridge PVST+ por um tronco, certifique-se que a bridge MST seja a raiz de todas as VLANs permitidas nesse tronco. Não use bridges PVST como a raiz da CST.

  • Certifique-se de que todas as bridges raiz da spanning tree do PVST possuam prioridades menores (numericamente maiores) que a bridge raiz da CST.

  • Não desabilite a spanning tree de nenhuma VLAN em nenhuma das bridges do PVST.

  • Não conecte switches com links de acesso, pois links de acesso podem particionar uma VLAN.

  • Toda configuração de MST que envolva um grande número de portas lógicas de VLAN atuais ou novas pode ser concluída dentro de uma janela de manutenção, pois o banco de dados completo do MST é reinicializado em quaisquer alterações incrementais, tal como a adição de novas VLANs a instâncias ou o movimento de VLANs entre instâncias.

Neste exemplo, a rede do campus possui uma região de MST chamada region1 e duas instâncias de MST1 - VLANs de dados 10, 30 e 100, e MST2 - VLANs de voz 20, 40 e 200. Você pode ver que o MST executa somente duas instâncias, mas o PVST+ executa seis instâncias. Distribution1 é escolhido como raiz regional da CIST. Isso significa que Distribution1 é a raiz da IST0. Para balancear a carga de tráfego na rede conforme o diagrama, Distribution1 é configurado como raiz de MST1 (instância para VLANs de dados), e MST2 é configurado como raiz de MST2 (instância para VLANs de voz).

Você precisa migrar o centro primeiro e trabalhar na direção dos switches de acesso. Antes de alterar o modo de spanning tree, defina a configuração de MST nos switches. Em seguida, altere o modo de STP para MST. Neste exemplo, a migração ocorre nesta ordem:

  1. Distribution1 e Distribution2

  2. Services1 e Services2

  3. Access1

  4. Access2

  1. Migração de Distribution1 e Distribution2:

    
    Distribution1 Configuration
    
    Distribution1(config)# spanning-tree mst configuration
    Distribution1(config-mst)# name region1
    Distribution1(config-mst)# revision 10
    Distribution1(config-mst)# instance 1 vlan 10, 30, 100
    Distribution1(config-mst)# instance 2 vlan 20, 40, 200
    Distribution1(config-mst)# exit
    Distribution1(config)# spanning-tree mst 0-1 root primary
    Distribution1(config)# spanning-tree mst 2 root secondary
    
    
    Distribution2 Configuration
    
    Distribution2(config)# spanning-tree mst configuration
    Distribution2(config-mst)# name region1
    Distribution2(config-mst)# revision 10
    Distribution2(config-mst)# instance 1 vlan 10, 30, 100
    Distribution2(config-mst)# instance 2 vlan 20, 40, 200
    Distribution2(config-mst)# exit
    Distribution2(config)# spanning-tree mst 2 root primary
    Distribution2(config)# spanning-tree mst 0-1 root secondary
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    
    Distribution1(config)# interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)# interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    STP Mode conversion
    
    Distribution1(config)# spanning-tree mode mst
    Distribution2(config)# spanning-tree mode mst
    
    
    MST tuning - to load balance data and voice vlan traffic
    
    Distribution2(config)# interface FastEthernet1/0/24
    Distribution2(config-if)# spanning-tree mst 2 port-priority 64
    
    
    PVST+ cleanup
    
    Distribution1(config)# no spanning-tree backbonefast
    Distribution2(config)# no spanning-tree backbonefast
    Distribution2(config)# interface FastEthernet1/0/24
    Distribution2(config-if)# no spanning-tree vlan 20,40,200 port-priority 64

    Nota: É recomendável que você defina a raiz de MST0 manualmente. Neste exemplo, Distribution1 é escolhido como raiz de MST0, portanto Distribution1 torna-se a raiz da CIST.

    Nesse ponto a rede estará em uma configuração mista. Ela pode ser representado com este diagrama:

    MST-2.gif

    Distribution1 e Distribution2 estão em region1 do MST, e os switches PVST+ veem region1 como uma única bridge. O fluxo de tráfego após a reconvergência é mostrado no Diagrama 2. Você ainda pode sintonizar os switches do PVST+ (VLAN x custo de spanning tree) para balancear a carga dos tráfegos de dados e voz como indicado no Diagrama 1. Após migrar todos os outros switches com os passos de 2 a 4, você obterá a topologia final da spanning tree conforme o Diagrama 1.

  2. Migração de Services1 e Services2:

    
    Services1 Configuration
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)# name region1
    Services1(config-mst)# revision 10
    Services1(config-mst)# instance 1 vlan 10, 30, 100
    Services1(config-mst)# instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    Services2 Configuration
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)# name region1
    Services2(config-mst)# revision 10
    Services2(config-mst)# instance 1 vlan 10, 30, 100
    Services2(config-mst)# instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    Services1(config)# interface FastEthernet0/5
    Services1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)# interface FastEthernet0/6
    Services2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    STP Mode conversion
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    MST tuning - to load balance data and voice vlan traffic
    
    Services1(config)# interface fastEthernet 0/46
    Services1(config-if)# spanning-tree mst 2 cost 200000
    Services1(config-if)# exit
    Services1(config)# interface fastEthernet 0/47
    Services1(config-if)# spanning-tree mst 2 cost 100000
    Services1(config-if)# exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)# exit
    
    
    PVST+ cleanup
    
    Services1(config)# no spanning-tree uplinkfast
    Services1(config)# no spanning-tree backbonefast
    Services1(config)# interface FastEthernet0/5
    Services1(config-if)# no spanning-tree vlan 100 cost 18
    Services1(config-if)# exit
    
    Services2(config)# no spanning-tree uplinkfast
    Services2(config)# no spanning-tree backbonefast
    Services2(config)# interface FastEthernet0/6
    Services2(config-if)# no spanning-tree vlan 200 cost 18
    Services2(config-if)# exit
    Services2(config)# interface FastEthernet0/48
    Services2(config-if)# no spanning-tree vlan 200 port-priority 64
    Services2(config-if)# exit
  3. Migração de Access1:

    
    Access1 Configuration
    
    Access1(config)# spanning-tree mst configuration
    Access1(config-mst)# name region1
    Access1(config-mst)# revision 10
    Access1(config-mst)# instance 1 vlan 10, 30, 100
    Access1(config-mst)# instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)# switchport trunk allowed vlan 10,20,30,40,100,200
    
    STP mode conversion
    
    Access1(config)# spanning-tree mode mst
    
    
    PVST+ cleanup
    
    Access1(config)# no spanning-tree uplinkfast
    Access1(config)# no spanning-tree backbonefast
  4. Migração de Access2:

    
    Access2 Configuration
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    Ensure that trunks carry all the VLANs that are mapped to an instance
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- As configurações backbonefast e uplinkfast serão limpas automaticamente
    
    
    

Verificação

Recomenda-se verificar a topologia da spanning tree toda vez que a configuração é alterada.

Verifique se o switch Distribution1 é a bridge raiz para as VLANs de dados 10, 30 e 100, e verifique se o caminho de encaminhamento da spanning tree corresponde ao caminho do diagrama.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1# show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1# show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- A raiz de CIST é Distribution1. Todos os switches estão na mesma região "region1".
Assim, em todos os switches de region1, você pode observar o custo do caminho igual a 0.


Distribution2# show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2# show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Troubleshooting

No momento, não existem informações específicas disponíveis sobre troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 72844