Sem fio/Mobilidade : LAN Wireless (WLAN)

Exemplo de Configuração de VLANs em Controladoras de LAN sem Fio

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (26 Agosto 2011) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração
      Diagrama de Rede
      Configuração dos Catalyst Switches
      Configuração da VLAN da Controladora de WLAN
Verificação
      Verificação dos Catalyst Switches
      Verificação da VLAN da Controladora de WLAN
Troubleshooting
      Procedimento de Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento fornece um exemplo de configuração de VLANs em controladoras de LAN sem fio (WLAN) e do Cisco Catalyst Switch associado à controladora.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento. No entanto, ele pressupõe que exista um servidor DHCP em funcionamento para fornecer endereços IP para os pontos de acesso (APs) registrados na controladora.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Configuração A:

    • Catalyst Switch com Cisco IOS® Software e uma controladora de WLAN

    • Cisco 4404 WLAN Controller

  • Configuração B:

    • Catalyst Switch com Catalyst OS (CatOS) Software e uma controladora de WLAN

    • Cisco 4404 WLAN Controller

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

As VLANs com controladoras de WLAN usam este modelo:

wlan_controllers_vlans1.gif

Configuração dos Catalyst Switches

Esta seção usa estas configurações:

Catalyst Switch com Cisco IOS Software

lab1sup720ip1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Catalyst Switch com CatOS Software

controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- Este comando deve estar em uma única linha.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

Configuração da VLAN da Controladora de WLAN

Configuração via interface gráfica do usuário

Execute os passos a seguir e a sequência de imagens da interface gráfica do usuário para configurar a LAN de uma controladora de WLAN.

  1. Escolha Controller > Interfaces > New.

    wlan_controllers_vlans2.gif

  2. Insira o nome da interface e o identificador da VLAN e clique em Apply.

    Esta janela é exibida após a definição do nome da interface e do identificador da VLAN:

    wlan_controllers_vlans3.gif

    Nota: Para criar uma interface dinâmica com espaços usando a interface de linha de comando, execute o comando config interface create e mencione o nome da interface entre aspas. Exemplo:

    (C4-4400) >config interface create 'int spaces'

    Nota: Para exibir os detalhes da interface, execute este comando:

    (C4-4400) >show interface detailed 'int spaces'
    
    Interface Name................................... int spaces
  3. Insira o endereço IP, a máscara de rede, o gateway e o endereço IP do servidor DHCP e clique em Apply.

    wlan_controllers_vlans4.gif

    Nota: O endereço IP atribuído a esta interface funciona como o retransmissor de DCHP para um cliente obter um endereço IP do servidor DHCP. Por exemplo, quando um cliente tenta se associar a uma WLAN/SSID (consulte o passo 5 nesta configuração) mapeada nesta interface dinâmica, ele executa um broadcast na sub-rede local para identificar o servidor DHCP. A controladora envia uma solicitação para o servidor DHCP (ou para si mesmo se ela for o servidor DHCP do segmento) com o endereço IP dessa interface dinâmica como o IP de retransmissão para o servidor DHCP configurado para essa interface. O servidor DHCP atribui então um endereço IP do escopo de DHCP configurado ao cliente.

  4. Verifique a configuração da interface.

    Clique na guia Controller no menu na parte superior da janela e selecione Interfaces no menu à esquerda.

    wlan_controllers_vlans5.gif

  5. Clique na guia WLANs no menu na parte superior da janela e clique em New....

    wlan_controllers_vlans6.gif

  6. Insira o identificador de conjunto de serviços (SSID) e clique em Apply.

    Este exemplo usa vlan15 para facilitar a compreensão.

    wlan_controllers_vlans7.gif

  7. Selecione vlan15 no menu suspenso Interface Name na parte inferior da janela e clique em Apply.

    Neste caso, o SSID vlan15 é vinculado ao valor de Interface Name vlan15.

    wlan_controllers_vlans8.gif

Configuração via interface de linha de comando

Use esta seção para configurar sua VLAN pela interface de linha de comando (CLI).

  1. Crie a interface e a marca da VLAN associada.

    O comando é config interface create interface_name vlan_id.

    (lab5wlc4404ip15) >config interface create vlan15 15
    
  2. Defina o endereço IP e o gateway padrão.

    O comando é config interface interface_name IP_address netmask gateway.

    (lab5wlc4404ip15) >config interface address vlan15 192.168.15.10
    255.255.255.0 192.168.15.1
    
    !--- Este comando deve estar em uma única linha.
    
    
  3. Defina o servidor DHCP.

    O comando é config interface dhcp interface_name dhcp_server 1 dhcp_server 2 dhcp_server 3 dhcp_server 4.

    (lab5wlc4404ip15) >config interface dhcp vlan15 192.168.5.15
    
  4. Verifique a configuração da interface.

    O comando é show interface summary.

    (lab5wlc4404ip15) >show interface summary
    
    Interface Name           Port     Vlan Id      IP Address          Type      Ap Mgr
    -----------------------  ----     --------     ---------------     -------   ------
    ap-manager               1        untagged     192.168.5.215       Static    Yes
    management               1        untagged     192.168.5.15        Static    No
    service-port             N/A      N/A          100.100.100.100     Static    No
    virtual                  N/A      N/A          1.1.1.1             Static    No
    vlan15                   1        15           192.168.15.10       Dynamic   No
    
    
    (lab5wlc4404ip15) >
  5. Defina a WLAN.

    O comando é config wlan create wlan_id name.

    (lab5wlc4404ip15) >config wlan create 2 vlan15
    
  6. Defina a interface para a WLAN.

    O comando é config wlan interface wlan_id interface_name.

    (lab5wlc4404ip15) >config wlan interface 2 vlan15
    
  7. Verifique a WLAN e a interface associada.

    O comando é show wlan summary.

    (lab5wlc4404ip15) >show wlan summary
    
    Number of WLANs.................................. 2
    
    WLAN ID   WLAN Name               Status        Interface Name
    -------   --------------------    ---------     --------------------------------
    1         lab5wlc4404ip15         Enabled       management
    2         vlan15                  Disabled      vlan15  
    
    (lab5wlc4404ip15) >

Verificação

Use esta seção para verificar se a sua configuração funciona corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Verificação dos Catalyst Switches

  • Catalyst Switch com Cisco IOS Software — show running-config interface interface_type interface_number

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
    
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • Catalyst Switch com CatOS Software — show config mod

    controller-catos> (enable) show config 2
    
    !--- Este comando mostra somente configurações diferentes da padrão.
    !--- Execute o comando show config mod all para
    !--- mostrar as configurações padrão e não padrão.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

Verificação da VLAN da Controladora de WLAN

Consulte a seção Configuração da VLAN da Controladora de WLAN deste documento para obter os passos de verificação

Troubleshooting

Use esta seção para fazer troubleshooting da sua configuração.

Procedimento de Troubleshooting

Siga estas instruções para fazer o troubleshooting da sua configuração.

  1. Envie um ping da controladora de WLAN para o gateway padrão que está configurado na interface roteada da VLAN. Em seguida, envie outro ping na direção oposta.

    • Controladora de WLAN:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • Interface roteada da VLAN:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
      lab1sup720ip1#
  2. Se os pings falharem, implemente um capturador/sniffer de pacotes no switch para verificar a marcação apropriada da VLAN.

    Nota: Quando você inicia o ping da sua controladora para um gateway da Camada 3, o qual está na mesma sub-rede que sua interface dinâmica, aparentemente a origem do ping na controladora é a interface dinâmica.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 68100