IP : Protocolos de roteamento IP

Exemplo de Configuração de Roteamento Baseado em Políticas com o Recurso Multiple Tracking Options

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração
      Diagrama de Rede
      Configuração
Verificação
Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento fornece um exemplo de configuração para roteamento baseado em políticas com o recurso Multiple Tracking Options. Esse recurso foi introduzido no Cisco IOS® Software versão 12.3(4)T. Consulte Suporte do PBR a Multiple Tracking Options para obter mais informações.

Esta funcionalidade estende os recursos de rastreamento objetivo para verificar o próximo endereço IP de salto antes de encaminhar o tráfego para o próximo salto. O método de verificação pode ser um ping Internet Control Message Protocol (ICMP), um ping User Datagram Protocol (UDP) ou uma solicitação GET Hypertext Transfer Protocol (HTTP). O ICMP é o método de verificação mais comum usado na Internet. O recurso Multiple Tracking Options é mais adequado para roteadores que tenham conexões Ethernet múltiplas como o próximo salto. Normalmente, as interfaces Ethernet se conectam a uma digital subscriber line (DSL) ou modems a cabo. No momento, não há método de detecção de upstream de falhas na rede de banda larga ISP — a interface Ethernet permanece ativa e qualquer forma de roteamento estático aponta para essa interface. Esse recurso permite fazer backup de duas interfaces Ethernet, escolher a interface que está disponível enviando pings ICMP para verificar sua acessibilidade e, em seguida, rotear o tráfego através dessa interface.

Pré-requisitos

Requisitos

Antes de você tentar esta configuração, verifique se estes requisitos são atendidos:

  • Carregue o conjunto de recursos Enterprise Base IOS nos seus roteadores caso isso ainda não tenha sido feito. Se você tiver pago por esse conjunto de recursos, ele poderá ser baixado do Cisco IOS Upgrade Planner (somente clientes registrados).

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Configuração

Esta seção apresenta as informações para configurar os recursos descritos neste documento.

Nota: Para obter informações adicionais sobre os comandos usados neste documento, use a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Este documento utiliza esta configuração de rede. Neste cenário, R1 está conectado a dois ISPs diferentes (ISP-1 e ISP-2). R1 rastreia a acessibilidade a ambos os roteadores ISP.

pbrtracking_01.gif

Configuração

Este documento utiliza esta configuração:

R1

R1# show running-config
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Controla a acessibilidade de Roteador 1.

!
track 124 rtr 2 reachability

!--- Controla a acessibilidade de Roteador 2.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Habilite o roteamento com base em políticas na interface de saída.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Defina um mapa de rotas para definir o próximo salto dependendo do
!--- estado dos roteadores controlados.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Defina e inicie Roteador 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Defina e inicie Roteador 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Alguns comandos show são aceitos pela Output Interpreter Tool (somente clientes registrados), o que permite exibir uma análise da saída do comando show.

  • show track — Exibe informações de rastreamento.

  • show track brief — Exibe informações de rastreamento limitado.

R1# show track
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

Na saída do comando show track brief, você pode ver que ambos os ISPs estão acessíveis. Se você desligar a interface conectada ao ISP-1, ela será mostrada como inativa quando rastreada.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

Nota: O PBR requer rastreamento para determinar se a interface ou a rota está ativa. Para exibir o status do rastreamento de rotas, você também pode utilizar o comando show route-map.

Troubleshooting

No momento, não existem informações disponíveis específicas sobre troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 48003