Switches de LAN : EtherChannel

Configuração de EtherChannel da Camada 2 e do Entroncamento entre 2900XL/3500XL/2950 Series Switches e Catalyst Switches que Executam o Cisco IOS Software

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (26 Fevereiro 2006) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
      DTP
      Consideração sobre a VLAN Nativa 802.1Q
      PAgP
Configuração 1: Entroncamento ISL e EtherChannel Entre um Catalyst 3500 XL e um Catalyst 6500 que Executa o Cisco IOS Software
      Diagrama de Rede
Configuração 2: Entroncamento 802.1Q e EtherChannel com o Uso de DTP e PAgP Entre um Catalyst 2950 e um Catalyst 6500 que Executa o Cisco IOS Software
      Diagrama de Rede
Verificação: Entroncamento ISL
      Catalyst 3500 XL
      Catalyst 6500 (Cisco IOS Software)
Verificação: Entroncamento 802.1Q
      Catalyst 2950
      Catalyst 6500 Cisco IOS Software
Troubleshooting
      O Tráfego Não Passa em um Tronco 802.1Q
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento fornece exemplos de configurações de entroncamento IEEE 802.1Q/ISL (Inter-Switch Link) e de EtherChannel da Camada 2 (L2) entre Cisco Catalyst 2900 XL/3500 XL ou Catalyst 2950 Series Switches e um Catalyst 6500/6000 Switch que executa o Cisco IOS® Software. Neste exemplo, também é possível utilizar um Catalyst 4500/4000 Switch que executa o Cisco IOS Software, em vez do Catalyst 6500/6000. Este documento aborda os fatores mais importantes a serem considerados durante a configuração do entroncamento e da canalização entre os switches. O documento também apresenta exemplos de configuração.

Neste documento, quatro portas Fast Ethernet de cada um dos switches foram entroncadas e agrupadas em FECs (Fast EtherChannels). O protocolo de entroncamento foi utilizado para o 3500 XL ISL, e o 802.1Q foi utilizado para o exemplo do 2950.

Nota: Como o Catalyst 2950 não oferece suporte ao entroncamento ISL, utilize o entroncamento 802.1Q.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Para criar os exemplos apresentados neste documento, os seguintes switches foram utilizados em um ambiente de laboratório, com configurações padrão:

  • Catalyst 3548 XL Switch que executa o Cisco IOS Software Release 12.0(5)WC2

  • Catalyst 2950-24 Switch que executa o Cisco IOS Software Release 12.1(6)EA2c

  • Catalyst 6509 Switch com Supervisor Engine II que executa o Cisco IOS Software Release 12.1(11b)E

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

DTP

Os troncos entre os dispositivos podem ser configurados de modo estático ou com o uso do DTP (Dynamic Trunking Protocol). O DTP permite que os dois dispositivos conectados negociem as definições de tronco antes que a conexão de tronco seja efetivamente estabelecida. Os modos de porta (entroncamento) configuráveis dos switches com o Cisco IOS Software incluem: dynamic (a porta negocia o modo de acesso ou de tronco), trunk (define incondicionalmene a porta para entroncamento) e access (porta de acesso sem tronco). As definições mais utilizadas de combinação de modos em ambos os lados de um tronco estático (não negociado pelo DTP) são trunk-to-trunk. Para troncos dinâmicos (negociados pelo DTP), as definições normais são dynamic-dynamic. Outras combinações podem produzir resultados válidos, mas estão fora do escopo deste documento. Uma conexão de tronco entre um switch com suporte a PAgP (Port Aggregation Protocol) e um dispositivo não PagP exige que o modo "trunk" esteja ativado.

Nota: A maioria dos Cisco routers e alguns Catalyst switches não oferecem suporte ao DTP e exigem a configuração do entroncamento estático. Por exemplo, os Catalyst XL Series, Catalyst 2948G-L3, Catalyst 4908G-L3, Catalyst 8500 Series, 2/3/4/7xxx Series Cisco Routers etc. não oferecem suporte ao DTP e exigem a configuração desse tipo de entroncamento.

Consideração sobre a VLAN Nativa 802.1Q

O entroncamento 802.1Q insere um campo com marca 802.1Q de 4 bytes nos frames enviados pelo tronco, os quais contêm informações sobre VLANs. A marca 802.1Q é inserida em cada frame transferido pelo tronco, exceto naqueles transmitidos na VLAN nativa, que são enviados sem marca. Na maioria dos casos, a VLAN nativa deverá ser igual em ambos os lados do tronco, a menos que exista um requisito incomum específico de configuração, o que está fora do escopo deste documento. Se as VLANs nativas forem diferentes, o switch registrará em log as mensagens CDP (Cisco Discovery Protocol) relatando a incompatibilidade. Embora não seja catastrófica, essa configuração faz com que as duas VLANs nativas diferentes sejam mescladas em um domínio L2 maior de broadcast (VLAN). Essas duas VLANs tentam calcular uma topologia STP (Spanning Tree Protocol) comum para essas VLANs nativas com bridge, com o risco de exceder eventualmente o diâmetro máximo do STP aceito.

Nota: Há uma situação especial em que um vizinho ou um dispositivo de terceiros exige que todas as VLANs sejam marcadas. Se isso ocorrer, você poderá implementar uma solução para criar uma VLAN fictícia e configurá-la como a VLAN nativa. Isso fará com que todas as outras VLANs necessárias sejam marcadas, e elas enviarão o tráfego pelo tronco para o vizinho ou o dispositivo de terceiros. No Cisco IOS Software Release 12.1.11bEX, 12.1.13E e posterior, o Catalyst 6500 que executa o Cisco IOS Software oferece suporte à opção de entroncamento 802.1Q, a qual marcará todo o tráfego da VLAN, incluindo o da VLAN nativa. Execute o comando vlan dot1q tag native no modo de configuração global. No Catalyst 4500/4000 com o Cisco IOS Software, o comando vlan dot1q tag native foi introduzido inicialmente no Cisco IOS Software Release 12.2(18)EW.

PAgP

Também é possível configurar GECs (Gigabit EtherChannels) e FECs entre switches de forma estática ou dinâmica com o uso do PAgP. O PAgP permite que os dois dispositivos conectados negociem as definições antes de formarem efetivamente o canal. Os modos de canal do PAgP incluem: desirable (a porta inicia ativamente a negociação de canal), auto (padrão, nesse modo a porta não inicia a negociação, mas responde às tentativas de negociação iniciadas pelo outro lado) e on (define incondicionalmente a porta no modo de canal e não realiza a troca de frames PAgP). Uma conexão entre um switch com suporte a PAgP e um dispositivo não PAgP exige o modo on para formar um canal.

A combinação de modos mais utilizada em ambos os lados de um canal estático (não negociado pelo PAgP) é on-on. Para canais dinâmicos (negociados pelo PAgP), as definições mais comuns são desirable-desirable ou desirable-auto. As portas conectadas configuradas no modo desirable realizam a negociação e a verificação de canal antes de iniciarem a canalização e também continuam a verificar o canal durante a sua operação. Devido à proteção adicional fornecida pelo PAgP, essa é a configuração geralmente recomendada quando os dois switches conectados oferecem suporte ao PAgP.

Nota: O PAgP possui algumas limitações de configuração deliberadas. Para negociar um canal, as portas devem ter a mesma definição de velocidade, duplex, encapsulamento de entroncamento e VLAN. Além disso, é possível que o algoritmo de balanceamento de carga de canal nos links seja configurável em algumas plataformas.

Nota: Um EtherChannel é considerado como uma porta STP exclusiva assim que é ativado. Portanto, para evitar inconsistências de STP ao configurar um canal não negociado, siga este procedimento:

  1. Encerre todas as portas do canal para fazer a configuração nos dois lados.

  2. Execute a configuração em ambas as extremidades.

  3. Ative novamente todas as portas.

A tentativa de configurar um canal como esse enquanto as portas estão ativadas poderá resultar em inconsistências temporárias de STP e/ou em loops. Os passos se aplicarão apenas se o PAgP não for utilizado.

Catalyst 2900 XL/3500 XL

Os Catalyst 2900 XL/ 3500 XL Series Switches não oferecem suporte aos protocolos DTP e PAgP e, portanto, requerem a configuração de um canal e de um tronco estáticos. Consulte a nota acima para obter mais informações. No momento, os Catalyst 2900 XL/ 3500 XL Series Switches oferecem suporte a encapsulamentos de entroncamento ISL e 802.1Q. Para obter mais informações, consulte este documento:

O Cisco IOS Software Release 11.2(8)SA4 e posterior oferece suporte ao ISL, e o Cisco IOS Software Release 11.2(8)SA5 e posterior, ao 802.1Q.

Com um Catalyst 2900 XL que executa o Cisco IOS Software Release 11.2(8)SA1 ou 11.2(8)SA2, você terá quatro EtherChannels (grupos de portas) por switch, com um número ilimitado de portas por grupo. O balanceamento de carga entre os links no canal é sempre baseado no endereço de destino. Não há suporte para SPAN (Switched Port Analyzer) e recursos de segurança de porta.

Em um Catalyst 2900 XL que executa o Cisco IOS Software Release 11.2(8)SA3 ou posterior, em um Catalyst 3500 XL que executa o Cisco IOS Software Release 11.2(8)SA6 ou posterior e em um Catalyst 2950, o balanceamento de carga entre os links do canal é configurável com base no endereço MAC de origem ou de destino. O padrão é o endereço de origem. O encaminhamento baseado na origem permite até oito portas em um FEC (grupo de portas). O encaminhamento baseado no destino permite um número ilimitado de portas por grupo de portas. Você pode configurar até 12 grupos de portas por switch e ter uma mistura de grupos baseados em origem/destino. Não há suporte para segurança de porta e SPAN.

Catalyst 2950

Os Catalyst 2950 Switches oferecem suporte apenas ao entroncamento 802.1Q; não há suporte para o entroncamento ISL. Os Catalyst 2950 Switches oferecem suporte à negociação de canal e ao entroncamento dinâmico PAgP e DTP com as releases do Cisco IOS Software Release 12.1 e a modos estáticos somente com as releases do Cisco IOS Software Release 12.0. O balanceamento de carga do EtherChannel pode usar o encaminhamento baseado nos endereços MAC de origem ou de destino. Você pode configurar o método de balanceamento de carga executando o comando de configuração global port-channel load-balance. Esses switches oferecem suporte a até oito portas por canal.

Catalyst 6500 que Executa o Cisco IOS Software

Os Catalyst 6500 Switches que executam o Cisco IOS Software oferecem suporte a configurações de EtherChannel L2 (porta de switch) e L3 (Camada 3) (porta roteada). Um Catalyst 6500/6000 Series Switch oferece suporte a, no máximo, 64 EtherChannels (256 com o Cisco IOS Software Release 12.1(2)E e anterior). É possível formar um EtherChannel com até oito portas de LAN de configurações compatíveis em qualquer módulo de um Catalyst 6000 Series Switch, com exceção dos módulos dotados de DFC (Digital Feature Card) (como WS-X6816 e assim por diante) que, no momento, permitem um canal L2 somente com o uso de portas do mesmo módulo DFC. Entretanto, é possível configurar um canal L3 em diversos módulos dotados de DFC. Essa limitação foi eliminada no Catalyst 6500/6000 Cisco IOS Software Release 12.1(11b)EX e posterior. Este documento configura um EtherChannel L2.

O Catalyst 6500/6000 que executa o Cisco IOS Software permite que você configure o balanceamento de carga do EtherChannel para utilizar informações de portas da Camada 4 (L4), endereços IP ou endereços MAC em qualquer combinação de origem, destino e origem-destino, com o comando de configuração global port-channel load-balance. O padrão é utilizar uma função de hash entre os endereços IP de origem e de destino.

Os Catalyst 6500/6000 Switches oferecem suporte a encapsulamentos de entroncamento ISL e 802.1Q e ao DTP. Para obter informações detalhadas sobre os recursos de porta, execute o comando show interface interface_id capabilities.

Catalyst 4000 que Executa o Cisco IOS Software

Os Catalyst 4000 Switches que executam o Cisco IOS Software (com Supervisor Engine III e IV) oferecem suporte a configurações de EtherChannel L2 (porta de switch) e L3 (porta roteada). Os Catalyst 4000 Series Switches oferecem suporte a, no máximo, 64 EtherChannels. É possível formar um EtherChannel com até oito interfaces Ethernet de configuração compatível em qualquer módulo e nos módulos de um Catalyst 4500/4000 Series Switch. Todas as interfaces em cada EtherChannel devem ter a mesma velocidade e ser configuradas como interfaces L2 ou L3.

O Catalyst 4000 que executa o Cisco IOS Software permite que você configure o balanceamento de carga do EtherChannel para utilizar informações de portas L4, endereços IP ou endereços MAC em qualquer combinação de origem, destino e origem-destino com o comando de configuração global port-channel load-balance. O padrão é utilizar uma função de hash entre os endereços IP de origem e de destino.

O Catalyst 4000 que executa o Cisco IOS Software oferece suporte a encapsulamentos de entroncamento ISL e 802.1Q e ao DTP. O ISL não está disponível em determinados módulos. Para obter uma lista completa desses módulos, consulte a seção Compreendendo Troncos de VLAN de Configurando Interfaces Ethernet da Camada 2. Em uma release futura do software, informações detalhadas sobre os recursos de porta poderão ser obtidas com o comando show interface capabilities. Esse comando não está disponível no momento.

Configuração 1: Entroncamento ISL e EtherChannel Entre um Catalyst 3500 XL e um Catalyst 6500 que Executa o Cisco IOS Software

Nesta seção, você encontrará as informações para configurar os recursos descritos neste documento.

Nota: Para obter mais informações sobre os comandos utilizados neste documento, utilize a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Esta configuração utiliza a seguinte configuração de rede:

144-a.gif

Catalyst 3524 XL


!--- O Catalyst 3500 XL não oferece suporte ao DTP/PAgP.
!--- Primeiro, desative as portas secundárias envolvidas no canal
!--- e, em seguida, habilite-as de volta quando a configuração for concluída em ambos os switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Saída suprimida.


!
interface FastEthernet0/17
port group 1

!--- Porta atribuída ao canal de portas 1.


switchport trunk encapsulation isl

!--- Porta configurada para usar o ISL de encapsulamento de entroncamento.


switchport mode trunk

!--- Porta configurada para estar no modo de entroncamento.


!
interface FastEthernet0/18

!--- Configuração do tronco e do canal repetida.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Configuração do tronco e do canal repetida.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Configuração do tronco e do canal repetida.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Saída suprimida.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (Cisco IOS Software)


!--- O Catalyst 3500 XL não oferece suporte ao DTP/PAgP.
!--- Primeiro, desative as portas secundárias envolvidas no canal
!--- e, em seguida, habilite-as de volta quando a configuração for concluída em ambos os switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy
main-cpu
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- Esta interface será criada e configurada automaticamente.
!--- Não é necessário fornecer esta parte da configuração.


switchport
switchport trunk encapsulation isl
switchport mode trunk
no ip address
!
interface GigabitEthernet1/1
no ip address
shutdown
!

!--- Saída suprimida.


!
interface FastEthernet4/2
switchport

!--- Configurando a interface como uma porta L2 já que, por padrão, a porta é uma porta roteada.



!--- Nota: O Catalyst 4500/4000 com Cisco IOS Software assume por padrão a porta L2.


switchport trunk encapsulation dot1q

!--- Definindo o encapsulamento do tronco como dot1q.


switchport mode trunk

!--- Porta configurada para estar no modo de entroncamento. 


no ip address
channel-group 1 mode on

!--- Porta configurada para participar do canal de portas 1 com o modo de canal on.


!
Interface FastEthernet4/3

!--- Configuração do tronco e do canal repetida. 


switchport
switchport trunk encapsulation isl
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface FastEthernet4/4

!--- Configuração do tronco e do canal repetida.



switchport
switchport trunk encapsulation isl
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface FastEthernet4/5

!--- Configuração do tronco e do canal repetida. 


switchport
switchport trunk encapsulation isl
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface FastEthernet4/6
no ip address
shutdown
!
!
interface VLAN 1
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500#

Configuração 2: Entroncamento 802.1Q e EtherChannel com o Uso de DTP e PAgP Entre um Catalyst 2950 e um Catalyst 6500 que Executa o Cisco IOS Software

Nesta seção, você encontrará as informações para configurar os recursos descritos neste documento.

Nota: Para obter mais informações sobre os comandos utilizados neste documento, utilize a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Esta configuração utiliza a seguinte configuração de rede:

144-b.gif

Catalyst 2950


!--- O Catalyst 2950 com Cisco IOS Software Release 12.1 oferece suporte ao PAgP.
!--- Não é necessário desativar as portas porque os Catalyst 2950 e 6500 podem negociar
!--- a canalização no modo desirable.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1
switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport mode trunk

!--- Porta configurada para estar no modo de entroncamento.


channel-group 1 mode desirable

!--- Porta configurada para participar do canal de portas 1 negociado pelo PAgP.


!
interface FastEthernet0/3

!--- Configuração do tronco e do canal repetida.


switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Configuração do tronco e do canal repetida. 



switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Configuração do tronco e do canal repetida. 


switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Saída suprimida.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip route-cache
!
ip http server
!
line con 0
transport input none
line vty 5 15
!
end
Cat2950#

Catalyst 6500 (Cisco IOS Software)


!--- O Catalyst 2950 com Cisco IOS Software Release 12.1 oferece suporte ao PAgP.
!--- Não é necessário desativar as portas porque os Catalyst 2950 e 6500 podem negociar
!--- a canalização no modo desirable.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy
main-CPU
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- Esta interface será criada e configurada automaticamente.
!--- Não é necessário fornecer esta parte da configuração.


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
!
interface GigabitEthernet1/1
no ip address
shutdown
!

!--- Saída suprimida.


!
interface FastEthernet4/2
switchport

!--- Configurando a interface como uma porta L2 já que, por padrão, a porta é uma porta roteada.



!--- Nota: O Catalyst 4500/4000 com Cisco IOS Software assume por padrão a porta L2.


switchport trunk encapsulation dot1q


!--- Definindo o encapsulamento do tronco como dot1q.


switchport mode trunk

!--- Porta configurada para estar no modo de entroncamento. 


No ip address
channel-group 1 mode desirable

!--- Porta configurada para participar do canal de portas 1 com o modo de canal desirable.


!
Interface FastEthernet4/3

!--- Configuração do tronco e do canal repetida. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode desirable
!
interface FastEthernet4/4

!--- Configuração do tronco e do canal repetida.


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode desirable
!
interface FastEthernet4/5

!--- Configuração do tronco e do canal repetida. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode desirable
!
interface FastEthernet4/6
no ip address
shutdown
!
!
interface VLAN 1
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500#

Verificação: Entroncamento ISL

Use esta seção para verificar se a sua configuração funciona corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Utilize a OIT para exibir uma análise da saída desses comandos.

Catalyst 3500 XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Nota: Se você tiver um EtherChannel de oito portas, a execução do comando show etherchannel summary poderá travar o switch caso você execute uma release do Cisco IOS Software anterior ao Cisco IOS Software Release 12.0(5)WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (Cisco IOS Software)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on
1     22     Fa4/3    on
2     44     Fa4/4    on
3     88     Fa4/5    on

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on
1     22     Fa4/3    on
2     44     Fa4/4    on
3     88     Fa4/5    on

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Verificação: Entroncamento 802.1Q

Use esta seção para verificar se a sua configuração funciona corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Utilize a OIT para exibir uma análise da saída desses comandos.

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL
0     00     Fa0/3    desirable-SL
0     00     Fa0/4    desirable-SL
0     00     Fa0/5    desirable-SL

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Catalyst 6500 Cisco IOS Software

Cat6500#show etherchannel port-channel 
Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL
3     22     Fa4/3    desirable-SL
0     44     Fa4/4    desirable-SL
2     88     Fa4/5    desirable-SL

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Troubleshooting

Use esta seção para fazer troubleshooting da sua configuração.

O Tráfego Não Passa em um Tronco 802.1Q

O problema pode ser ocasionado por um destes motivos:

  • Há uma incompatibilidade na configuração das VLANs nativas nas portas conectadas entre dois switches.

    Verifique a configuração das VLANs nativas nos dois switches. Execute o comando show trunk no CatOS Switch para ver a definição das VLANs nativas. Execute o comando show interface interface_id switchport no Switch XL para ver a definição das VLANs nativas. Se houver uma incompatibilidade dessas VLANs entre os dois switches, configure-os com a mesma VLAN nativa. Execute o comando de configuração de interface switchport trunk native vlan para alterar a VLAN nativa no Switch XL. Execute o comando set vlan para alterar a VLAN nativa no CatOS Switch.

  • Não há suporte para frames DTP em Switches XL.

    Os CatOS Switches enviam frames DTP pelo link do tronco, mas os Switches XL não oferecem suporte a esses frames. Não há suporte para o DTP em Switches XL. Para evitar esse problema, defina o status da porta do CatOS Switch de modo que não haja negociação. Execute o comando set trunk mod/port nonegotiate dot1q a fim de definir o modo de entroncamento dot1q como "nonegotiate".

  • Há uma incompatibilidade de encapsulamento no Switch XL.

    No Switch XL, verifique se o encapsulamento de tronco está definido como dot1q. Execute o comando show interface interface_id switchport para ver a definição atual. Execute o comando de configuração de interface switchport trunk encapsulation dot1q para alterar o encapsulamento para dot1q.

  • Uma versão anterior do CatOS não oferece suporte ao entroncamento dot1q.

    A versão anterior do CatOS era utilizada nos switches que não oferecem suporte ao entroncamento dot1q. Atualize o CatOS do switch para uma versão posterior com suporte para troncos dot1q e ISL.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 22422