Qualidade de Serviço (QoS) : Regulamentação QoS

Configurando o CBWFQ em PVCs de Frame Relay

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback

Índice

Introdução
Antes de Começar
      Convenções
      Pré-requisitos
      Componentes Utilizados
Modelagem e Enfileiramento
Cisco 7200, 3600, 2600 Series
Cisco 7500 Series
Escolha de Onde Aplicar uma Política de Serviço
Problemas Conhecidos
Notas de Configuração
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento apresenta exemplos de configurações do CBWFQ (Enfileiramento Justo e Ponderado Baseado em Classes) em uma interface de Frame Relay. O CBWFQ é habilitado com o comando bandwidth, conforme configurado em um mapa de políticas com os comandos da interface de linha de comando modular de Qualidade de Serviço (QoS).

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Pré-requisitos

Não existem pré-requisitos específicos para este documento.

Componentes Utilizados

O CBWFQ é suportado a partir dos seguintes releases do Cisco IOS® Software, dependendo da plataforma:

  • Cisco 7500 Series com processadores de interface versáteis (VIP) (CBWFQ distribuído) - 12.1(5)T

  • Cisco 7200 Series, 2600/3600 Series e outras plataformas não 7500 Series - 12.1(2)T

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Modelagem e Enfileiramento

O enfileiramento é geralmente usado no contexto de modelagem, o que reduz a taxa de saída e induz congestionamento. Use o CBWFQ com os seguintes mecanismos e comandos de modelagem dependendo da sua plataforma.

 

Cisco 7500 Series

Cisco 7200, 3600, 2600 e outras plataformas não VIP

Mecanismos de modelagem com suporte

Modelagem de tráfego distribuída (DTS)

Modelagem de tráfego de Frame Relay (Frame Relay TS)

Comando de configuração

Comando shape em um mapa de políticas

frame-relay traffic-shaping em uma interface principal, comandos de configuração map-class para especificar parâmetros de modelagem

Requer o Distributed Cisco Express Forwarding (dCEF)

Sim (verifique com o comando show cef linecard)

Não

Cisco 7200, 3600, 2600 Series

O Cisco IOS 12.1(2)T introduziu o suporte ao CBWFQ nas séries 7200, 2600/3600 e em plataformas não Route Switch Processor (RSP). (Para obter mais informações, consulte Enfileiramento com Baixa Latência (LLQ) sobre Frame Relay.) Nessas plataformas, o CBWFQ nas interfaces Frame Relay está sempre no contexto da Frame Relay TS. Use o comando frame-relay traffic-shaping para habilitar a Frame Relay TS. Não é possível usar o CBWFQ com o Generic Traffic Shaping (GTS) e o comando shape nessas plataformas. Um exemplo de configuração é apresentado a seguir.

Exemplo de Configuração do CBWFQ na Cisco 7200, 3600, 2600 Series

 policy-map mypolicy
  class voice
   priority 16
  class priority-data
   bandwidth 16

!--- Crie um mapa de políticas e aplique o comando
!--- bandwidth a uma classe. 

!
 int s0/0
  encapsulation frame-relay IETF
  load-interval 30
  frame-relay traffic-shaping

!--- Habilite o TS do Frame Relay. 

!
 interface Serial0/0.1 point-to-point
  frame-relay interface-dlci 100
    class frclass

!--- Aplique o mapa de classes ao PVC do Frame Relay. 

!
 map-class frame-relay frclass
  service-policy output mypolicy
  frame-relay cir 64000
  frame-relay bc 640

!--- Aplique a política de serviço dentro do mapa de classes.

Nota: Se você habilitar uma política de serviço diretamente em uma interface principal e não em um comando map-class, não será possível aplicar a Frame Relay TS diretamente à interface. É importante observar que os mecanismos de enfileiramento se aplicam a uma única fila de interface grande, e não a filas por circuito virtual (VC).

Na Cisco 7200 Series, a partir do Cisco IOS Software versão 12.0(26)S, não é mais possível configurar uma política de serviço de saída em um comando frame-relay map-class. Em vez disso, a configuração do Cisco 7500 deve ser aplicada conforme explicado na próxima seção. Um mapa de políticas hierárquico deve ser configurado com modelagem em uma política pai e enfileiramento em uma política filha. A política pai deve então ser associada à interface principal ou à subinterface. Se você tentar configurar uma saída de política de serviço no comando map-class frame-relay, a seguinte mensagem de erro será mostrada:

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Cisco 7500 Series

Assim como no Cisco IOS 12.1(5)T, as políticas de QoS devem ser executadas no modo distribuído no VIP, pois não há mais suporte à QoS com base em RSP. Assim, você deve usar o comando shape e outros comandos da CLI modular de QoS para implementar a DTS para interfaces Frame Relay em VIPs da Cisco 7500 Series. A DTS combina GTS e Frame Relay TS. Um exemplo de configuração é fornecido em Configuração da Modelagem de Tráfego Distribuída e a seguir.

Exemplo de Configuração de DTS com Uma Política Hierárquica

ip cef distributed
 !
 class-map 1
   match < >

!--- Define critérios de compatibilidade.

 class-map 2
   match < >

!--- Define critérios de compatibilidade.

 !
 policy-map CBWFQ
   class 1
     bandwidth < >
     !--- Define o valor em kbps ou percentagem.
   class 2
     priority < >
 
!--- Define o valor em kbps ou percentagem.

 !
 Policy-map SHAPE
    class class-default
     shape average
     service-policy CBWFQ
 !
 int s0/0/0
   encapsulation frame-relay
   ip route-cache distributed
 !
 int s0/0/0.1 point-to-point
   ip address a.b.c.d
   frame-relay interface-dlci xxx
    class cisco
 !
 map-class frame-relay cisco
   service-policy output SHAPE

Escolha de Onde Aplicar uma Política de Serviço

Ao configurar o CBWFQ, você usa os comandos da CLI modular de QoS para criar um mapa de políticas de tráfego com várias classes de tráfego e um ou mais recursos de QoS. Nas versões atuais do Cisco IOS Software, as interfaces de Frame Relay aceitam a aplicação de mapas de políticas com o comando service-policy a interfaces, subinterfaces e VCs. Apenas as combinações corretas de políticas são aceitas agora A tabela a seguir descreve especificamente onde é possível aplicar uma política de QoS com modelagem de tráfego.

 

Cisco 7500 Series

Cisco 7200, 2600/3600 Series e outras plataformas

Interface principal

Configure uma política de serviço na interface principal

Aceita somente se a Frame Relay TS não estiver habilitada e os mecanismos de enfileiramento se aplicarem a um único pipe de interface.

Subinterface

Configure uma política de serviço na subinterface.

Configure uma política de serviço em uma classe de mapa de Frame Relay e habilite o enfileiramento por VC com o comando frame-relay traffic-shaping. Você pode aplicar a classe de mapa à subinterface.

Nível de VC

 

Configure uma política de serviço em uma classe de mapa de Frame Relay e habilite o enfileiramento por VC com o comando frame-relay traffic-shaping. Você pode aplicar a classe de mapa ao VC.

Problemas Conhecidos

Ao configurar o CBWFQ em interfaces de Frame Relay, observe o seguinte:

  • Após o recarregamento de um roteador, os contadores de correspondência de pacotes de uma política de serviço talvez não sejam incrementados quando a política for aplicada à interface principal. Para solucionar esse problema, certifique-se de que os flags de classificação de Weighted Fair Queueing (WFQ) sejam copiados da interface principal para as subinterfaces.

  • Não há suporte à configuração do LLQ e da Frame Relay TS ao mesmo tempo no nível de interface física. O roteador remove a política de serviço da configuração em execução após o recarregamento de um roteador. A política de serviços deve ser anexada a classe de mapa quando a Frame Relay TS está habilitada na interface. Tentar configurar esta combinação resultará na mensagem de erro CBWFQ: Not supported on this interface.

  • Quando uma política de serviço com CBWFQ é aplicada diretamente a uma interface principal de Frame Relay (como tal, enfileiramento não baseado em VC), a política poderá ser removida após um recarregamento do roteador se as instruções bandwidth estiverem configuradas em uma subinterface e em uma interface principal. O roteador pode relatar mensagens de log semelhantes às seguintes:

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps)
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    Esse problema é resolvido alterando-se o comportamento do CBWFQ para ignorar as notificações quando bandwidth na subinterface é alterado, já que o CBWFQ pode ser configurado fora de um mapa de classe de Frame Relay somente no nível da interface principal. Como solução alternativa, remova o comando bandwidth da subinterface. Se você estiver usando bandwidth na subinterface para influenciar a métrica de roteamento, use um método alternativo como custo, como no protocolo OSPF, ou retardo, como no protocolo EIGRP.

Notas de Configuração

  • Quando os comandos bandwidth e priority calculam a quantidade total de largura de banda disponível em uma entidade, as seguintes diretrizes são chamadas quando a entidade é modelada como um PVC (circuito virtual permanente) de Frame Relay:

    • Se uma taxa mínima aceitável de informações comprometidas (minCIR) não estiver configurada, a CIR será dividida por dois.

    • Se uma minCIR estiver configurada, a definição da minCIR será usada no cálculo.

    • A largura de banda total da taxa acima pode ser atribuída a classes de prioridade e de largura de banda. Portanto, o comando max-reserved-bandwidth não é aceito em PVCs de Frame Relay, embora você deva garantir que a quantidade de largura de banda configurada seja grande o suficiente para acomodar também o overhead da Camada 2 (L2). Para obter mais informações, consulte Que Bytes São Contatos pelo Enfileiramento de CoS de IP para ATM?.

  • Evite definir a CIR ou a minCIR na taxa de acesso. Caso contrário, você poderá ver filas de saída aumentando e gerando grandes retardos nas classes de CBWFQ. A razão é que a taxa de modelagem não leva em consideração os bytes de overhead dos campos de sinalização e verificação de redundância cíclica (CRC). Portanto, a modelagem na taxa de linha está, na verdade, com excesso de assinaturas e provocará o congestionamento da interface. Na realidade, não há motivo algum para modelar na taxa de acesso. Você deve sempre modelar o tráfego a 95% da taxa de acesso ou, de forma mais geral, a taxa modelada agregada deve ser sempre 95% abaixo da taxa de acesso.

  • Quando o FRF.12 está configurado, o tamanho da fila de saída aumenta para acomodar o mesmo número de bytes que são fragmentados agora. Em outras palavras, você vai de uma fila de pacotes para uma fila de fragmentos.

  • O WFQ por VC está incluído no Cisco IOS Software versão 12.0(7)T.

  • O CBWFQ com GTS está incluído no Cisco IOS Software versão 12.1(2)T.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 18661