IP : Serviços de endereçamento IP

Exemplo de Configuração Usando o Comando ip nat outside source static

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (1 Junho 2006) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração
      Diagrama de Rede
      Configurações
Verificação
Troubleshooting
Resumo
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas neste documento para obter mais informações.

Componentes Utilizados

As informações contidas neste documento são baseadas em Cisco 2500 Series Routers com Cisco IOS® Software Release 12.2(27) .

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configuração

Esta seção apresenta as informações necessárias para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza esta configuração de rede.

2a.gif

Quando você executa um ping proveniente da interface Loopback1 do Roteador 2514W destinado à interface Loopback0 do Roteador 2501E, o seguinte cenário ocorre.

Na interface externa (S1) do Roteador 2514X, o comando ping packet surge com um endereço de origem (SA) 172.16.89.32 e um endereço de destino (DA) 171.68.1.1. O NAT converte o SA para o endereço local externo 171.68.16.5 (de acordo com o comando ip nat outside source static configurado no Roteador 2514X). O Roteador 2514X verifica então a tabela de roteamento para obter uma rota para 171.68.1.1. Se não houver uma rota, o Roteador 2514X descartará o pacote. Neste caso, o Roteador 2514X possui uma rota para 171.68.1.1 por meio da rota estática para 171.68.1.0. Ele encaminha o pacote para o destino. O roteador 2501E enxerga o pacote em sua interface de entrada (E0) com um SA 171.68.16.5 e um DA 171.68.1.1. Ele responde ao enviar uma resposta de eco do Internet Control Message Protocol (ICMP) para 171.68.16.5. Se não houver uma rota, ele descartará o pacote. No entanto, neste caso, ele possui a rota (padrão). Assim, ele envia um pacote de resposta para o Roteador 2514X usando SA 171.68.1.1 e um DA 171.68.16.5. O roteador 2514X detecta o pacote e verifica se há uma rota para o endereço 171.68.16.5. Caso não haja uma, ele responderá com uma resposta de inalcançável de ICMP. Nesse caso, ele possui uma rota para 171.68.16.5 (devido à rota estática). Assim, ele converte o pacote de volta para o endereço 172.16.89.32 e o encaminha para sua interface externa (S1).

Configurações

Este documento utiliza estas configurações:

Roteador 2514W

hostname 2514W
!


!--- Saída suprimida.

interface Loopback1
 ip address 172.16.89.32 255.255.255.0
!
interface Ethernet1
 no ip address
 no ip mroute-cache
!
interface Serial0
 ip address 172.16.191.254 255.255.255.252
 no ip mroute-cache
!

!--- Saída suprimida.

ip classless
ip route 0.0.0.0 0.0.0.0 172.16.191.253

!--- Rota padrão para encaminhar pacotes para 2514X.

!


!--- Saída suprimida.

Roteador 2514X

hostname 2514X
!


!--- Saída suprimida.

ip nat outside source static 172.16.89.32 171.68.16.5

!--- Endereço local externo.

!


!--- Saída suprimida.

interface Ethernet1
 ip address 171.68.192.202 255.255.255.0
 ip nat inside

!--- Define Ethernet 1 como uma interface interna de NAT.

 no ip mroute-cache
 no ip route-cache
!
interface Serial1
 ip address 172.16.191.253 255.255.255.252
 no ip route-cache
 ip nat outside

!--- Define Serial 1 como uma interface externa de NAT.

 clockrate 2000000



!


!--- Saída suprimida.

ip classless
ip route 171.68.1.0 255.255.255.0 171.68.192.201
ip route 171.68.16.0 255.255.255.0 172.16.191.254

!--- Rotas estáticas para alcançar as interfaces de loopback


!--- em 2514E e 2514W.

!


!--- Saída suprimida.

Roteador 2501E

hostname rp-2501E
!


!--- Saída suprimida.

interface Loopback0
 ip address 171.68.1.1 255.255.255.0
!
interface Ethernet0
 ip address 171.68.192.201 255.255.255.0
!


!--- Saída suprimida.

ip classless
ip route 0.0.0.0 0.0.0.0 171.68.192.202

!--- Rota padrão para encaminhar pacotes para 2514X.

!


!--- Saída suprimida.

Verificação

Use esta seção para verificar se a sua configuração funciona corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Use o comando show ip nat translations para verificar as entradas de conversão, conforme mostrado nesta saída.

2514X#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- ---                ---                171.68.16.5        171.16.89.32
2514X#

Troubleshooting

Esse exemplo usa a depuração da conversão de NAT e a depuração de pacotes IP para demonstrar o processo de NAT.

Nota: Como os comandos debug geram uma quantidade significativa de saída, use-os somente quando houver pouco tráfego na rede para que as outras atividades do sistema não sejam afetadas.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Esta saída é o resultado da execução dos comandos debug ip packet e debug ip nat simultaneamente no Roteador 2514X enquanto um ping do endereço da interface Loopback1 do Roteador 2514W (172.16.89.32) é enviado para o endereço da interface Loopback0 do Roteador 2501E (171.68.1.1):

Esta saída mostra o primeiro pacote a chegar na interface externa do Roteador 2514X. O endereço de origem 172.16.89.32 é convertido para 171.68.16.5. O pacote ICMP é encaminhado para o destino a partir da interface Ethernet1.

5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [171]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0

Esta saída mostra o pacote de retorno proveniente de 171.68.1.1 com um endereço de destino 171.68.16.5, o qual é convertido para 172.16.89.32. O pacote ICMP resultante é encaminhado para a interface Serial1.

5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [171]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0

A troca de pacotes ICMP continua. O processo de NAT para esta saída de depuração é o mesmo que a saída anterior.

5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [172]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [172]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0
5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [173]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [173]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0
5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [174]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [174]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0
5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [175]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [175]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0

Resumo

Quando o pacote trafega do exterior para o interior, a conversão ocorre primeiro. Em seguida, a tabela de roteamento é consultada em busca do destino. Quando o pacote trafega do interior para o exterior, a tabela de roteamento é examinada primeiro em busca do destino e, em seguida, a conversão ocorre. Consulte Ordem de Operação do NAT para obter informações adicionais.

É importante observar qual parte do pacote IP é convertida quando cada um dos comandos discutidos neste documento é usado. Esta tabela contém uma diretriz:

Command

Ação

ip nat outside source static

  • Converte a origem dos pacotes de IP que trafegam de fora para dentro.

  • Converte o destino dos pacotes IP que trafegam de dentro para fora.

ip nat inside source static

  • Converte a origem dos pacotes IP que trafegam de dentro para fora.

  • Converte o destino dos pacotes IP que trafegam de fora para dentro.

Essas diretrizes indicam que há mais do que uma maneira de converter um pacote. Dependendo das suas necessidades específicas, você deve determinar como definir as interfaces de NAT (interna ou externa) e quais rotas a tabela de roteamento deve conter antes ou após a conversão. Lembre-se de que a parte do pacote que é convertida depende da direção na qual o pacote trafega e de como o NAT está configurado.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 13773