IP : Roteamento IP

Definindo uma Rota Preferencial Influenciando as Métricas de EIGRP

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback

Interativo: Este documento oferece uma análise personalizada de seu dispositivo Cisco.

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Informações de Apoio
Histórico - Fundamentos de Métricas de EIGRP
Possíveis Configurações
      Configuração Padrão de Compartilhamento de Carga
      Alteração do Parâmetro de Atraso de Interface em R4
      Uso de uma lista de deslocamento em R4 para Modificar a Métrica Composta em R2
      Alteração da Distância Administrativa em R2
      Alteração da Largura de Banda em R2
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento descreve como criar uma rota preferencial influenciando as métricas de EIGRP (Enhanced Interior Gateway Routing Protocol). Com base na topologia mostrada no diagrama de rede, este documento descreve diversas maneiras de influenciar o tráfego IP dos clientes para os servidores de modo que o caminho R1>R2>R3 seja o preferencial. O objetivo é tornar R1>R2>R4 um caminho alternativo que seja utilizado somente em caso de falha em R3.

Pré-requisitos

Requisitos

Este documento requer um conhecimento básico de roteamento IP e roteamento EIGRP. Para obter mais informações sobre roteamento IP e EIGRP, consulte estes documentos:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware.

  • O suporte para o EIGRP está disponível no Cisco IOS® Software Release 9.21 e posterior. As informações neste documento são baseadas no Cisco IOS Software Release 12.3(3).

  • O EIGRP pode ser configurado em todos os roteadores (como os Cisco 2500 series e os Cisco 2600 series) e em todos os switches da Camada 3.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Informações de Apoio

Há vários métodos para definir uma rota preferencial influenciando as métricas de EIGRP. Este documento descreve esses métodos, bem como suas vantagens e desvantagens. Ele também descreve o que acontece quando a largura de banda é modificada, embora esse procedimento não seja uma forma viável de alterar o caminho neste exemplo.

14_a.gif

Clique no diagrama de rede para exibi-lo em outra janela do navegador, a fim de utilizá-lo como referência mais adiante neste documento.

Dois dos comandos utilizados neste documento para verificar o comportamento do EIGRP sãoshow ip eigrp topology e show ip eigrp topology network-ip subnet-mask.

Nota: Para obter mais informações sobre os comandos utilizados neste documento, consulte a Command Lookup Tool (somente clientes registrados).

Se tiver a saída de um comando show ip eigrp topology ou show ip eigrp topology network-ip subnet-mask do seu dispositivo Cisco, você poderá utilizar a Output Interpreter (somente clientes registrados) para exibir possíveis problemas e correções. Para utilizar a Output Interpreter (somente clientes registrados), você deverá ter feito login e ter o JavaScript ativado em seu navegador.

Histórico - Fundamentos de Métricas de EIGRP

As atualizações do EIGRP contêm cinco métricas: largura de banda mínima, atraso, carga, confiabilidade e MTU (unidade máxima de transmissão). Dessas cinco métricas, por padrão, somente a largura de banda mínima e o atraso são utilizados para calcular o melhor caminho. Diferentemente da maioria das métricas, a largura de banda mínima é definida como a largura de banda mínima de todo o caminho e não reflete quantos saltos ou links de largura de banda baixa existem no caminho. O atraso é um valor cumulativo que aumenta com base no valor de atraso de cada segmento no caminho. Para obter mais informações sobre as métricas de EIGRP, consulte o White Paper Enhanced Interior Gateway Routing Protocol.

Possíveis Configurações

Estas configurações podem ser utilizadas para definir uma rota preferencial.

Configuração Padrão de Compartilhamento de Carga

R1

R1# show run

Current configuration: 640 bytes
!
version 12.3
!
hostname R1
!
interface Serial0
 no ip address
 encapsulation frame-relay

!--- Habilita o encapsulamento Frame Relay.

!
interface Serial0.201 point-to-point

!--- Habilita um link ponto a ponto na subinterface.

 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 201

!--- Atribui um identificador de conexão de link de dados (DLCI)
!--- a uma subinterface Frame Relay.

!
router eigrp 1
 network 10.0.0.0
!
end

Nota: O switch Frame Relay está oculto no diagrama de rede.

R1# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:07:08, Serial0.201
D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:07:08, Serial0.201
C       10.1.1.0 is directly connected, Serial0.201

R1# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
  Routing Descriptor Blocks:
  10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
      Composite metric is (2221056/307200), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 22000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2

R2

R2# show run

Current configuration: 618 bytes
!
version 12.3
!
hostname R2
!
interface Ethernet0
 ip address 10.1.2.2 255.255.255.0
 no ip directed-broadcast
!
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.101 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 101
!
router eigrp 1
 network 10.0.0.0
!
end

R2# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/307200] via 10.1.2.4, 00:03:47, Ethernet0
                 [90/307200] via 10.1.2.3, 00:03:48, Ethernet0
C       10.1.2.0 is directly connected, Ethernet0
C       10.1.1.0 is directly connected, Serial0.101

Nota: R2 possui dois caminhos de custos idênticos para 10.1.3.0/24 através de R3 (10.1.2.3) e R4 (10.1.2.4).

R2# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 307200
  Routing Descriptor Blocks:
  10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Nota: Ambos os caminhos possuem a mesma Métrica Composta (Distância/Distância Relatada). A FD (Distância Viável) para R1 é anunciada, tornando-se a Distância Relatada de R1.

R3

R3# show run

Current configuration: 556 bytes
!
version 12.3
!
hostname R3
!
interface Ethernet0/0
 ip address 10.1.2.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.3 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R3# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:16:14, Ethernet0/0

R3# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.4 (Ethernet0/0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

R3# show interface ethernet0/1

Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 0050.7329.52e1 (bia 0050.7329.52e1)
  Internet address is 10.1.3.3/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     291 packets input, 28402 bytes, 0 no buffer
     Received 283 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     500 packets output, 50876 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

R4

R4# show run

Current configuration: 549 bytes
!
version 12.3
!
hostname R4
!
interface Ethernet0/0
 ip address 10.1.2.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.4 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R4# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:17:08, Ethernet0/0

R4# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

Alteração do Parâmetro de Atraso de Interface em R4

Como as alterações na métrica de atraso são propagadas para todos os roteadores downstream, a alteração do parâmetro de atraso de interface é o método preferencial para influenciar a seleção do caminho nestes dois cenários:

  • O segmento Ethernet 10.1.3.0/24 contém somente servidores e não há outras sub-redes atrás da sub-rede 10.1.3.0/24. (Essa configuração é ideal para um server farm).

  • Você deseja influenciar a seleção de caminho para todas as rotas aprendidas através de vizinhos do EIGRP no segmento 10.1.3.0/24.

  1. Verifique o atraso na interface antes de fazer quaisquer alterações.

    No momento, ele está definido como o mesmo valor de atraso de R3, conforme mostrado aqui.

    R4# show interface ethernet0/1
    
    Ethernet0/1 is up, line protocol is up
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         284 packets input, 27914 bytes, 0 no buffer
         Received 276 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         482 packets output, 49151 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  2. Altere o valor do atraso no segmento 10.1.3.0/24.

    Tenha cuidado ao selecionar o novo atraso. Evite aumentar o atraso até um ponto no qual R2 não veja mais a rota como um sucessor viável.

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# interface ethernet0/1
    
    R4(config-if)# delay 120
    
    !--- O atraso é inserido em dezenas de microssegundos.
    
    R4(config-if)# end
    
    R4#
  3. Confirme se o atraso dessa interface foi alterado para 1200 microssegundos.

    R4# show interface ethernet0/1
    
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1200 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:03, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         345 packets input, 33508 bytes, 0 no buffer
         Received 333 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         575 packets output, 57863 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  4. Confirme se R2 possui apenas uma rota 'melhor' para 10.1.3.0 via R3.

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:02:43, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101
    
    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (312320/286720), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2200 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

    O comando show ip eigrp topology mostra que a métrica de atraso anunciada por R4 foi aumentada em 200 (para 2200 microssegundos), conforme o esperado. Esse aumento faz com que as duas rotas tenham custos diferentes e impede o balanceamento de carga de R2.

    Nota: Como a distância anunciada por R4 (286720) é menor do que a distância anunciada por R2 (a distância viável, 307200), o caminho é considerado sem loops. Como o caminho anunciado por R4 é considerado sem loops, ele é um sucessor viável e será instalado imediatamente se R3 parar de anunciar uma rota para 10.1.3.0/24.

    R1# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:25:27, Serial0.201
    D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:25:27, Serial0.201
    C       10.1.1.0 is directly connected, Serial0.201
    
    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

Utilização de uma Lista de Deslocamento em R4 para Modificar a Métrica Composta em R2

A Métrica Composta em R2 pode ser modificada com o uso de uma lista de deslocamento no roteador R4. O valor de lista de deslocamento 20 em R4 aumenta em 20 a Métrica Composta do caminho R2-R4 em R2. Portanto, o caminho R2-R4 torna-se um caminho alternativo para R2-R3. Uma lista de deslocamento será o método preferencial se:

  • Você desejar influenciar somente um caminho específico anunciado.

  • Outros roteadores estiverem conectados à sub-rede 10.1.3.0/24 e você não desejar influenciar os caminhos originados por eles.

  1. Configure uma lista de deslocamento em R4 que aumente (em 20) o atraso de qualquer rota que inicie com 10.1.3.x.

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R4(config)# router eigrp 1
    
    R4(config-router)# offset-list 99 out 20 e0/0
    
    R4(config-router)# end
    
    R4#
  2. Nesta saída, é possível ver que a lista de deslocamento não implementa alteração alguma na tabela de topologia EIGRP em R4.

    A métrica só é alterada quando a rota é anunciada.

    R4# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
      Routing Descriptor Blocks:
      0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
          Composite metric is (281600/0), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 1000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 0
      10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  3. Em R2, confirme se a rota através de R3 (10.1.2.3) é novamente o único melhor caminho.

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:00:20, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    A tabela de topologia EIGRP reflete o aumento no atraso de R4 (10.1.2.4).

    Distância viável de R4 (281600) + Lista de deslocamento de R4 (20) = Distância relatada de R4 (281620).

    Nota: Um defeito superficial no Cisco IOS Software Release 12.0(7) impede que o aumento no atraso seja refletido com precisão na seção Total Delay da saída mostrada aqui.

    DDTS

    Descrição

    CSCdp36097 (somente clientes registrados)

    EIGRP: a lista de deslocamento adiciona um valor de atraso incorreto

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307220/281620), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

Alteração da Distância Administrativa em R2

Também é possível alterar o processo de seleção de caminho modificando-se a distância administrativa da rota aprendida de R4 em R2. Esse método não é tão bom quanto os outros. Ele pode aumentar a probabilidade de que ocorram loops de roteamento pelos motivos listados aqui:

  • Em geral, a distância administrativa é utilizada para determinar o método pelo qual uma rota foi aprendida. Se ela for definida incorretamente, o roteador não poderá escolher uma rota redistribuída, em vez do melhor caminho real.

  • As distância administrativa não é propagada para outros roteadores. Os protocolos de roteamento consideram que todos os roteadores escolhem o mesmo caminho com base no mesmo conjunto de parâmetros. A alteração dos parâmetros em um único roteador poderá resultar em loops de roteamento.

  1. Altere a configuração de R2 de modo que, quando uma atualização de roteamento de R4 (10.1.2.4) para a sub-rede 10.1.3.0/24 for detectada, a distância administrativa seja aumentada para 91.

    O valor 91 é escolhido porque é uma unidade maior que a distância administrativa EIGRP padrão para rotas internas (que é 90). A distância administrativa padrão para rotas externas EIGRP (rotas redistribuídas para o EIGRP) é 170. Consulte a Tabela de Valores de Distância Padrão no documento O Que É Distância Administrativa? para obter os valores padrão de todos os protocolos de roteamento.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R2(config)# router eigrp 1
    
    R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99
    
    R2(config-router)# end
    
    R2#
  2. Neste momento, talvez seja necessário executar o comando clear ip route para que as alterações tenham efeito.

    Nota: Agora existe apenas um caminho para 10.1.3.0/24 através de R3 (10.1.2.3).

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:05:28, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    Nota: Não há qualquer alteração na tabela de topologia EIGRP.

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

Possíveis Problemas

Para ilustrar um possível problema que esse método poderá ocasionar se não for utilizado com cautela, imagine que R1 e R2 estejam executando o OSPF (Open Shortest Path First), com uma distância administrativa de 110, para a rede 11.0.0.0/8. Imagine também que R4 tenha uma rota estática para 11.1.1.0/24 que aponte para R2 (10.1.2.2). R4 está redistribuindo as rotas estáticas no EIGRP para que alguns roteadores novos em 10.1.3.0/24 possam chegar a 11.1.1.0/24.

Normalmente, R2 recebe a rota externa EIGRP para 11.1.1.0/24 de R4 com uma distância administrativa igual a 170. Como essa distância é maior que a da rota OSPF (110), ela não é instalada.

Esta saída é um exemplo do comando de distância utilizado acima quando configurado incorretamente.

R2# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)# access-list 99 permit 11.1.1.0 0.0.0.255

R2(config)# router eigrp 1

R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99

R2(config-router)# end

R2#

Essa configuração cria um loop de roteamento entre R2 e R4 para a sub-rede 11.1.1.0/24. Agora, R2 prefere a rota 11.1.1.0/24 anunciada por R4. Isso ocorre porque a distância administrativa (91) é menor do que a distância administrativa da rota OSPF (110).

Alteração da Largura de Banda em R2

Não se aconselha utilizar a largura de banda para influenciar os caminhos do EIGRP por duas razões:

  • A alteração da largura de banda poderá ter um impacto maior do que simplesmente afetar as métricas de EIGRP. Por exemplo, a qualidade de serviço (QoS) também examina a largura de banda em uma interface.

  • O EIGRP é limitado para utilizar 50% da largura de banda configurada. A redução da largura de banda poderá ocasionar problemas, como, por exemplo, impedir que os vizinhos do EIGRP recebam pacotes de hello por causa dessa limitação.

A alteração do atraso não afeta outros protocolos nem limita o EIGRP.

  1. Verifique a tabela de topologia EIGRP de R1 antes de fazer quaisquer alterações.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
  2. Verifique os valores iniciais da interface ethernet0 em R2.

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:01, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1938 packets input, 165094 bytes, 0 no buffer
         Received 1919 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1482 packets output, 124222 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  3. Reduza a largura de banda para ver o impacto em R1.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet0
    
    R2(config-if)# bandwidth 5000
    
    R2(config-if)# end
    
    R2#
  4. Confirme a alteração.

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 5000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:01, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1995 packets input, 169919 bytes, 0 no buffer
         Received 1969 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1525 packets output, 127831 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  5. Confirme se ela também foi alterada na tabela de topologia EIGRP.

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 2 Successor(s), FD is 563200
      Routing Descriptor Blocks:
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  6. Verifique o impacto na tabela de topologia EIGRP em R1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/563200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

    Não há nenhuma alteração, uma vez que a conexão Frame Relay entre R1 e R2 ainda é o link de menor velocidade. Você só verá uma alteração se reduzir essa largura de banda na interface ethernet0 de R2 para um valor menor que 1544.

  7. Reduza a largura de banda na interface ethernet0 de R2 para 1000.

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet 0
    
    R2(config-if)# bandwidth 1000
    
    R2(config-if)# end
    
    R2#
  8. Verifique o impacto na tabela de topologia EIGRP em R1.

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): Topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 312320
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (3123200/2611200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1000 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 13673