Switches de LAN : EtherChannel

Exemplo de Configuração de EtherChannels entre Catalyst 3550/3750 Series Switches e Catalyst Switches com o Cisco IOS System Software

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (25 Setembro 2008) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
      Teoria de Apoio
      Notas Importantes
Configuração
      Diagrama de Rede
      Configurações
Verificação
      Catalyst 3550
      Catalyst 6500/6000
Troubleshooting
      Estado Err-Disable
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento apresenta um exemplo de como estabelecer um EtherChannel entre um Catalyst 3550 e um Catalyst 6500/6000 que executa o Cisco IOS® System Software. O EtherChannel pode ser chamado de Fast EtherChannel ou Gigabit EtherChannel, dependendo da velocidade das interfaces ou portas usadas para formá-lo.

Nota: Os comandos de EtherChannel aplicados ao Catalyst 3550 Switch neste documento também podem ser aplicados aos Catalyst 3750 Series Switches.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Catalyst 3550 Switch com Cisco IOS® Software Release 12.1(14)EA

  • Catalyst 6500/6000 Switch com Cisco IOS® Software Release 12.1(13)E1

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Teoria de Apoio

Neste documento, duas interfaces Gigabit Ethernet em um Catalyst 3550 Switch -- a interface GigabitEthernet no 3500 é uma interface Ethernet 10/100/1000 negociada -- foram colocadas em um Fast EtherChannel com duas interfaces Fast Ethernet de um Catalyst 6500/6000 Switch com Cisco IOS System Software para formar um EtherChannel da Camada 2 (L2).

Nota: Neste documento, os termos Fast EtherChannel, Gigabit EtherChannel, canal de portas e grupo de canais referem-se a EtherChannels.

A configuração do Catalyst Switch neste documento se aplica a qualquer Catalyst 6500/6000 ou Catalyst 4500/4000 Series Switch que executa o Cisco IOS System Software.

Este documento mostra arquivos de configuração apenas para os switches, bem como a saída dos comandos show de exemplo relacionados. Para obter detalhes de como configurar um EtherChannel, consulte estes documentos:

Notas Importantes

Um EtherChannel pode ser configurado manualmente com os comandos apropriados. Você também pode configurá-lo automaticamente usando o protocolo PAgP para que o switch negocie o canal com o outro lado. Para obter detalhes sobre o PAgP, consulte estes documentos:

As configurações nesse documento são implementadas com o uso do modo desejado. Se você planeja configurar o EtherChannel manualmente, siga os passos fornecidos para criar um canal de portas. Isso evita problemas com o Spanning Tree Protocol (STP) durante o processo de configuração. O STP poderá desativar algumas portas, com um status de porta de error-disabled [errdisable], se um lado for configurado como um canal antes do outro poder ser configurado da mesma forma.

Siga estes passos para criar um canal de portas:

  1. Mantenha as interfaces que serão usadas no canal de portas como desativadas administrativamente.

  2. Crie o canal de portas (grupo de canais) no Catalyst 6500/6000 Switch.

    Certifique-se de definir o modo do canal como on. Por exemplo, channel-group 1 mode on.

  3. Crie canais de portas no Catalyst 3550, 3560 ou 3750 Switch.

    Certifique-se de definir o modo do canal como on.

  4. Reabilite as interfaces que foram desabilitadas anteriormente no Catalyst 6500/6000 Switch com o comando no shut.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para obter informações adicionais sobre os comandos usados neste documento, use a Command Lookup Tool (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

89-a.gif

Nota: A interface Gigabit Ethernet no Catalyst 3550 é uma interface Ethernet de 10/100/1000 Mbps negociada. A porta Gigabit no Catalyst 3550 também pode ser conectada a uma porta FastEthernet (100 Mbps) em um Catalyst 6500/6000.

Nota: Os Catalyst 3750 Series Switches oferecem suporte ao EtherChannel de pilha cruzada, o que permite que interfaces de switches em stack diferentes sejam membros do mesmo grupo de EtherChannel. Para obter mais informações sobre EtherChannels em um ambiente de switch em stack, consulte a seção EtherChannel e Switches em Stack da documentação Configurando EtherChannels dos Catalyst 3750 Series Switches.

Configurações

Este documento utiliza estas configurações:

Catalyst 3550

Building configuration...
Current configuration : 1610 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
enable password ww
!
ip subnet-zero
no ip finger
!
!
!
!
!--- Uma interface de canal de portas lógico é criada automaticamente
!--- quando portas são agrupadas em um grupo de canais.

interface Port-channel 1


!--- Neste exemplo, o EtherChannel L2 é configurado.
!--- Um EtherChannel da Camada 3 (L3) também pode ser configurado nos Catalyst 3550 Switches.
!--- Para obter mais informações, consulte o documento Configurando o EtherChannel.

switchport mode access no ip address snmp trap link-status!

!--- Nota: A interface Gigabit Ethernet no Catalyst 3550 é uma
!--- interface Ethernet negociada de 10/100/1000 Mbps. A porta Gigabit no Catalyst 3550 é
!--- conectada a uma porta FastEthernet (100 Mbps) no Catalyst 6500/6000.

!--- A porta é um membro do grupo de canais 1.

interface GigabitEthernet0/1
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!


!--- A porta é um membro do grupo de canais 1.

interface GigabitEthernet0/2
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!
interface GigabitEthernet0/3
 switchport mode access
 no ip address
 snmp trap link-status
!


!--- Saída suprimida.

interface GigabitEthernet0/12
 switchport mode access
 no ip address
 snmp trap link-status


!--- A interface VLAN1 é necessária para fins de gerenciamento.

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 transport input none
line vty 5 15
!
end

Catalyst 6500/6000

Building configuration...

 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !


!--- Uma interface de canal de portas lógico é criada automaticamente
!--- quando portas são agrupadas em um grupo de canais.

 interface Port-channel 1
  no ip address
  switchport
  switchport mode access
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !

!--- Nota: A interface Gigabit Ethernet no Catalyst 3550 é uma
!--- interface Ethernet negociada de 10/100/1000 Mbps. A porta Gigabit no Catalyst 3550 é
!--- conectada a uma porta FastEthernet (100 Mbps) no Catalyst 6500/6000.

 interface FastEthernet3/1
  no ip address


!--- Neste exemplo, o EtherChannel L2 é configurado.
!--- Um EtherChannel L3 também pode ser configurado no Catalyst 6500/6000 que executa o
!--- Cisco IOS System Software. Para obter mais detalhes, consulte o documento
!--- Configurando o EtherChannel.

!--- Em um Catalyst 6500/6000, você deve executar o comando switchport
!--- uma vez, sem nenhuma palavra-chave, para configurar a interface como uma porta L2.
!--- Por padrão, todas as portas são portas de roteador (portas L3).
!--- Em um Catalyst 4500/4000 Switch, todas as portas são L2 por padrão.
!--- Nenhum comando adicional é necessário.

 switchport

!--- Este comando coloca a interface em VLAN1 por padrão.

 switchport mode access

!--- A porta é um membro do grupo de canais 1.

 channel-group 1 mode desirable
 !
 interface FastEthernet3/2
  no ip address

!--- Em um Catalyst 6500/6000, você deve executar o comando switchport
!--- uma vez, sem nenhuma palavra-chave, para configurar a interface como uma porta L2.
!--- Por padrão, todas as portas são portas de roteador (portas L3).
!--- Em um Catalyst 4500/4000 Switch, todas as portas são L2 por padrão.
!--- Nenhum comando adicional é necessário.

  switchport

!--- Este comando coloca a interface em VLAN1 por padrão.

  switchport mode access

!--- A porta é um membro do grupo de canais 1.

  channel-group 1 mode desirable
 !
 interface FastEthernet3/3
  no ip address
 switchport
  switchport mode access
 !


!--- Saída suprimida.

 !
 interface FastEthernet3/48
  no ip address
 switchport
  switchport mode access
 !


!--- A interface VLAN1 é necessária para fins de gerenciamento.

 interface Vlan1
  ip address 10.1.1.2 255.255.255.0
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

Nota: Este exemplo de configuração mostra uma configuração de EtherChannel com links de acesso. A mesma configuração se aplica aos links de troncos do EtherChannel. Execute o comando switchport mode trunk ou permita que os switches negociem o modo com o modo dynamic desirable. Para obter mais informações sobre como configurar o entroncamento, consulte a seção Configuração de Troncos de VLAN do documento Configurando VLANs.

Verificação

Alguns comandos show são aceitos pela Output Interpreter Tool (somente clientes registrados), o que permite exibir uma análise da saída do comando show.

Para verificar o canal de portas nos Catalyst 6500/6000 e Catalyst 3500 Switches com Cisco IOS System Software, execute estes comandos:

  • show interfaces port-channel channel-group-number

  • show etherchannel channel-group-number summary

Para verificar o status do STP nos Catalyst 6500/6000 e Catalyst 3500 Switches com Cisco IOS System Software, execute este comando:

  • show spanning-tree vlan vlan-number detail

Catalyst 3550

Cat3550# show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 0002.4b28.db02 (bia 0002.4b28.db02)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
 Members in this channel: Gi0/1 Gi0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:27, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
26 packets input, 5344 bytes, 0 no buffer
Received 17 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
59 packets output, 5050 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cat3550# show spanning-tree vlan 1 detail

 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0002.4b28.db01
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:00:38 ago
          from Port-channel1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 0

 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 34, received 0

Cat3550# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Gi0/1(P)   Gi0/2(P)

Cat3550# ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Catalyst 6500/6000

Cat6500# show interface port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0002.7ef1.36e1 (bia 0002.7ef1.36e1)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s
  Members in this channel: Fa3/1 Fa3/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/2000, 0 drops
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     407 packets input, 34994 bytes, 0 no buffer
     Received 311 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     93 packets output, 16598 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Cat6500# show spanning-tree vlan 1 detail

 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.024f.6001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0002.4b28.db01
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:02:13 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

 Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 66

Cat6500# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa3/1(P)   Fa3/2(P)

Cat6500# ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Troubleshooting

Estado Err-Disable

Um problema comum na configuração de um EtherChannel é as interfaces entrarem no modo err-disable. Isso pode ocorrer quando o EtherChannel é ativado em um switch e o outro switch não é configurado imediatamente. Se isso for mantido por cerca de um minuto, o STP no switch em que o EtherChannel está habilitado pensará que há um loop. Isso faz com que as portas de canal sejam colocadas no estado err-disable. Consulte este exemplo para obter mais informações sobre como determinar se suas interfaces EtherChannel estão no estado err-disable:

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state
Switch1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SD)         -        Gi0/9(D)    Gi0/10(D)

Switch1#show interfaces GigabitEthernet 0/9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/9                        err-disabled 1            auto   auto 10/100/1000BaseTX

Switch1#show interfaces GigabitEthernet 0/10 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/10                       err-disabled 1            auto   auto 10/100/1000BaseTX

A mensagem indica que o EtherChannel encontrou um loop de spanning tree. Para resolver o problema, defina o modo do canal como desirable em ambos os lados da conexão. Em seguida, habilite as interfaces novamente:

Switch1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#interface gi0/9
Switch1(config-if)#channel-group 10 mode desirable

Isso faz com que cada lado forme um canal somente se ambos concordarem com o canal. Se não concordarem em formar um canal, eles continuarão a operar como portas normais.

Após o modo do canal ser definido como desirable em ambos os lados da conexão, execute os comandos shutdown e no shutdown na interface associada para reabilitar as portas manualmente:

Switch1(config-if)#shutdown
Switch1(config-if)#no shutdown

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 12033