Switches de LAN : EtherChannel

Exemplo de Configuração: EtherChannel entre Catalyst Switches que Executam o CatOS e o Cisco IOS Software

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (25 Outubro 2006) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
      Teoria de Apoio
Configuração
      Diagrama de Rede
      Diretrizes
      Configurações
Verificação
Exemplo de Saída do Comando show
      Catalyst 5500 Switch
      Catalyst 6500 Switch
      Consideração Especial com o Uso de uma Configuração Incondicional no Modo de Canal
Troubleshooting
      Problemas de Desempenho em EtherChannels
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento aborda a configuração de um EtherChannel entre um Catalyst 5500/5000 switch que executa o Catalyst OS (CatOS) e um Catalyst 6500/6000 ou um Catalyst 4500/4000 switch que executa o Cisco IOS® Software. Um EtherChannel agrupa links individuais em um único link lógico que fornece maior largura de banda e redundância entre switches ou outros dispositivos. O EtherChannel pode ser chamado de FEC (Fast EtherChannel) ou GEC (Gigabit EtherChannel), dependendo da velocidade das interfaces ou das portas utilizadas para formá-lo. Essa configuração também se aplica a um Catalyst 4500/4000 ou 6500/6000 series switch que executa o CatOS conectado a um Catalyst 4500/4000 ou 6500/6000 series switch que executa o Cisco IOS Software.

A configuração apresentada neste documento agrupa duas portas FE (Fast Ethernet) de cada um dos switches em um FEC. Este documento utiliza o termo "EtherChannel" para se referir ao GEC, ao FEC, a um canal de porta, a um canal e a um grupo de portas.

Este documento mostra somente os arquivos de configuração dos switches e a saída dos comandos show de exemplo relacionados. Para obter detalhes sobre como configurar um EtherChannel, consulte os seguintes documentos:

Pré-requisitos

Requisitos

Antes de testar esta configuração, você deverá ter um conhecimento básico de:

  • Configuração do EtherChannel

  • Configuração de Catalyst 6500/6000 e Catalyst 5500/5000 series switches com a Interface de Linha de Comando (CLI)

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco Catalyst 5505 switch executando o CatOS 6.4(8) software

  • Cisco Catalyst 6509 switch executando o Cisco IOS Software Release 12.1(20)E

Nota: Para saber quais são os requisitos de sistema do EtherChannel em Catalyst switches, consulte Requisitos de Sistema para Implementação do EtherChannel em Catalyst Switches.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos foram iniciados com uma configuração vazia (padrão). Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Teoria de Apoio

Você pode configurar o EtherChannel incondicionalmente (com channel mode on) ou através da negociação automática. Quando a negociação automática é utilizada, o switch negocia o canal com a extremidade oposta. Para fazer isso, ele utiliza o protocolo PAgP (Port Aggregation Protocol) proprietário da Cisco (com o comando channel mode desirable) ou o protocolo LACP (Link Aggregate Control Protocol) IEEE 802.3ad (com os comandos channel mode active ou channel mode passive). Neste documento, a configuração do EtherChannel utiliza o PAgP para negociação automática.

Todos os Catalyst switches que executam o CatOS system software oferecem suporte ao PAgP. Os Catalyst 6500/6000 ou 4500/4000 series switches que executam o Cisco IOS System Software também oferecem suporte ao PAgP. O modo recomendado para estabelecer um EtherChannel entre os dispositivos com suporte ao PAgP é o modo desirable. O PAgP fornece proteção contra configurações inadequadas entre os dois dispositivos. Você poderá utilizar o channel mode on quando o dispositivo de conexão não oferecer suporte ao PAgP e for necessário configurar o canal incondicionalmente. É possível utilizar as palavras-chave silent ou non-silent com os modos de canal auto e desirable. Os Catalyst 6500/6000 ou 4500/4000 switches possuem a palavra-chave silent ativada, por padrão, em todas as portas. Os Catalyst 5500/5000 series switches possuem a palavra-chave silent ativada, por padrão, nas portas de cobre. Para todas as portas de fibra (FE e GE [Gigabit Ethernet]), os 5500/5000 switches possuem a palavra-chave non-silent ativada, por padrão. Utilize a palavra-chave silent ou non-silent padrão para a conexão entre Cisco switches.

Nota: Para obter mais informações sobre os modos silent/non-silent e os modos de canalização PAgP, consulte as seções Utilização do PAgP para Configurar o EtherChannel (Recomendado) e Modo Sitent/Non-silent do documento Configurando o EtherChannel entre Catalyst 4500/4000, 5500/5000 e 6500/6000 Switches que Executam o CatOS System Software.

Configuração

Esta seção apresenta as informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

71a.gif

Diretrizes

Quando links ativos são agregados em um EtherChannel, as portas deixam temporariamente a Spanning Tree e associam-se de novo como uma única porta lógica. O tráfego da rede é interrompido até que ocorra a reconvergência da Spanning Tree.

Se você não utilizar protocolos, como o PAgP ou o LACP, para a configuração do EtherChannel devido a outras considerações, certifique-se de que os parâmetros necessários sejam os mesmos em ambas as extremidades. Se eles forem diferentes, uma extremidade do canal entrará no modo err-disable. Para recuperar as portas desse modo, consulte:

Configurações

Este documento utiliza estas configurações:

Nota: Para verificar os recursos de um módulo ou de uma porta do switch configurada, utilize o comando show port capabilities module nos switches que executam o CatOS. Nos switches que executam o Cisco IOS Software, utilize o comando show interfaces capabilities.

Nota: Nas configurações, os comentários entre as saídas são exibidos na cor azul em itálico.

Catalyst 5500

cat5500 (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
......
................
................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# time: Wed Jan 28 2004, 09:39:55
!

# version 6.4(2)
!
# errordetection
set errordetection portcounter enable
!
# frame distribution method
set port channel all distribution mac both
!
# vtp
set vtp domain cisco
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state
active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state
active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state
active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
# ip

!--- Este é o endereço IP usado para gerenciamento.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!
# set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat5000-supg.6-4-8.bin
!
# mls
set mls nde disable
!
# port channel


!--- As portas são atribuídas ao grupo administrativo 200. Os grupos administrativos
!--- especificam quais portas podem formar um EtherChannel em conjunto. Um grupo administrativo
!--- pode conter no máximo oito portas. Essa atribuição de grupo administrativo acontece
!--- automaticamente com a configuração do canal de portas. Você também pode
!--- fazer a atribuição manualmente, conforme feito neste exemplo. No entanto, não é necessário atribuir
!--- o grupo administrativo manualmente. Deixe o switch criar
!--- o grupo administrativo automaticamente.
!--- Nota: Esta configuração define as portas de 4/1 a 4/4
!--- para o canal de portas, mas configura somente as portas 4/1-2. Esse é
!--- o comportamento normal. Você pode usar as portas 4/3 e 4/4 para qualquer outra finalidade.

set port channel 4/1-4 200
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 : 2-port MM MIC FDDI
!
#module 3 : 24-port 10/100BaseTX Ethernet
!
#module 4 : 12-port 10/100BaseTX Ethernet

!--- Isto habilita a canalização de portas com o PAgP e configura o modo silencioso desejado.

set port channel 4/1-2 mode desirable silent
!
#module 5 : 2-port MM OC-3 Dual-Phy ATM

!--- Saída suprimida.

end

Consulte a Referência de Comandos da Família Catalyst 5000 (6.3 e 6.4) para obter mais informações sobre os comandos na configuração.

Catalyst 6500

Cat6509# show running-config
Building configuration...

Current configuration : 3852 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6509
!
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
!
interface port-channel1
 no ip address


!--- Este exemplo configurou um EtherChannel da Camada 2 (L2).
!--- Você pode configurar um EtherChannel da Camada 3 (L3) nos Catalyst
!--- 6500/6000 Switches que executam o Cisco IOS Software. No entanto, esse não é
!--- o foco deste documento. Para obter detalhes sobre a configuração do EtherChannel da Camada 3,
!--- consulte o documento Configurando EtherChannels.


 switchport


!--- Este comando coloca a interface em VLAN1 por padrão.

switchport mode access
!
interface FastEthernet6/1
no ip address

!--- No Catalyst 6500/6000, você deve executar o comando switchport uma vez,
!--- sem nenhuma palavra-chave, para configurar a interface como uma porta L2.
!--- Por padrão, todas as portas são portas de roteador (portas L3).
!--- Em um Catalyst 4500/4000 Switch, todas as portas são L2 por padrão.
!--- Nenhum comando adicional é necessário.

switchport


!--- Este comando coloca a interface em VLAN1 por padrão.

 switchport mode access


!--- A porta é um membro do grupo de canais 1 com negociação automática
!--- que usa o PAgP e o modo silencioso.

 channel-group 1 mode desirable
!
interface FastEthernet6/2
 no ip address


!--- No Catalyst 6500/6000, você deve executar o comando switchport uma vez,
!--- sem nenhuma palavra-chave, para configurar a interface como uma porta L2.
!--- Por padrão, todas as portas são portas de roteador (portas L3).
!--- Em um Catalyst 4500/4000 Switch, todas as portas são L2 por padrão.
!--- Nenhum comando adicional é necessário.

 switchport


!--- Este comando coloca a interface em VLAN1 por padrão.

 switchport mode access


!--- A porta é um membro do grupo de canais 1 com negociação automática
!--- que usa o PAgP e o modo silencioso.

 channel-group 1 mode desirable
!
interface FastEthernet6/3
 no ip address
!
interface FastEthernet6/4
 no ip address
!

!--- Saída suprimida.

interface FastEthernet6/45
 no ip address
 shutdown
!
interface FastEthernet6/46
 no ip address
 shutdown
!
interface FastEthernet6/47
 no ip address
 shutdown
!
interface FastEthernet6/48
 no ip address
 shutdown
!


!--- Este é o endereço IP usado para gerenciamento.

 ip address 10.10.10.3 255.255.255.0


!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
end
Cat6509#

Para obter mais informações sobre os comandos na configuração, consulte Referência de Comandos da Família Catalyst 5000 (6.3 e 6.4).

Nota: Se você atribuir uma interface a uma VLAN inexistente, a interface será encerrada até que você crie a VLAN no banco de dados de VLANs. Para obter mais detalhes, consulte a seção Criação ou Modificação de uma VLAN Ethernet de Configurando VLANs.

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Há suporte para alguns comandos show na Output Interpreter Tool (somente clientes registrados), o que permite exibir uma análise da saída desses comandos.

Para verificar o canal de porta nos CatOS switches, execute estes comandos:

Para verificar o status do STP (Spanning Tree Protocol) nos CatOS switches, execute estes comandos:

Para verificar o canal de porta nos Catalyst 6500/6000 ou Catalyst 4500/4000 series switches que executam o Cisco IOS Software, utilize estes comandos:

Para verificar o status do STP nos Catalyst 6500/6000 ou Catalyst 4500/4000 series switches que executam o Cisco IOS Software, utilize estes comandos:

Exemplo de Saída do Comando show

Catalyst 5500 Switch

Este comando verifica se o módulo é capaz de efetuar a canalização. Ele também informa qual grupo de portas pode ser agrupado para formar o EtherChannel. Neste exemplo, é possível agrupar as duas portas 4/1-2 ou as quatro portas 4/1-4 para formar um canal:

cat5500 (enable) show port capabilities 4
Model                    WS-X5203
Port                     4/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         ISL
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  4/1-2,4/1-4
Broadcast suppression    pps(0-150000),percentage(0-100)
Flow control             no
Security                 yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(none)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
AuxiliaryVlan            no
SPAN                     source,destination

!--- Saída suprimida.

Este comando, junto com o comando show port, verifica o status do canal de porta.

cat5500 (enable) show port channel
Port  Status     Channel              Admin Ch
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
4/1  connected  desirable silent       200   865
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----

Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ----------------
4/1  Switch                          Fa6/1                     cisco Catalyst 6000
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------
cat5500 (enable)
cat5500 (enable) show port 4/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
4/1                     connected  1          normal a-full a-100 10/100BaseTX

!--- Saída suprimida.


Port  Status     Channel              Admin Ch
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
4/1  connected  desirable silent       200   865
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----


!--- Saída suprimida.


cat5500 (enable) show port 4/2
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
4/2                     connected  1          normal a-full a-100 10/100BaseTX


!--- Saída suprimida.


Port  Status     Channel              Admin Ch
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
4/1  connected  desirable silent       200   865
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----


!--- Saída suprimida.

cat5500 (enable) show port channel info
Switch Frame Distribution Method: Mac both

Port  Status     Channel              Admin Channel Speed Duplex Vlan
                 mode                 group id
----- ---------- -------------------- ----- ------- ----- ------ ----
4/1  connected  desirable silent       200     865 a-100 a-full    1
4/2  connected  desirable silent       200     865 a-100 a-full    1
----- ---------- -------------------- ----- ------- ----- ------ ----

Port  ifIndex Oper-group Neighbor   Oper-Distribution PortSecurity/
                         Oper-group Method            Dynamic port
----- ------- ---------- ---------- ----------------- -------------
4/1  334              1 65537      Mac both
4/2  334              1 65537      Mac both
----- ------- ---------- ---------- ----------------- -------------

Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ----------------
4/1  Switch                          Fa6/1                     cisco Catalyst 6000
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------


!--- Saída suprimida.

Os comandos STP verificam se todas as portas de um canal estão agrupadas e encontram-se no estado de encaminhamento.

cat5500 (enable) show spantree 1
VLAN 1
Spanning tree enabled
Spanning tree type          IEEE

Designated Root             00-30-40-a7-a4-00
Designated Root Priority    32768
Designated Root Cost        0
Designated Root Port        1/0
Root Max Age   20 sec    Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-30-40-a7-a4-00
Bridge ID Priority          32768
Bridge Max Age 20 sec    Hello Time 2  sec   Forward Delay 15 sec

Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
2/1-2                   1    not-connected    19       32 disabled   0
3/1                     1    not-connected   100       32 disabled   0
3/2                     1    not-connected   100       32 disabled   0
3/3                     1    not-connected   100       32 disabled   0
3/4                     1    not-connected   100       32 disabled   0
3/5                     1    not-connected   100       32 disabled   0
3/6                     1    not-connected   100       32 disabled   0
3/7                     1    not-connected   100       32 disabled   0
3/8                     1    not-connected   100       32 disabled   0
3/9                     1    not-connected   100       32 disabled   0
3/10                    1    not-connected   100       32 disabled   0
3/11                    1    not-connected   100       32 disabled   0
3/12                    1    not-connected   100       32 disabled   0
3/13                    1    not-connected   100       32 disabled   0
3/14                    1    not-connected   100       32 disabled   0
3/15                    1    not-connected   100       32 disabled   0
3/16                    1    not-connected   100       32 disabled   0
3/17                    1    not-connected   100       32 disabled   0
3/18                    1    not-connected   100       32 disabled   0
3/19                    1    not-connected   100       32 disabled   0
3/20                    1    not-connected   100       32 disabled   0
3/21                    1    not-connected   100       32 disabled   0
3/22                    1    not-connected   100       32 disabled   0
3/23                    1    not-connected   100       32 disabled   0
3/24                    1    not-connected   100       32 disabled   0
4/1-2                   1    forwarding       12       32 disabled   865
4/3                     1    forwarding       19       32 disabled   0
4/4                     1    forwarding       19       32 disabled   0
4/5                     1    not-connected   100       32 disabled   0
4/6                     1    not-connected   100       32 disabled   0
4/7                     1    not-connected   100       32 disabled   0
4/8                     1    not-connected   100       32 disabled   0
4/9                     1    not-connected   100       32 disabled   0
4/10                    1    not-connected   100       32 disabled   0
4/11                    1    not-connected   100       32 disabled   0
4/12                    1    not-connected   100       32 disabled   0
cat5500 (enable)  
cat5500 (enable) show spantree 4/1
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) show spantree 4/2
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) 

Nota: A saída do comando show spantree module/port referente às portas 4/1 e 4/2 exibe resultados idênticos. Isso ocorre porque elas são agrupadas em um canal com o ID 865.

Catalyst 6500 Switch

Este comando verifica se o módulo é capaz de efetuar a canalização.

Cat6509# show interfaces capabilities module 6 
FastEthernet6/1
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
FastEthernet6/2
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
  • show interfaces port-channel port-channel interface number

Este comando verifica o status do canal de porta. Ele também informa quais portas formam esse canal.

Cat6509# show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0009.1267.27d9 (bia 0009.1267.27d9)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
Members in this channel: Fa6/1 Fa6/2 
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
     126880 packets input, 10173099 bytes, 0 no buffer
     Received 126758 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     6101 packets output, 1175124 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cat6509#

Este comando exibe o resumo de uma linha por grupo de canais. Neste exemplo de saída, observe o flag P com as portas Fa6/1 e Fa6/2. Isso implica que essas portas formam o canal.

Cat6509# show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

u - unsuitable for bundling
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
--------- +-----------------------+ ----------------+ ---------------
1 Po1(SU) PAgP Fa6/1(P) Fa6/2(P)

Este comando exibe as informações sobre o canal de porta.

Cat6509# show etherchannel port-channel


Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel = 00d:00h:02m:25s
Logical slot/port = 14/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = PAgP

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
1 55 Fa6/1 Desirable-Sl 4
0 AA Fa6/2 Desirable-Sl 4

Time since last port bundled: 00d:00h:01m:03s Fa6/1
Time since last port Un-bundled: 00d:00h:01m:05s Fa6/1

Este comando verifica se o canal encontra-se no estado de encaminhamento para determinada VLAN.

Cat6509# show spanning-tree detail

VLAN1 is executing the IEEE compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.029a.8001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0030.40a7.a400
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:23:59 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0030.40a7.a400
   Designated bridge has priority 32768, address 0030.40a7.a400
   Designated port id is 131.97, designated path cost 0
   Timers: message age 2, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 1, received 718 

Este comando exibe informações sobre a spanning tree da VLAN1.

Cat6509# show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0030.40a7.a400
Cost 12
Port 833 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 00d0.029a.8001
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1 Root FWD 12 128.833 P2p

Consideração Especial com o Uso de uma Configuração Incondicional no Modo de Canal

A Cisco recomenda o uso do PAgP para a configuração do canal de porta, conforme descrito neste documento. Se configurar o EtherChannel incondicionalmente (com o uso de channel mode on) por qualquer motivo, você deverá criar um canal de porta. Esta seção fornece o procedimento. Se criar um canal de porta, você evitará possíveis problemas com o STP durante o processo de configuração. A detecção de loop do STP poderá desativar as portas se você configurar um lado como um canal antes do outro lado se tornar um canal.

  1. Para definir as portas da canalização no modo desativado no CatOS switch, execute o comando set port disable module/port.

  2. Crie o canal de porta (grupo de portas) no Cisco IOS switch e defina o modo do canal como ativado.

  3. Crie o canal de porta no CatOS switch e defina o modo do canal como ativado.

  4. Para ativar de novo as portas desativadas anteriormente no primeiro CatOS switch, execute o comando set port enable module/port.

Troubleshooting

Problemas de Desempenho em EtherChannels

Os problemas de desempenho em EtherChannels são ocasionados por diversas condições. Algumas causas comuns são o algoritmo incorreto de balanceamento de carga e problemas específicos da camada física da porta.

Para entender melhor e configurar o algoritmo de balanceamento de carga, consulte estes documentos:

Para obter informações sobre o troubleshooting de problemas na camada física, consulte Troubleshooting de Problemas na Interface e na Porta do Switch.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 12029