Qualidade de Serviço (QoS) : Regulamentação QoS

Opções de QoS (Quality of Service) em Interfaces de Túnel GRE

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (24 Janeiro 2006) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Visão Geral de GRE
Cisco QoS para Túneis GRE
      Modelagem
      Política
      Prevenção de Congestionamento
      Comando qos pre-classify
Caracterização do Tráfego para Políticas de QoS
Onde Aplico a Política de Serviço?
Interfaces de Túnel Multiponto
Problemas Conhecidos
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento examina quais recursos de QoS (Quality of Service) podem ser configurados em interfaces de túnel utilizando GRE (Generic Routing Encapsulation). Os túneis configurados com o IPsec (IP Security) estão fora do escopo deste documento.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Visão Geral de GRE

Antes de aprender sobre QoS nos túneis GRE, é necessário entender o formato de um pacote em túnel.

Uma interface de túnel é uma interface virtual ou lógica de um roteador que executa o Cisco IOS® Software. Ela cria um link virtual ponto a ponto entre dois Cisco routers em pontos remotos sobre redes interconectadas IP.

O GRE é um protocolo de encapsulamento com suporte no IOS e definido na RFC 1702 leavingcisco.com. Os protocolos de tunelamento encapsulam pacotes em um protocolo de transporte.

Uma interface de túnel oferece suporte a um cabeçalho para cada um destes protocolos:

  • Um protocolo passageiro ou encapsulado, como IP, AppleTalk, DECnet ou IPX.

  • Um protocolo da portadora (neste caso, GRE).

  • Um protocolo de transporte (neste caso, somente IP).

O formato de um pacote de túnel é ilustrado aqui:

qostunnel_01.gif

Consulte Configuração de Interfaces Lógicas para obter mais informações sobre como configurar túneis GRE.

Cisco QoS para Túneis GRE

Uma interface de túnel oferece suporte a vários recursos de QoS também disponíveis em uma interface física. As seções a seguir descrevem os recursos de QoS com suporte.

Modelagem

O Cisco IOS Software Release12.0(7)T introduziu o suporte à aplicação da GTS (generic traffic shaping) diretamente na interface de túnel. O exemplo de configuração a seguir modela a interface de túnel em uma taxa de saída geral de 500 kbps. Consulte Configuração da Generic Traffic Shaping para obter mais informações.

interface Tunnel0
  ip address 130.1.2.1 255.255.255.0
  traffic-shape rate 500000 125000 125000 1000
  tunnel source 10.1.1.1
  tunnel destination 10.2.2.2

O Cisco IOS Software Release 12.1(2)T adicionou o suporte à modelagem baseada em classe por meio da interface de linha de comando de QoS modular (MQC). O exemplo de configuração a seguir mostra como aplicar a mesma política de modelagem à interface do túnel com os comandos MQC. Consulte Configuração da Modelagem Baseada em Classe para obter mais informações.

policy-map tunnel
  class class-default
    shape average 500000 125000 125000
interface Tunnel0
  ip address 130.1.2.1 255.255.255.0
  service-policy output tunnel
  tunnel source 130.1.35.1
  tunnel destination 130.1.35.2

Política

Quando uma interface torna-se congestionada e os pacotes começam a ser enfileirados, é possível aplicar um método de enfileiramento aos pacotes que estão aguardando transmissão. As interfaces lógicas do Cisco IOS não oferecem suporte inerente a um estado de congestionamento nem à aplicação direta de uma política de serviço que utiliza um método de enfileiramento. Em vez disso, é necessário aplicar uma política hierárquica da seguinte maneira:

  1. Crie uma política secundária ou de nível inferior que configure um mecanismo de enfileiramento, como o enfileiramento de baixa latência com o comando priority e o enfileiramento CBWFQ (class-based weighted fair queueing) com o comando bandwidth. Consulte Gerenciamento do Congestionamento para obter mais informações.

    policy-map child
     class voice
      priority 512
  2. Crie uma política primária ou de nível superior que aplique a modelagem baseada em classe. Aplique a política secundária como um comando sob a política primária, uma vez que o controle de admissão da classe secundária é feito com base na taxa de modelagem da classe primária.

    policy-map tunnel
     class class-default
      shape average 2000000
      service-policy child 
  3. Aplique a política primária à interface de túnel.

    interface tunnel0
       service-policy tunnel

O roteador imprime a seguinte mensagem de log quando uma interface de túnel é configurada com uma política de serviço que aplica o enfileiramento sem modelagem.

router(config)# interface tunnel1
router(config-if)# service-policy output child
 Class Based Weighted Fair Queueing not supported on this interface

As interfaces de túnel também oferecem suporte à política baseada em classe, mas não suportam CAR (taxa de acesso comprometida).

Nota: As interfaces de túnel no 7500 não oferecem suporte a políticas de serviço.

Prevenção do Congestionamento

O Cisco IOS Software Release 11.3T introduziu a Precedência IP para Túneis GRE, a qual configura o roteador para copiar os valores de bit de precedência IP do byte de ToS no cabeçalho IP do GRE ou do túnel que encapsula o pacote interno. Anteriormente, esses bits eram definidos como zero. Os roteadores intermediários entre os pontos finais do túnel podem usar os valores de precedência IP a fim de classificar os pacotes para os recursos de QoS, como roteamento baseado em política, WFQ e WRED (Weighted Random Early Detection).

Comando qos pre-classify

Quando pacotes são encapsulados por cabeçalhos de criptografia ou de túnel, os recursos de QoS não conseguem examinar os cabeçalhos originais dos pacotes nem classificar corretamente os pacotes. Os pacotes que percorrem o mesmo túnel possuem os mesmos cabeçalhos e, portanto, são tratados de forma idêntica quando a interface física está congestionada. Com a introdução do recurso de QoS (Quality of Service) para Redes Virtuais Privadas VPNs, agora os pacotes podem ser classificados antes de ocorrer o tunelamento e a criptografia.

Neste exemplo, tunnel0 é o nome do túnel. O comando qos pre-classify ativa o recurso de QoS para VPNs em tunnel0:

Router(config)# interface tunnel0
Router(config-if)# qos pre-classify

Caracterização do Tráfego para Políticas de QoS

Ao configurar uma política de serviço, talvez você precise caracterizar primeiro o tráfego que atravessa o túnel. O Cisco IOS oferece suporte à contabilização do Netflow e do IP Cisco Express Forwarding (CEF) nas interfaces lógicas como túneis. Consulte o Guia de Soluções de Serviços NetFlow para obter mais informações.

Onde Aplico a Política de Serviço?

É possível aplicar uma política de serviço à interface de túnel ou à interface física subjacente. A decisão sobre onde aplicar a política depende dos objetivos de QoS. Ela também depende de qual cabeçalho você precisa usar para classificação.

  • Aplique a política à interface de túnel sem qos-preclassify se desejar classificar os pacotes com base no cabeçalho pré-túnel.

  • Aplique a política à interface física sem qos-preclassify se desejar classificar os pacotes com base no cabeçalho pós-túnel. Além disso, aplique a política à interface física quando desejar modelar ou vigiar todo o tráfego pertencente a um túnel, e a interface física oferecer suporte a diversos túneis.

  • Aplique a política a uma interface física e ative qos-preclassify quando desejar classificar os pacotes com base no cabeçalho pré-túnel.

Interfaces de Túnel Multiponto

Na modelagem baseada em classe, não há suporte para o CBWFQ em uma interface multiponto. A ID de bug CSCds87191 da Cisco configura o roteador para imprimir uma mensagem de erro quando rejeitar a política.

Problemas Conhecidos

Em raras condições, a aplicação de uma política de serviço configurada com o comando shape resultará em uma alta utilização de CPU e em erros de alinhamento. A carga da CPU é ocasionada pelo registro em log dos erros de alinhamento, os quais, por sua vez, são gerados quando o CEF define incorretamente as informações de regravação da adjacência e da interface de saída. Esse problema afeta somente as plataformas não-RSP (low-end) e as que utilizam o switching CEF baseado em partículas. O problema é resolvido através das IDs de bug CSCdu45504 e CSCuk30302 da Cisco. Considere também as seguintes soluções:

  • Substitua o encapsulamento GRE por um tunnel mode ipip.

  • Substitua o comando shape pelo comando police.

  • Configure a modelagem na interface física que oferece suporte ao túnel.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 10106