Qualidade de Serviço (QoS) : Regulamentação QoS

Aplicando Recursos de QoS a Subinterfaces Ethernet

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (10 Agosto 2005) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Aplicação de uma Política de Serviço
      Aplicação de uma Política Hierárquica
Configuração da Modelagem Baseada em Classe
      Configuração
Verificação
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento descreve como aplicar o CBWFQ (class-based weighted fair queueing) e outros recursos de QoS (Quality of Service) baseados no Cisco IOS® Software em uma subinterface Ethernet. Uma subinterface Ethernet é uma interface lógica no Cisco IOS. Você pode usar a interface de linha de comando (CLI) de QoS modular (MQC) para criar e aplicar uma política de serviço a uma subinterface Ethernet.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco IOS Software 12.2(2)T

  • Cisco 2620 router com um módulo de rede Fast Ethernet

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Aplicação de uma Política de Serviço

Em geral, a escolha de onde aplicar uma política depende dos recursos de QoS ativados pela política. Uma subinterface Ethernet oferece suporte ao seguinte:

  • Política baseada em classe - Se você aplicar uma política com o comando police à interface e à subinterface, apenas o vigilante da subinterface será ativado para o tráfego correspondente à classe. Consulte Política de Tráfego para obter mais informações.

  • Marcação baseada em classe — consulte Visão Geral de Classificação para obter mais informações.

  • Modelagem baseada em classe — consulte Configuração da Modelagem Baseada em Classe para obter mais informações.

  • Enfileiramento baseado em classe — o enfileiramento é um caso especial em subinterfaces Ethernet. Leia o restante desta seção para obter mais informações.

Um roteador começa a enfileirar pacotes quando o número de pacotes que precisa ser transmitido de uma interface excede a taxa de saída dessa interface. Os pacotes excedentes são colocados em fila. Um método de enfileiramento pode ser aplicado aos pacotes que aguardam transmissão.

As interfaces lógicas do Cisco IOS não oferecem suporte inerente a um estado de congestionamento nem à aplicação direta de uma política de serviço que utilize um método de enfileiramento. Em vez disso, é necessário aplicar primeiro a modelagem à subinterface, usando a modelagem GTS (generic traffic shaping ) ou a modelagem baseada em classe. Consulte Política e Modelagem para obter mais informações.

O roteador imprime esta mensagem de log quando uma subinterface Ethernet é configurada com uma política de serviço que aplica o enfileiramento sem modelagem:

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

Observe que a mesma regra se aplica a uma subinterface Gigabit Ethernet.

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

Em outras palavras, você deve configurar uma política hierárquica com o comando shape no nível primário. Utilize o comando bandwidth para CBWFQ ou o comando priority para LLQ (Low Latency Queueing) em níveis inferiores. A modelagem baseada em classe limita a taxa de saída e (podemos pressupor) ocasiona um estado congestionado na subinterface lógica. Em seguida, a subinterface aplica uma "pressão contrária", e o Cisco IOS começa a enfileirar os pacotes excedentes mantidos pelo modelador.

Aplicação de uma Política Hierárquica

Siga estes passos para aplicar uma política hierárquica:

  1. Crie uma política secundária ou de nível inferior que configure um mecanismo de enfileiramento. No exemplo abaixo, configuraremos o LLQ usando o comando priority e o CBWFQ com o comando bandwidth. Consulte Visão Geral do Gerenciamento do Congestionamento para obter mais informações.

    policy-map child
     class voice
      priority 512
  2. Crie uma política primária ou de nível superior que aplique a modelagem baseada em classe. Aplique a política secundária como um comando sob a política primária, uma vez que o controle de admissão da classe secundária é feito com base na taxa de modelagem da classe primária.

    policy-map parent
     class class-default
      shape average 2000000
      service-policy child 
  3. Aplique a política primária à subinterface.

    interface ethernet0/0.1
     service-policy parent 

Configuração da Modelagem Baseada em Classe

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para obter informações adicionais sobre os comandos usados neste documento, utilize a Command Lookup Tool (somente clientes registrados).

Configuração

Router 2620A

hostname 2620A
!
ip cef
!
class-map match-any dscp46
 match ip dscp 46
class-map match-all telnet_ping_snmp
 match access-group 150
class-map match-all http
 match access-group 154
class-map match-all pop3_smtp
 match access-group 153
!
!
policy-map voice_traffic
 class dscp46
  shape average 30000 10000
 class telnet_ping_snmp
  shape average 20000 15440
 class pop3_smtp
  shape average 20000 15440
 class http
  shape average 20000 15440
!
interface FastEthernet0/0
 ip address 10.10.247.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.1.1.1 255.255.255.0
 service-policy output voice_traffic

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Certos comandos show têm suporte na ferramenta Output Interpreter, a qual permite exibir uma análise da saída desses comandos.

  • show policy-map {policy name} - Exibe a configuração de todas as classes referentes a um mapa de políticas de serviço especificado.

    2620A# show policy-map voice_traffic
    Policy Map voice_traffic
    Class dscp46
    Traffic Shaping
    Average Rate Traffic Shaping
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets)
    Bc 10000
    Class telnet_ping_snmp
    Traffic Shaping
    Average Rate Traffic Shaping
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets)
    Bc 15440
    Class pop3_smtp
    Traffic Shaping
    Average Rate Traffic Shaping
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets)
    Bc 15440
    Class http
    Traffic Shaping
    Average Rate Traffic Shaping
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets)
    Bc 15440
    
    2620A# show policy-map voice_traffic class dscp46
    Class dscp46
    Traffic Shaping
    Average Rate Traffic Shaping
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets)
    Bc 10000
  • show policy-map interface fast - Exibe os contadores de correspondência referentes a todas as classes de um mapa de políticas de serviço especificado.

    2620A# show policy-map interface fa0/0.1
    FastEthernet0/0.1
    Service-policy output: voice_traffic
    Class-map: dscp46 (match-any)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: ip dscp 46
    0 packets, 0 bytes
    5 minute rate 0 bps
    Traffic Shaping
    Target    Byte   Sustain   Excess    Interval  Increment Adapt
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
    30000     2500   10000     10000     333       1250      -
    Queue     Packets   Bytes     Packets   Bytes     Shaping
    Depth                         Delayed   Delayed   Active
    0         0         0         0         0         no
    Class-map: telnet_ping_snmp (match-all)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group 150
    Traffic Shaping
    Target    Byte   Sustain   Excess    Interval  Increment Adapt
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
    20000     3860   15440     15440     772       1930      -
    Queue     Packets   Bytes     Packets   Bytes     Shaping
    Depth                         Delayed   Delayed   Active
    0         0         0         0         0         no
    Class-map: pop3_smtp (match-all)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group 153
    Traffic Shaping
    Target    Byte   Sustain   Excess    Interval  Increment Adapt
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
    20000     3860   15440     15440     772       1930      -
    Queue     Packets   Bytes     Packets   Bytes     Shaping
    Depth                         Delayed   Delayed   Active
    0         0         0         0         0         no
    Class-map: http (match-all)
    0 packets, 0 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group 154
    Traffic Shaping
    Target    Byte   Sustain   Excess    Interval  Increment Adapt
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
    20000     3860   15440     15440     772       1930      -
    Queue     Packets   Bytes     Packets   Bytes     Shaping
    Depth                         Delayed   Delayed   Active
    0         0         0         0         0         no
    Class-map: class-default (match-any)
    926 packets, 88695 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: any

Nota: O mapeamento baseado em classe funciona no nível da interface e da subinterface. O Cisco IOS 12.2(2.5) introduz a capacidade de configurar a modelagem nos endereços da interface principal e IP nas subinterfaces.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 10104