IP : Roteamento IP

Compreendendo a Redistribuição das Rotas OSPF no BGP

1 Julho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (28 Fevereiro 2012) | Feedback

Autor: Syed Faraz Shamim

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração de Rede
Redistribuição de Rotas OSPF Internas (Intra e Interárea) Somente no BGP
Redistribuição de Rotas OSPF Externas (Tipo 1 e 2) Somente no BGP
      Redistribuição de Rotas OSPF Externas Tipo 1 e Tipo 2 Somente no BGP
Redistribuição de Rotas OSPF Internas e Externas no BGP
Redistribuição de Rotas OSPF NSSA Externas no BGP
Modificação da Opção de Redistribuição no OSPF
Não É Possível Redistribuir Rotas iBGP Aprendidas em um IGP como EIGRP, OSPF
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Esta Nota Técnica explica o comportamento do Open Shortest Path First (OSPF) para redistribuição BGP em roteadores da Cisco. O comportamento do OSPF para redistribuição BGP está descrito em RFC 1403 leavingcisco.com.

Há vários tipos de rotas OSPF:

  • Intra-área — Em uma rede OSPF multiárea, as rotas originadas em uma área são conhecidas pelos roteadores na mesma área como rotas Intra-área. Essas rotas são sinalizadas com O na saída do comando show ip route.

  • Interárea — Quando uma rota cruza um Roteador de Borda de Área (ABR) OSPF, a rota é conhecida como uma rota Interárea OSPF. Essas rotas são sinalizadas com O IA na saída do comando show ip route.

    Ambas as rotas Intra e Interárea são chamadas rotas OSPF internas, pois são geradas pelo OSPF em si quando uma interface é coberta com o comando network de OSPF.

  • Tipo 2 Externa ou Tipo 1 Externa — Rotas que foram redistribuídas no OSPF, como Conectadas, Estáticas ou outro Protocolo de Roteamento, são conhecidas como Tipo 2 Externa ou Tipo 1 Externa. Essas rotas são sinalizadas com O E2 ou O E1 na saída do comando show ip route.

  • Tipo 2 Externa NSSA ou Tipo 1 Externa NSSA — Quando uma área é configurada como Not-So-Stub Area (NSSA), e as rotas são redistribuídas no OSPF, as rotas são conhecidas como tipo 2 externa NSSA ou tipo 1 externa NSSA. Essas rotas são sinalizadas com O N2 ou O N1 na saída do comando show ip route.

    A descrição das diferenças entre Tipo 2 ou 1 Externa NSSA está além do escopo deste documento — consulte o Guia de Design de OSPF para obter mais informações.

O comportamento padrão é não redistribuir rotas de OSPF no BGP. A redistribuição deve ser configurada. Você pode usar o comando route-map para filtrar rotas durante a redistribuição de OSPF para BGP. Ao redistribuir, palavras-chave específicas como internal, external e nssa-external são necessárias para redistribuir as respectivas rotas.

Pré-requisitos

Requisitos

Uma compreensão sobre os tipos de rota OSPF é necessária antes de usar este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Configuração de Rede

Há quatro casos de redistribuição de rotas OSPF no BGP abordadas abaixo. O diagrama de rede se aplica aos primeiros três casos. O diagrama e a configuração para o quarto caso podem ser encontrados na seção Redistribuição de Rotas OSPF NSSA Externas no BGP.

bgp-ospf-redis1.jpg

Redistribuição de Rotas OSPF Internas (Intra e Interárea) Somente no BGP

Se você configurar a redistribuição de OSPF no BGP sem palavras-chave, somente rotas intra-área e interárea são redistribuídas no BGP, por padrão. Você pode usar a palavra-chave internal junto com o comando redistribute em router bgp para redistribuir rotas intra e interárea de OSPF.

Esta é uma nova configuração do Roteador B que redistribui somente a rota intra-área (131.108.2.0/24) e a rota interárea (131.108.1.0/24) no BGP e somente as rotas OSPF internas (intra e interárea) são redistribuídas no BGP:

RTB

hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1


!--- Redistribui somente rotas OSPF intra e interárea no BGP.


 neighbor 3.3.3.2 remote-as 200
!
end

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O E2 200.1.1.0/24 [110/20] via 2.2.2.2, 00:16:17, Ethernet0/0
O E1 200.2.2.0/24 [110/104] via 2.2.2.2, 00:00:41, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:16:17, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:16:17, Ethernet0/0
RTB#

O Roteador B redistribui somente rotas OSPF internas:

RTB# show ip bgp
BGP table version is 10, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
RTB#

Roteador C aprendendo essas rotas do BGP:

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:11:19
C    3.0.0.0/8 is directly connected, Serial0/0
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:03:56
B       131.108.1.0 [20/84] via 3.3.3.1, 00:03:28
RTC#

Redistribuição de Rotas OSPF Externas (Tipo 1 e 2) Somente no BGP

Use a palavra-chave external junto com o comando redistribute em router bgp para redistribuir rotas OSPF externas no BGP. Com a palavra-chave external, você possui três escolhas:

  • redistribuir ambos os tipos 1 e 2 externos (padrão)

  • redistribuir o tipo 1

  • redistribuir o tipo 2

Insira os comandos no modo de configuração como aqui descrito:

RTB(config-router)# router bgp 100
RTB(config-router)# redistribute ospf 1 match external

Nesta configuração do Roteador B, redistribuímos apenas rotas OSPF externas, mas ambos os tipos 1 e 2:

RTB

hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match external 1 external 2


!--- Redistribui SOMENTE rotas externas OSPF,
!--- mas tanto do tipo 1 quanto do tipo 2.


 neighbor 3.3.3.3 remote-as 200
!
end

Nota: A configuração mostra match external 1 external 2 e o comando inserido foi redistribute ospf 1 match external. Isso é normal porque o OSPF anexa automaticamente "external 1 external 2" à configuração. Ele corresponde ambas as rotas OSPF externas 1 e 2 e as redistribui no BGP.

O Roteador B redistribui somente rotas OSPF externas:

RTB# show ip bgp
BGP table version is 21, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

O Roteador C aprende sobre essas duas rotas OSPF externas do BGP:

RTC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:43
B    200.2.2.0/24 [20/0] via 3.3.3.1, 00:01:43
C    3.0.0.0/8 is directly connected, Serial0/0

Redistribuição de Rotas OSPF Externas Tipo 1 e 2 Somente no BGP

Insira este comando em router bgp 100 no Roteador B para redistribuir as rotas OSPF externas 1:

router bgp 100
 redistribute ospf 1 match external 1

A tabela BGP do Roteador B mostra que ele está redistribuindo apenas as rotas externas 1 no BGP e todas as outras rotas OSPF não são redistribuídas no BGP:

RTB# show ip bgp
BGP table version is 24, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

Da mesma forma, insira este comando em router bgp 100 no Roteador B para redistribuir apenas rotas OSPF externas 2:

router bgp 100
 redistribute ospf 1 match external 2

Redistribuição de Rotas OSPF Internas e Externas no BGP

Neste caso, todas as rotas OSPF são redistribuídas no BGP usando as palavras-chave internal e external, como mostrado nesta configuração do Roteador B:

RTB

hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match internal external 1 external 2


!--- Distribui todas as rotas OSPF no BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Novamente, external é substituído por external 1 external 2 na configuração. Isso é normal a menos que você especifique quais rotas externas específicas deseja redistribuir no BGP. Após executar a alteração de configuração, o Roteador B redistribuirá todas as rotas OSPF e o Roteador C iniciará o aprendizado de todas as rotas do BGP:

RTB# show ip bgp
BGP table version is 30, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

RTC# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:01:24
C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:24
B    200.2.2.0/24 [20/104] via 3.3.3.1, 00:01:24
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:01:24
B       131.108.1.0 [20/84] via 3.3.3.1, 00:01:24
RTC#

Redistribuição de Rotas OSPF NSSA Externas no BGP

Este é um caso especial no qual somente rotas Not-So-Stubby Area (NSSA) são redistribuídas no BGP. Esse caso é muito semelhante ao descrito na seção Redistribuição de Rotas OSPF Externas (Tipo 1 e 2) Somente no BGP. A única diferença é que o BGP agora corresponde às rotas NSSA externas em vez de apenas rotas externas. A tabela de roteamento do Roteador B mostra essas rotas OSPF NSSA externas:

RTB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O N2 200.1.1.0/24 [110/20] via 2.2.2.1, 00:22:53, Ethernet0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O IA 131.108.1.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O 131.108.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
C    2.0.0.0/8 is directly connected, Ethernet0
C    3.0.0.0/8 is directly connected, Serial1

Este diagrama de rede é usado para este caso:

bgp-ospf-redis2.jpg

O diagrama de rede mostra que o Roteador B recebe ambas as rotas OSPF N1 e N2. O comportamento padrão é redistribuir ambas as rotas N1 e N2 se somente a palavra-chave nssa-external for usada. Esta configuração do Roteador B permite que as rotas OSPF N1 (200.1.1.0/24) e OSPF N2 (200.2.2.0/24) sejam redistribuídas no BGP:

RTB

hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
nssa

!
router bgp 100
 redistribute ospf 1 match nssa-external 1 nssa-external 2


!--- Redistribui somente rotas OSPF NSSA externas
!--- do tipo 1 e do tipo 2 no BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Nota: Como a configuração OSPF externa, a configuração acima exibe match nssa-external 1 nssa-external 2 e o comando inserido foi redistribute ospf 1 match nssa-external. Isso é normal porque o OSPF anexa automaticamente "nssa-external 1 nssa-external 2" à configuração. Corresponde ambas as rotas OSPF N1 e OSPF N2 e redistribui ambas as rotas no BGP.

Após a alteração da configuração no Roteador B, ele redistribui as rotas OSPF NSSA externas e o Roteador C inicia o aprendizado das rotas OSPF NSSA externas do BGP:

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O N2 200.1.1.0/24 [110/94] via 2.2.2.1, 00:11:12, Ethernet0/0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:12:23, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:12:23, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:12:11, Ethernet0/0
RTB#

RTB# show ip bgp
BGP table version is 21, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 94         32768 ?
*> 200.2.2.0        2.2.2.1                 20         32768 ?
RTB#

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/94] via 3.3.3.1, 00:02:06
B    200.2.2.0/24 [20/20] via 3.3.3.1, 00:02:06
RTC#

De forma semelhante às rotas OSPF externas, para redistribuir apenas as rotas OSPF N1, insira o seguinte comando sob router BGP 100 no Roteador B:

router bgp 100
 redistribute ospf 1 match nssa-external 1

!--- Redistribui somente rotas OSPF NSSA externas
!--- do tipo 1 no BGP.

Para redistribuir apenas as rotas OSPF N2, insira o seguinte comando sob router BGP 100 no Roteador B:

router bgp 100
 redistribute ospf 1 match nssa-external 2

!--- Redistribui somente rotas OSPF NSSA externas
!--- do tipo 2 no BGP.

Modificação da Opção de Redistribuição no OSPF

É importante compreender como alterações de configuração sucessivas podem afetar a sua configuração. Um novo comando com a opção de correspondência não substitui o anterior, mas é adicionado a ele. Começando sem redistribuição, esta sequência de comandos de configuração de exemplo mostra seu impacto na redistribuição:

R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match internal
R4(config-router)# ^Z

!--- Inicialmente, distribuímos todas as rotas OSPF no BGP 100.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal
R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match external
R4(config-router)# ^Z

!--- Com este segundo comando, dizemos ao BGP
!--- para distribuir também as rotas OSPF externas.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1 external 2
R4#
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match external 2
R4(config-router)# ^Z

!--- Com este comando no, desabilitamos somente a
!--- a redistribuição do tipo externo 2 no BGP.
!--- Todos os demais tipos de rotas previamente configurados permanecem.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1
 
!--- Como podemos observar o tipo 1 interno e externo permanece.

R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match internal external 1
R4(config-router)# ^Z

!--- Agora, com este comando no que inclui todas as palavras-chave
!--- configuradas, é importante observar que ainda
!--- não desabilitamos completamente a redistribuição.
!--- Apenas removemos a palavra-chave. Após isso,
!--- o IOS ainda atua como padrão, redistribuindo
!--- somente as rotas internas.


R4# sh run | i redistribute ospf
 redistribute ospf 1
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1

!--- Use sempre este comando para desabilitar
!--- completamente a redistribuição.

R4(config-router)# ^Z
R4# sh run | i redistribute ospf
R4#

Não É Possível Redistribuir Rotas iBGP Aprendidas em um IGP como EIGRP, OSPF

A Redistribuição de Rotas é usada para propagar rotas aprendidas com o uso de um protocolo, em outro protocolo de roteamento. Quando o BGP é redistribuído em um IGP, somente as rotas eBGP aprendidas são redistribuídas. As rotas iBGP aprendidas conhecidas no roteador não são introduzidas no IGP para impedir que haja loops de roteamento.

Por padrão, a redistribuição iBGP no IGP está desativada. Execute o comando bgp redistribute-internal para ativar a redistribuição de rotas iBGP no IGP. Tenha cuidado ao redistribuir rotas específicas usando mapas de rotas no IGP.

Uma configuração de exemplo para redistribuição de rotas iBGP no OSPF é aqui exibida:

router bgp 65345
bgp redistribute-internal
!
router ospf 100
redistribute bgp 65345 subnets

Nota: A redistribuição de todas as rotas Border Gateway Protocol (iBGP) internas em um Interior Gateway Protocol pode causar loops de roteamento no Sistema Autônomo (AS). Isso não é recomendado. Os filtros de rotas devem ser definidos para controlar as informações que são importadas no IGP.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 5242