Switches de LAN : Virtual LANs/VLAN Trunking Protocol (VLANs/VTP)

Entroncamento 802.1Q entre Catalyst Switches Executando CatOS e Cisco IOS System Software

25 Junho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (17 Novembro 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
      Background Theory
Configuração
      Diagrama de Rede
      Configurações
Verificação
      Comandos show
      Exemplo de Saída do Comando show
Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento apresenta configurações de exemplo para o entroncamento IEEE 802.1Q entre Catalyst Switches que executam o software de sistema Catalyst OS (CatOS) e switches modulares da Camada 3 (L3) que executam o Cisco IOS® System Software. Os switches que executam o CatOS incluem os Catalyst 4500/4000, 5500/5000 e 6500/6000 Series Switches. Switches L3 modulares que executam o Cisco IOS Software incluem os Catalyst 4500/4000 e Catalyst 6500/6000 Series Switches As configurações de exemplo usam um Catalyst 4000 (CatOS) e um Catalyst 6500 (Cisco IOS Software), mas qualquer um dos switches mencionados poderia ter sido utilizado para obter os mesmos resultados.

O entroncamento é um modo de transferir tráfego de várias VLANs através de um link ponto a ponto entre dois dispositivos. Dois modos para implementação de entroncamento Ethernet são:

  • Inter-Switch Link Protocol (ISL) (protocolo proprietário da Cisco)

  • 802.1Q (padrão IEEE)

Pré-requisitos

Requisitos

Para obter requisitos do sistema, diretrizes e restrições relacionadas ao 802.1Q e ISL nos Catalyst Switches, consulte Requisitos do Sistema para Implementação de Entroncamento.

Componentes Utilizados

Para criar os exemplos neste documento, os seguintes switches foram utilizados:

  • Catalyst 4000 Switch com Supervisor Engine II (WS-X4013) executando software CatOS versão 8.1.3

  • Catalyst 6509 com Supervisor Engine 2/Multilayer Switch Feature Card 2 (MSFC2) executando Cisco IOS Software Release 12.1(20)E2 no Supervisor Engine e na MSFC2

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documentos, consulte as Convenções de Dicas Técnicas da Cisco.

Teoria de Apoio

Este documento inclui somente arquivos de configuração de switches e saída a partir de comandos show de exemplo relacionados. Para obter detalhes sobre a configuração de um tronco 802.1Q entre Catalyst Switches, consulte as Páginas de Suporte ao Produto de LAN.

No entroncamento 802.1Q, todos os pacotes de VLAN são marcados no link do tronco, exceto a VLAN nativa. Os pacotes da VLAN nativa são enviados sem marcações no link do tronco. Portanto, a VLAN nativa deve ser a mesma em ambos os switches configurados para entroncamento. Dessa maneira, podemos deduzir à qual VLAN o frame pertence quando recebemos um frame sem marcação. Por padrão, VLAN1 é a VLAN nativa em todos os switches.

  • No CatOS, a VLAN nativa pode ser alterada executando o comando set vlan vlan-id mod/port onde mod/port é a porta do tronco.

  • No Cisco IOS Software, a VLAN nativa pode ser alterada executando o comando switchport trunk native vlan vlan-id interface que está configurado na porta do tronco.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

As configurações neste documento foram implementadas em um ambiente de laboratório isolado. Certifique-se de que você compreende o impacto potencial de qualquer configuração ou comando em sua rede antes de utilizá-lo. As configurações em todos os dispositivos foram limpas com os comandos clear config all e write erase para garantir uma configuração padrão.

Nota: Para obter informações adicionais sobre os comandos usados neste documento, use a Command Lookup Tool leavingcisco.com (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

67-a.gif

Configurações

Este documento utiliza estas configurações:

Nota: Os comentários e as explicações são exibidos em itálico azul.

Catalyst 4000 Switch

#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco

!--- Neste exemplo, o nome do domínio VLAN Trunk Protocol (VTP) é o mesmo
!--- nos dois lados Isto é necessário para a negociação automática do tronco
!--- pelo Dynamic Trunking Protocol (DTP).


set vtp mode client vlan

!--- Neste exemplo, o modo de VTP é definido como client.
!--- Defina o modo de VTP de acordo com os requisitos da sua rede.

!--- Para obter mais detalhes, consulte
!--- Compreendendo e Configurando o VLAN Trunk Protocol (VTP).


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!--- Este é o endereço IP usado para gerenciamento.

!--- Saída suprimida.

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24

!--- As portas 5/13-24 foram atribuídas a VLAN 2.



set trunk 5/1  desirable dot1q 1-1005,1025-4094

!--- O modo de entroncamento é definido como desirable, o que significa que
!--- a porta tenta formar automaticamente um tronco com uma
!--- porta vizinha definida no modo desirable, auto ou on.

!--- Para obter configurações recomendadas do modo de entroncamento, consulte
!--- a seção Dynamic Trunking Protocol de
!--- Práticas Recomendadas para o Catalyst 4500/4000, 5500/5000 e 6500/6000
Series Switches com CatOS Configuration and Management.

!--- Saída suprimida.


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off

!--- O comando de macro set port host 5/2-24 era usado para fazer três coisas:
!--- desabilitar o entroncamento, desabilitar a canalização de portas e habilitar o portfast de spanning tree.

!--- Para obter detalhes sobre o uso do comando set port host, consulte
!--- Usando o Portfast e Outros Comandos para Corrigir os Atrasos de Conectividade de Inicialização da Estação de Trabalho.

!
#module 6 empty
end

Catalyst 6500 Switch

Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret

!--- Esta é a senha do modo privilegiado usada no exemplo.


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport

!--- O comando switchport deve ser inserido uma vez,
!--- sem nenhuma palavra-chave, para configurar a interface como uma porta da Camada 2.
!--- A interface é agora configurada com o comando padrão
!--- switchport mode dynamic desirable.

!--- Isto significa que a interface está pronta para negociar automaticamente o
!--- encapsulamento do entroncamento e formar um link de tronco (via FTP) com uma porta vizinha
!--- no modo desirable, auto ou on.

!--- Para obter configurações recomendadas do modo de entroncamento, consulte
!--- a seção "Dynamic Trunking Protocol" de
!--- Práticas Recomendadas para o Catalyst 6500/6000 Series e o Catalyst 4500/4000
Series Switches com Cisco IOS Software.



!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast


!--- O comando interface range fastethernet mod/beginport - endport
!--- é usado para configurar as interfaces 3/2 - 24 de uma vez.

!--- Em seguida, o comando switchport é executado (caso ainda não tenha sido).


switchport mode access
 spanning-tree portfast

!--- Depois, execute o comando de macro switchport host 3/2 - 24 para configurar automaticamente
!--- essas portas como portas de acesso e para habilitar o portfast de spanning tree.

!--- Para obter detalhes sobre o uso do comando switchport host, consulte
!--- Usando o Portfast e Outros Comandos para Corrigir os Atrasos de Conectividade de Inicialização da Estação de Trabalho.


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2

!--- As interfaces 3/13 - 24 são colocadas em VLAN 2
!--- com o comando switchport access vlan 2.


 switchport mode access
 spanning-tree portfast


!--- Saída suprimida.


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast


!--- Saída suprimida.

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0

!--- Este é o endereço IP usado para gerenciamento.

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret


!--- Esta é a senha de Telnet usada no exemplo.


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

Verificação

Esta seção fornece informações que você pode usar para confirmar se a configuração está funcionando corretamente.

Comandos show

Alguns comandos show são aceitos pela Output Interpreter Tool leavingcisco.com (somente clientes registrados), o que permite exibir uma análise da saída do comando show.

Nos Catalyst Switches que executam o CatOS, utilize estes comandos:

  • show port capabilities módulo/porta

  • show port módulo/porta

  • show trunk módulo/porta

  • show vtp domain

Nos Catalyst 6000 Switches executando o Cisco IOS Software, utilize os seguintes comandos:

  • show interfaces tipo-interface módulo/porta trunk

  • show vlan

Exemplo de Saída do Comando show

Catalyst 4000 Switch

O comando show port capabilities módulo/porta é utilizado para verificar se a porta é compatível com entroncamento.

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

O comando show port módulo/porta mostra o status de uma porta específica e se ela está executando entroncamento.

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

O comando show trunk é utilizado para verificar o status e a configuração do entroncamento.

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

O comando show vtp domain é usado para verificar informações de VTP.

cat4000> (enable) show vtp domain
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Catalyst 6500 Switch

O comando show interfaces tipo-interface módulo/porta trunk informa se a porta está executando entroncamento.

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

The O comando show vlan fornece informações sobre as VLANs e as portas que pertencem a uma VLAN específica.

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                                Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                                Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


!--- Saída suprimida.

cat6500#

Nota: Somente as portas configuradas como sem tronco da Camada 2 são exibidas.

Troubleshooting

No momento, não existem informações disponíveis específicas sobre troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 8760