Cisco Interfaces and Modules : Módulos de rede da Cisco

Exemplo de Configuração do EtherSwitch Network Module (ESW)

8 Junho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (19 Março 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Produtos Relacionados
      Convenções
Módulos EtherSwitch - Conceitos
Configuração
      Diagrama de Rede
      Configurações
      Configuração de Interfaces VLAN
      Configuração de VTPs, Troncos, Port Channels e Spanning Trees
      Configuração de Portas de Acesso
      Configuração de Portas de Voz
      Configuração da Qualidade de Serviço (QoS)
Verificação
Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento apresenta um exemplo de configuração do EtherSwitch Network Module instalado no Integrated Service Router (ISR). Este documento não discute o exemplo de configuração do EtherSwitch Service Module.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2800 Series Router com Cisco IOS® Software Versão 12.4 ou posterior

  • Cisco EtherSwitch Network Module (NM) 10/100 com 16 portas NM-16ESW-PWR

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração também pode ser utilizada com estas versões de hardware e software:

Convenções

Consulte Convenções de Dicas Técnicas da Cisco para obter mais informações sobre as convenções de documentos.

Módulos EtherSwitch - Conceitos

Há dois tipos de módulos EtherSwitch disponíveis para os Cisco ISRs. São eles:

  • EtherSwitch Network Module (ESW)

  • EtherSwitch Service Module (ES)

Os módulos ESW são configurados pelo IOS do roteador. Esses módulos não executam software separado. O software é integrado no IOS do roteador host. Você pode criar VLANs e configurar VLANs, spanning trees, VLAN Trunking Protocols (VTP) e assim por diante no roteador host. O roteador também armazena o arquivo de banco de dados da VLAN (vlan.dat) na Flash. Este documento mostra um exemplo de configuração do módulo ESW.

Os módulos ES possuem seus próprios processadores, mecanismos de chaveamento e memória Flash que trabalham de forma independente dos recursos do roteador host. Após o módulo ES ser instalado no roteador, você poderá se conectar pelo console no módulo ES via roteador host. Em seguida, você poderá criar VLANs e configurar VLANs, spanning trees, VTP e assim por diante no módulo ES. Os módulos ES baseiam-se na plataforma Catalyst 3750.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota:  Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

ether-switch-nm-config-1.gif

Configurações

Este documento utiliza as seguintes configurações:

Configuração das Interfaces de VLAN

Por padrão, todas as portas pertencem à VLAN1. Você pode criar VLANs somente no modo de banco de dados de VLANs. Após a criação das VLANs nesse modo, o arquivo vlan.dat é criado e armazenado no sistema de arquivos da Flash do roteador. Você pode exibir as VLANs com o comando show vlan-switch. Neste exemplo, um servidor Dynamic Host Configuration Protocol (DHCP) (172.16.10.20) está localizado na VLAN 10. O comando ip helper-address está configurado em todas as VLANs, exceto na VLAN 10, para obter um endereço IP do servidor DHCP para os dispositivos localizados nessas VLANs.

Router1


Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4,
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active
50   VLAN0050                         active
51   VLAN0051                         active
100  VLAN0100                         active
200  VLAN0200                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
50   enet  100050     1500  -      -      -        -    -        0      0
51   enet  100051     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Configuração de VTPs, Troncos, Port Channels e Spanning Trees

Por padrão, o modo VTP é servidor e o nome do domínio é vazio. Você pode criar VTPs somente no modo de banco de dados de VLANs. O único modo de spanning tree com suporte é o PVST+. O encapsulamento padrão do tronco é dot1q. Ao configurar a porta do tronco para permitir somente VLANs especificadas, você poderá receber uma mensagem de erro semelhante a Bad VLAN allowed list. Nesse caso, talvez seja necessário permitir as VLAns padrão 1-2, 1002-1005 junto com sua lista de VLANs personalizadas. Por isso, você também precisará permitir as VLAns padrão e suas VLANs personalizadas no switch vizinho conectado a esta porta de tronco para evitar inconsistências no tronco.

Router1


VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q é o encapsulamento padrão.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q é o encapsulamento padrão.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1


Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Configuração de Portas de Acesso

A configuração de portas de acesso é semelhante à configuração do switch de LAN padrão.

Router1


Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Configuração de Portas de Voz

A configuração das portas de voz é semelhante à configuração do switch de LAN padrão.

Router1


Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Configuração da Qualidade de Serviço (QoS)

Esta é a configuração de QoS padrão no módulo ESW:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

Estas seções explicam essas configurações:

Configuração de Filas do WRR

Não é possível configurar a QoS com base em portas nas portas do switch da camada 2. As filas podem ser configuradas somente de uma configuração global. O exemplo de configuração mapeia os valores de CoS nas quatro filas diferentes. Quando um pacote entra no mecanismo da camada 2 diretamente de uma porta do switch, ele é colocado em uma das quatro filas do buffer dinâmico de memória compartilhada com 32 MB. Todos os pacotes de voz recebidos dos telefones IP Cisco na VLAN de voz são automaticamente colocados na fila de prioridade mais alta (fila 4) com base no valor 802.1p (CoS 5) gerado pelo telefone IP. As filas são atendidas de acordo com a aplicação de um algoritmo de rodízio balanceado (WRR). O tráfego de controle, o qual usa um CoS ou Tipo de Serviço (ToS) igual a 3, é colocado na fila 3.

Router1

Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <valores de cos separados por espaços>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Tamanho de Queue1> <Tamanho de Queue2>
!--- <Tamanho de Queue3> <Tamanho de Queue4>

Verifique os parâmetros de fila:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8

!--- Valores padrão


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255

!--- Valores configurados


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4

!--- Valores padrão

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4

!--- Valores configurados

Esta tabela mostra o número da fila, o valor de CoS e o peso de cada fila após a configuração.

Número da Fila

Valor de CoS

Peso

1

0 1

1

2

2

16

3

3 4

64

4

5 6 7

255

Configuração da Porta para Confiar no CoS

Router1

Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- Confie no valor de CoS dos frames para o telefone IP.

Router1(config-if)#mls qos cos override

!--- Redefina o valor de CoS dos frames do PC para 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- Confie no valor de CoS dos frames para este link de tronco.

Router1(config-if-range)#exit

Configuração do Vigilante

Esta seção mostra a configuração do vigilante na interface fa1/2 para limitar o tráfego de FTP em 5 Mpbs.

Router1

Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Há algumas restrições na configuração do vigilante nos módulos ESW. Elas são relacionadas aqui:

  • Os mapas de políticas com classificação de ACL na direção de saída não são aceitas e não podem ser anexados à interface por meio do comando de configuração service-policy input policy-map-name interface.

  • Em um mapa de políticas não há suporte à classe chamada class-default. O switch não filtra o tráfego com base no mapa de políticas definido pelo comando de configuração class class-default policy-map.

  • Você pode criar um mapa de políticas e aplicá-lo somente na entrada das interfaces do ESW. Além disso, no mapa de políticas, somente o vigilante é aceito.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • Não há suporte à aplicação de políticas em uma VLAN ou no nível de interface virtual comutada (SVI).

Verificação

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

No momento, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 82156