Sem fio/Mobilidade : LAN Wireless (WLAN)

Exemplo de QoS em Wireless LAN Controllers e APs Lightweight

8 Junho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (27 Junho 2008) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Informações de Apoio
      Aprimoramentos na Marcação de Pacotes de QoS da Camada 3
      Configuração de Rede
Configuração
      Configuração da Rede Wireless para a QoS
      Configuração da Rede com Fio para a QoS
Verificação e Troubleshooting
      Comandos de Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este exemplo apresenta um exemplo de configuração que mostra como configurar a Qualidade de Serviço (QoS) em redes wireless Cisco Unified usando Cisco Wireless LAN Controllers (WLCs) e pontos de acesso lightweight (LAPs).

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Conhecimento básico da configuração de LAPs e Cisco WLCs.

  • Conhecimento de como configurar o roteamento básico e a QoS em uma rede com fio.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2006 WLC com firmware versão 4.0

  • Cisco 1000 Series LAPs

  • Cisco 802.11a/b/g Wireless Client Adapter com firmware versão 2.6

  • Cisco 3725 Router com Cisco IOS® Software Versão 12.3(4)T1

  • Cisco 3640 Router com Cisco IOS Software Versão 12.2(26)

  • Dois Cisco 3500 XL Series Switches com Cisco IOS Software Versão 12.0(5)WC3b

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

QoS refere-se à capacidade da rede fornecer serviços melhores ou especiais a um conjunto de usuários ou aplicativos em detrimento de outros usuários ou aplicativos.

Com a QoS, a largura de banda pode ser gerenciada de forma mais eficiente entre LANs, o que inclui WLANs e WANs. A QoS oferece serviços de rede aprimorados e confiáveis da seguinte forma:

  • Oferece suporte à largura de banda dedicada para usuários e aplicativos críticos

  • Controla o jitter e a latência (necessário para o tráfego em tempo real)

  • Gerencia e minimiza o congestionamento rede

  • Ajusta o tráfego de rede para suavizar o fluxo de tráfego

  • Define as prioridades do tráfego de rede

No passado, as WLANs eram usadas principalmente para transportar tráfego específico de aplicativos com baixa largura de banda. Atualmente, com a expansão das WLANs no setor vertical (como varejo, finanças e educação) e em ambientes corporativos, as WLANs são usadas para transportar aplicativos de dados com requisitos de largura de banda elevada em conjunto com aplicativos multimídia sensíveis ao tempo. Esse requisito leva à necessidade da QoS wireless.

O grupo de trabalho IEEE 802.11e no comitê de padrões IEEE 802.11 concluiu a definição do padrão. No entanto, a adoção do 802.11e está em seus estágios iniciais e, assim como em muitos outros padrões, há vários componentes opcionais. Assim como ocorreu com a segurança 802.11 no 802.11i, os grupos do setor, como a Wi-Fi Alliance, e as empresas líderes da área, como a Cisco, estão definindo os requisitos chave da QoS de WLANs por meio de seus programas Wi-Fi MultiMedia (WMM) e Cisco Compatible Extensions (CCX), respectivamente. Isso garante o fornecimento de recursos base e inteoperabilidade em seus programas de certificação.

Os produtos wireless Cisco Unified oferecem suporte ao WMM, um sistema de QoS baseado no draft IEEE 802.11e publicado pela Wi-Fi Alliance.

Consulte a seção Qos Wireless do Cisco Unified do Guia de Design de Mobilidade Corporativa para obter mais informações sobre como a QoS funciona na rede wireless Cisco Unified.

Este documento apresenta um exemplo de configuração que ilustra como configurar a QoS em controladores e estabelecer comunicação com uma rede com fio configurada com a QoS.

Aprimoramentos na Marcação de Pacotes de QoS da Camada 3

A rede wireless Cisco Unified oferece suporte à marcação de pacotes Differentiated Services Code Point (DSCP) de IP da camada 3 enviados por WLCs e LAPs. Esse recurso aprimora o modo como os pontos de acesso (APs) usam essas informações da camada 3 para garantir que os pacotes recebam a priorização correta no ar do AP para o cliente wireless.

Em uma arquitetura de WLAN centralizada, os dados da WLAN são encapsulados entre o AP e o WLC via Lightweight Access Point Protocol (LWAPP). Para manter a classificação de QoS original neste túnel, as configurações de QoS do pacote de dados encapsulado deve ser mapeada de forma apropriada nos campos da camada 2 (802.1p) e da camada 3 (IP DSCP) do pacote do túnel de saída.

Não é possível marcar com DSCP os pacotes entre o controlador e o LAP quando não há valor de DSCP ou 802.1P no pacote original em si.

O controlador não aplica sua própria QoS. O suporte à QoS no WLC dá ao WLC a capacidade de aplicar a mesma prioridade definida no cabo (ou aplicativo).

Assim, a única ação que será feita em um WLC ou AP é copiar o valor do pacote original para o cabeçalho de saída do pacote LWAPP. O único objetivo das opções de QoS Gold, Silver e Bronze no WLC é executar conversões de QoS adequadas entre os valores de UP do 802.11e/802.1p e os valores de DCSP de IP, os quais dependem do aplicativo ou padrão que é usado. Mais uma vez, a QoS no WLC garante que os pacotes recebam o tratamento de QoS adequado fim a fim. O controlador não executa seu próprio comportamento de QoS. O suporte existe para que o controlador o siga se a QoS já existir e houver necessidade de aplicação de prioridade a pacotes wireless. A QoS não pode existir somente no controlador.

O controlador não oferece suporte a valores de marcação de Classe de Serviço (CoS) baseados na configuração da WLAN no modo LWAPP da camada 2. Recomenda-se usar o LWAPP da camada 3 para implementar a QoS da CoS.

Este é um exemplo de como a QoS funciona com WLCs. O aplicativo, por exemplo, o CallManager, poderia definir um valor de QoS de High. Assim, o pacote de dados original do aplicativo será encapsulado por um cabeçalho IP que possui o valor de DCSP definido como High. Agora o pacote chega ao controlador. Em seguida, o pacote passa pelo SSID Test. No entanto, se você possui um SSID Test em seu controlador configurado para o perfil de QoS Bronze, o cabeçalho IP do pacote que encapsula o pacote de LWAPP do controlador para o AP terá o valor Bronze (embora a prioridade do cabeçalho IP ao redor do pacote original do aplicativo seja alta). Este documento supõe que o DCSP definido pelo aplicativo e que o perfil de QoS para aquele SSID no controlador sejam os mesmos. Entretanto, esse nem sempre é o caso.

qos-wlc-lap1.gif

Por exemplo, quando o tráfego 802.11e é enviado por um cliente WLAN, ele possui uma classificação de prioridade de usuário (UP) em seu frame. O AP precisa mapear esta classificação de 802.11e em um valor de DSCP para o pacote de LWAPP que transporta o frame. Isso garante que o pacote receba a prioridade apropriada em seu caminho para o WLC. Um processo semelhante precisa ocorrer no WLC para os pacotes de LWAPP que vão para o AP. Além disso, um mecanismo é necessário para classificar o tráfego no AP e no WLS para clientes não-802.11e para que seus pacotes de LWAPP também recebam a prioridade adequada. Esta tabela ilustra como os pacotes são gerenciados em cada dispositivo:

#

De

Para

UP (802.1p/802.11e)

DSCP de IP

1

Controlador

Ponto de acesso

NÃO converte o valor de DSCP do pacote recebido para o valor de UP do AVVID 802.1p. O valor de DSCP, se presente no pacote, segue de forma transparente no pacote.

Copia o valor de DSCP do pacote recebido.

2

Ponto de acesso

Cliente wireless

Cliente WMM: Converte o valor de DSCP do pacote de LWAPP recebido para o valor de UP do 802.11e. Controla o valor para garantir que ele não exceda o valor máximo permitido para a política de QoS da WLAN atribuída a esse cliente. Coloca o pacote na fila de transmissão do 802.11 apropriada para o valor de UP.

Cliente regular: Coloca o pacote na fila de transmissão padrão do 802.11 para a política de QoS da WLAN atribuída a esse cliente.

N/D (o valor de DSCP original é preservado)

3

Ponto de acesso

Controlador

N/A (os pontos de acesso não oferecem suporte a marcas 802.1Q/802.1p)

Cliente WMM: Controla o valor de UP do 802.11e para garantir que ele não exceda o valor máximo permitido para a política de QoS atribuída ao cliente. Converte o valor para o valor de DSCP.

Cliente regular: Usa o valor de UP do 802.11e UP para a política de QoS atribuída ao cliente. Converte o valor para o valor de DSCP.

4

Controlador

Switch Ethernet

Converte o valor de DSCP dos pacotes de LWAPP recebidos para o valor de UP do 802.11p.

N/D (o valor de DSCP original é preservado)

Esta próxima tabela mostra as conversões que podem ocorrer entre os valores de UP do 802.11e/802.1p e os valores de DSCP de IP. Como a Cisco Architecture for Voice, Video and Integrated Data (AVVID) define a conversão de UP do 802.1 para DSCP de IP e o IEEE define a conversão de DSCP de IP para UP do 802.11e, dois conjuntos diferentes de conversões podem ser usados.

Tipo de tráfego baseado em UP da Cisco AVVID 802.1p

DSCP de IP da Cisco AVVID

UP da Cisco AVVID 802.1p

UP do IEEE 802.11e

Notas

Controle de rede

-

7

-

Reservado somente para controle de rede

Controle inter-rede

48

6

7 (AC_VO)

Controle de LWAPP

Voz

46 (EF)

5

6 (AC_VO)

Controlador: perfil de QoS Platinum

Vídeo

34 (AF41)

4

5 (AC_VI)

Controlador: perfil de QoS Gold

Controle de voz

26 (AF31)

3

4 (AC_VI)

-

Melhor esforço

0 (BE)

0

3 (AC_BE)

0 (AC_BE)

Controlador: perfil de QoS Silver

-

Apoio (Cisco AVVID Gold Background)

18 (AF21)

2

2 (AC_BK)

-

Apoio (Cisco AVVID Silver Background)

10 (AF11)

1

1 (AC_BK)

Controlador: perfil de QoS Bronze

Configuração de Rede

Este documento utiliza a seguinte configuração de rede:

  • A rede com fio é formada por dois roteadores, Router1 e Router2, que executam o OSPF entre eles. Os hosts com fio consistem em um servidor FTP (F1), um cliente de voz (V1) e um cliente de vídeo (Vi1). Os hosts com fio conectam-se à rede por meio de um switch da camada 2 ligado à Fast Ethernet do roteador R1.

  • A rede wireless se conecta à rede via Router2, conforme mostrado no diagrama. Os hosts wireless consistem em um cliente FTP (com WWM desabilitado), um cliente de voz V1 (telefones 7920) e um cliente de vídeo Vi1 (com WMM habilitado).

  • Os pacotes de voz devem receber a prioridade mais alta, seguidos pelos pacotes de vídeo. Os pacotes de FTP devem receber a prioridade mais baixa.

  • Na rede com fio, a Weighted Random Early Detection (WRED) é usada para implementar a QoS. Os diferentes tipos de tráfego são classificados e priorizados com base nos valores de DSCP. A WRED é implementada em pacotes não priorizados.

  • Na rede wireless, três WLANs devem ser criadas para cada tipo de tráfego e para habilitar os perfis de QoS apropriados.

    • WLAN 1 — Clientes FTP: Perfil de QoS Bronze

    • WLAN 2 — Clientes de vídeo: Perfil de QoS Gold

    • WLAN 3 — Clientes de voz: Perfil de QoS Platinum

Os dispositivos para a conectividade IP básica e a habilitação da QoS devem ser configurados nas redes com fio e wireless.

qos-wlc-lap4.gif

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Para configurar os dispositivos nesse cenário, os seguintes passos devem ser executados:

Configuração da Rede Wireless para a QoS

Antes de configurar a QoS nos WLCs, você deve configurar o WLC para operação básica e registrar os LAPs no WLC. Este documento pressupõe que o WLC esteja configurado para operação básica e que os LAPs estejam registrados no WLC. Se você for um novo usuário que está tentando configurar o WLC para operação básica com LAPs, consulte Registro do LAP (Lightweight AP) em um WLC (Wireless LAN Controller).

Assim que os LAPs forem registrados no WLC, conclua estas tarefas para configurar os LAPs e o WLC para esta configuração:

  1. Configure as WLANs para as diferentes classes de tráfego

  2. Habilite os perfis de QoS para as WLANs

Conclua estes passos para criar uma WLAN no WLC para os clientes de voz:

  1. Clique em WLANs na interface gráfica do usuário do controlador para criar uma WLAN.

  2. Clique em New para configurar uma nova WLAN.

    Neste exemplo, a WLAN é chamada VoiceClients e o WLAN ID é 1.

  3. Clique em Apply.

    qos-wlc-lap5.gif

  4. Na janela WLAN > Edit, defina os parâmetros específicos da WLAN VoiceClients.

    1. Para a WLAN, selecione a interface apropriada no campo Interface Name.

      Este exemplo mapeia a interface Voice na WLAN VoiceClients.

    2. No menu suspenso Quality of Service (QoS), selecione o perfil de QoS apropriado para a WLAN.

      Neste exemplo, o perfil de QoS Platinum é selecionado. Isso garante a prioridade mais alta à WLAN de voz.

    3. Para o parâmetro de suporte ao telefone 7920, escolha o tipo de controle de admissão de chamadas (CAC).

      Este exemplo usa AP CAC Limit.

    4. Selecione os outros parâmetros, os quais dependem dos requisitos de design.

      Os valores padrão são usados neste exemplo.

    5. Clique em Apply.

      qos-wlc-lap6.gif

      Nota: Não habilite o modo WMM se telefones Cisco 7920 forem usados em sua rede. Não é possível habilitar o modo WMM e o modo de CAC controlado por clientes na mesma WLAN. Quando o CAC controlado por AP é habilitado, o AP envia um Elemento de Informação (IE) de CAC proprietário da Cisco e não envia o IE de QBSS padrão.

A implementação de uma infra-estrutura de voz sobre WLAN envolve mais do que simplesmente oferecer QoS em uma WLAN. Uma WLAN de voz precisa considerar os requisitos de cobertura de pesquisa do site, comportamento dos usuários, requisitos de roaming e controle de admissão. Isso é coberto no Guia de Design e Implementação do Cisco Unified Wireless IP Phone 7920.

De forma semelhante, crie as WLANs para os clientes de vídeo e os clientes FTP. Os clientes de vídeo são mapeados na interface dinâmica Video e os clientes FTP são mapeados na interface dinâmica FTP. Estas são as capturas de tela:

Nota: Este documento não explica como criar VLANs em WLCs. Consulte Exemplo de Configuração de VLANs em Wireless LAN Controllers para obter informações sobre como configurar interfaces dinâmicas em WLCs.

qos-wlc-lap7.gif

qos-wlc-lap8.gif

Nota: O suporte do cliente da WLAN ao WMM não significa que o tráfego do cliente se beneficia automaticamente da WMM. Os aplicativos que procuram os benefícios do WMM atribuem uma classificação de prioridade apropriada ao tráfego, e o sistema operacional precisa informar essa classificação para a interface da WLAN. Em dispositivos criados com fins específicos, como handsets VoWLAN, isso é feito como parte do design. No entanto, se você implementar em uma plataforma de uso geral, como um PC, a classificação de tráfego de aplicativos e o suporte ao sistema operacional devem ser implementados antes que os recursos de WMM surtam efeito.

Para os clientes de vídeo, o perfil de QoS Gold é selecionado e o WMM é habilitado. Para os clientes FTP, Bronze é selecionado como o perfil de QoS e o WMM é desabilitado porque, neste exemplo, os clientes FTP não oferecem suporte a ele.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Nota: Quando o controlador está no modo da camada 2 e o WMM está habilitado, é necessário colocar os APs em uma porta de tronco para permitir que eles se unam ao controlador.

Execute estes comandos para configurar as WLANs e a QoS no WLC usando a CLI:

  • Execute o comando config wlan create <wlan-id> <wlan-name> para criar uma nova WLAN. Insira um ID entre 1 e 16 para wlan-id. Insira um SSID com até 31 caracteres alfanuméricos como o wlan-name.

  • Execute o comando config wlan enable <wlan-id> para habilitar uma WLAN.

  • Execute o comando config wlan qos wlan-id {bronze | silver | gold | platinum} para atribuir um nível de QoS a uma WLAN.

  • Execute o comando config wlan wmm {disabled | allowed | required} wlan-id para habilitar o modo WMM.

  • Execute o comando config wlan 7920-support client-cac-limit {enabled | disabled} wlan-id para telefones que necessitam de CA controlado por clientes.

  • Execute o comando config wlan 7920-support ap-cac-limit {enabled | disabled} wlan-id para telefones que necessitam de CAC controlado por AP.

Configuração da Rede com Fio para a QoS

Para configurar a rede com fio para esse cenário, é necessário configurar os roteadores para conectividade básica e habilitar a QoS na rede com fio. O OSPF é usado como o protocolo de roteamento unicast.

O recurso de WRED é usado para implementar a QoS na rede com fio. O recurso de WRED compatível com DiffServ permite que a WRED use o valor de DSCP ao calcular a probabilidade de descarte de um pacote.

Estas são as configurações para os roteadores R1 e R2:

Router1

Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifica os pacotes de FTP com base na lista de acesso 103.

  match access-group 103
class-map match-all Video

!--- Classifica os pacotes de vídeo com base na lista de acesso 102.

  match access-group 102
class-map match-all Voice

!--- Classifica os pacotes de voz com base na lista de acesso 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Define o valor de DSCP af11 para os pacotes de FTP.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Define o valor de DSCP ef para os pacotes de voz.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Define o valor de DSCP af41 para os pacotes de vídeo.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based

!--- Habilita a WRED com base no valor de DSCP do pacote.

 random-detect dscp 10 30 40

!--- Define os limites mínimo e máximo dos pacotes
!--- como 30 e 40 pacotes para o valor de DSCP 10.

 random-detect dscp 34 40 50

!--- Define os limites mínimo e máximo dos pacotes
!--- como 40 e 50 pacotes para o valor de DSCP 34.

 random-detect dscp 46 50 60

!--- Define os limites mínimo e máximo dos pacotes
!--- como 50 e 60 pacotes para o valor de DSCP 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Aplica a política Marking-For-Voice à interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Aplica a política Marking-For-Vídeo à interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Aplica a política Marking-For-FTP à interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configura o OSPF como o protocolo de roteamento.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Lista de acesso usada para classificar pacotes de voz.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Lista de acesso usada para classificar pacotes de vídeo.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Lista de acesso usada para classificar pacotes de FTP.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2

Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Habilita a WRED com base no valor de DSCP do pacote.

 random-detect dscp 10 30 40

!--- Define os limites mínimo e máximo dos pacotes
!--- como 30 e 40 pacotes para o valor de DSCP 10.

 random-detect dscp 34 40 50

!--- Define os limites mínimo e máximo dos pacotes
!--- como 40 e 50 pacotes para o valor de DSCP 34.

 random-detect dscp 46 50 60

!--- Define os limites mínimo e máximo dos pacotes
!--- como 50 e 60 pacotes para o valor de DSCP 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configura o OSPF como o protocolo de roteamento.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Verificação e Troubleshooting

Assim que as redes wireless e com fio são configuradas para a conectividade básica e a QoS é implementada, os pacotes são classificados, marcados e enviados com base nas políticas configuradas para cada tipo de tráfego.

A aplicação dos recursos de QoS pode não ser detectada facilmente em uma rede com pouca carga. Os recursos de QoS começam a impactar o desempenho dos aplicativos à medida que a carga na rede aumenta. A QoS atua para manter a latência, o jitter e a perda para os tipos selecionados de tráfego dentro de limites aceitáveis.

Para um cliente de vídeo com WMM habilitado:

Quando um cliente de vídeo na rede com fio envia dados para o cliente de vídeo na rede wireless, esta seqüência de eventos ocorre:

  1. Na interface FastEthernet de Router1, a política Marking-For-Video é aplicada aos pacotes de vídeo e os pacotes são marcados com um valor de DSCP AF41.

  2. Os pacotes de vídeo marcados passam pelas interfaces seriais S3/0 em Router1 e S0/0 em Router2. Aqui é onde a probabilidade de descarte do pacote é comparada contra o limite configurado para a WRED. Quando o comprimento médio da fila atinge o limite mínimo (neste caso, 40 pacotes de vídeo), a WRED descarta aleatoriamente alguns pacotes com o valor de DSCP AF41. Da mesma forma, quando o comprimento médio da fila excede o limite máximo (neste caso, 50 pacotes de vídeo), a WRED descarta todos os pacotes com o valor de DSCP AF41.

  3. Quando os pacotes de vídeo chegam até o WLC por meio da Fast Ethernet em Router2, o WLC converte o valor de DSCP do pacote recebido para o valor de UP de AVVID 802.1p e copia o valor de DSCP do pacote recebido para o pacote de LWAPP conforme mostrado aqui. Neste exemplo, o valor de DSCP AF41 é convertido para o valor de 802.1p correspondente 4.

    qos-wlc-lap11.gif

  4. Quando o pacote chega ao LAP, o LAP converte o valor de DSCP do pacote de LWAPP recebido para o valor de UP de 802.11e UP e controla o valor para garantir que ele não exceda o valor máximo permitido para a política de QoS da WLAN atribuída ao cliente. O LAP então coloca o pacote na fila de transmissão 802.11 apropriada para o valor de UP. Neste exemplo, o valor de DSCP AF41 é convertido para o valor de UP de 802.11e correspondente 5.

    qos-wlc-lap12.gif

Quando um cliente de vídeo na rede wireless envia dados para a rede com fio, esta seqüência de eventos ocorre:

  1. Quando um cliente com suporte ao WMM envia um pacote para o LAP, o LAP controla o valor de UP de 802.11e UP para garantir que ele não exceda o valor máximo permitido para a política de QoS atribuída ao cliente. Em seguida, ele converte o valor para o valor de DSCP. Neste exemplo, a WLAN de vídeo foi configurada com o perfil de QoS Gold, o qual possui um valor de UP de 802.11e 4. Esse valor é convertido para o valor de DSCP correspondente AF41 e enviado para o controlador.

    qos-wlc-lap13.gif

  2. O controlador converte o valor de DSCP do pacote de LWAPP recebido para o valor de UP de 802.1p conforme mostrado, e o valor de DSCP original também é enviado inalterado.

    qos-wlc-lap14.gif

  3. Os pacotes com valor de DSCP AF41 na Fast Ethernet de Router2 passam pelas interfaces seriais em Router2 e Router1 e chegam aos clientes de vídeo na rede com fio. Quando o pacote atravessa as interfaces seriais, a sua probabilidade de descarte é comparada com o limite configurado para a WRED.

Para um cliente de vídeo com WMM desabilitado:

Quando o cliente FTP na rede com fio envia dados para o cliente FTP na rede wireless, esta seqüência de eventos ocorre:

  1. Na interface FastEthernet de Router1, a política Marking-For-FTP é aplicada aos pacotes FTP e os pacotes são marcados com um valor de DSCP AF11.

  2. Os pacotes de FTP marcados passam pelas interfaces seriais S3/0 em Router1 e S0/0 em Router2. Aqui é onde a probabilidade de descarte do pacote é comparada contra o limite configurado para a WRED. Quando o comprimento médio da fila atinge o limite mínimo (neste caso, 30 pacotes de FTP), a WRED descarta aleatoriamente alguns pacotes com o valor de DSCP AF11. Da mesma forma, quando o comprimento médio da fila excede o limite máximo (neste caso, 40 pacotes de FTP), a WRED descarta todos os pacotes com o valor de DSCP AF11.

  3. Quando os pacotes de FTP chegam até o WLC por meio da Fast Ethernet em Router2, o WLC converte o valor de DSCP do pacote recebido para o valor de UP de AVVID 802.1p e copia o valor de DSCP do pacote recebido para o pacote de LWAPP conforme mostrado aqui. Neste exemplo, o valor de DSCP AF11 é convertido para o valor de 802.1p correspondente 1.

  4. Quando o pacote chega no LAP, o LAP o coloca na fila de transmissão padrão do 802.11 para a política de QoS da WLAN atribuída ao cliente. Neste exemplo, o pacote é colocado na fila para o perfil de QoS Bronze.

Quando um cliente de FTP na rede wireless envia dados para a rede com fio, esta seqüência de eventos ocorre:

  1. Quando um cliente FTP na rede wireless envia um pacote para o LAP, o LAP usa o valor de UP de 802.11e para a política de QoS atribuída ao cliente. Em seguida, o LAP converte o valor para o valor de DSCP e envia o pacote para o controlador. Como o cliente FTP pertence ao perfil de QoS Bronze, o valor de UP de IEEE 802.11e 1 é convertido para o valor de DSCP AF11.

  2. O controlador converte o valor de DSCP do pacote de LWAPP recebido para o valor de UP de 802.1p conforme mostrado, e o valor de DSCP original também é enviado inalterado. O pacote é então encaminhado para Router2 por meio do switch da camada 2.

  3. Os pacotes com valor de DSCP AF11 na Fast Ethernet de Router2 passam pelas interfaces seriais em Router2 e Router1 e chegam aos clientes de vídeo na rede com fio. Quando o pacote atravessa as interfaces seriais, a sua probabilidade de descarte é comparada com o limite configurado para a WRED.

Um procedimento semelhante ocorre quando um pacote de voz atravessa da rede com fio para a rede wireless e vice-versa.

Comandos de Troubleshooting

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Você pode executar os seguintes comandos do Cisco IOS no roteador para fazer o troubleshooting e verificar sua configuração de QoS:

  • show queue {interface-name interface-number} — Lista informações sobre os pacotes que estão aguardando em uma fila na interface.

  • show queueing random-detect interface {interface-name interface-number} — Lista informações de configuração e estatísticas sobre a ferramenta de enfileiramento em uma interface.

  • show policy-map interface {interface-name interface-number} — Exibe as estatísticas e configurações das políticas de entrada e saída que estão conectadas a uma interface. Certifique-se de usar este comando no modo EXEC apropriado.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debug qos set — Exibe informações sobre a marcação de pacotes de QoS.

No WLC, execute este comando para exibir as configurações de perfil de QoS:

  • show qos {bronze/silver/gold/platinum} — Fornece informações sobre o perfil de QoS configurado para as WLANs.

    Este é um exemplo de saída do comando show qos:

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <WLAN-ID> — Exibe informações sobre a WLAN. Este é um exemplo de saída:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 81831