Switches : Switches Cisco Catalyst série 6500

Exemplo de Configuração de Migração de Spanning Tree do PVST+ para o Rapid-PVST

8 Junho 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (12 Janeiro 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Informações de Apoio
Configuração
      Diagrama de Rede
      Configurações
      Configuração do PVST+
      UplinkFast e BackboneFast
      Migração do Rapid-PVST+
      Saída de Depuração - Modo Misto
      Saída de Depuração - Modo Rapid-PVST+
Verificação
Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

Este documento fornece um exemplo de configuração de migração do modo de spanning tree do PVST+ para o Rapid-PVST+ na rede do campus. Ele também explica a configuração do PVST+, o balanceamento de carga de Spanning Tree e os recursos UplinkFast e BackboneFast.

Pré-requisitos

Requisitos

Recomenda-se a leitura de Entendendo o Rapid Spanning Tree Protocol (802.1w) antes de configurar o Rapid-PVST+.

Esta tabela mostra o suporte ao Rapid Spanning Tree Protocol (RSTP) nos Catalyst Switches e o software mínimo necessário para esse suporte.

Plataforma Catalyst

Rapid-PVST+

Catalyst 2900 XL/3500 XL

Não disponível.

Catalyst 2940

12.1(20)EA2

Catalyst 2950/2955/3550

12.1(13)EA1

Catalyst 2970/3750

12.1(14)EA1

Catalyst 3560

12.1(19)EA1

Catalyst 3750 Metro

12,1(14)AX

Catalyst 2948G-L3/4908G-L3

Não disponível.

Catalyst 4000/2948G/2980G (CatOS)

7.5

Catalyst 4000/4500 (IOS)

12.1(19)EW

Catalyst 5000/5500

Não disponível.

Catalyst 6000/6500

7.5

Catalyst 6000/6500 (IOS)

12.1(13)E

Catalyst 8500

Não disponível.

Componentes Utilizados

As informações neste documento são baseadas no Cisco IOS® Software Versão 12.2(25) e no CatOS 8.5(8). No entanto, a configuração se aplica somente à versão mínima do Cisco IOS mostrada na tabela.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

O Spanning Tree Protocol (STP) 802.1D possui a desvantagem de uma convergência lenta. Os Cisco Catalyst Switches oferece suporte a três tipos de STPs: PVST+, Rapid-PVST+ e MST. O PVST+ é baseado no padrão IEEE802.1D e inclui extensões proprietárias da Cisco, como BackboneFast, UplinkFast e PortFast. O Rapid-PVST+ é baseado no padrão IEEE 802.1w e possui uma convergência mais rápida que o 802.1D. O RSTP (IEEE 802.1w) inclui nativamente a maioria dos aprimoramentos proprietários da Cisco para a Spanning Tree 802.1D, como BackboneFast e UplinkFast. O Rapid-PVST+ possui os seguintes recursos exclusivos:

  • Usa a Bridge Protocol Data Unit (BPDU) versão 2, a qual é compatível com o STP 802.1D (que usa a BPDU versão 0).

  • Todos os switches geram BPDUs e os enviam em todas as portas a cada 2 segundos, enquanto que no RTP 802.1D somente a bridge raiz envia as BPDUs de configuração.

  • Funções de portas — Porta raiz, porta designada, porta alternativa e porta de backup.

  • Estados de portas — Descartando, Aprendendo e Encaminhando.

  • Tipos de portas — Portas Edge (PortFast), ponto a ponto e porta compartilhada.

O Rapid-PVST usa o RSTP para oferecer uma convergência mais rápida. Quando uma porta qualquer do RSTP recebe uma BPDU 802.1D antiga, ele retorna para o STP antigo e os benefícios da convergência rápida inerentes do 802.1w são perdidos nas interações com bridges mais antigas.

Configuração

Este exemplo contém duas seções. A primeira seção mostra a configuração atual do PVST+. A segunda seção mostra a configuração para a migração do PVST+ para o Rapid-PVST+.

Nota:  Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

O diagrama contém os seguintes switches:

  • Distribution1 e Distribution2 na camada de distribuição.

  • Dois switches da camada de acesso chamados Access1 (IOS) e Access2 (CatOS).

  • Dois switches de agregação de servidores chamados Services1 e Services2.

As VLANs 10, 30 e 100 transportam tráfego de dados. As VLANs 20, 40 e 200 transportam tráfego de voz.

rapidpvst-mig-config1.gif

Configurações

Este documento utiliza as seguintes configurações:

Configuração do PVST+

Os switches são configurados no PVST+ para transportar os tráfegos de dados e voz de acordo com o diagrama de rede. Um pequeno resumo da configuração é:

  • O switch Distribution1 é configurado para se tornar uma bridge raiz primária para as VLANs de dados 10, 30, 100 com o comando Distribution1(config)# spanning-tree vlan 10,30,100 root primary e a bridge raiz secundária para as VLANs de voz 20, 40, 200 usa o comando Distribution1(config)# spanning-tree vlan 20,40,200 root secondary.

  • O switch Distribution2 é configurado para se tornar uma bridge raiz primária para as VLANs de voz 20, 40, 200 com o comando Distribution2(config)# spanning-tree vlan 20,40,200 root primary e a bridge raiz secundária para as VLANs de dados 10, 30, 100 usa o comando Distribution2(config)# spanning-tree vlan 10,30,100 root secondary.

  • O comando spanning-tree backbonefast é configurado em todos os switches para convergir o STP mais rápido no caso de falha indireta do link na rede.

  • O comando spanning-tree uplinkfast é configurado nos switches da camada de acesso para convergir o STP mais rápido no caso de direta do uplink.

Distribution1

Distribution1#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Podemos ver que a porta Fa1/0/24 é configurada com o comando spanning-tree vlan 20,40,200 port-priority 64. Distribution2 é configurado como raiz para as VLANs 20,40,200. Distribution2 possui dois links para Distribution1: Fa1/0/23 e Fa1/0/24. Ambas as portas são portas designadas para as VLANs 20, 40, 200 porque Distribution2 é a raiz para essas VLANs. Ambas as portas possuem a mesma prioridade 128 (padrão). Além disso, esses dois links possuem o mesmo custo de Distribution1: fa1/0/23 e fa1/0/24. Distribution1 seleciona o menor número de porta entre as duas portas para defini-la no estado Encaminhando. O menor número de porta é Fa1/0/23. No entanto, de acordo com o diagrama de rede, as VLANs de voz 20, 40, 200 devem fluir por Fa1/0/24. Isso pode ser feito com os seguintes métodos:

  1. Diminua o custo da porta em Distribution1: Fa1/0/24

  2. Diminua a prioridade da porta em Distribution2: Fa1/0/24

Neste exemplo, a prioridade da porta é diminuída para encaminhar as VLANs 20, 40, 200 via fa1/0/24.

Distribution2

Distribution2#show running-config
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Podemos observar que a porta Fa0/5 em Services1 e ambas as portas Fa0/6 e Fa0/48 em Services2 possuem custo de porta e configuração de prioridade de porta de Spanning Tree. Aqui o STP é ajustado para que as VLANs 100 e 200 de Services1 e Services2 passem pelos links de tronco entre elas. Se essa configuração não for aplicada, Services1 e Services2 não transmitirão pelos links de tronco entre eles. Em vez disso, o caminho através de Distribution1 e Distribution2 será escolhido.

Services2 enxerga dois caminhos com o mesmo custo para a raiz de VLAN 100 (Distribution1). Um via Services1 e o outro via Distribution2. O STP escolhe o melhor caminho (porta raiz) nesta ordem:

  1. Custo do caminho

  2. A ID da bridge do switch de encaminhamento

  3. A menor prioridade de porta

  4. O menor número de porta interna

Neste exemplo, ambos os caminhos tem o mesmo custo. No entanto, Distribution2 (24576) tem uma prioridade menor que Services1 (32768) para a VLAN 100. Assim, Services2 escolhe Distribution2. Neste exemplo, o custo da porta em Services1: fa0/5 é definido como menor para que Services2 escolha Services1. O custo do caminho tem precedência sobre o número de prioridade do switch de encaminhamento.

Services1

Services1#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

O mesmo conceito é aplicado para Services1 escolher Services2 para encaminhar tráfego da VLAN 200. Após a redução do custo da VLAN 200 em Services2 - fa0/6, Services1 escolhe fa0/47 para encaminhar a VLAN 200. No entanto, o requisito aqui é encaminhar a VLAN 200 via fa0/48. Isso pode ser feito com estes dois métodos:

  1. Reduzir o custo da porta em Services1: Fa0/48

  2. Reduzir a prioridade da porta em Services2: Fa0/48

Neste exemplo, a prioridade da porta em Services2 é diminuída para encaminhar a VLAN 200 via fa0/48.

Services2

Services2#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1

Access1#show running-config
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2

Access2> (enable)show config all

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

UplinkFast e BackboneFast

É bom conhecer o comportamento de UplinkFast e BackboneFast antes de iniciar o processo de migração. No diagrama de rede, o switch Access1 executa o Cisco IOS. Esta saída é obtida antes da migração para o modo Rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  Uplinkfast enabled

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p


Access1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled
BackboneFast                 is enabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Esta saída é obtida após o modo ser alterado para Rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  UplinkFast enabled but inactive in rapid-pvst mode

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled but inactive in rapid-pvst mode
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Na saída do comando show spanning-tree summary, é possível observar que o UplinkFast e o BackboneFast estão habilitados. No entanto, estão inativos no modo Rapid-PVST. É opcional remover ambos os comandos. A operação do Rapid-PVST não será afetada se você não remover os comandos. Se você desabilitar o UplinkFast com o comando de modo de configuração no spanning-tree uplinkfast, a prioridade da bridge e o custo da porta serão revertidos para os valores padrão. Recomenda-se definir a prioridade da bridge no switch não-raiz como o número mais alto. Esta saída é mostrada após o recurso UplinkFast ser desabilitado no modo Rapid-PVST:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        19
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 19        128.107  P2p
Fa3/0/2          Altn BLK 19        128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

O CatOS não permite a alteração do modo para Rapid-PVST quando o recurso BackboneFast está habilitado. Você deve desabilitar o BackboneFast antes da migração. O UplinkFast age da mesma forma como se comporta no IOS.

Access2> (enable) set spantree mode rapid-pvst+
Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.

Migração do Rapid-PVST+

O Rapid-PVST+ usa o mesmo formato de BPDU que o 802.1D e é compatível com versões anteriores. É difícil converter todos os switches na rede corporativa ao mesmo tempo para o Rapid-PVST+. Devido à compatibilidade com versões anteriores, é possível converter uma fase de cada vez. Recomenda-se implementar as alterações na janela de manutenção programada porque a reconfiguração da spanning tree interrompe o fluxo de tráfego. Os recursos de UplinkFast e BackboneFast da Spanning Tree são recursos do PVST+. Eles são desabilitados quando o Rapid-PVST+ é habilitado porque esses recursos são incorporados ao Rapid-PVST+. Assim, durante a migração, você pode remover esses comandos. A configuração de recursos como PortFast, BPDUguard, BPDUfilter, root guard e loopguard também se aplicam ao modo Rapid-PVST+. O uso desses recursos é o mesmo que no modo PVST+. Se você já tiver habilitado esses recursos no modo PVST+, os recursos permanecerão ativos após a migração para o modo Rapid-PVST+. Neste exemplo, a migração ocorre nesta ordem:

  1. Access1

  2. Access2

  3. Services1 e Services2

  4. Distribution1 e Distribution2

  1. Migração de Access1:

    Access1(config)#spanning-tree mode rapid-pvst
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
    
    Access1#show spanning-tree vlan 10
    
    VLAN0010
      Spanning tree enabled protocol rstp
      Root ID    Priority    24586
                 Address     0015.63f6.b700
                 Cost        19
                 Port        107 (FastEthernet3/0/1)
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                 Address     000f.f794.3d00
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time 300
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
    Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
    
    
    !--- Type P2p Peer(STP) representa que o switch vizinho executa o PVST.
    
    
  2. Migração de Access2:

    Access2> (enable) set spantree backbonefast disable
    Backbonefast disabled for all VLANs.
    
    Access2> (enable) set spantree mode rapid-pvst+
    PVST+ database cleaned up.
    Spantree mode set to RAPID-PVST+.
    
    
    Access2> (enable) clear spantree uplinkfast
    This command will cause all portcosts, portvlancosts, and the
    bridge priority on all vlans to be set to default.
    Do you want to continue (y/n) [n]? y
    VLANs 1-4094 bridge priority set to 32768.
    The port cost of all bridge ports set to default value.
    The portvlancost of all bridge ports set to default value.
    uplinkfast all-protocols field set to off.
    uplinkfast disabled for bridge.
  3. Migração de Services1 e Services2:

    Services1(config)#spanning-tree mode rapid-pvst
    Services1(config)#no spanning-tree backbonefast
    
    Services2(config)#spanning-tree mode rapid-pvst
    Services2(config)#no spanning-tree backbonefast
    
  4. Migração de Distribution1 e Distribution2:

    Distribution1(config)#spanning-tree mode rapid-pvst
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- O switch Distribution1 possui interfaces de VLAN da Camada 3 e
    !--- é desativado e ativado durante a conversão.
    
    
    Distribution1(config)#no spanning-tree backbonefast
    
    
    Distribution2(config)#spanning-tree mode rapid-pvst
    
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    own
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    p
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- O switch Distribution2 possui interfaces de VLAN da Camada 3 e
    !--- é desativado e ativado durante a conversão.
    
    
    Distribution2(config)#no spanning-tree backbonefast
    

Saída de Depuração - Modo Misto

Em um ambiente corporativo de grande porte, o processo de migração pode levar alguns dias. Durante o processo de migração, a LAN pode funcionar no modo misto, como alguns switches no modo PVST+ e outros switches no modo Rapid-PVST+. No modo misto, nem todos os benefícios do Rapid-PVST+ estão disponíveis. O tempo total de convergência é o mesmo que o tempo de convergência do modo PVST+. Para aproveitar ao máximo o Rapid-PVST+, todos os switches na topologia de spanning tree devem executar o Rapid-PVST+ . Para mostrar como a spanning tree se comporta no modo misto, um exemplo de saída do comando debug é mostrado aqui. Distribution1 e Distribution2 estão no modo PVST+ e Access1 está no modo Rapid-PVST+.

A saída do comando debug spanning-tree mostra a operação do STP quando o link entre Access1 e Distribution1 falha.

Access1

00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
00:55:13: RSTP(10): Fa0/2 is now root port
00:55:13: RSTP(10): Fa0/2 received a tc ack
00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Distribution2

00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23

A saída do comando debug spanning-tree mostra a operação do STP quando o link entre Access1 e Distribution1 está ativo.

Access1

00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
00:55:43: RSTP(10): initializing port Fa0/1
00:55:43: RSTP(10): Fa3/0/1 is now designated
00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
00:55:43: RSTP(20): initializing port Fa0/1
00:55:43: RSTP(20): Fa0/1 is now designated
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
00:55:43: RSTP(10): Fa0/1 is now root port
00:55:43: RSTP(10): Fa0/2 blocked by re-root
00:55:43: RSTP(10): Fa0/2 is now alternate
00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to up
00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
00:55:44: RSTP(20): Fa0/1 is now alternate

Distribution1

00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to up
00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding


!--- Esta saída torna evidente que o switch Access1 aguarda o
!--- processo de Spanning Tree 802.1D padrão de escutar, aprender e encaminhar
!--- ser concluído em Distribution1.




Distribution2

00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24


!--- Esta saída mostra que Distribution2 é notificado
!--- sobre a falha indireta do link pelas BPDUs da TCN.

Saída de Depuração - Modo Rapid-PVST+

Os switches Distribution1, Distribution2 e Access1 estão no modo Rapid-PVST+. A saída do comando debug spanning-tree mostra a operação do STP quando o link entre Access1 e Distribution1 falha.

Access1

01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
01:31:04: RSTP(10): Fa0/2 is now root port
01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

A saída do comando debug spanning-tree mostra a operação do STP quando o link entre Access1 e Distribution1 está ativo.

Access1

01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
01:35:48: RSTP(10): initializing port Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now designated
01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
01:35:48: RSTP(20): initializing port Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now designated
01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now root port
01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
01:35:48: RSTP(10): synced Fa3/0/1
01:35:48: RSTP(10): Fa3/0/2 is now alternate
01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now alternate
01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
osal

Distribution1

01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
01:35:56: RSTP(10): initializing port Fa1/0/1
01:35:56: RSTP(10): Fa1/0/1 is now designated
01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
01:35:56: RSTP(20): initializing port Fa1/0/1
01:35:56: RSTP(20): Fa1/0/1 is now designated
01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(10): received an agreement on Fa1/0/1
01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired


!--- Distribution1 coloca a porta Fa1/0/1 conforme o designado para as VLANs 10 e 20.
!--- Ele também propõe que Fa1/0/1 seja designada para as VLANs 10, 20. Access1 concorda com a
!--- proposta para VLAN10. No entanto, ele não concorda com a proposta para VLAN20 porque
!--- possui a BPDU superior para VLAN20 de Distribution2.

Verificação

Use esta seção para verificar se a sua configuração funciona corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Recomenda-se verificar a topologia da spanning tree toda vez que a configuração é alterada.

Verifique se o switch Distribution1 é a bridge raiz para as VLANs de dados 10, 30, 100. Além disso, verifique se o caminho de encaminhamento da spanning tree corresponde ao caminho do diagrama de rede.

Distribution1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0015.63f6.b700
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 19        128.1    P2p
Fa1/0/3          Desg FWD 19        128.3    P2p
Fa1/0/5          Desg FWD 19        128.5    P2p
Fa1/0/23         Desg FWD 19        128.23   P2p
Fa1/0/24         Desg FWD 19        128.24   P2p


Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Access2> (enable) show spantree 30
VLAN 30
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24606
Designated Root Cost        19
Designated Root Port        3/3
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-1d
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT        19   32 P2P
 3/4                     blocking      ALTR        19   32 P2P

Access2> (enable) show spantree 40
VLAN 40
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24616
Designated Root Cost        19
Designated Root Port        3/4
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-27
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR        19   32 P2P
 3/4                     forwarding    ROOT        19   32 P2P


Services1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        18
             Port        7 (FastEthernet0/5)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Root FWD 18        128.7    P2p
Fa0/46           Desg FWD 19        128.50   P2p
Fa0/47           Desg FWD 19        128.51   P2p

Services1#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        37
             Port        51 (FastEthernet0/47)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Altn BLK 19        128.7    P2p
Fa0/46           Altn BLK 19        128.50   P2p
Fa0/47           Root FWD 19        128.51   P2p

Services2#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        37
             Port        42 (GigabitEthernet0/42)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Altn BLK 19        128.6    P2p
Fa0/42           Root FWD 19        128.42   P2p
Fa0/43           Altn BLK 19        128.43   P2p

Services2#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        18
             Port        6 (GigabitEthernet0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Root FWD 18        128.6    P2p
Fa0/42           Desg FWD 19        128.42   P2p
Fa0/43           Desg FWD 19         64.43   P2p

Troubleshooting

No momento, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 72836