Switches : Sistema de switching virtual 1140 Cisco Catalyst 6500

Migre o Cisco Catalyst 6500 Switch autônomo ao sistema de switching virtual do Cisco catalyst 6500

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece a informação sobre o procedimento migrando um Cisco Catalyst 6500 Series Switch autônomo a um sistema de switching virtual do Cisco catalyst 6500.

Nota: Este documento fornece as etapas comuns que são exigidas para a migração. As etapas exatas são baseadas na configuração de switch atual e podem variar levemente do procedimento mencionado.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

Componentes Utilizados

A informação neste documento é baseada nos Cisco Catalyst 6500 Series Switch com supervisor VS-S720-10G-3C/XL que executa o Software Release 12.2(33)SXH1 ou Mais Recente do½ do¿Â do Cisco IOSïÂ.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

O sistema de switching virtual (VSS) é uma característica nova e inovativa em Cisco Catalyst 6500 Series Switch que permita eficazmente uma aglomeração de dois chassis físicos junto em uma única entidade lógica. Tal tecnologia permite realces novos em todas as áreas do desenvolvimento do campus de empreendimento e do centro de dados, que inclui a Alta disponibilidade, a escalabilidade/desempenho, o Gerenciamento e a manutenção.

A implementação atual do VSS permite que você funda dois Cisco Catalyst 6500 Series Switch físicos junto em uma única entidade lógico-controlada. Esta figura fornece uma representação gráfica deste conceito onde dois 6509 chassis podem ser controlados como um único 18-slot chassi VSS são permitidos uma vez:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration1.gif

Processo de migração

Suporte de hardware e software

O VSS é uns recursos de software disponíveis somente com os Cisco Catalyst 6500 Series Switch. A fim permitir e configurar esta característica, isto é exigido:

Hardware VS-S720-10G-3C/XL

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration2.gif

Software Cisco IOS Software Release 12.2(33)SXH1 ou Mais Recente

Chassi apoiado pelo sistema de switching virtual de Cisco

Número de modelo Descrição
WS-C6503-E Chassi das E-séries 3-slot
WS-C6504-E Chassi das E-séries 4-slot
WS-C6506 chassi 6-slot
WS-C6506-E Chassi das E-séries 6-slot
WS-C6509 chassi 9-slot
WS-C6509-E Chassi das E-séries 9-slot
WS-C6509-NEB-A chassi vertical dos padrões de construção do equipamento de rede 9-slot (NEBS)
WS-C6509-V-E Chassi do vertical das E-séries 9-slot
WS-C6513 chassi 13-slot

Esta tabela dá uma lista completa do chassi apoiado com a versão inicial do sistema de switching virtual de Cisco. Para mais informação, refira o sistema de switching virtual do Cisco Catalyst 6500 Series (VSS) 1440.

Caminhos de migração

A tabela alista alguns dos caminhos de migração possíveis ao VSS. Esta lista é somente sugestivo e não detalhada.

Instalação inicial Elevação exigida Instalação final
Dois Cisco Catalyst 6500 Series Switch com supervisores WS-SUP720-3B.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration3.gif

Upgrade de hardware - Upgrade de software dos supervisores VS-S720-10G-3C/XL - Cisco IOS 12.2(33)SXH1 ou mais tarde VSS

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration4.gif

Dois Cisco Catalyst 6500 Series Switch com supervisores VS-S720-10G-3C/XL.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration5.gif

Upgrade de software - Cisco IOS 12.2(33)SXH1 ou mais tarde VSS

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration4.gif

Vista geral da migração

Configuração comum no ambiente independente

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration6.gif

Características ou protocolos que são executado entre o núcleo da camada 3 (L3) e a distribuição L2/L3:

  • Protocolos de IP Routing

  • Característica MultiPath dos Canais de porta L3 ou do EqualCost de Roteamento IP

Características ou protocolos que são executado entre a distribuição L2/L3 e a camada de acesso:

  • Spanning Tree Protocol

  • Primeiros protocolos do roteamento de salto (FHRP)

  • Políticas: QoS, ACL

  • Troncos L2, VLAN, Canais de porta

Migração ao VSS

Este é um processo da multi-etapa, e cada etapa é explicada nesta seção.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration7.gif

Etapas da migração entre o núcleo e a camada de distribuição:

  • Configurando o EtherChannel de Multichassi (MEC)

  • Configuração de Roteamento IP e comandos de alteração da remoção, que são mais exigidos

Etapas da migração entre a distribuição e a camada de acesso:

  • Configurando MEC

  • Mantendo o Spanning Tree Protocol permitido

  • Comandos de alteração FHRP

  • Políticas móveis de QoS e ACL a MEC (se for necessário)

  • Configuração móvel dos troncos L2 a MEC

Processo de migração passo a passo

Conclua estes passos:

  1. Na instalação autônoma inicial, o tráfego é geralmente função de balanceamento de carga entre switch de distribuição usando a partilha e a configuração de HSRP de carga de vlan.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration8.gif

  2. Altere o HSRP e a configuração STP de modo que Distribution-1 seja ativo para todos os fluxos, e os dispositivos confinante detectam esta mudança e enviam todo o tráfego a Distribution-1.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration9.gif

  3. Feche as interfaces física de Distribution-2, de modo que seja isolado da rede.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration10.gif

    .

    Uma vez que o Distribution-2 é removido completamente da rede, pode ser convertido ao modo VSS sem tráfego de produção de interrupção.

  4. Se não instalado previamente, instale o supervisor novo (VS-SUP720-10G) e verifique o estado.

    Distribution-2#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      5    5  Supervisor Engine 720 10GE (Active)    VS-S720-10G        SAD104707BB
      9   48  CEF 720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX     SAL1020NGY3
  5. Copie o Cisco IOS Software compatível VSS ao sup-bootdisk:

    Distribution-2#copy ftp: sup-bootdisk:
    Address or name of remote host []? 172.16.85.150
    Source filename []? s72033-ipservices_wan_vz.122-33.SXH1.bin
    Destination filename [s72033-ipservices_wan_vz.122-33.SXH1.bin]?
    Accessing ftp://172.16.85.150/s72033-ipservices_wan_vz.122-33.SXH1.bin...
  6. Atualize o bootvar para carregar o Cisco IOS Software copiado ao sup-bootdisk:

    Distribution-2(config)#boot system flash sup-bootdisk:s72033-ipservices_wan_vz.122-33.SXH1.bin
    
    
  7. Para o Distribution-2 comute para ser executado no modo VSS, um link do virtual switch (VSL) é exigido. O link atual do Canal de porta entre Distribution-1 e Distribution-2 pode ser utilizado para formar o VSL.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration11.gif

  8. Configurar os atributos do virtual switch:

    1. Número de domínio do virtual switch (original dentro da rede)

    2. Número do virtual switch (original dentro do domínio)

    3. Link do virtual switch (VSL)

    Distribution-2(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 1
    
    
    !--- After conversion Distribution-2 will be noted 
    !--- as Switch 1 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 1
    VSS(config-if)#switch virtual link 1
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)# ^Z
    VSS#
  9. Converta o interruptor Distribution-2 ao modo VSS.

    Nota: Emita este comando através do console do interruptor:

    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 1/5/4 is member of
    PortChannel 1
     Interface TenGigabitEthernet 1/5/5 is member of
    PortChannel 1
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 1 brought up
    Initializing as Virtual Switch Active
    
  10. Verifique a conversão do interruptor Distribution-2 ao modo VSS.

    VSS#show switch virtual role
    
    Switch  Switch Status  Preempt    Priority   Role     Session ID
            Number         Oper(Conf) Oper(Conf)          Local  Remote
    -------------------------------------------------------------------
    LOCAL    1     UP      FALSE(N)    110(110)  ACTIVE    0      0
    
    In dual-active recovery mode: No

    O interruptor Distribution-2 com sucesso é convertido e está operando-se no modo VSS. as etapas da PRE-configuração podem igualmente ser executadas após ter convertido o interruptor Distribution-1. Contudo, a PRE-configuração ajuda a reduzir a quantidade de perda de pacotes durante a migração.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration12.gif

  11. Termine estas etapas PRE-para configurar VSS Switch1:

    1. Configurar MEC usando interfaces local Switch-1. As relações do switch 2 (atualmente Distribution-1) podem ser adicionadas a MEC após ter convertido o ao modo VSS.

      • Configurar MEC.

      • Mova a configuração da interface para MEC.

      • Mova QoS e políticas ACL para MEC.

      Configuração inicial
      interface TenGigabitEthernet1/2/1
       ip address 192.168.4.2 255.255.255.0
      
      interface GigabitEthernet1/1/2
       switchport
       switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 10,20
      Alterações de configuração
      
      !--- MEC to Core layer
      
      VSS(config)# int ten 1/2/1
      VSS(config-if)# no ip address
      VSS(config-if)# interface po20
      VSS(config-if)# ip address 192.168.4.2 255.255.255.0
      VSS(config-if)# no shut
      VSS(config-if)# interface ten1/2/1
      VSS(config-if)# channel-group 20 mode desirable
      
      
      !--- MEC to Access layer
      
      VSS(config-if)# interface po10
      VSS(config-if)# switchport
      VSS(config-if)# switchport trunk encapsulation dot1q
      VSS(config-if)# switchport trunk allowed vlan 10,20
      VSS(config-if)# no shut
      VSS(config-if)# interface gig1/1/2
      VSS(config-if)# switchport
      VSS(config-if)# channel-group 10 mode desirable
      Configurar dispositivos confinante para acomodar o Canal de porta

      A conexão entre o Switch 1 VSS e os seus dispositivos confinante está para baixo neste momento. Consequentemente, um Canal de porta é configurado sem tráfego de interferência corre através de Distribution-1.

      
      !--- In Core layer devices
      
      Core(config)# int gig 1/1
      Core(config-if)# no ip address
      Core(config-if)# int po20
      Core(config-if)# ip address 192.168.4.1 255.255.255.0
      Core(config-if)# no shut
      Core(config-if)# int gig 1/1
      Core(config-if)# channel-group 20 mode desirable
      
      !--- In Access layer devices
      
      Access(config)# int po10
      Access(config-if)# switchport
      Access(config-if)# switchport trunk encapsulation dot1q
      Access(config-if)# switchport trunk
      Access(config-if)# no shut
      Access(config-if)# int gig 1/1
      Access(config-if)# channel-group 10 mode desirable
    2. No chassi ativo e à espera VSS, use chassis ativos queimar-no MAC address e no endereço IP de Um ou Mais Servidores Cisco ICM NT VLAN. O HSRP é exigido já não.

      • Mova endereços IP de Um ou Mais Servidores Cisco ICM NT virtuais HSRP às interfaces de VLAN.

      • Remova a configuração de HSRP das interfaces de VLAN.

      Configuração inicial
      interface Vlan10
       ip address 10.1.1.2 255.255.255.0
       standby 10 ip 10.1.1.1
       standby 10 priority 110
      !
      interface Vlan20
       ip address 20.1.1.2 255.255.255.0
       standby 20 ip 20.1.1.1
       standby 20 priority 110
      !
      Alterações de configuração
      VSS(config)# interface Vlan10
      VSS(config-if)# no standby 10 ip 10.1.1.1
      VSS(config-if)# no standby 10 priority 110
      VSS(config-if)# ip address 10.1.1.1 255.255.255.0
      VSS(config-if)# interface Vlan20
      VSS(config-if)# no standby 20 ip 20.1.1.1
      VSS(config-if)# no standby 20 priority 110
      VSS(config-if)# ip address 20.1.1.1 255.255.255.0

      Nota: Os dispositivos finais ainda estariam apontando suas entradas de ARP para rubricar o MAC address HSRP. Até que estas entradas cronometrem para fora ou um outro ARP estiver enviado para atualizar seu esconderijo, há alguma perda de conectividade.

    3. Permita a característica NSF-SSO para os protocolos de IP Routing usados. O VSS simplifica a configuração de roteamento, assim que algumas das instruções de rede são exigidas já não. Consequentemente, podem ser removidos.

      Switch 1 VSS
      VSS#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 10.1.1.0 0.0.0.255 area 0
       network 20.1.1.0 0.0.0.255 area 0
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      VSS(config)# router ospf 1
      VSS(config-router)# nsf
      VSS(config-router)# no network 192.168.5.0 0.0.0.255 area 0
      Centro
      Core#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      Core(config)# router ospf 1
      Core(config-router)# nsf
      Core(config-router)# no network 192.168.5.0 0.0.0.255 area 0
    4. Altere a configuração STP de modo que o Switch 1 VSS se transforme a raiz para todos os VLAN.

  12. Verifique a configuração e a Conectividade do Switch 1 VSS.

    • Permita relações do Switch 1 VSS.

    • Verifique a Conectividade L2 aos dispositivos da camada de acesso.

    • Verifique a Conectividade L3 aos dispositivos da camada central.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration13.gif

  13. Depois que a Conectividade do Switch 1 VSS é verificada, feche as relações de Distribution-1 para comutar sobre o tráfego ao VSS.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration14.gif

  14. Repita as etapas da conversão no interruptor Distribution-1 para trazer isso no modo standby preferido VSS.

    Distribution-1(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 2
    
    
    !--- After conversion Distribution-1 will be noted 
    !--- as Switch 2 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 2
    VSS(config-if)#switch virtual link 2
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)# ^Z
    VSS#
    
    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 2/5/4 is member of
    PortChannel 2
     Interface TenGigabitEthernet 2/5/5 is member of
    PortChannel 2
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 2 brought up
    Initializing as Virtual Switch Standby
    
  15. Após as botas à espera do interruptor VSS acima, a configuração ativa VSS é sincronizada automaticamente ao apoio VSS. Na bota acima, as relações do apoio VSS (switch 2) estão no estado de fechamento.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration15.gif

  16. Finalize a configuração do virtual switch.

    Nota: Este final, passo crítico é aplicável somente para uma conversão principiante. Se o interruptor tem sido convertido ou convertido parcialmente já, você não pode usar este comando. Um Mensagem de Erro é gerado se o interruptor é convertido ou convertido parcialmente:

    11:27:30: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected
    on Po110, putting Gi9/2 in err-disable state
    

    Você pode emitir este comando configurar automaticamente a configuração à espera do virtual switch no virtual switch ativo:

    VSS#switch accept mode virtual
    
    This command will bring in all VSL configurations from the standby 
    switch and populate it into the running configuration.
    In addition the startup configurations will be updated with the 
    new merged configurations.
    Do you want proceed? [yes/no]: yes
    Merging the standby VSL configuration. . .
    Building configuration...

    Nota: Esteja ciente que o interruptor aceita o comando virtual do modo está precisado já não no Cisco IOS Software Release 12.2 SXI enquanto as configurações são fundidas automaticamente.

  17. Adicionar as relações do switch 2 a MEC.

    • VSS
      
      !--- To Core layer
      
      VSS(config)# interface range tengig 1/2/1, tengig2/2/1
      VSS(config-if-range)# channel-group 20 mode desirable
      VSS(config-if-range)# no shut
      
      
      !--- To Access layer
      
      VSS(config)# interface range gig 1/1/2, gig 2/1/2
      VSS(config-if-range)# switchport
      VSS(config-if-range)# channel-group 10 mode desirable
      VSS(config-if-range)# no shut
      
    • Vizinho VSS - Núcleo
      Core(config)# interface range gig 1/1, gig 1/2
      Core(config-if-range)# channel-group 20 mode desirable
      Core(config-if-range)# no shut
    • Vizinho VSS - Acesso
      Access(config)# interface range gig 1/1, gig 1/2
      Access(config-if-range)# channel-group 10 mode desirable
      Access(config-if-range)# no shut

    A migração ao VSS está completa. Neste momento, ambo o Switches do VSS está sendo executado e o tráfego é função de balanceamento de carga em todas as interfaces de uplink.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration16.gif


Informações Relacionadas


Document ID: 109573