Voz e comunicações unificadas : Cisco Unified Border Element

Exemplo de Configuração do Unified Border Element (CUBE) com o Cisco Unified Communications Manager (CUCM)

8 Abril 2009 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (31 Outubro 2007) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Convenções
Configuração
      Configurações
      Configuração do SIP User Agent
      Interconexão com o Cisco Unified Communications Manager
      Transcodificação no Cisco Unified Border Element
      Uso do Tcl IVR no Cisco Unified Border Element
      Exemplo de Configuração Completa
Verificação
Troubleshooting
      Comandos para Troubleshooting
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

O Cisco Unified Border Element possibilita a conectividade simples e eficiente em termos de custo entre os troncos do Session Initiation Protocol (SIP) da comunicação integrada corporativa e a rede telefônica pública comutada (PSTN). Desenvolvido para atender às necessidades de dispositivos de Controle de Sessão Border (SBC) corporativas e de provedores de serviços, o Cisco Unified Border Element (CUBE) é um aplicativo integrado do Cisco IOS® Software que pode ser executado em:

  • Cisco 2800 Series Integrated Services Routers

  • Cisco 3800 Series Integrated Services Routers

  • Cisco 2600XM Series Multiservice Platforms

  • Cisco 3700 Series Routers

  • Cisco 7200VXR Routers

  • Cisco 7301 Routers

  • Cisco AS5400XM e AS5350XM Access Gateways

As interconexões de IP diretas entre redes de comunicação integrada oferecem uma maior flexibilidade para oferecer suporte a serviços novos quando comparadas às interconexões de multiplexação no tempo (TDM) das redes telefônicas PSTN convencionais.

O Cisco Unified Border Element oferece um ponto de interface rede a rede para:

  • Interconexão de sinalização — H.323, SIP.

  • Interconexão de mídia — Dual-Tone Multifrequency [DTMF], fax, modem e transcodificação de codecs.

  • Conversões de endereços e portas — privacidade e ocultação de topologia.

  • Cobrança e normalização de Registros de Detalhes de Chamadas (CDR).

  • Gerenciamento de Qualidade de Serviço (QoS) e largura de banda — QoS com o uso de pontos de código de serviços diferenciados (DSCP) ou tipo de serviço (ToS), imposição de largura de banda via Resource Reservation Protocol (RSVP) e filtragem de codecs.

O Cisco Unified Border Element opera com vários elementos de rede diferentes, inclusive gateways de voz, telefones IP e servidores de controle de chamadas em vários ambientes de aplicativos distintos, desde serviços corporativos avançados de voz e/ou vídeo com o Cisco Unified Communications Manager ou Cisco Unified Communications Manager Express a aplicativos mais simples de desvio de cobrança e transporte Voz sobre IP (VoIP).

O Cisco Unified Border Element fornece às organizações todas as funções de controlador de borda integradas à camada de rede para interconectar as arquiteturas de comunicação integrada de voz e vídeo da empresa e do provedor de serviços. O Cisco Unified Border Element é usado por grandes corporações e pequenas e médias organizações para interconectar o acesso PSTN SIP a redes de comunicação integrada SIP e H.323 corporativas.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento baseiam-se no Cisco Unified Border Element (CUBE).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre as convenções de documentos.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota:  Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Configurações

Esta configuração habilita a funcionalidade básica do Cisco Unified Border Element em uma plataforma. Essa funcionalidade encerra uma chamada de VoIP recebida e a recria por meio de um peer de discagem VoIP de saída. As chamadas podem ser H.323 para SIP ou SIP para SIP.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

Configure os peers de discagem de entrada e saída com as informações de protocolo, tipo de DTMF e codec relevantes.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

Configuração do SIP User Agent

Configure o SIP User Agent (UA) para registro e autenticação.

SIP User Agent (UA)

sip-ua
register ipv4:10.1.1.10
ou
register dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Interconexão com o Cisco Unified Communications Manager

O Cisco Unified Communications Manager pode ser interconectado ao Cisco Unified Border Element via tronco de comunicação integrada H.323 ou SIP.

Tronco H.323 para o Cisco Unified Border Element

Há dois métodos para definir um tronco H.323 para o Cisco Unified Border Element no Cisco Unified Communications Manager:

  • Com um gatekeeper — Configurar um tronco H.225 (controlado pelo GK) para o Cisco Unified Border Element.

  • Sem um gatekeeper — Configurar o Cisco Unified Border Element como um gateway H.323.

Requisitos do Media Termination Point (MTP):

  • Se o Cisco Unified Border Element fizer chamadas H.323 para H.323, um MTP não será obrigatório desde que a versão do Cisco Unified Border Element seja a 12.4(6)T ou posterior e o Cisco Unified Communications Manager seja 4.1 ou posterior.

  • Um MTP de hardware ou software pode coexistir no mesmo roteador que o Cisco Unified Border Element (em plataformas de roteador que oferecem suporte a MTPs CUCM, o que inclui os ISRs Cisco 2800 e 3800 Series).

Requisitos do Fast Start H.323:

  • Se o Cisco Unified Border Element fizer a interconexão entre H.323 e SIP para o Cisco Unified Communications Manager, a maioria dos servidores proxy exigirá que a chamada SIP seja do tipo Early Offer. Isso implica que o lado do H.323 deve ser um Fast Start H.323. Assim, o Cisco Unified Communications Manager deverá ser configurado para Fast Starts H.323 de entrada e saída, o que também requer um MTP.

A figura 1 mostra a configuração de um Cisco Unified Border Element definido como gateway H.323 no Cisco Unified Communications Manager.

Figura 1. A configuração do Cisco Unified Border Element como um gateway H.323 no Cisco Unified Communications Manager

cube-config01.gif

cube-config02.gif

A figura 2 mostra a configuração do Cisco Unified Border Element de forma a corresponder à configuração anterior do Cisco Unified Communications Manager.

Figura 2. Configuração do Cisco Unified Border Element para um tronco H.323

cube-config03.gif

Tronco SIP para o Cisco Unified Border Element

O Cisco Unified Communications Manager versão 5.x ou posterior é necessário para a definição de um tronco SIP de comunicação integrada para o Cisco Unified Border Element.

Requisitos do MTP:

  • Tronco SIP sem um MTP — Configure um tronco SIP de comunicação integrada sem MTP se Delayed Media ou Invite with No SDP forem aceitáveis.

  • Tronco SIP com MTP — Configure um tronco SIP de comunicação integrada (com MTP) se Early Media ou Invite with SDP for um requisito (somente chamadas G.711).

A figura 3 mostra a configuração de um Cisco Unified Border Element definido com um tronco SIP de comunicação integrada para o Cisco Unified Communications Manager.

Figura 3. A configuração do Cisco Unified Border Element com um tronco SIP no Cisco Unified Communications Manager

cube-config04.gif

A figura 4 mostra a configuração do Cisco Unified Border Element de forma a corresponder à configuração anterior do Cisco Unified Communications Manager.

Figura 4. Configuração do Cisco Unified Border Element para um tronco SIP

cube-config05.gif

MTP coexistente com o Cisco Unified Border Element

Se um MTP de software for exigido pela configuração do Cisco Unified Communications Manager, ele poderá ser configurado no mesmo roteador usado para o Cisco Unified Border Element.

Esta é a configuração do Cisco Unified Border Element para um MTP:

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Transcodificação no Cisco Unified Border Element

O Cisco Unified Border Element pode fazer a transcodificação entre G.711µ-law/a-law e várias apresentações do G.729. A transcodificação pode ser solicitada para qualquer chamada, seja ela originada do Cisco Unified Communications Manager para a PSTN ou da PSTN para o Cisco Unified Communications Manager. O critério principal é se as duas pernas de chamadas no Cisco Unified Border Element possuem codecs diferentes - G.711 e G.729. A configuração da transcodificação no Cisco Unified Border Element exige a disponibilidade de DSPs na plataforma.

Esta é a configuração do Cisco Unified Border Element para a transcodificação:

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Uso do Tcl IVR no Cisco Unified Border Element

O Cisco Unified Border Element oferece suporte a scripts Tcl, e você pode configurá-los nos peers de discagem VoIP. Não é necessário haver um DSP para usar a funcionalidade Tcl. Há vários aplicativos Tcl que já fazem parte do Cisco IOS Software que podem ser usados nas implantações do Cisco Unified Border Element. A funcionalidade de autenticação, autorização e contabilidade (AAA) do Cisco IOS também pode ser usada em conjunto com os scripts Tck e o Cisco Unified Border Element para promover a autenticação e a autorização das chamadas.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Exemplo de Configuração Completa

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip

!--- Comando de chave

allow-connections sip to h323

!--- Comando de chave

allow-connections sip to sip

!--- Comando de chave

allow-connections h323 to h323

!--- Comando de chave

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard

!--- Aplicativo TCL

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric

!--- Configuração de DTMF para h.245 alfanumérico

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte

!--- Configuração de DTMF para RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
register ipv4:200.1.1.10 ou register dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Verificação

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas no troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • logging — É importante garantir que o Cisco Unified Border Element esteja configurado para registrar eventos, como neste exemplo, e também para executar a depuração o máximo possível fora do horário comercial, já que os comandos de depuração são muito detalhados.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • show — Esta é a saída relevante:

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • debug — Certifique-se de limpar o log antes de uma chamada de depuração ser feita e obtenha a saída do comando show logging após a execução da chamada.

    Cenários de H.323 para H.323

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    Cenários de H.323 para SIP

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    Cenários de SIP para SIP

    debug ccsip all
    debug voip ccapi inout
  • debug — Além dos comandos de depuração baseados no cenário descrito anteriormente, os seguintes comandos de depuração do transcodificador devem ser habilitados:

    debug dspfarm all
    debug sccp messages
  • debug voip rtp session named-events — Se a RFC2833 (dtmf-relay rtp-nte) for usada, você também deverá ativar este comando debug.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 99863