Voz e comunicações unificadas : Cisco Unity

Exemplo de partida da configuração de gateway do fax IP do Unity

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Enviar de partida é apoiado com o wizard de configuração do fax IP do Unity e começa com Software Release 12.3(7)T do ½ do ¿  do Cisco Unity 4.04 e do Cisco IOSïÂ. Este serviço permite que os usuários enviem fax de partida através de um e-mail simples. O número de telefone do fax do destino é incluído na linha de assunto do email e enviado a uma caixa postal que o serviço do fax IP do Unity verifique. Os re-formatos do serviço a mensagem, rendem todos os acessórios no formato apropriado, re-endereços, e enviam a mensagem. A mensagem é enviada através do Simple Mail Transfer Protocol (SMTP) ao Gateway de IOS configurado com a característica do off-ramp de T.37 a fim enviar o fax ao número de telefone de destino. Este documento centra-se sobre as etapas de configuração para o Cisco IOS gateway.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter um conhecimento básico do S TP e ser familiares com uma configuração de VoIP do Cisco IOS. Um server de trabalho do Cisco Unity com a versão 2.0.0.19 ou mais recente do wizard de configuração do fax IP do Unity instalada precisa de ser usado conjuntamente com a configuração de gateway definida neste documento a fim ter um sistema em funcionamento completo. No lado do Gateway de IOS, um roteador do Cisco IOS que apoie funcionalidade do off-ramp de T.37 e o Cisco IOS Software Release 12.3(7)T ou Mais Recente são exigidos junto com a versão 4.04 ou mais recente do Cisco Unity com Microsoft Exchange 2000 ou 2003 como o armazenamento de mensagens do sócio. Mais informação na parcela do Cisco Unity da configuração do fax IP pode ser encontrada no wizard de configuração do fax IP do Unity.

Nota: O off-ramp de T.37 não é apoiado em redes de MGCP. Refira o manual de configuração do fax de T.37 store and forward (guarda e passa adiante) para obter mais informações sobre da plataforma e das outras limitações usando T.37.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 3725 como o Gateway de IOS

  • Cisco IOS Software Release 12.3(8)T4

Nota: O gateway não é restringido à plataforma de Cisco 37xx. Algum gateway de voz com IP PLUS e trabalhos do Cisco IOS Software Release 12.3(7)T.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Quando o usuário envia um email à caixa postal do serviço do fax IP, contém o [FAXPHONE=----] no assunto, onde o #### é o número da máquina de fax do destino. As responsabilidades do serviço do fax IP estão a:

  • Assegure-se de que os acessórios que devem ser enviada seja válido e são rendidos no tipo formato do arquivo TIF F.

  • Endereço e email com o anexo TIF novo a FAX=####@gateway.com.

  • Interprete e tome a ação em toda a notificação de Status de entrega (DSN) recebida do gateway. Isto pode incluir enviar novamente a mensagem ao gateway (por exemplo, busy signal (sinal ocupado) ou sem resposta), ou a emissão de uma notificação ao utilizador final (por exemplo, número incorreto).

O Microsoft Exchange é responsável para:

  • A entrega do email endereçou a gateway.com ao Gateway de IOS.

  • A entrega de todo o correio entre o utilizador final à caixa postal do fax IP e entre o Gateway de IOS e o IP envia a caixa postal. Nenhuma mensagem é enviada do utilizador final ao gateway ou vice-versa.

As responsabilidades do Gateway de IOS estão a:

  • Interprete de FAX=####@gateway.com, da colocação de um atendimento ao ####, e do relé do fax usando protocolos padrão do fax G3 (T.30 e T.4).

  • Envie uma notificação de Status de entrega (DSN) embandeirada como um “erro permanente” à caixa postal do fax IP para cada chamada de fax colocada. Isto permite que o serviço do fax IP saiba que o fax esteve enviado corretamente, ou se havia um problema (tal como ocupado, sem resposta, e assim por diante). O serviço do fax IP é inteiramente responsável para segurar novas tentativas e enviar o feedback ao remetente ao contrário da confiança na configuração de sistema de correio.

Configuração de gateway

Há alguns comandos que você deve ter na configuração do IOS da Cisco para que este aplicativo trabalhe. Alguns dos estes sobreposição com os comandos configuration exigidos para a funcionalidade de entrada do fax (“on-ramp”). Note que é mais fácil compreender e pesquisar defeitos se estas encenações são tomadas separadamente:

  • envie o fax-correio do tipo de interface — Configurar este comando no gateway. Isto diz o gateway para processar store and forward (guarda e passa adiante) chamadas de fax de T.37. A ausência deste comando faz com que os email entrantes do fax da troca/servidor de unidade falhem e o roteador de T.37 debuga é não disponível até que este comando esteja adicionado. É importante recordar que depois que este comando é configurado, você precisa de recarregar o roteador.

    vnt-3725-51(config)#fax interface-type fax-mail
    You must reload the router
  • O Cisco gateway exige o software adicional a fim executar o off-ramp do fax de T.37. Este software é um script TCL que é executado pelo gateway quando necessário para o off-ramp do fax. Este software do script pode ser carregado no flash interno do roteador ou ser carregado fora de um servidor TFTP. O arquivo a transferir para o off-ramp do fax é arquivo app-faxmail-offramp.2.0.1.1.zip situado no Centro de Software da Cisco (clientes registrados somente). Este arquivo precisa de ser acessível pelo gateway. Neste exemplo de saída, o arquivo é carregado no flash interno do roteador desde que há uma abundância do espaço.

    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    [23454064 bytes used, 104734348 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)
    vnt-3725-51#copy tftp flash:
    Address or name of remote host []? 172.18.106.4
    Source filename []? app_faxmail_offramp.2.0.1.1.tcl
    Destination filename [app_faxmail_offramp.2.0.1.1.tcl]?
    Accessing tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl...
    Erase flash: before copying? [confirm]n
    Loading app_faxmail_offramp.2.0.1.1.tcl from 172.18.106.4 (via FastEthernet0/0): !
    [OK - 5095 bytes]
    Verifying checksum... OK (0xB729)
    5095 bytes copied in 0.076 secs (67039 bytes/sec)
    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    2 5095 app_faxmail_offramp.2.0.1.1.tcl 
    [23459224 bytes used, 104729188 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)

    O roteador deve ser dito sobre este arquivo e onde reside. Use o comando global configuration do offramp flash:app_faxmail_offramp.2.0.1.1.tcl da Voz do aplicativo do atendimento a fim realizar isto.

    Se o arquivo é ficado situado em um servidor TFTP em vez do flash, o comando olha como este:

    call application voice offramp tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl
  • o mta recebe o <recipients> máximo — Este comando especifica o número de recepções simultâneas para conexões SMTP no gateway. Este comando é usado limitar o USO de recurso do gateway. É importante recordar que o valor padrão para este comando é 0. Se este comando não é ajustado a um valor maior de 0, o gateway não responde a nenhuns pedidos S TP. Isto faz com que todas as transações do off-ramp falhem imediatamente.

  • o mta recebe o <string> dos pseudônimos — Este comando é importante porque identifica um nome de host válido que seja aceitado como um S TP aliás para o off-ramp faxing. A corda neste comando pode ser um endereço IP de Um ou Mais Servidores Cisco ICM NT ou tipo nome de host DNS. Este comando é muito importante porque todas as conexões SMTP falham se o “rcpt a: do” o domínio campo não combina exatamente o que é configurado enquanto um pseudônimo usando este comando. Ou seja o gateway aceita somente o correio recebido se o nome de host de destino do correio de entrada combina configurado aliás. Os pseudônimos múltiplos podem ser configurados (o máximo é 10) a fim acomodar Domain Name e mesmo endereços IP de Um ou Mais Servidores Cisco ICM NT diferentes. Por exemplo, quando o serviço do fax IP envia uma mensagem a “FAX=####@gateway.com”, o comando olha como:

    mta receive aliases gateway.com
  • o mta recebe gerencie o erro permanente — Este comando é exigido porque sem ele, não todos os mensagens de DSN são enviados para trás à caixa postal do serviço do fax IP. Desde que os mensagens de DSN são parte da especificação de SMTP, o mail server (Microsoft Exchange) é esperado tentar segurar qualquer coisa que não é um erro “permanente” antes que envie a mensagem de volta ao remetente (neste caso a caixa postal do serviço do fax IP). As mensagens tais como o usuário ocupado (à revelia) são embandeiradas como erros de DSN “transientes”. A troca tenta enviar novamente por si só a mensagem durante um longo período do tempo. A configuração do comando mta receive generate permanent-error força o roteador a embandeirar cada mensagem de DSN enquanto um erro permanente assim que são enviados imediatamente para trás ao remetente (a caixa postal do serviço do fax IP). O serviço próprio (baseado na configuração do usuário) pode determinar quantas novas tentativas na resposta busy/no devem ser tentadas. Este comando está somente no Cisco IOS Software Release 12.3(7)T e Mais Recente. Se este comando não está atual em seu roteador, as possibilidades são você estão executando um Cisco IOS Release que é mais idoso do que o que é exigido.

  • porta 25 do server> do <exchange do servidor de envio mta — Este comando especifica o server a ser usado a fim retornar mensagens à caixa postal do fax (tal como o DSNs). Este deve ser o endereço IP de Um ou Mais Servidores Cisco ICM NT do server de câmbio ou pode ser o nome de DNS. Se o nome de DNS é especificado, um comando ip name-server <ip address> está exigido de modo que o DNS possa resolver o nome.

  • Os dial peer de entrada e de saída são exigidos associar o mensagem SMTP de entrada com um número de fax chamado assim como distribuir o atendimento a um circuito de partida da telefonia. Por exemplo:

    dial-peer voice 5590 pots
    destination-pattern 991....
    port 2/0:23
    forward-digits all
    prefix 9
    !
    dial-peer voice 2 mmoip
    description off-ramp inbound VoiP from Unity
    application offramp
    information-type fax
    incoming called-number 991
    dsn delayed
    dsn success
    dsn failure
    !

    O POTS dial peer próprio não é nada especial. Isto é precisado para que o roteador distribua uma chamada de voz a um circuito. O artigo importante aqui é o dial peer MMoiP. Tem o “offramp de aplicativo”, que é o nome associado com o script TCL (do “offramp flash:app_faxmail_offramp.2.0.1.1.tcl" da Voz do aplicativo atendimento). O “informação-tipo fax” é precisado igualmente de deixar o sistema saber que chama esse fósforo que este dial-peer é chamadas de fax. Adicionalmente, uma indicação entrante do chamar-número é precisada. Esta é a maneira a mais fácil de associar um número discado com um dial-peer. Note que não há nenhum destino-teste padrão. Não se exige porque este dial-peer é usado somente para os atendimentos de entrada (do lado de VoIP). Neste exemplo, é permitido ao roteador aceitar chamadas de fax para todo o número que começar com os 991. O mensagem SMTP precisa de ser endereçado a “, onde o pode combinar todo o número de 4 dígitos. O POTS dial peer, devido ao “destino-teste padrão 991....", envia o atendimento a um PRI (porta 2/0:23) ao prefixar o 9. Consequentemente, uma mensagem a “9912345@gateway.com" faz com que um atendimento seja colocado no PRI na porta 2/0 para numerar 99912345 (devido ao comando prefix 9).

    Os comandos dsn no dial peer MMoiP fazem com que o estado da entrega seja enviado para cada circunstância (atrasada/sucesso/falha). Este sozinho não é suficiente. O comando mta receive generate permanent-error é exigido igualmente de modo que estes mensagens de DSN todos sejam enviados com status de erro, em vez possivelmente do transeunte. O transeunte (por potencialmente um muito tempo) não é enviado para trás à caixa postal do serviço do fax IP.

    Uns detalhes mais adicionais da documentação do produto e do comando podem ser encontrados na seção configurando do fax de T.37 store and forward (guarda e passa adiante) dos serviços do fax de Cisco sobre o guia do aplicativo IP. Uma configuração direta de um gateway de trabalho de T.37 conectado a um server do Cisco Unity é ficada situada na seção de configuração de exemplo completa deste documento. Os atendimentos S TP do server do Cisco Unity são recebidos na porta fastethernet do gateway e do T1 PRI para fora então distribuído 2/0:23 ISDN.

Termine a configuração de exemplo

Esta configuração é um exemplo de uma configuração do IOS da Cisco mínima para a capacidade enviando de partida do Cisco Unity. Os comandos configuration os mais importantes estão na fonte em negrito.

vnt-3725-51#show run
Building configuration...
Current configuration : 1608 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vnt-3725-51
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 2
no network-clock-participate aim 0
no network-clock-participate aim 1
voice-card 2
dspfarm
!
no aaa new-model
ip subnet-zero
ip cef
! 
no ftp-server write-enable
isdn switch-type primary-ni
!
fax interface-type fax-mail
mta send server 14.84.31.12 port 25
mta receive aliases vnt-3725-51.gateway.com
mta receive maximum-recipients 10
mta receive generate permanent-error
! 
controller T1 2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2/1
framing sf
linecode ami
!
interface FastEthernet0/0
ip address 14.80.51.14 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip default-gateway 14.80.51.1
ip classless
ip route 0.0.0.0 0.0.0.0 14.80.51.1
ip http server
!
control-plane
!
call application voice offramp flash:app_faxmail_offramp.2.0.1.1.tcl
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 2/0:23
!
dial-peer voice 5590 pots
destination-pattern 991....
port 2/0:23
forward-digits all
prefix 9
!
dial-peer voice 2 mmoip
description off-ramp inbound SMTP from Unity
application offramp
information-type fax
incoming called-number 991
dsn delayed
dsn success
dsn failure
! 
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
vnt-3725-51#

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 62995