Cisco Interfaces and Modules : Módulo de switching de conteúdo da Cisco

RHI no exemplo de configuração do módulo content switching

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo de configuração para a injeção da saúde da rota (RHI) em um Módulo de comutação de conteúdo da Cisco (CS).

O RHI permite que o CS anuncie a Disponibilidade de um endereço do IP virtual (VIP) durante todo a rede. Os dispositivos múltiplos CS com endereços e serviços idênticos VIP podem existir durante todo a rede. Um CS pode cancelar os serviços do Server Load Balancing (SLB) sobre os outros dispositivos se os serviços estão já não disponíveis nos outros dispositivos. Um CS igualmente pode proporcionar os serviços porque é logicamente mais perto dos sistemas de cliente do que outros dispositivos SLB. O CS anuncia o endereço VIP como uma rota do host.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada na versão de execução de CSM 3.x ou 4.x.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/60043/rhi_csm.jpg

Configurações

Este documento utiliza as seguintes configurações:

  • Catalizador A

  • Catalizador B

Catalizador A
hostname Catalyst A
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.1.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.1.20.1 255.255.255.0
  gateway 10.1.20.2
!
 probe LINUXPING icmp


!--- This probe is to verify that the servers are alive. This could be any 
!--- type of probe.

!
 serverfarm MYLINUX
  nat server
  no nat client
  real 10.1.10.3
   inservice
  real 10.1.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20


!--- The VLAN is important. When the VIP address is not part of the subnet
!--- of any VLAN configured on the CSM, the VLAN is used to tell the CSM on 
!--- which VLAN the traffic is coming in. This allows the CSM to set the 
!--- next-hop correctly when configuring the static route on the MSFC.

  serverfarm MYLINUX
advertise active



!--- The advertise command tells the CSM to create the static route.
!--- If you specify the active option, the static route is created only 
!--- if the vserver is operational.

  inservice
!    
interface Vlan20
 ip address 10.1.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.1.30.97 255.255.254.0
 no ip proxy-arp
!
router ospf 1


!--- In this example, OSPF is used to advertise the VIP through the network.
!--- You can use any IGP however.

 log-adjacency-changes
 redistribute static metric 10 subnets


!--- Since the CSM creates a static route on the MSFC, you simply need to 
!--- redistribute static routes to advertise the VIP.

 network 10.1.0.0 0.0.255.255 area 1
!

A configuração do Catalyst B é idêntica ao catalizador A. O endereçamento de IP é levemente diferente porque o catalizador B está em uma área diferente da rede. O endereço VIP é o mesmo contudo. A métrica das rotas estáticas redistribuídas foi mudada igualmente de modo que o catalizador A fosse o caminho preferido ao VIP, e o catalizador B fosse a solução de backup.

Catalizador B
hostname Catalyst B
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.2.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.2.20.1 255.255.255.0
  gateway 10.2.20.2
!
 probe LINUXPING icmp
!
 serverfarm MYLINUX
  nat server
  no nat client
  predictor hash address source
  real 10.2.10.3
   inservice
  real 10.2.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20
  serverfarm MYLINUX
  advertise active
  inservice
!    
interface Vlan20
 ip address 10.2.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.2.30.97 255.255.254.0
 no ip redirects
 no ip proxy-arp
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 20 subnets
 network 10.2.0.0 0.0.255.255 area 2
!

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a estática da rota IP — Emita este comando ver as rotas estáticas criadas pelo CS para cada vserver configurado com o comando advertise. Se você não vê nenhuma rotas, certifique-se que o vserver é operacional e aquele lá é um VLAN especificado sob o vserver.

    SwitchA#show ip route static 
         192.168.1.0/32 is subnetted, 1 subnets
    S       192.168.1.1 [1/0] via 10.1.20.1, Vlan20
    SwitchA#
  • mostre o detalhe do NOME do nome do vserver modificação csm X

    SwitchB#sho mod csm 4 vservers name rhitest
    
    vserver         type  prot virtual                  vlan state        conns
    ---------------------------------------------------------------------------
    RHITEST         SLB   any  192.168.1.1/32:0         20   OPERATIONAL  0       
    SwitchA#show mod csm 4 probe name linuxping detail
    probe           type    port  interval retries failed  open   receive
    ---------------------------------------------------------------------
    LINUXPING       icmp          120      3       300            10     
     real                  vserver         serverfarm      policy          status
     ------------------------------------------------------------------------------
     10.1.10.4:0        RHITEST         MYLINUX         (default)       OPERABLE
     10.1.10.3:0        RHITEST         MYLINUX         (default)       OPERABLE
  • mostre o detalhe do NOME do nome da ponta de prova modificação csm X

  • o base de dados OSPF da mostra IP auto-origina — Emita este comando verificar que o OSPF está anunciando o endereço VIP.

    SwitchA#sho ip ospf database self-originate 
    
                OSPF Router with ID (10.1.30.97) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    10.1.30.97      10.1.30.97      5           0x80000001 0x00B9BE 2
    
                    Type-5 AS External Link States
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    192.168.1.1     10.1.30.97      5           0x80000001 0x00CCC7 0
  • mostre a rota x.x.x.x IP

  • mostre o base de dados OSPF IP extern x.x.x.x

    lsd#sho ip ospf database external 192.168.1.1
    
                OSPF Router with ID (200.200.200.200) (Process ID 1)
    
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 39
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.20.97
      LS Seq Number: 80000001
      Checksum: 0x8310
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 20 
            Forward Address: 10.2.20.1
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 89
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.30.97
      LS Seq Number: 80000001
      Checksum: 0xCCC7
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 10 
            Forward Address: 10.1.20.1
            External Route Tag: 0

Troubleshooting

Não há atualmente nenhuma informação de Troubleshooting específica disponível para esta configuração.


Informações Relacionadas


Document ID: 60043