Distribuição de vídeo e conteúdo : Roteadores universais de banda larga Cisco uBR7200 Series

Serviço de LAN transparente sobre redes de cabo

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Tradicionalmente, o sistema de terminação do cable modem Cisco (CMTS) foi usado para proporcionar serviços dos dados de alta velocidade para utilizadores domésticos e para o Virtual Private Networks (VPNs) com base em IP da camada 3.

Há, contudo, alguns clientes que precisam conexões da camada 2 de executar seus negócios.

Algumas das razões justificar o desenvolvimento de uma camada 2 Virtual Private Network (L2VPN) incluem:

  • Apoie para protocolos do non-IPv4

  • Criptografia de ponta a ponta

  • Mais controle de rede

  • Uso de um espaço de endereço IP privado

Tipicamente, mergulhe 2 serviços são fornecidos pela companhia telefônica (telco) e empregam Tecnologias diferentes, tais como linhas alugadas, Frame Relay, ISDN, ATM, e outro.

Com a introdução da característica de serviço de LAN transparente (TLS) do 802.1Q, o operador de serviço múltiplo (MSO) pode leverage suas distribuições de DOCSIS para proporcionar serviços L2VPN e para aumentar desse modo suas ofertas comerciais.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Software Release 12.2(15)BC2 do ½ do ¿  de Cisco IOSïÂ

  • plataforma do uBR7200VXR

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco ubr7246 VXR Universal Broadband Router

  • Cisco catalyst 2924-XL (fim da vida)

  • Cisco 7206VXR Router

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Que é o 802.1Q TLS sobre o cabo?

A característica do 802.1Q TLS fornece os meios criar L2VPN entre as sites múltiplo, similares às linhas alugadas privadas, Frame Relay, ISDN, ATM, S DS, e semelhante que são oferecidas pelos telcos.

Em muitos casos, o TLS pode ser visto como um “Frame Relay - como” o serviço. Pode acomodar muitos testes padrão de tráfego, tais como ponto a ponto, point-to-multipoint, ou engrenou inteiramente.

Figura 1 mostra como um desenvolvimento do 802.1Q TLS olha conceptualmente como um VLAN.

Figura 1

/image/gif/paws/60027/tls_over_cable_01.gif

Direcionadores do mercado

O motivo principal para a adoção desta característica é o potencial aumentar os fluxos de receita.

A característica do 802.1Q TLS permite que um MSO compita com os telcos proporcionando um serviço L2VPN que possa ser mais econômico ao cliente final.

A footprint MSO já toca em muitas áreas comerciais durante todo seu desenvolvimento. Muitos daqueles negócios já subscrevem aos serviços do TV a cabo e aos serviços existentes da camada 2 de um telco.

Estes serviços do telco L2 tendem a ter despesas de retorno, tais como o acesso do loop local, acesso da porta de switch, e assim por diante.

Na maioria dos casos, o desenvolvimento de um serviço do 802.1Q TLS pode ser tão fácil quanto este:

  1. Deixe cair um modem a cabo na site de cliente.

  2. Provision corretamente a engrenagem dos trabalhos em rede do MSO.

Para fazer o oferecimento de mais atraente e negociável, o MSO pode escolher empacotar junto o TV a cabo e o TLS.

Como a operação do 802.1Q TLS trabalha?

Em uma instalação do 802.1Q TLS, o modem a cabo de um cliente específico é fornecida com os métodos de provisionamento padrão que são esboçados pelo DOCSIS.

Além do que o abastecimento, o CMTS é configurado com definições que são sabidas como os mapas do dot1q. Os mapas do dot1q contêm o MAC address do modem a cabo, o ID de VLAN, e a interface externa. Estas definições (ou os emperramentos) são propagados no base de dados do identificador de serviço (SID).

Trafique que está vindo de um modem a cabo específico é etiquetado com um ID de VLAN e mandado então na rede, onde pode ser construída uma ponte sobre com outros VLAN do mesmo cliente. Há diverso maneira de realizar o VLAN Bridging.

Figura 2 descreve uma topologia Point-to-Point L2VPN, para ilustrar como o TLS trabalha.

Figura 2

/image/gif/paws/60027/tls_over_cable_02.gif

Em cada CMTS há uma definição do mapa do dot1q que ligue o MAC address do modem a cabo com um ID de VLAN e uma interface externa.

Supõe que você segue um pacote do local A para situar B; os seguintes eventos explicam como o CMTS A processa o tráfego do local A:

  1. O modem a cabo toma o frame da Ethernet e adiciona um cabeçalho de DOCSIS, que inclua o modem a cabo SID (ou SFID).

  2. Quando o tráfego é recebido, o CMTS executa uma consulta de SID.

  3. O CMTS determina se o tráfego é TLS, com base em SID.

  4. Se o tráfego é TLS, o CMTS olha no pacote e verifica para ver se há o endereço MAC de origem.

    1. Se o MAC address combina o MAC address do modem a cabo, a seguir o tráfego está enviado ao código do switching da camada 3.

    2. Se o MAC address não combina o MAC address do modem a cabo, a seguir o tráfego está etiquetado com a etiqueta apropriada VLAN e mandado na interface externa apropriada.

No CMTS B, o pacote que está vindo do local A é processado desta maneira:

  1. Quando o CMTS recebe um quadro VLAN-etiquetado, executa uma consulta de base de dados para determinar se o VLAN está traçado a um modem a cabo.

  2. Se um fósforo é encontrado, a seguir o CMTS remove a etiqueta VLAN e adiciona um cabeçalho de DOCSIS.

  3. O processo CMTS o pacote DOCSIS novo, para conformar-se ao CoS ou aos parâmetros de QoS apropriados.

  4. O pacote é mandado então na interface de cabo.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Figura 3 ilustra a topologia de rede usada nas configurações e verifica seções.

Figura 3

tls_over_cable_03.gif

Configurações

Este documento utiliza as seguintes configurações:

  1. CMTS A

  2. CMTS B

  3. Switch

  4. Roteador de agregação

CMTS A
UBR-1:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.3973.be53 FastEthernet0/1 12 
!

CMTS B
UBR-2:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.39a7.8a67FastEthernet0/0 21 
!

Switch
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         

SW# show vlan id 12

00:44:03: %SYS-5-CONFIG_I: Configured from console by console
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
12   VLAN0012                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
12   enet  100012     1500  -      -      -        -    -        0      0   

SW# show vlan id 21

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
21   VLAN0021                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
21   enet  100021     1500  -      -      -        -    -        0      0

Roteador de agregação
!         
bridge irb
!         
!         
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!         
interface FastEthernet0/1.12
 encapsulation dot1Q 12
 bridge-group 1
!         
interface FastEthernet0/1.21
 encapsulation dot1Q 21
 bridge-group 1
!         
bridge 1 protocol ieee
!

Verificar

Esta seção fornece a informação que você pode usar para confirmar que sua configuração está trabalhando corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Inicialização do Cable Modem

Quando o modem que foi fornecida para o 802.1Q TLS vem em linha, um mapa está criado que ligue o modem a um ID de VLAN e a uma interface de saída.

Emita estes comandos debug verificar o mapeamento:

Esta saída mostra como o CMTS traça o VLAN e a interface externa, quando o modem a cabo vem em linha. Igualmente mostra os a jusante e o fluxo de serviço fluxo acima ID que são associados com o VLAN.


!--- Logs from CMTS A (UBR-1):

UBR-1# show debug

CMTS:
  CMTS L2 VPN debugging is on
CMTS specific:
  Debugging is on for Address 0000.3973.be53, Mask ffff.ffff.ffff

UBR-1#

cmts_l2vpn_init_cm: cm 0000.3973.be53 on Cable3/0, sid 0xA
map to FastEthernet0/1 VLAN id 12
 Mapped DS srv flow 22 on Cable3/0 to FastEthernet0/1 VLAN 12
 Mapped US srv flow 21 sid 10 on Cable3/0 to FastEthernet0/1 VLAN 12

Passagem do tráfego

Para ver se esse tráfego está vindo do modem a cabo ou destinado ao modem a cabo, você pode debugar o ou o olhar nos contadores.

Para debugar-lo, gire sobre estes debuga:

Nota: Estes debugam estão somente disponíveis na plataforma uBR7200.

A saída de exemplo seguinte mostra debugar de um pacote do local A para situar B, quando você ativa debuga o endereço MAC do endereço MAC do cabo verboso e debuga o cabo l2-vpn condicional.

O primeiros debugam a linha são os pacotes de origem do local A. Porque o pacote é um pacote de ping, o seguintes debugam a linha são a resposta de ping. Mostra como um pacote é enviado ao modem a cabo.

UBR-1#

Pkt (size 114) from CM 0000.3973.be53 sid 10 src 0008.a3b6.d371
dst 0008.a3b6.d74b fwd to FastEthernet0/1 vlan 12

Send pkt size 118 from 0008.a3b6.d74b on FastEthernet0/1:vlan 12
to 0008.a3b6.d371 on Cable3/0:0xA CM 0000.3973.be53

Para ver os bytes ou os contadores dos pacotes, emita o comando show cable l2-vpn dot1q-vc-map mac-address verbose:

UBR-1# show cable l2-vpn dot1q-vc-map 0000.3973.be53 verbose

MAC Address                         : 0000.3973.be53
Customer Name                       :
Prim Sid                            : 5
Cable Interface                     : Cable3/0
Ethernet Interface                  : FastEthernet0/1
DOT1Q VLAN ID                       : 12
Total US pkts                       : 0
Total US bytes                      : 0
Total DS pkts                       : 12
Total DS bytes                      : 816

Troubleshooting

Não há atualmente nenhuma informações disponíveis específica para pesquisar defeitos esta configuração.

Considerações do projeto

Há diversos fatores de design a considerar quando você distribui serviços sobre uma rede de DOCSIS. Alguns são específicos ao lado do cabo e as outro são umas edições mais gerais.

Lado do cabo (DOCSIS)

Tamanho ou taxa de transferência da tubulação

Tipicamente, a limitação principal está na largura de banda fluxo acima. A tabela 1 mostra figuras aproximadas para os valores diferentes da taxa de transferência.

Tabela 1

Versão de DOCSIS Largura do canal (megahertz) Modulação Taxa de transferência aproximada (Mbps)
1.x 1.6 QPSK 2,2
1.x 1.6 16-QAM 4.4
1.x 3.2 16-QAM 8.9
2.0 3.2 64-QAM 13
2.0 6.4 64-QAM 26

A versão de DOCSIS 1.1 incorporou muitas características que fornecem a otimização do canal upstream. Algumas daquelas características incluem:

  • Concatenação

  • Fragmentação

  • Supressão do cabeçalho de payload

DOCSIS QoS

Comprometido contra o melhor esforço — A versão de DOCSIS 1.0 permite uma taxa garantida no ascendente somente. A versão 1.1 e 2.0 permite uma taxa garantida nos ambos sentidos. A fim garantir uma taxa de informação comprometida (CIR), o agendador CMTS executa o controle de admissão no ascendente, para impedir a assinatura em excesso.

Latência controlada e Jitter — As concessões não solicitada da versão de DOCSIS 1.1's (UG) fornecem uma taxa de bits constante (CBR) - como o serviço. A latência e o tremor podem eficazmente ser controlados, para fornecer uma taxa de dados mínima garantida para o tráfego que exige concessões em intervalos fixos.

Segurança

Trafique que está atravessando a planta de cabos pode ser fixado com o Baseline Privacy Interface (BPI) DOCSIS, na versão de DOCSIS 1.0, ou o BPI+, em umas versões mais novas do DOCSIS. Então, alguém não pode espião ou para bisbilhotar nos dados no lado do cabo.

Para os clientes que exigem mais Segurança — por exemplo, as instituições financeiras e semelhante — uma estratégia do IPSec de ponta a ponta é recomendada. Refira a Segurança em Cisco.

Problemas gerais

qos

Em um ambiente do 802.1Q, há três áreas principais de QoS:

  • Lado CPE — Como o CPE policia e marca o tráfego. Isto é controlado pelo cliente e é relevante a suas políticas internas de QoS.

  • Lado do cabo — Isto conforma-se ao protocolo DOCSIS e ao abastecimento do modem a cabo.

  • Backbone — O MSO pode aplicar as políticas de QoS baseadas no Service Level Agreements.

Desempenho e escalabilidade

No CMTS, há somente um leve aumento da memória para guardar as estruturas de dados e os mapas do dot1q (base de dados). Comutar para pacotes TLS é a mesma que para todo o outro pacote.

O número de VLAN apoiados varia baseado na plataforma.

Construindo uma ponte sobre grupos varie baseado na plataforma.

Como estender o TLS além do 802.1Q os limites de Ethernet

Haverá as épocas em que os clientes precisam a Conectividade aos locais que são além dos limites do exame dos Ethernet; por exemplo, locais em cidades, em cidades, ou em estados diferentes.

Nos casos, os MSO podem usar uma de diversas soluções do serviço do relé dos metros Ethernet.

Duas daquelas soluções que foram laboratório testado são:

  • TLS sobre uma rede central IP através da versão 3 do protocolo de túnel da camada 2 (L2TP)

  • TLS sobre um núcleo do Multiprotocol Label Switching (MPLS) através do Ethernet sobre MPLS (EoMPLS)

Apêndice A - Rastreamento de pacotes entre o interruptor L2 e o roteador de agregação

Esta seção mostra um rastreamento de pacotes de um pacote de ping entre o interruptor e o roteador de agregação. Observe que há dois pacotes de solicitação de ping: um do local A ao roteador de agregação, e um do roteador de agregação para situar o B. O mesmo aplica-se à resposta do sibilo.

Frame 1 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 2 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 3 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 4 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Informações Relacionadas


Document ID: 60027