Serviços de rede de aplicativos : Switches de serviços de conteúdo Cisco CSS 11500 Series

Redundância de caixa a caixa no exemplo de configuração CSS 11xxx

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para a redundância de caixa a caixa 11xxx do Content Services Switch (CSS). A redundância de caixa a caixa fornece uma Redundância do chassi-nível entre dois CSS identicamente configurados.

Pré-requisitos

Requisitos

Antes de tentar esta configuração, verifique se estes requisitos são atendidos:

  • Ambos os CSS que você se está usando para esta configuração redundante devem executar a mesma versão de código. As versões de código diferentes running não são apoiadas para a Redundância.

  • Espere o comportamento dos CSS ser (mestre) /standby ativo (backup); somente os fluxos de processos do mestre CSS.

  • Você deve configurar um link dedicado do Fast Ethernet (FE) entre os CSS para a pulsação do coração do Virtual Router Redundancy Protocol (VRRP).

  • Não use a caixa-à-caixa se você exige a conexão de um dispositivo da camada 2 entre os pares redundantes CSS. Use a redundância de VIP pelo contrário. Refira configurar o VIP e a Redundância da interface virtual para mais informação.

Componentes Utilizados

A informação neste documento é baseada na Versão do SW do CSS 11150: 6.10 Construção 107.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração também pode ser utilizada com estas versões de hardware e software:

  • todo o Cisco CSS 11000 - Produtos do 11500 Series CSS

  • Liberação de software webns 5.0 de Cisco e mais atrasado

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Os CSS participam em uma configuração redundante quando um enlace de redundância foi definido entre dois CSS. O protocolo usado para este enlace de redundância é VRRP, usando o endereço de multicast 224.0.0.18. Os CSS usam este link para manter um com o outro o contato e o status de atividade. Somente um link do cruzamento entre os CSS é apoiado. Você deve usar um cabo crossover para conectar diretamente às portas FE nos CSS redundantes. Não use dispositivos da camada 2 entre os dois CSS no enlace redundante. Não instale o cabo crossover em portas do gigabit Ethernet; Essa configuração não é suportada.

Nota: O protocolo da redundância de caixa a caixa CSS é apoiado agora nas portas CSS11501, CSS 11503, e CSS11506 GE na versão de software 7.10.1.02 e 7.20.0.01 e mais tarde.

Há duas condições principal detectadas neste enlace de redundância que conduzem os estados mestres e alternativos nos dois CSS:

  • A primeira circunstância está mantendo a pulsação do coração, que é uma propaganda cada segundo. O mestre CSS fornece esta pulsação do coração no enlace de redundância, e o backup CSS mantém-se a par da pulsação do coração cada três segundos (padrão). Se os tempos da pulsação do coração para fora (por exemplo, as pulsação do coração não são detectadas neste período), a seguir o backup tomam sobre como o mestre.

    O mestre novo CSS começa a mandar mensagens de protocolo de redundância assim como mensagens do protocolo gratuito de resolução de endereço (ARP) para atualizar as tabelas ARP em nós confinante e as tabelas do forwarding de dispositivos de Bridging anexados (por exemplo, switch de Camada 2) com o MAC address novo do mestre CSS. O CSS transmite um pacote de solicitação ARP e um pacote da resposta ARP para cada invocação do ARP gratuito.

  • A segunda circunstância é aquela de uma mudança da prioridade do interruptor VRRP. O CSS que anuncia a prioridade mais alta é negociado para transformar-se mestre. Este é o mecanismo usado pelos serviços de uplink, e alguns dos comandos especiais (descritos abaixo) iniciando um evento do Failover.

Note que caso os CSS forem desconfigurados (por exemplo, dois ou mais CSS estão estabelecidos o mestre da redundância de IP), o CSS com o endereço IP de Um ou Mais Servidores Cisco ICM NT o mais alto VRRP toma sobre como o mestre.

O software webns de Cisco permite-o a:

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Emita o comando redundancy IP permitir a Redundância CSS-à-CSS em dois CSS conectados com um cabo crossover. À revelia, a Redundância está desabilitada nos CSS até que você emita este comando em ambos os CSS.

Quando você inclui a opção mestra com este comando, você pode designar que CSS é o mestre CSS. Inicialmente, carreg dois CSS conectados com um cabo crossover determina qual são o mestre e qual é o backup. O CSS que carreg primeiramente é o mestre CSS. Se os CSS carreg ao mesmo tempo, o CSS com o endereço IP de Um ou Mais Servidores Cisco ICM NT numericamente mais alto transforma-se o mestre.

Quando você emite o comando ip redundancy master no CSS, o CSS transforma-se o mestre CSS. Você pode emitir este comando no mestre atual ou no backup. Se você emite a opção mestra no backup CSS, o CSS transforma-se o mestre e o outro CSS transforma-se automaticamente o backup.

Se você designa um mestre CSS, o CSS recupera o status mestre após ir para baixo e vem então acima outra vez. Por exemplo, quando o mestre CSS vai para baixo, o backup CSS transforma-se mestre. Quando o mestre designado anterior CSS vem acima outra vez, contudo, o CSS transforma-se o mestre outra vez.

Se você não tem nenhuma exigência designar um CSS como o mestre quando ambos os CSS estão acima, não inclua a opção mestra ao permitir a Redundância no mestre CSS.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/50405/box_to_box_config.jpg

Configurações

Este documento utiliza as seguintes configurações:

  • CSS 11150 FL

  • nws-4-5

CSS 11150 FL
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


Suporte para diversos serviços de uplink

Você pode criar um serviço que seja associado com o endereço IP de Um ou Mais Servidores Cisco ICM NT de um roteador. Este serviço permite o mestre CSS de monitorar o roteador com um keepalive (ICMP). Se o keepalive falha, o mestre abandona o controle e o backup CSS toma o controle. Você pode configurar mais de um serviço emitindo o comando type redundancy-up; os CSS usam todos os uplinks da Redundância ao fazer a decisão de failover.

Se um CSS é ativo, e perde todos os uplinks designados como a redundância, o CSS abandona o estado ativo e transforma-se o backup. O CSS usa o protocolo de redundância para informar o outro CSS para tornar-se ativo. Se ambos os CSS perderam seus uplinks, estadas CSS no estado ativo por 45 segundos, esperando o uplink para vir vivo. Após 45 segundos, se não há ainda nenhum uplink viável, o CSS entra no modo de backup, dando ao outro interruptor uma tentativa. Isto permite que ambos os CSS tenham uma oportunidade para testar seus uplinks sem debulhar para a frente e para trás muitas vezes cada minuto.

Nota: Um CSS entra no Failover quando há já não uns serviços de uplink vivos.

Considerações

Esta característica é desabilitada quando o comando ip redundancy master é emitido. Quando o comando ip redundancy master é emitido, o comando type redundancy-up não pode ser configurado. Quando um serviço é configurado emitindo o comando type redundancy-up, o comando ip redundancy master não pode ser emitido.

Configuração

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

Suporte a failover por falha na interface física

Se qualquer das interfaces física configuradas para a Redundância vai para baixo, o CSS abandona o controle, e o backup CSS toma imediatamente sobre como o mestre. Esta característica é baseada no estado do link ao contrário do serviço da redundância, que é baseado na conectividade IP. O CSS puder determinar o estado do link quando no modo de backup. Você deve certificar-se de que o trajeto ascendente ou a jusante do backup CSS igualmente não é executado através desta mesma relação; isto fará com que as caixas CSS batam a posse do status mestre.

Considerações

Esta característica é desabilitada emitindo o comando ip redundancy master. Quando o comando ip redundancy master é emitido, o comando interface Redundância-PHY falha. Quando o comando interface Redundância-PHY é emitido, o comando ip redundancy master falha.

Configuração

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • Redundância sh — Este comando verifica que os CSS estão sendo executado em uma configuração redundante; este comando igualmente indica que CSS é mestre e qual é alternativo, assim como a razão para o último Failover.

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • mostre o log sys.log — Este comando indica mensagens com informação de habilidades entre os dispositivos CSS.

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • mostre o app e mostre a sessão de app — Este comando indica o estado da sessão de app.

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

Você pode forçar o backup para dominar para propósitos de manutenção. Emita o comando mestre de força da Redundância configurar um backup CSS como um mestre provisório. Este é um ajuste provisório porque o comando não é copiado à executar-configuração. Este comando é útil em uma configuração redundante quando você precisa de tomar off line o mestre CSS para a manutenção ou uma elevação.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 50405