IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Entendimento do LSP de pseudo nó IS-IS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve o pseudonó do pacote de estado de link (LSP). Um pseudonó é uma representação lógica da LAN que é gerada por um Designated Intermediate System (DIS) em um segmento de LAN. O documento também descreve a propagação de informações aos roteadores.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada na versão de software e hardware associada com:

  • Software Release 12.1(5)T9 do½ do¿Â do Cisco IOSïÂ.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

DIS e o pseudo nó

Esta seção descreve o DIS e o pseudo nó.

O que é o DIS?

Em redes de multi-acesso da transmissão, um roteador único é elegido como o DIS. Não há nenhum backup DIS eleito. O DIS é o roteador que cria o pseudo nó e atua em nome do pseudo nó.

Duas tarefas principal são executadas pelo DIS:

  • Criando e atualizando o LSP de pseudo nó para relatar os links a todos os sistemas na sub-rede da transmissão. Veja a seção de Pseudenode LSP para mais informação.

  • Inundando LSP sobre o LAN.

Inundar sobre o LAN significa que o DIS envia as unidades de dados de protocolo periódicas do número de sequência completa (CSNP) (configuração padrão dos segundos 10) resumindo a informação seguinte:

  • ID DE LSP

  • Número de seqüência

  • Checksum

  • Duração restante

O DIS é responsável para inundar. Cria e inunda um LSP de pseudo nó novo para cada roteamento em nível em qual está participando (nível 1 ou nível 2) e para cada LAN a que é conectado. Um roteador pode ser o DIS para todos os LAN conectados ou um subconjunto de LAN conectados, segundo a prioridade IS-IS ou o endereço da camada 2. O DIS igualmente criará e inundar um LSP de pseudo nó novo quando uma adjacência vizinha é estabelecida, rasgado para baixo, ou o temporizador de intervalo de atualização expira. O mecanismo DIS reduz a quantidade de inundação em LAN.

Eleição do DIS

Em um LAN, um do Roteadores elege-se o DIS, com base na prioridade de interface (o padrão é 64). Se todas as prioridades de interface são as mesmas, o roteador com o ponto de ligação de subrede o mais alto (SNPA) está selecionado. O SNPA é o MAC address em um LAN, e o identificador de conexão do link de dados local (DLCI) em uma rede do Frame Relay. Se o SNPA é um DLCI e é o mesmo em ambos os lados de um link, o roteador com o ID de sistema mais alto transforma-se o DIS. Cada interface do roteador IS-IS é atribuída uma prioridade L1 e uma prioridade L2 na escala de 0 a 127.

A eleição de DIS é preventivo (OSPF desigual). Se as botas novas de um roteador no LAN com uma prioridade de interface mais alta, o roteador novo se transformam o DIS. Remove o LSP de pseudo nó velho e inunda um grupo novo de LSP.

O que é o pseudo nó (PSN)?

A fim reduzir o número de adjacências da malha cheia entre Nós nos links multiaccess, o link multiaccess próprio é modelado como um pseudo nó. Este é um nó virtual, porque o nome implica. O DIS cria o pseudo nó. Todo o Roteadores na transmissão liga, incluindo o DIS, adjacências do formulário com o pseudo nó.

Representação de um pseudo nó:

pseodonode.gif

No IS-IS, um DIS não sincroniza com seus vizinhos. Depois que o DIS cria o pseudo nó para o LAN, envia a pacotes Hello para cada nível (1 e 2) cada três segundos e CSNP cada dez segundos. Os pacotes Hello indicam que é o DIS no LAN para esse nível, e os CSNP descrevem o sumário de todos os LSP, incluindo o ID de LSP, o número de sequência, a soma de verificação, e a duração restante. Os LSP são inundados sempre ao endereço de multicast e o mecanismo CSNP corrige somente para todas as unidades de dados de protocolo perdidas (PDU). Por exemplo, um roteador pode pedir o DIS um LSP faltante usando um pacote parcial do número de sequência (PSNP) ou, para dar por sua vez ao DIS um LSP novo.

Os CSNP são usados para dizer o outro Roteadores sobre todos os LSP no um base de dados do roteador. Similar a um pacote descritor da base de dados do OSPF, os PSNP são usados para pedir um LSP e para reconhecer o recibo de um LSP.

LSP de pseudonó

O LSP de pseudo nó é gerado pelo DIS. O DIS relata todos os vizinhos de LAN (que incluem o DIS) no LSP de pseudo nó com uma métrica de zero. Todos os roteadores de LAN, incluindo o DIS, relatam a Conectividade ao pseudo nó em seus LSP. Isto é similar no conceito à rede LSA no OSPF.

Exemplo

Nós usaremos o diagrama de rede seguinte para demonstrar como o LSP de pseudo nó, gerado pelo DIS, é usado para relatar todos os vizinhos de LAN.

Nota: No exemplo abaixo, a característica dinâmica do hostname é permite. Consequentemente, os ID de sistema são traçados automaticamente aos nomes de host do roteador mostrados nas saídas resultante dos comandos show abaixo.

Diagrama de Rede

isis-pnode.jpg

Configurações

Estas configurações foram usadas para o Roteadores mostrado no diagrama da rede:

Roteador IS-IS
Router 6
  
       interface e0
       ip address 172.16.126.6 255.255.255.0 
       ip router isis
       Isis priority 127
	   
       router isis
       net 49.0001.0000.0c4a.4598.00
       is-type level-1
  
  Router 2

       interface e0
       ip address 172.16.126.2 255.255.255.0
       ip router isis
	
       router isis
       net 49.0001.0000.0c8d.e6b4.00
       is-type level-1
	   
  Router 1

       interface e0
       ip address 172.16.126.1 255.255.255.0
       ip router isis


       interface s1
       ip address 172.16.1.1 255.255.255.0
       ip router isis

       router isis
       net 49.0001.0000.5c75.d0e9.00
       is-type level-1
	   
  Router 8
 
       interface s1
       ip address 172.16.1.8 255.255.255.0
       ip router isis
	  
       router isis
       net 49.0001.0000.0c31.c2fd.00
       is-type level-1c

A tabela a seguir divide a área, o MAC address, e a rede para cada um do Roteadores configurado acima. Observe que todo o Roteadores está na mesma área.

Router Área Endereço MAC REDE (título da entidade de rede)
6 49.0001 0000.0c4a.4598 49.0001.0000.0c4a.4598.00
2 0000.0c8d.e6b4 49.0001.0000.0c8d.e6b4.00
1 0000.5c75.d0e9 49.0001.0000.5c75.d0e9.00
8 0000.0c31.c2fd 49.0001.0000.0c31.c2fd.00

Com o Roteadores configurado como descrito nesta seção, você pode usar o comando show clns is-neighbor ver os vizinhos IS-IS:

router-6# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-6#

router-2# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-2#

router-1# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-8       Se1         Up     L1   0         00                 Phase V
router-1#

router-8# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
Router-1       Se1         Up     L1   0         00                 Phase V
router-8#

Nas lista vizinhas precedentes, observe que o Roteadores conectado à rede de multi-acesso (Ethernet) todo tem o mesmo circuit id. O circuit id é um número do octeto que os usos do roteador identificar excepcionalmente a interface IS-IS. Se a relação é anexada a uma rede de multi-acesso, o circuit id está concatenado com o ID de sistema do DIS. Isto é sabido como o pseudo nó ID. Observe igualmente, isso que o DIS é o roteador 6 devido à prioridade IS-IS configurada sob sua interface Ethernet.

Bancos de dados IS-IS

Esta saída indica a base de dados IS-IS de cada um do Roteadores descrito na seção anterior:

Router-6# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
router-2.00-00        0x0000006D   0x59DE        589               0/0/0
router-1.00-00        0x00000074   0xC4B0        759               0/0/0
router-6#

router-2# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
router-6.00-00        0x0000006D   0xDD58        633               0/0/0
router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
router-1.00-00        0x00000074   0xC4B0        746               0/0/0
router-2#

router-1# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
router-6.00-00        0x0000006D   0xDD58        619               0/0/0
router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
router-2.00-00        0x0000006D   0x59DE        561               0/0/0
router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
router-1#

router-8# show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
router-6.00-00        0x0000006D   0xDD58        607           0/0/0
router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
router-2.00-00        0x0000006D   0x59DE        550           0/0/0
router-1.00-00        0x00000074   0xC4B0        723           0/0/0
router-8#

Enquanto a saída precedente indica, o comando show isis database indica uma lista de LSP no base de dados. Neste caso, todo o Roteadores é 1 Router nivelados na mesma área, assim que todo tem os mesmos LSP em sua base de dados IS-IS. Observe que cada um do Roteadores gerencie um LSP. O DIS gerencie um LSP para se, e igualmente gerencie um LSP em nome do pseudo nó. O LSP de pseudo nó neste exemplo é 0000.0C4A.4598.01-00.

Nós mencionamos que o Roteadores no LAN envia somente propagandas ao pseudo nó do LAN. O pseudo nó relata todos os vizinhos de LAN, no LSP de pseudo nó, com uma métrica de zero — segundo as indicações destes exemplos de emissor do comando show isis database lsp detail:

  • Roteador 6 LSP (como visto do roteador 8)

    Observe que o roteador 6 anuncia que pode somente alcançar sua rede conectada diretamente e o pseudo nó. Neste caso, o pseudo nó tem uma métrica do 10. Como nós mencionamos, o Roteadores no LAN anunciará que pode ser alcançado ao pseudo nó do LAN somente.

    router-8# show isis database router-6.00-00 detail
    IS-IS Level-1 LSP router-6.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.00-00        0x00000071   0xD55C        456           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.6
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • LSP de pseudo nó (como visto do roteador 8)

    O LSP de pseudo nó anuncia todos os vizinhos de LAN com uma métrica de zero. O LSP de pseudo nó é gerado pelo DIS, o roteador 6 neste caso, em nome do pseudo nó.

    Router-8# show isis database router-6.01-00 detail
    IS-IS Level-1 LSP router-6.01-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.01-00        0x0000006D   0x65CF        759           0/0/0
      Metric: 0  IS router-6.00
      Metric: 0  IS router-2.00
      Metric: 0  IS router-1.00
    router-8#
  • Roteador2 LSP (como visto do roteador 8)

    Além disso, o roteador2 LSP contém a informação se pode alcançar sua rede conectada diretamente e o pseudo nó somente.

    Router-8# show isis database router-2.00-00 detail
    IS-IS Level-1 LSP router-2.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-2.00-00        0x00000072   0x4FE3        791           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.2
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Roteador1 LSP (como visto do roteador 8)

    A única informação que o roteador1 LSP contém para a rede de LAN é a rede própria e se pode alcançar o pseudo nó. Desde que o roteador1 é conectado igualmente a uma outra rede, a rede serial, esta rede conectada diretamente é anunciada igualmente.

    Router-8# show isis database router-1.00-00 detail
    IS-IS Level-1 LSP router-1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-1.00-00        0x00000079   0xBAB5        822           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.1.1
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-6.01
      Metric: 10 IS router-8.00
    router-8#
  • Roteador 8 LSP

    Neste caso, o roteador 8 não é conectado ao LAN, assim que não anuncia ao pseudo nó que pode ser alcançado. , Contudo, anuncia (esse pode ser alcançado) a se, ao roteador1, e à rede conectada diretamente.

    Router-8# show isis database router-8.00-00 detail
    IS-IS Level-1 LSP router-8.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-8.00-00*       0x00000072   0xF71E        554           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      IP Address:  172.16.1.8
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-1.00
      Metric: 0  ES router-8
    router-8#

Informações Relacionadas


Document ID: 49627