IP : Protocolos de roteamento IP

Policy Based Routing with the Multiple Tracking Options Feature Configuration Example

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo de configuração para o roteamento baseado em política com o recurso Multiple Tracking Options (Opções de Rastreamento Múltiplo). Esta característica foi introduzida no Software Release 12.3(4)T do � do Cisco IOS. Para obter mais informações, consulte PBR Support for Multiple Tracking Options (Suporte PBR para as múltiplas opções de rastreamento).

Esse recurso estende as capacidades do rastreamento objetivo para verificar o próximo endereço IP de salto IP antes de encaminhar o tráfego para o próximo salto. O método de verificação pode ser um ping do Protocolo de mensagens de controle da Internet (ICMP), um ping do Protocolo de datagrama de usuário (UDP) ou uma solicitação GET do Protocolo de transferência de hipertexto (HTTP). O ICMP é a maioria de método comum de verificação usado no Internet. O recurso Multiple Tracking Options (Opções de rastreamento múltiplo) é mais adequado para roteadores que tenham conexões Ethernet múltiplas como o próximo salto. Normalmente, as interfaces Ethernet conectam ao digital subscriber line (DSL) ou ao Modems a cabo. Atualmente, não há nenhum método para detectar uma falha rio acima na rede de banda larga ISP — as sobras da interface Ethernet ascendentes e nenhum formulário de pontos do roteamento estático a essa relação. A força desta característica permite-lhe o backup duas interfaces Ethernet, escolhe a relação que está disponível enviando ping ICMP para verificar o reachablity, e distribui então o tráfego para fora a essa relação.

Pré-requisitos

Requisitos

Antes que você tente esta configuração, assegure-se de que você cumpra esta exigência:

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Esta seção apresenta as informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede. Nesta encenação, o r1 é conectado ao dois ISP diferentes (ISP-1 e ISP-2). R1 rastreia a alcançabilidade para ambos os roteadores de ISP.

/image/gif/paws/48003/pbrtracking_01.gif

Configuração

Este documento utiliza esta configuração:

R1
R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Track Router 1's reachability.

!         
track 124 rtr 2 reachability

!--- Track Router 2's reachability.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Enable policy routing on the outgoing interface.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Define a route-map to set the next hop depending on 
!--- the state of the tracked routers.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Define and start Router 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Define and start Router 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • trilha da mostra — Indica a informação de rastreamento.

  • mostre o resumo da trilha — Informação de rastreamento limitada dos indicadores.

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

Da saída do comando show track brief, você pode ver que ambos os ISP são alcançáveis. Se você fecha a relação que está conectada ao ISP-1, mostra-se como para baixo quando seguido.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

Nota: O PBR exige o seguimento a fim determinar se a relação ou a rota são ativa. A fim ver o estado da rota que segue, você pode igualmente usar o comando show route-map.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 48003