IP : Protocolos de roteamento IP

Policy Routing with Catalyst 3550 Series Switch Configuration Example

17 Outubro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (6 Outubro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o roteamento baseado em políticas nos switches da série Catalyst 3550. Os Catalyst 3550 Series Switch têm a transmissão baseada hardware, assim a informação de encaminhamento é programada no Ternary Content Addressable Memory (TCAM). Para que o TCAM ao roteamento baseado política de suporte (PBR), deve ser formatada mudando o molde do gerenciamento de banco de dados do interruptor (SDM). Você deve alterar o molde de SDM, tais que apoia a camada 3 TCAM do 144-bit. Consulte para compreender e configurar o Switching Database Manager em Catalyst 3550 Series Switch para obter mais informações sobre do SDM.

Nota: O Catalyst 3550 tem limitações nos comandos route-maps que você pode se usar.

Pré-requisitos

Requisitos

Assegure-se de que você esteja conhecedor destas áreas antes que você tente esta configuração:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.1.19-EA1a de Cisco IOS�

  • Cisco Catalyst 3550

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Antes que você possa permitir o roteamento de política, você deve configurar um destes comandos no modo de configuração global, e então a configuração deve ser escrita e o interruptor ser recarregada:

  • sdm prefer extended-match

  • sdm prefer access extended-match

  • sdm prefer routing extended-match

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
CAT3550(config)# route-map pbr permit 10
CAT3550(config-route-map)# match ip address 10
CAT3550(config-route-map)# set ip next-hop 12.12.12.12

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)#
06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

CAT3550# show run int vlan 3
Building configuration...

Current configuration : 60 bytes
!
interface Vlan3
ip address 55.55.55.1 255.255.255.0

!--- Command not taken - you need to enable SDM.

end

CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect 
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK] 

ltd-1-2# reload
Proceed with reload? [confirm]

Você deve estar ciente de comandos unsupported — refira comandos map Unsupported da rota se esta configuração existe:

!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
match ip address 10
set ip default next-hop 12.12.12.12
!

Uma mensagem de erro é gerada se você tentar configurar o mapa de rota de política na interface.

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)# end
CAT3550#
00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/47900/cat3550pbr-1.gif

Configurações

Este documento utiliza esta configuração:

A configuração toma o origem de tráfego de 20.20.20.X (lista de acesso 10) e envia-o a 30.30.30.2 — a configuração cancela o conjunto de gateway padrão a 10.10.10.2.

CAT3550 (Cisco catalyst 3550)
CAT3550# show running-config 
Building configuration...
.
.
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 ip address 20.20.20.1 255.255.255.0
 ip policy route-map pbr
!
interface Vlan3
 ip address 30.30.30.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip classless
ip http server
!
!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
 match ip address 10
 set ip next-hop 30.30.30.2
!
.
!
end

Quando o comando set ip next-hop é posto o tráfego de correspondência não pode ser considerado na saída e é um comportamento esperado em um interruptor. Isto é porque um interruptor funciona no hardware somente, e os comandos show apresentam somente a informação que é segurada no software. O salto seguinte do grupo IP está funcionando todo o tempo no hardware, porque a tabela de roteamento e processa nunca obtém verificado pelo interruptor. Recebe um pacote e se esse quedas nas indicações do mapa de rotas está enviado então diretamente ao salto seguinte que você especificou, sem verificar a tabela de roteamento.

As primeiras verificações do comando set ip default next-hop a tabela de roteamento inteira para ver se há uma outra rota ao destino. Se nenhuma rota é encontrada, a seguir o salto seguinte do padrão está usado.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debug ip policy Exibe os pacotes que são 'roteados por política' ou 'rejeitados por política'. Um exemplo da saída do comando debug ip policy é:

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47900