IP : Open Shortest Path First (OSPF)

Como o OSPF injeta uma rota padrão em uma área de não muito stub

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como o Open Shortest Path First (OSPF) injeta uma rota padrão em uma Not So Stubby Area (NSSA). Por padrão, o ABR (Roteador de borda de área) do NSSA não origina uma rota padrão no NSSA. É necessário utilizar o comando area <x> nssa default-information originate.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/47870/ospfdb11a.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 nssa

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa default-information originate

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Examine a base de dados do OSPF em um Not So Stubby Area

Para ver como a base de dados do OSPF olha, use o comando show ip ospf database.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

           Router Link States (Area 0) 

Link ID    ADV Router     Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2        600     0x80000001    0x9583          1 

           Summary Net Link States (Area 0) 

Link ID    ADV Router      Age     Seq#          Checksum 
5.0.0.0     2.2.2.2        600     0x80000001    0x8E61 

           Router Link States (Area 1) 

Link ID    ADV Router     Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1        864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2        584     0x8000001E     0xF667         2 

           Summary Net Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum 
6.0.0.0    2.2.2.2        585     0x80000004    0xA87C 

           Type-7 AS External Link States (Area 1) 

Link ID    ADV Router     Age     Seq#          Checksum   Tag 
0.0.0.0    2.2.2.2        601     0x80000001    0xD0D8      0 

O ABR para o NSSA origina um tipo 7 e um LSA com um link ID de 0.0.0.0. Este é um resultado do comando area 1 nssa default-information-originate nessa configuração OSPF.

r2.2.2.2#show ip ospf database nssa-external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  LS age: 650 
  Options: (No TOS-capability, No Type 7/5 translation, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 

O ABR origina o tipo 7 LSA de 0.0.0.0, mesmo que não tenha uma rota padrão.

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table 

r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*N2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47870