IP : Open Shortest Path First (OSPF)

Como o OSPF injeta uma rota padrão em uma área normal

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como o Open Shortest Path First (OSPF) injeta uma rota padrão em uma área normal. As rotas padrão injetadas em uma área normal podem ser originadas por qualquer roteador OSPF. O roteador OSPF, por padrão, não gera uma rota padrão para o domínio OSPF. Para que o OSPF gere uma rota padrão, é necessário usar o comando default-information originate.

Há duas maneiras de anunciar uma rota padrão em uma área normal. A primeira coisa a fazer é anunciar o 0.0.0.0 no domínio OSPF, considerando que o roteador do anúncio já possua uma rota padrão. A segunda maneira é anunciar 0.0.0.0, mesmo que um roteador de anúncio já tenha uma rota padrão. O segundo método pode ser realizado adicionando a palavra-chave sempre ao comando default-information originate.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/47868/ospfdb9a.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 default-information originate
 
ip route 0.0.0.0 0.0.0.0 6.0.0.3

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Examine a base de dados do OSPF

Indicadores desta saída como os olhares da base de dados do OSPF dados este ambiente de rede, usando o comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2     600     0x80000001    0x9583          1 

                Summary Net Link States (Area 0) 

Link ID    ADV Router   Age     Seq#          Checksum 
5.0.0.0     2.2.2.2     600     0x80000001    0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     864     0x8000005E     0xD350         2 
2.2.2.2    2.2.2.2     584     0x8000001E     0xF667         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#          Checksum 
6.0.0.0    2.2.2.2     585     0x80000004    0xA87C 

                Type-5 AS External Link States 

Link ID   ADV Router   Age     Seq#          Checksum    Tag 
0.0.0.0    2.2.2.2     601     0x80000001    0xD0D8       0 

Porque tem uma rota padrão, o roteador 2.2.2.2 origina um tipo 5 LSA com um link ID de 0.0.0.0. Esse é o resultado do comando default-information originate na configuração do OSPF.

r2.2.2.2#show ip ospf database external 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States  

  LS age: 650 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 0.0.0.0 (External Network Number ) 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xD0D8 
  Length: 36 
  Network Mask: /0 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0 
        External Route Tag: 0 


r2.2.2.2#show ip route 0.0.0.0 
S* 0.0.0.0/0 [1/0] via 6.0.0.3, 00:28:00, ATM1/0.20  


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
O*E2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 

Você pode igualmente adicionar sempre a palavra-chave ao comando default-information originate fazer um roteador originar um tipo 5 LSA de 0.0.0.0 mesmo se o roteador não tem uma rota padrão em sua tabela de roteamento.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47868