IP : Open Shortest Path First (OSPF)

Conversão de anúncio de estado de enlace OSPF Not So Stubby Area tipo 7 em tipo 5

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como o Open Shortest Path First (OSPF) converte um anúncio link state (LSA) Not So Stubby Area (NSSA) do tipo 7 em um LSA do tipo 5.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/47867/ospfdb8a.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
  
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1
 area 1 nssa
 
ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o base de dados OSPF IP — Indica uma lista dos LSA e datilografa-os em um base de dados do estado do link. Esta lista mostra somente a informação no cabeçalho LSA.

  • mostre o base de dados OSPF IP nssa externo — Indica a informação somente sobre o LSAs externo NSSA.

  • mostre o base de dados OSPF IP externo — Indica a informação somente sobre o LSAs externo.

  • show ip ospf database [router] [link-state-id] — Indica uma lista de todos os LSA de um roteador no base de dados. Os LSA são produzidos por cada roteador, e estes LSA fundamentais alistam os links de todo o Roteadores, ou as relações, junto com os estados e os custos de envio do link. São inundados somente dentro da área em que originam.

  • mostre o id> do <link-estado do sumário de base de dados OSPF IP — Indica os links de resumo do roteador de borda de área (ABR).

  • mostre a rota IP — Indica o status atual da tabela de roteamento.

Examine a base de dados do OSPF

Para ver como os olhares da base de dados do OSPF dados este ambiente de rede, usam o comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router    Age    Seq#           Checksum     Link count 
2.2.2.2    2.2.2.2      1235   0x8000001D     0xD9FF           2 
3.3.3.3    3.3.3.3      1100   0x8000000B     0x9455           2 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum 
4.0.0.0    2.2.2.2     1979   0x80000002    0xFDE7 
5.0.0.0    2.2.2.2     1483   0x80000004    0x8864 

                Router Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Link count 
1.1.1.1    1.1.1.1     319    0x8000000C    0xAFA8           3 
2.2.2.2    2.2.2.2     220    0x8000002F    0xD478           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age    Seq#           Checksum 
6.0.0.0    2.2.2.2     1483   0x8000001C     0x7894 

                Type-7 AS External Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    1.1.1.1     334    0x80000005    0xD738        0 

                Type-5 AS External Link States 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    2.2.2.2     1725   0x80000004    0x50C6        0 

Para anunciar rotas externas para um NSSA, o Roteador de Limite de Sistema Autônomo (ASBR) cria LSAs externos à NSSA (tipo 7).

r2.2.2.2#show ip ospf database nssa-external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 381 
  Options: (No TOS-capability, Type 7/5 translation, DC)

!--- This can be translated into a type 5 LSA by 
!--- an ABR. 

  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number ) 

!--- The ASBR (Router 1.1.1.1) advertises 
!--- 9.0.0.0/8. 

  Advertising Router: 1.1.1.1

!--- Router ID of the ASBR.
 
  LS Seq Number: 80000005 
  Checksum: 0xD738 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1

!--- Forwarding address is incorrectly specified
!--- as an interface on the ASBR.
 

O ABR converte o tipo 7 LSA no tipo 5 LSA, e propaga o tipo 5 LSA em áreas normal.

r2.2.2.2#show ip ospf database external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States 

  LS age: 1782 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number )

!--- Router 2.2.2.2 advertises 9.0.0.0/8.
 
  Advertising Router: 2.2.2.2 

!--- When the conversion is complete, the advertising 
!--- router ID becomes the ABR router ID 
!--- because the ABR originates this type 5 LSA. 

  LS Seq Number: 80000004 
  Checksum: 0x50C6 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1 
        External Route Tag: 0 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 426 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same 
!--- as the advertising router (next line). 

  Advertising Router: 1.1.1.1
  LS Seq Number: 8000000C 
  Checksum: 0xAFA8 
  Length: 60 
  AS Boundary Router

!--- Bit E in the router LSA indicates that this router
!--- originates from external LSAs.
 
   Number of Links: 3

!--- There are three links in area 1. 


    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

!--- The OSPF cost of the Ethernet segment.
 

    Link connected to: another Router (point-to-point) 

!--- Shows that Router 1.1.1.1 is a neighbor with 
	!--- Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1

!--- The interface address that connects to Router
!--- 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the link that connects 
!--- the two routers.

    Link connected to: a Stub Network 

!--- This represents the serial link 5.0.0.0/8.
 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the serial link.

Você pode ver da saída corajosa aqui que embora o roteador 2.2.2.2 não mande alguns redistribuir indicações em sua configuração, é ainda um ASBR porque converte o tipo 7 LSA no tipo 5 LSA.

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1361 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001D 
  Checksum: 0xD9FF 
  Length: 48 
  Area Border Router 
  
!--- Bit B is set in the router LSA to indicate
!--- that this router is an ABR.
 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this router 
!--- originates from external LSAs.

   Number of Links: 2 
  
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1

                Router Link States (Area 1) 

  LS age: 346 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000002F 
  Checksum: 0xD478 
  Length: 48 
  Area Border Router 
  AS Boundary Router 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1245 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000B 
  Checksum: 0x9455 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Para anunciar rotas de uma área em outra, o ABR cria LSA sumário (tipo 3).

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 172 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 4.0.0.0/8 into area 0.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0xFBE8 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 5.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 1687 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 5.0.0.0/8 into area 0. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000004 
  Checksum: 0x8864 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 1697 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 6.0.0.0/8 into area 1.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001C 
  Checksum: 0x7894 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

O sumário ASBR LSA não é precisado neste caso porque o ABR origina o LSA externo, e o ABR é alcançável dentro da área 0. compara este exemplo com uma encenação onde o NSSA seja uma área normal olhando o exemplo de base de dados como o OSPF propaga rotas externas em áreas múltiplas.

Estas saídas da tabela de roteamento mostram os tipos diferentes de rotas de OSPF que 9.0.0.0 é sabido como por cada roteador.

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 01:10:13, Serial0/1/0 
O N1 9.0.0.0/8 [110/79] via 5.0.0.1, 01:07:20, Serial0/1/0 

R3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 02:11:14, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 03:10:41, ATM2/0.20 
O E1 9.0.0.0/8 [110/80] via 6.0.0.2, 02:08:11, ATM2/0.20 

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 47867