IP : Open Shortest Path First (OSPF)

Como o OSPF propaga as rotas externas em áreas múltiplas

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra como o Open Shortest Path First (OSPF) propaga rotas externas em áreas da rede múltiplas.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/47865/ospfdb6a.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0

interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1

ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o banco de dados OSPF IP — Indica uma lista das propagandas do estado do link (LSA) e datilografa-as em um banco de dados do estado do link. Esta lista mostra somente a informação no cabeçalho LSA.

  • show ip ospf database [router] [link-state-id] — Indica uma lista de todos os LSA de um roteador no banco de dados. Os LSA são produzidos por cada roteador. Estes LSA fundamentais alistam os links de todo o Roteadores, ou as relações, junto com os estados e os custos de envio do link. São inundados somente dentro da área em que originam.

  • mostre o id> do <link-estado do sumário de banco de dados OSPF IP — Indica os links de resumo do roteador de borda de área (ABR).

  • mostre o banco de dados OSPF IP externo — Indica a informação somente sobre o LSAs externo.

  • mostre o resumo asbr do banco de dados OSPF IP — Indica a informação somente sobre os LSA sumário do roteador de limite de sistema autônomo.

Examine a base de dados do OSPF

Esta saída mostra como os olhares da base de dados do OSPF dados este ambiente de rede, usando o comando show ip ospf database.

r2.2.2.2#show ip ospf database
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
Link ID    ADV Router    Age    Seq#          Checksum   Link count 
2.2.2.2    2.2.2.2       93     0x80000020    0xCD0B         2 
3.3.3.3    3.3.3.3       1225   0x8000000D    0x9057         2 
  
                Summary Net Link States (Area 0) 
  
Link ID    ADV Router    Age   Seq#           Checksum 
4.0.0.0     2.2.2.2      73    0x80000001     0xFFE6 
5.0.0.0     2.2.2.2      1651  0x80000006     0x8466 
  
                Summary ASB Link States (Area 0) 
  
Link ID   ADV Router    Age   Seq#           Checksum 
1.1.1.1    2.2.2.2      74    0x80000001     0x935C 
  
                Router Link States (Area 1) 
  
Link ID   ADV Router   Age   Seq#         Checksum    Link count 
1.1.1.1   1.1.1.1      89    0x80000011   0xFF59          3 
2.2.2.2   2.2.2.2      88    0x80000033   0x2130          2 
  
                Summary Net Link States (Area 1) 
  
Link ID   ADV Router  Age    Seq#         Checksum 
6.0.0.0   2.2.2.2     94     0x8000001F   0xCC43 
  
                Type-5 AS External Link States 
  
Link ID   ADV Router   Age   Seq#         Checksum   Tag 
9.0.0.0   1.1.1.1      135   0x80000001   0x3AE8      0 

Para anunciar rotas externas no OSPF, o ASBR (Roteador de limite de sistema autônomo) cria LSAs externos (tipo 5) .

r2.2.2.2#show ip ospf database external 9.0.0.0
          OSPF Router with ID (2.2.2.2) (Process ID 2)
                   Type-5 AS External Link States
     Routing Bit Set on this LSA
     LS age: 286
     Options: (No TOS-capability, DC)
     LS Type: AS External Link
     Link State ID: 9.0.0.0 (External Network Number )
  
!--- 9.0.0.0/8 is advertised by the
   !--- ASBR (Router 1.1.1.1).

   Advertising Router: 1.1.1.1
   LS Seq Number: 80000001
   Checksum: 0x3AE8
   Length: 36
   Network Mask: /8
         Metric Type: 1 (Comparable directly to link state metric)
         TOS: 0
         Metric: 5
         Forward Address: 0.0.0.0
		  
!--- Forwarding address is not specified since there
  		!--- are no OSPF neighbors on Router 1.1.1.1's Ethernet.
    !--- When the forward address is 0.0.0.0, this means that 
    !--- the traffic for this network is to be sent to the 
    !--- advertising router (1.1.1.1).
 
External Route Tag: 0  

Para anunciar a alcançabilidade de um ASBR em outras áreas, o ABR cria (tipo 4) o resumo asbr LSA.

r2.2.2.2#show ip ospf database asbr-summary 1.1.1.1 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary ASB Link States (Area 0) 
  
  LS age: 266 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(AS Boundary Router) 
  Link State ID: 1.1.1.1 (AS Boundary Router address)
  
!--- ABR (Router 2.2.2.2) is advertising that it knows how
  !--- to reach the ASBR (Router 1.1.1.1). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x935C 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 64
		
!--- The ABR's cost to reach the ASBR.
 

O ABR (roteador 2.2.2.2) instalou uma rota externa aprendida do ASBR (roteador 1.1.1.1) e inundada o LSA externo da área 1 na área 0. (o LSAs externo é inundado inalterado em todas as áreas.) Contudo, o ASBR não está no Roteadores da área 0. na área 0 não sabe alcançar o ASBR. Eis porque o ABR cria um resumo asbr LSA e anuncia a alcançabilidade para o roteador 1.1.1.1 na área 0.

Nota: Este grupo seguinte de saída é apresentado para dar somente mais detalhes sobre a base de dados do OSPF nesta instalação do exemplo. Se você é familiar com esta informação, salte ao cálculo a seção do caminho mais curto.


r2.2.2.2#show ip ospf database router 1.1.1.1 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 1) 
  
  Routing Bit Set on this LSA 
  LS age: 109 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created
  !--- this LSA. 

  LS Seq Number: 80000011 
  Checksum: 0xFF59 
  Length: 60 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this 
  !--- router originates external LSAs. 

   Number of Links: 3
   
!--- There are three links in area 1. 

  
    Link connected to: a Stub Network
	
!--- This line represents the Ethernet segment 
    !--- 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- OSPF cost of the Ethernet segment. 

  
    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a 
	!--- neighbor with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- The interface address that connects to 
	 !--- Router 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- OSPF cost of the link connecting the two routers. 

  
    Link connected to: a Stub Network
	
!--- This line represents the serial link 5.0.0.0/8. 

     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- OSPF cost of the serial link. 

  
r2.2.2.2#show ip ospf database router 2.2.2.2 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
  LS age: 135 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000020 
  Checksum: 0xCD0B 
  Length: 48 
  Area Border Router
   Number of Links: 2
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
  
                Router Link States (Area 1) 
  
  LS age: 130 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000033 
  Checksum: 0x2130 
  Length: 48 
  Area Border Router
   Number of Links: 2
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Router Link States (Area 0) 
  
  LS age: 1280 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000D 
  Checksum: 0x9057 
  Length: 48 
   Number of Links: 2 
  
    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Para anunciar as rotas de uma área à outra, o ABR cria LSAs de resumo (tipo 3).

r2.2.2.2#show ip ospf database summary 4.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 0) 
  
  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 0 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 



r2.2.2.2#show ip ospf database summary 5.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 0) 
  
  LS age: 1768 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
 
 !--- 5.0.0.0/8 is advertised into area 0 by 
  !--- the ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000006 
  Checksum: 0x8466 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 



r2.2.2.2#show ip ospf database summary 6.0.0.0 
  
       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  
                Summary Net Link States (Area 1) 
  
  LS age: 216 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0
  
!--- 6.0.0.0/8 is advertised into area 1 by the ABR(2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001F 
  Checksum: 0xCC43 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

Calcule o caminho mais curto

Esta seção calcula o caminho mais curto da perspectiva do roteador 3.3.3.3.

O roteador 3.3.3.3 procura em seu próprio LSA e vê que o roteador 2.2.2.2 é um vizinho. Em seguida, ele observa o LSA do Roteador 2.2.2.2 para verificar se o Roteador 2.2.2.2 vê o Roteador 3.3.3.3 como um vizinho. Se ambo o Roteadores se vê como vizinhos, a seguir está considerado alcançável.

Cada roteador verifica também sua tabela vizinha local (que pode ser vista com o comando show ip ospf neighbor) para verificar se a interface e a interface do vizinho estão em uma sub-rede de IP comum.

Nota: Esta verificação não é executada em uma interface não numerada.

Se as interfaces não estiverem em uma sub-rede comum, os roteadores instalam rotas para todas as redes stub listadas no LSA do roteador de seus vizinhos. Neste exemplo, 60.0.0.0/8 são a única rede stub alistada no roteador 2.2.2.2's LSA na área 0, a que o roteador 3.3.3.3 já é conectado diretamente.

Após ter examinado todos os lsa de roteador alcançável na área 0, o roteador 3.3.3.3 olha LSA sumário no banco de dados. Encontra LSA sumário para 4.0.0.0/8 e 5.0.0.0/8. Se o Router 3.3.3.3 souber como acessar o roteador de anúncio que criou o LSA de resumo, ele instalará a rota em sua tabela de roteamento. Em nosso exemplo, o roteador de anúncio é o roteador 2.2.2.2, que o roteador 3.3.3.3 sabe alcançar. Instala rotas para 4.0.0.0/8 e 5.0.0.0/8 em sua tabela de roteamento. A métrica dessas rotas é a métrica para atingir o roteador de anúncio mais a métrica do sumário LSA. A métrica do sumário LSA é calculada a partir do custo para atingir a rota intra ou inter-áreas para as quais o LSA sumário é gerado.

Após calcular todas as rotas OSPF internas (intra-área e inter-área), o Roteador 3.3.3.3 examina os LSAs externos. Examina antes o LSA 9.0.0.0/8 externo criado pelo ASBR 1.1.1.1 e, em seguida, calcula como atingir o ASBR. O roteador 3.3.3.3 examina o resumo asbr LSA para o roteador 1.1.1.1, criado pelo ABR (roteador 2.2.2.2). Após fazer isso, o roteador 3.3.3.3 sabe que o ASRB é alcançável por meio do ABR. Portanto, o Router 3.3.3.3 instala uma rota para 9.0.0.0/8 sua tabela de roteamento. No nosso exemplo, é uma rota E1, portanto, a métrica para ela é a métrica do roteador 3.3.3.3 para atingir o ABR, mais a métrica do ABR para atingir o ASBR, mais a métrica do LSA externo.

Esta saída mostra as rotas de OSPF na tabela de roteamento de cada roteador descrito.

r3.3.3.3#
show ip route ospf
 
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 00:07:59, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 00:07:59, ATM2/0.20 
O E1 9.0.0.0/8 [110/70] via 6.0.0.2, 00:07:59, ATM2/0.20 
  

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:06:55, Serial0/1/0 
O E1 9.0.0.0/8 [110/69] via 5.0.0.1, 00:06:55, Serial0/1/0 
  

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47865