IP : Open Shortest Path First (OSPF)

OSPF Inter-Area Routing

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento olha dentro do Banco de Dados do Open Shortest Path First (OSPF) e da tabela de Roteamento quando o OSPF executam por duas áreas.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/47864/ospfdb5a.gif

Configurações

Este documento utiliza estas configurações.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial0/1/0
 ip unnumbered Ethernet0/0/4

interface ATM1/0.20 point-to-point
 ip address 200.0.0.2 255.255.255.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 200.0.0.0 0.255.255.255 area 1

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 200.0.0.3 255.255.255.0
 
router ospf 2
 network 200.0.0.0 0.255.255.255 area 1

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o base de dados OSPF IP — Indica uma lista das propagandas do estado do link (LSA) no base de dados do estado do link. Esta lista mostra somente a informação no cabeçalho LSA.

  • show ip ospf database [router] [link-state-id] — Indica o índice do LSA de roteador (tipo-1 LSA) no base de dados. Os LSA de roteador são produzidos por cada roteador, e estes LSA fundamentais alistam todo o dos links do roteador, ou das relações, junto com os estados e os custos de envio do link. São inundados somente dentro da área em que originam.

  • mostre o id> do <link-estado do sumário de base de dados OSPF IP — Indica os links de resumo do roteador de borda de área (ABR).

Examine a base de dados do OSPF

Desde que o roteador 2.2.2.2 é o ABR, tem o base de dados para ambas as áreas que está conectado a. Isso o torna o melhor lugar para ver o banco de dados OSPF, usando o comando show ip ospf database.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      697    0x80000040    0x5A21         2 
2.2.2.2   2.2.2.2      696    0x80000045    0xEE82         2 

                Summary Net Link States (Area 0) 

Link ID     ADV Router   Age  Seq#          Checksum 
200.0.0.0   2.2.2.2      352  0x80000001    0x2546 

                Router Link States (Area 1) 

Link ID   ADV Router Age    Seq#          Checksum   Link count 
2.2.2.2   2.2.2.2    351    0x8000000B    0xCA9D         2 
3.3.3.3   3.3.3.3    354    0x80000006    0x71F7         2 

                Summary Net Link States (Area 1) 

Link ID    ADV Router   Age   Seq#         Checksum 
4.0.0.0    2.2.2.2      689   0x80000001   0xFFE6 
6.0.0.0    2.2.2.2      700   0x80000001   0x63C1 

 r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 773 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000040 
  Checksum: 0x5A21 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a neighbor 
    !--- with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
    
 !--- The link is unnumbered, so the address starts with 
	 !--- zero. In the case of unnumbered links, the interface address 
     !--- displays the MIB II IfIndex value that usually starts with 0.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- This is the OSPF cost of the link that connects 
       !--- the two routers.
 

    Link connected to: a Stub Network

	!--- This line represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

        Router Link States (Area 0) 

!--- This is the router LSA for 2.2.2.2 in area 0. 


  LS age: 789 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000045 
  Checksum: 0xEE82 
  Length: 48 
  Area Border Router
  
!--- Bit B is set in the router LSA. 
  !--- It indicates that this router is an ABR.
 
   Number of Links: 2
   
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

                Router Link States (Area 1)    
				
!--- This is the router LSA for 
    			!--- Router 2.2.2.2 in area 1. 


  LS age: 445 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0xCA9D 
  Length: 48 
  Area Border Router
   Number of Links: 2

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 200.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  LS age: 465 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 80000006 
  Checksum: 0x71F7 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 200.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Para anunciar rotas de uma área em outra, o ABR cria os links de resumo, que você pode ver usando o comando show ip ospf database summary <link-state id>.

r2.2.2.2#show ip ospf database summary 200.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 487 
  Options: (No TOS-capability, DC, Upward) 

  !--- The Upward keyword indicates that this is not an LSA imported 
  !--- from a VPN backbone (from a PE to a CE).

  LS Type: Summary Links(Network) 
  Link State ID: 200.0.0.0 (summary Network Number)
  
!--- 200.0.0.0/24 is advertised into area 0 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x2546 
  Length: 28 
  Network Mask: /24 
        TOS: 0  Metric: 1 

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 840 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 1 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 861 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- 6.0.0.0/8 is advertised into area 1 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x63C1 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 10 

Calcule o caminho mais curto

Esta seção calcula o caminho mais curto da perspectiva do roteador 3.3.3.3.

O roteador 3.3.3.3 procura em seu próprio LSA e vê que o roteador 2.2.2.2 é um vizinho. O roteador 3.3.3.3 olha então o roteador 2.2.2.2's LSA para verificar que o roteador 2.2.2.2 vê o roteador 3.3.3.3 como um vizinho. Se ambo o Roteadores se vê como vizinhos, está considerado alcançável.

Cada roteador verifica também sua tabela vizinha local (que pode ser vista com o comando show ip ospf neighbor) para verificar se a interface e a interface do vizinho estão em uma sub-rede de IP comum.

Nota: Esta verificação não é executada em uma interface não numerada.

Se as relações estão em uma sub-rede comum, o Roteadores instala rotas para todas as redes stub alistadas no LSA do seu vizinho. Neste exemplo, 200.0.0.0/24 são a única rede stub alistada no roteador 2.2.2.2's LSA, a que o roteador 3.3.3.3 já é conectado diretamente.

Os lsa de roteador alcançável na área 1 são examinados afinal, olhares de 3.3.3.3 do roteador em LSA sumário no base de dados. Encontra LSA sumário para 4.0.0.0/8 e 6.0.0.0/8. Se o Router 3.3.3.3 souber como acessar o roteador de anúncio que criou o LSA de resumo, ele instalará a rota em sua tabela de roteamento. Neste exemplo, o roteador de anúncio é roteador 2.2.2.2. Desde que o roteador 3.3.3.3 sabe alcançar o roteador 2.2.2.2, instala rotas para 4.0.0.0/8 e 6.0.0.0/8 em sua tabela de roteamento. A métrica dessas rotas é a métrica para atingir o roteador de anúncio mais a métrica do sumário LSA. A métrica do sumário LSA é calculada a partir do custo para atingir a rota intra ou inter-áreas para as quais o LSA sumário é gerado.

Nota: O Roteadores usa o tipo-1 LSA para anunciar as redes e o outro Roteadores a que é conectado diretamente em uma área, que seja inundada dentro da mesma área. Assim, todo o Roteadores dentro da mesma área tem a informação de topologia completa para sua própria área. Em consequência, os ABR mantêm a informação de topologia completa sobre todas as áreas a que são anexados diretamente. Contudo, quando os ABR anunciam uma rede que pertença a uma área em uma segunda área, anunciam somente o prefixo e a máscara da rede usando o Type-3 LSA. O Roteadores na segunda área não sabe sobre a informação de topologia de outras áreas, mas tem a informação de alcançabilidade para as redes em outras áreas.

Esta saída mostra as rotas de OSPF na tabela de roteamento de cada roteador descrito acima.

r1.1.1.1# show ip route ospf 
O IA 200.0.0.0/24 [110/65] via 6.0.0.2, 00:09:00, Serial2/1/0 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:14:41, Serial2/1/0 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:09:16, Serial0/1/0 

r3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 200.0.0.2, 00:09:27, ATM2/0.20 
O IA 6.0.0.0/8 [110/11] via 200.0.0.2, 00:09:27, ATM2/0.20 

Troubleshooting

Para obter informações sobre de pesquisar defeitos o OSPF quando a informação no base de dados falta da tabela de roteamento, refira porque são algumas rotas de OSPF no base de dados mas não na tabela de roteamento? Para a informação geral do Troubleshooting de OSPF, refira a pesquisa de defeitos do OSPF.


Informações Relacionadas


Document ID: 47864