IP : Open Shortest Path First (OSPF)

OSPF Routers Conectados por uma Rede Multiacesso

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra dois roteadores Open Shortest Path First (OSPF) conectados em uma rede de multiacesso.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/47863/ospfdb4a.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Ethernet2/0/2
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Ethernet0/0/2
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o banco de dados OSPF IP — Indica uma lista das propagandas do estado do link (LSA) e datilografa-as em um banco de dados do estado do link. Esta lista mostra somente a informação no cabeçalho LSA.

  • show ip ospf database [router] [link-state-id] — Indica uma lista de todos os LSA de um roteador no banco de dados. Os LSA são produzidos por cada roteador, e estes LSA fundamentais alistam os links de todo o Roteadores, ou as relações, junto com os estados e os custos de envio do link. São inundados somente dentro da área em que originam.

Examine a base de dados do OSPF

Para ver como os olhares da base de dados do OSPF dados este ambiente de rede, olham a saída do comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum  Link count 
1.1.1.1   1.1.1.1     107   0x80000018   0x7966        2 
2.2.2.2   2.2.2.2     106   0x80000015   0x6770        2 

                Net Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum 
5.0.0.2   2.2.2.2     102   0x80000004   0x7E9D 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 147 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.
 
  LS Seq Number: 80000018 
  Checksum: 0x7966 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network
    
!--- This router (1.1.1.1) has a link connected to 
    !--- a transit network that has a designated router (DR)
    !--- and backup designated router (BDR) listed here.  

     (Link ID) Designated Router address: 5.0.0.2
	 
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- This router's (1.1.1.1) interface address 
     !--- connected to the DR is 5.0.0.1. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The OSPF cost of the link is 10.
 

    Link connected to: a Stub Network 
    
!--- This represents the subnet of the Ethernet segment
    !--- 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The cost of the link is 10. 


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 162 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000015 
  Checksum: 0x6770 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network 
     (Link ID) Designated Router address: 5.0.0.2
     
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.2
     
!--- Since these values are equal, router
     !--- (2.2.2.2) is the DR. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 
  

r2.2.2.2#show ip ospf database network 5.0.0.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Net Link States (Area 0) 

  Routing Bit Set on this LSA 
  LS age: 182 
  Options: (No TOS-capability, DC) 
  LS Type: Network Links 
  Link State ID: 5.0.0.2 (address of Designated Router)
  
!--- This is the IP address of the DR 
  !--- (not the router ID). 

  Advertising Router: 2.2.2.2
  
!--- This is the router ID of the router that 
  !--- created this LSA.

  LS Seq Number: 80000004 
  Checksum: 0x7E9D 
  Length: 32 
  Network Mask: /8
  
!--- Binary and the DR's interface address with the 
  !--- mask to get to network 5.0.0.0/8. 

        Attached Router: 2.2.2.2
	
!--- The DR's router ID, along with a list of routers 
    !--- adjacent on the transit network. 

        Attached Router: 1.1.1.1 

Calcule o caminho mais curto

Esta seção calcula a árvore de caminho mais curto da perspectiva do roteador 1.1.1.1.

O roteador 1.1.1.1 olha em seu próprio LSA e vê que tem um link a um transit network para que 5.0.0.2 é o endereço da relação do DR. Procura então a rede LSA com um estado ID do link de 5.0.0.2. Ele encontra uma lista de roteadores anexos (roteadores 1.1.1.1 e 2.2.2.2) na rede LSA. Isso indica que todos os roteadores são alcançáveis por meio dessa rede de transito. O roteador 1.1.1.1 pode verificar que seu próprio ID está na lista. Então pode calcular rotas através de qualquens um roteadores anexados.

Roteador 1.1.1.1 busca LSA do Roteador 2.2.2.2 para verificar se ele contém um enlace conectado à mesma rede de trânsito, 5.0.0.2. O Roteador 1.1.1.1 pode instalar agora rotas para todas as redes stub no LSA do Roteador 2.2.2.2.

O Router 1.1.1.1 instala uma rota para a rede 6.0.0.0/8 em sua tabela de roteamento, pois a 6.0.0.0/8 foi listado como uma rede de stub em seu LSA.

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 

O banco de dados de estado de link OSPF olha idêntico se é uma rede de transmissão ou uma rede sem broadcast. A principal diferença é o mecanismo de descoberta de vizinho. Em uma rede de transmissão, os vizinhos são descobertos através dos pacotes de hello de transmissão múltipla. Em uma rede de não-difusão, os vizinhos são configurados estaticamente e pacotes de saudação de unicast são enviados para formar a adjacência entre vizinhos.

O próximo salto em redes multiacesso sem broadcast

Para explorar a introdução do salto seguinte em uma rede do multiacesso sem broadcast (NBMA), olhe este exemplo. Há três roteadores em uma rede de trânsito (roteadores non_DR_a, non_DR_b e DR). É uma topologia de hub e spoke no mídias de NBMA tais como o Frame Relay, o Asynchronous Transfer Mode (ATM), ou o X.25.

/image/gif/paws/47863/ospfdb4b.gif

Quando o Router non_DR calcula rotas por meio do Router non_DR_b, isto torna o Router non_DR_b o Next Hop. Contudo, o non_DR_a do roteador não tem um virtual circuit (VC) ao non_DR_b do roteador, que significa que este Roteadores não pode se sibilar. O OSPF instala rotas na tabela de roteamento com um salto seguinte que não possa ser alcançado.

A solução para esse problema é adicionar uma segunda instrução mapa de frame-relay para tornar todos os vizinhos alcançáveis pelo VC que vai para o roteador DR. Por exemplo:

interface Serial0 
 frame-relay map ip 1.1.1.1 700 broadcast
 
!--- This is a map for the DR. 

 frame-relay map ip 1.1.1.2 700 broadcast
 
!--- This is a map on the same VC data-link connection 
 !--- identifier (DLCI) for a non-DR router. 

Quando você compara este comportamento com o aquele do protocolo do Intermediate System-to-Intermediate System (ISIS), um roteador não instala uma rota isis através de um salto seguinte, a menos que o salto seguinte for um vizinho. Isto significa que o ISIS não trabalha em uma relação do multi-ponto a menos que o Roteadores for engrenado inteiramente.

O OSPF instala rotas mesmo que o salto seguinte não seja um vizinho, e não é a camada direta alcançável 2. Contudo, você pode fixar este problema configurando indicações do mapa múltiplas.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47863