IP : Open Shortest Path First (OSPF)

Roteadores OSPF conectados por um enlace ponto-a-ponto numerado

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra dois Roteadores do Open Shortest Path First (OSPF) conectados por um link Point-to-Point numerado.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/47861/ospfdb2a.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o banco de dados OSPF IP — Indica uma lista das propagandas do estado do link (LSA) e datilografa-as em um banco de dados do estado do link. Esta lista mostra somente a informação no cabeçalho LSA.

  • show ip ospf database [router] [link-state-id] — Indica uma lista de todos os LSA de um roteador no banco de dados. Os LSA são produzidos por cada roteador. Estes LSA fundamentais alistam os links ou as relações de todo o Roteadores, junto com os estados e os custos de envio do link. São inundados igualmente somente dentro da área em que originam.

Examine a base de dados do OSPF

Para ver como os olhares da base de dados do OSPF dados este ambiente de rede, olham a saída do comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age   Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      522   0x80000002    0x96D3         3 
2.2.2.2   2.2.2.2      401   0x80000003    0x9FC2         3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 540 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the same 
  !--- as the Advertising Router (the next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that  
  !--- created this LSA. 

  LS Seq Number: 80000002 
  Checksum: 0x96D3 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point)
    
!--- This entry shows that this router (1.1.1.1) is a neighbor
    !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1
     
!--- Interface on this router (1.1.1.1) which connects the 
     !--- neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
     	
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network
	
!--- This represents the subnet of the serial link 5.0.0.0/8. 

     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
		
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network
	
!--- This represents the subnet of the 
!--- Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
		
!--- The OSPF cost of the link is 10.

  

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 424 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0x9FC2 
  Length: 60 
   Number of Links: 3 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

Calcule o caminho mais curto

Esta seção calcula a árvore de caminho mais curto da perspectiva do roteador 2.2.2.2.

O Router 2.2.2.2 olha para seu próprio LSA e vê que o Router 1.1.1.1 é um vizinho. O roteador 2.2.2.2 inspeciona o LSA do roteador 1.1.1.1 para verificar se 1.1.1.1 vê 2.2.2.2 como vizinho. Se ambo o Roteadores se vê como vizinhos, a seguir está considerado alcançável.

Cada roteador verifica também sua tabela vizinha local (pode ser verificada usando o comando show ip ospf neighbor) para verificar se a interface e a interface do vizinho estão em uma sub-rede de IP comum. Se estiverem, os roteadores instalarão rotas para quaisquer redes stub listadas no LSA de roteador de seus vizinhos.

Neste exemplo, o Router 2.2.2.2 instala uma rota para 4.0.0.0/8 em sua tabela de roteamento, porque o Router 1.1.1.1 listou 4.0.0.0/8 como uma rede stub no Router LSA. O roteador 1.1.1.1 igualmente alistou 5.0.0.0/8 como uma rede stub. Contudo, o roteador 2.2.2.2 não instala uma rota de OSPF para 5.0.0.0/8 porque tem uma rota conectada para 5.0.0.0/8. Uma rota conectada é sempre melhor do que dinamicamente uma rota aprendida.

Router 2_2_2_2#
show ip route ospf
 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 

Router 1_1_1_1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47861