IP : Open Shortest Path First (OSPF)

Roteadores OSPF conectados por um enlace serial não numerado

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback



Índice


Introdução

O comando ip unnumbered configuration permite habilitar o processamento de IP em uma interface serial sem atribuí-lo a um endereço IP explícito. A interface não numerada IP pode “pedir” o endereço IP de Um ou Mais Servidores Cisco ICM NT de uma outra relação que seja configurada já no roteador. Isto conserva a rede e o espaço de endereços. Para obter mais informações sobre do comando ip unnumbered, refira a compreensão e configurar do comando ip unnumbered. Este documento ilustra dois Roteadores do Open Shortest Path First (OSPF) conectados por um enlace serial unnumbered.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/47860/ospfdb1.gif

Configurações

Este documento utiliza as seguintes configurações:

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet0/0/4
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verificar

Esta seção fornece a informação para confirmar que a configuração trabalha corretamente.

Determinados comandos show são suportados pela ferramenta Output Interpreter (clientes registrados somente). Isso permite que você veja uma análise da saída do comando show.

  • mostre o base de dados OSPF IP — Indica uma lista das propagandas do estado do link (LSA) no base de dados do estado do link. Esta lista mostra somente a informação no cabeçalho LSA.

  • show ip ospf database [router] [link-state-id] — Indica o índice do LSA de roteador (tipo-1 LSA) no base de dados. Os LSA de roteador são produzidos por cada roteador. Estes LSA fundamentais alistam os links de todo o Roteadores, ou as relações, junto com os estados e os custos de envio do link. São inundados somente dentro da área em que originam.

Examine a base de dados do OSPF

Para ver como a base de dados do OSPF olha quando é dada este ambiente de rede, olhe a saída do comando show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#           Checksum     Link count 
1.1.1.1   1.1.1.1     254   0x8000001A     0xA6FA           2 
2.2.2.2   2.2.2.2     253   0x80000017     0x4858           2 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 279 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1   
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line). 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router which created 
  !--- this LSA.

  LS Seq Number: 8000001A 
  Checksum: 0xA6FA 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that this router (1.1.1.1) is a neighbor 
 !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
		
!--- In the case of unnumbered link, use the MIB II IfIndex  
  !--- value. This value usually starts with 0. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
	   
!--- This is the OSPF cost of the link that connects 
!--- the two routers.


    Link connected to: a Stub Network 
	
!--- This entry represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10  
	   
!--- This is the OSPF cost of the Ethernet segment. 



r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 295 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000017 
  Checksum: 0x4858 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

Calcule o caminho mais curto

Esta seção calcula a árvore de caminho mais curto da perspectiva do roteador 2.2.2.2.

O Router 2.2.2.2 olha para seu próprio LSA e vê que o Router 1.1.1.1 é um vizinho. Olha então o roteador 1.1.1.1's LSA para verificar que 1.1.1.1 vê 2.2.2.2 como um vizinho. Se ambo o Roteadores se vê como vizinhos, está considerado alcançável. O Roteadores instala então rotas para todas as redes stub alistadas no LSA do seu vizinho.

Neste exemplo, o roteador 2.2.2.2 instala uma rota para 4.0.0.0/8 em sua tabela de roteamento porque o roteador 1.1.1.1 alista 4.0.0.0/8 como uma rede stub em seu LSA. Isto é visto com a ajuda do comando show ip route ospf.

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0 

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0 

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 47860