Multiprotocol Label Switching (MPLS) : Multiprotocol Label Switching para VPNs (MPLS para VPNs)

Vazamento de rota em redes MPLS/VPN

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento traz configurações de exemplo para vazamento de rota em um ambiente MPLS/VPN.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Isto secciona contém estes dois exemplos de configuração:

  • Direcione o vazamento de uma tabela de roteamento global para uma instância de roteamento/encaminhamento de VPN e direcione o vazamento de um VRF para uma tabela de roteamento global

  • Vazamento de rota entre VRF diferentes

Nota: Para encontrar a informação adicional sobre os comandos neste documento, use a ferramenta de consulta de comandos (clientes registrados somente).

Vazamento de rota de uma tabela de roteamento global em um VRF e vazamento de rota de um VRF em uma tabela de roteamento global

Esta configuração descreve o vazamento de rota de uma tabela de roteamento global em um VRF e o vazamento de rota de um VRF em uma tabela de roteamento global.

Diagrama de Rede

Essa configuração utiliza esta configuração de rede:

/image/gif/paws/47807/routeleaking_01.gif

Configuração

Neste exemplo, uma estação do sistema de gerenciamento de rede (NMS) situada em um VRF é alcançada da tabela de roteamento global. Os roteadores na extremidade do provedor (PE) e roteadores do provedor (P) precisam exportar as informações do netflow para uma estação NMS (10.0.2.2) em um VRF. O 10.0.2.2 é alcançável por meio de uma interface de VRF em PE-4.

Para alcançar 10.0.2.0/30 da tabela global, uma rota estática a 10.0.2.0/30 que indique da relação VRF é introduzida no PE-4. Esta rota estática é redistribuída então através do Interior Gateway Protocol (IGP) a todo o Roteadores PE e P. Isso assegura que todos os roteadores PE e P possam alcançar o 10.0.2.0/30 via PE-4.

Uma rota estática VRF é adicionada igualmente. Os pontos de rota estáticos VRF à sub-rede na rede global que envia o tráfego a esta estação NMS. Sem esta adição, o PE-4 deixa cair o tráfego, da estação NMS, que é recebida na relação VRF; e o PE-4 envia o ICMP: mensagem receptor do host inalcançável à estação NMS.

Essa seção utiliza esta configuração:

PE-4
!
ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
!
interface Serial1/0
ip address 10.1.2.5 255.255.255.252
no ip directed-broadcast
!
interface Serial2/0
ip vrf forwarding vpn2
ip address 10.0.2.1 255.255.255.0
no ip directed-broadcast
!
ip classless
ip route 10.0.2.0 255.255.255.252 Serial2/0
ip route vrf vpn2 10.1.2.4 255.255.255.252 Serial1/0
!

As rotas estáticas podem agora ser redistribuídas em todo o IGP para ser toda a rede anunciada. O mesmo aplica-se se a relação VRF é uma interface de LAN (por exemplo, Ethernet). O comando de configuração exata para aquele é:

ip route 10.0.2.0 255.255.255.252 Ethernet2/0 10.0.2.2

Nota: O endereço IP de Um ou Mais Servidores Cisco ICM NT configurado depois que o nome da relação é usado somente pelo Address Resolution Protocol (ARP), para conhecer que endereço para resolver.

Nota: Para 4500 Series Switch, você deve configurar entradas de ARP estáticas nas tabelas VRF para os endereços de próximo salto respectivos.

Nota: À revelia, o software de Cisco IOS� aceita rotas estáticas VRF como configuradas. Isto pôde comprometer a Segurança porque pôde introduzir o vazamento de rota entre VRF diferentes. Você pode usar o comando no ip route static inter-vrf impedir a instalação de tais rotas estáticas VRF. Consulte MPLS Virtual Private Networks (VPNs) [VPNs (Redes privadas virtuais) da MPLS] para obter mais informações sobre o comando no ip route static inter-vrf.

Verificar

Esta seção fornece a informação para confirmar que sua configuração está trabalhando corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre a rota 10.0.2.0 IP — Indica uma entrada de roteamento do endereço IP especificado.

  • mostre o vrf vpn2 10.1.2.4 da rota IP — Indica uma entrada de roteamento do endereço IP especificado VRF.

PE-4# show ip route 10.0.2.0

Routing entry for 10.0.2.0/30
Known via "static", distance 1, metric 0 (connected)
Routing Descriptor Blocks:
* directly connected, via Serial2/0
Route metric is 0, traffic share count is 1

PE-4# show ip route vrf vpn2 10.1.2.4

Routing entry for 10.1.2.4/30
Known via "static", distance 1, metric 0 (connected)
Redistributing via bgp 1
Advertised by bgp 1
Routing Descriptor Blocks:
* directly connected, via Serial1/0
Route metric is 0, traffic share count is 1

Vazamento de rotas entre VRFs diferentes

Essa configuração descreve vazamento de rotas entre diferentes VRFs.

Diagrama de Rede

Essa configuração utiliza este diagrama de rede:

/image/gif/paws/47807/routeleaking_02.gif

Configuração

Você não pode configurar duas rotas estáticas para anunciar cada prefixo entre os VRF, porque este método não é apoiado — os pacotes não serão distribuídos pelo roteador. Para conseguir o vazamento de rota entre VRF, você deve usar a funcionalidade da importação do rota-alvo e permitir o Border Gateway Protocol (BGP) no roteador. Nenhum vizinho de BGP é exigido.

Essa seção utiliza esta configuração:

PE-4
!
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 route-target import 200:1
!
ip vrf vpn2
 rd 200:1
 route-target export 200:1
 route-target import 200:1
 route-target import 100:1
!
interface Serial1/0
 ip vrf forwarding vpn1
 ip address 10.1.2.5 255.255.255.252
 no ip directed-broadcast
!
interface Serial2/0
 ip vrf forwarding vpn2
 ip address 10.0.2.1 255.255.255.0
 no ip directed-broadcast
router bgp 1
!
address-family ipv4 vrf vpn2
 redistribute connected
 !
address-family ipv4 vrf vpn1
 redistribute connected
!

Verificar

Esta seção fornece a informação para pesquisar defeitos sua configuração.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o VPNv4 todo BGP IP — Indica todos os prefixos do VPNv4 que são instruídos através do BGP.

PE-4# show ip bgp vpnv4 all

BGP table version is 13, local router ID is 7.0.0.4
Status codes: s suppressed, d damped, h history, * valid,
> best, i - internal, r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?
Route Distinguisher: 200:1 (default for vrf vpn2)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?

Nota: A outra maneira de escapar rotas entre VRF é conectar junto duas interfaces Ethernet no roteador PE-4 e associar cada interface Ethernet com um dos VRF. Você igualmente deve configurar entradas de ARP estáticas nas tabelas VRF para os endereços de próximo salto respectivos. Contudo, esta não é uma solução recomendada para o vazamento de rota entre VRF; a técnica previamente descrita BGP é a solução recomendada.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47807