IP : Protocolos de roteamento IP

Roteamento Baseado em Políticas, Utilizando o Exemplo de Configuração dos Comandos set ip default next hop e set ip next-hop

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o roteamento com base em políticas (PBR) usando os comandos set ip default next-hop e set ip next-hop.

O comando set ip default next-hop verifica a existência do endereço IP de destino na tabela de roteamento, e…

  • se o IP Address de destino existir, o comando não roteia o pacote com base na política, mas o encaminha baseado na tabela de roteamento.

  • se o endereço IP de destino não existir, a política do comando roteará o pacote, enviando-o ao Next Hop especificado.

O comando set ip next-hop verifica a existência do salto seguinte especificado, e…

  • se o salto seguinte estiver na tabela de roteamento, a política de comando direcionará o pacote para o salto seguinte.

  • se o próximo salto não existir na tabela de roteamento, o comando usará a tabela de roteamento normal para encaminhar o pacote.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não é restringido à versão de software e hardware específica; contudo, o software usado deve roteamento baseado política de suporte. Use o Feature Navigator para determinar o hardware e o software que são compatíveis com esta configuração.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/47121/pbr_cmds_ce_01.gif

Casos Práticos 1: Roteamento de Política usando o comando set ip default next-hop com Dynamic Protocol Routing

Esta seção utiliza as seguintes configurações:

R1
R1# show running-config 
Building configuration...
.
!
interface Ethernet0/0
 ip address 100.100.100.1 255.255.255.0
 ip policy route-map blah
!
interface Serial1/0
 ip address 10.10.10.1 255.255.255.0
!
interface Serial2/0
 ip address 20.20.20.1 255.255.255.0
!
router ospf 1
  
!--- OSPF is not configured on Serial1/0.

 log-adjacency-changes
 network 20.20.20.0 0.0.0.255 area 0
 network 100.100.100.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 100 permit ip host 100.100.100.3 host 200.200.200.4
!
route-map blah permit 10
 match ip address 100
 set ip default next-hop 10.10.10.2
.
.
!
end

R2
R2# show running-config 
Building configuration...
.
!
!
interface Ethernet0/0
 ip address 200.200.200.2 255.255.255.0
 ip policy route-map blah
!
interface Serial1/0
 ip address 10.10.10.2 255.255.255.0
 fair-queue
!
interface Serial2/0
 ip address 20.20.20.2 255.255.255.0
!
router ospf 1
 
!--- OSPF is not configured on Serial1/0.

 log-adjacency-changes
 network 20.20.20.0 0.0.0.255 area 0
 network 200.200.200.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 100 permit ip host 200.200.200.4 host 100.100.100.3
!
route-map blah permit 10
 match ip address 100
 set ip default next-hop 10.10.10.1
!
end

Verifique os Casos Práticos 1

Quando a rota do destino existe na tabela de roteamento, a transmissão normal está usada — não faz a rota da política o pacote.

R1# show ip route 200.200.200.4 
   Routing entry for 200.200.200.0/24
   Known via "ospf 1", distance 110, metric 74, type intra area
   Last update from 20.20.20.2 on Serial2/0, 00:11:48 ago
   Routing Descriptor Blocks:
   * 20.20.20.2, from 30.30.30.3, 00:11:48 ago, via Serial2/0
   Route metric is 74, traffic share count is 1

R1# debug ip policy 
Policy routing debugging is on
*Dec 4 12:50:57.363: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 4 12:50:57.363: IP: route map blah, item 10, permit
*Dec 4 12:50:57.363: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0), len 100, policy rejected -- normal forwarding
*Dec 4 12:50:57.431: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 4 12:50:57.431: IP: route map blah, item 10, permit
*Dec 4 12:50:57.431: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0), len 100, policy rejected -- normal forwarding
*Dec 4 12:50:57.491: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 4 12:50:57.491: IP: route map blah, item 10, permit
*Dec 4 12:50:57.491: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0), len 100, policy rejected -- normal forwarding
  
R2# show ip route 100.100.100.3
Routing entry for 100.100.100.0/24
  Known via "ospf 1", distance 110, metric 74, type intra area
  Last update from 20.20.20.1 on Serial2/0, 00:11:42 ago
  Routing Descriptor Blocks:
  * 20.20.20.1, from 100.100.100.1, 00:11:42 ago, via Serial2/0
      Route metric is 74, traffic share count is 1

R2# debug ip policy 
Policy routing debugging is on
*Dec 4 12:50:57.779: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec 4 12:50:57.779: IP: route map blah, item 10, permit
*Dec 4 12:50:57.779: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial2/0), len 100, policy rejected -- normal forwarding
*Dec 4 12:50:57.839: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec 4 12:50:57.839: IP: route map blah, item 10, permit
*Dec 4 12:50:57.839: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial2/0), len 100, policy rejected -- normal forwarding
*Dec 4 12:50:57.911: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec 4 12:50:57.911: IP: route map blah, item 10, permit
*Dec 4 12:50:57.911: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial2/0), len 100, policy rejected -- normal forwarding

Quando o Serial 2/0 fica inativo e o endereço de destino desaparece da tabela de roteamento, o pacote é roteado por política.

R1# show ip route 200.200.200.0
% Network not in table
R1#
*Dec 5 13:26:27.567: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:26:27.567: IP: route map blah, item 10, permit
*Dec 5 13:26:27.567: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:26:27.567: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 5 13:26:27.655: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:26:27.655: IP: route map blah, item 10, permit
*Dec 5 13:26:27.655: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:26:27.655: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 5 13:26:27.727: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:26:27.727: IP: route map blah, item 10, permit
*Dec 5 13:26:27.727: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:26:27.727: IP: Ethernet0/0 to Serial1/0 10.10.10.2

Casos Práticos 2: Roteamento de Política Usando o Comando set ip next-hop com Dynamic Routing Protocol

Esta seção utiliza as seguintes configurações:

R1
R1# show running-config 
Building configuration...
.
!
interface Ethernet0/0
 ip address 100.100.100.1 255.255.255.0
 ip policy route-map blah
!
interface Serial1/0
 ip address 10.10.10.1 255.255.255.0
!
interface Serial2/0
 ip address 20.20.20.1 255.255.255.0
!
router ospf 1
 
!--- OSPF is not configured on Serial1/0.

 log-adjacency-changes
 network 20.20.20.0 0.0.0.255 area 0
 network 100.100.100.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 100 permit ip host 100.100.100.3 host 200.200.200.4
!
route-map blah permit 10
 match ip address 100
 set ip next-hop 10.10.10.2
.
.
!
end

R2
R2# show running-config 
Building configuration...
.
!
!
interface Ethernet0/0
 ip address 200.200.200.2 255.255.255.0
 ip policy route-map blah
!
interface Serial1/0
 ip address 10.10.10.2 255.255.255.0
 fair-queue
!
interface Serial2/0
 ip address 20.20.20.2 255.255.255.0
!
router ospf 1
 
!--- OSPF is not configured on Serial1/0.

 log-adjacency-changes
 network 20.20.20.0 0.0.0.255 area 0
 network 200.200.200.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
!
access-list 100 permit ip host 200.200.200.4 host 100.100.100.3
!
route-map blah permit 10
 match ip address 100
 set ip next-hop 10.10.10.1
!
end

Verifique os Casos Práticos 2

Verifique a existência do salto seguinte, 10.10.10.2, na tabela de roteamento. Se a rota do destino existe na tabela de roteamento, o pacote é política distribuído se o salto seguinte é alcançável.

R1# show ip route 200.200.200.4 
Routing entry for 200.200.200.0/24
  Known via "ospf 1", distance 110, metric 74, type intra area
  Last update from 20.20.20.2 on Serial2/0, 00:11:48 ago
  Routing Descriptor Blocks:
  * 20.20.20.2, from 30.30.30.3, 00:11:48 ago, via Serial2/0
      Route metric is 74, traffic share count is 1

R1# debug ip policy 
Policy routing debugging is on
*Dec 4 12:53:38.271: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 4 12:53:38.271: IP: route map blah, item 10, permit
*Dec 4 12:53:38.271: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0), len 100, policy routed
*Dec 4 12:53:38.271: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 4 12:53:38.355: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 4 12:53:38.355: IP: route map blah, item 10, permit
*Dec 4 12:53:38.355: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0), len 100, policy routed
*Dec 4 12:53:38.355: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 4 12:53:38.483: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 4 12:53:38.483: IP: route map blah, item 10, permit

R2# sh ip route 100.100.100.3
Routing entry for 100.100.100.0/24
  Known via "ospf 1", distance 110, metric 74, type intra area
  Last update from 20.20.20.1 on Serial2/0, 00:11:42 ago
  Routing Descriptor Blocks:
  * 20.20.20.1, from 100.100.100.1, 00:11:42 ago, via Serial2/0
      Route metric is 74, traffic share count is 1

R2# debug ip policy 
Policy routing debugging is on
*Dec  4 12:53:38.691: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec  4 12:53:38.691: IP: route map blah, item 10, permit
*Dec  4 12:53:38.691: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial1/0), len 100, policy routed
*Dec  4 12:53:38.691: IP: Ethernet0/0 to Serial1/0 10.10.10.1
*Dec  4 12:53:38.799: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec  4 12:53:38.799: IP: route map blah, item 10, permit
*Dec  4 12:53:38.799: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial1/0), len 100, policy routed
*Dec  4 12:53:38.799: IP: Ethernet0/0 to Serial1/0 10.10.10.1
*Dec  4 12:53:38.899: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec  4 12:53:38.899: IP: route map blah, item 10, permit

Quando o endereço IP de destino desaparece do roteamento, o pacote é roteado por política.

*Dec 5 13:33:23.607: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:33:23.607: IP: route map blah, item 10, permit
*Dec 5 13:33:23.607: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:33:23.607: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 5 13:33:23.707: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:33:23.707: IP: route map blah, item 10, permit
*Dec 5 13:33:23.707: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:33:23.707: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 5 13:33:23.847: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:33:23.847: IP: route map blah, item 10, permit

Quando a interface 1/0 Serial for desativada, soltaremos o nó seguinte, 10.10.10.1 da tabela de roteamento e o pacote seguirá a tabela de roteamento normal.

*Dec 5 13:40:38.887: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:40:38.887: IP: route map blah, item 10, permit
*Dec 5 13:40:38.887: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0), len 100, policy rejected -- normal forwarding
*Dec 5 13:40:39.047: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:40:39.047: IP: route map blah, item 10, permit
*Dec 5 13:40:39.047: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0), len 100, policy rejected -- normal forwarding
*Dec 5 13:40:39.115: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:40:39.115: IP: route map blah, item 10, permit
*Dec 5 13:40:39.115: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0), len 100, policy rejected -- normal forwarding

Casos Práticos 3: Roteamento de política usando o salto seguinte do padrão do grupo IP com uma rota padrão

Esta seção utiliza as seguintes configurações:

R1
R1 
R1# show running-config 
Building configuration...
.
!
interface Ethernet0/0
 ip address 100.100.100.1 255.255.255.0
 ip policy route-map blah
!
interface Serial1/0
 ip address 10.10.10.1 255.255.255.0
!
interface Serial2/0
 ip address 20.20.20.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 20.20.20.2
!
ip classless
no ip http server
!
access-list 100 permit ip host 100.100.100.3 host 200.200.200.4
!
route-map blah permit 10
 match ip address 100
 set ip default next-hop 10.10.10.2
.
.
!
end

R2
R2# show running-config 
Building configuration...
.
!
!
interface Ethernet0/0
 ip address 200.200.200.2 255.255.255.0
 ip policy route-map blah
!
interface Serial1/0
 ip address 10.10.10.2 255.255.255.0
 fair-queue
!
interface Serial2/0
 ip address 20.20.20.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 20.20.20.1
!
ip classless
no ip http server
!
!
!
access-list 100 permit ip host 200.200.200.4 host 100.100.100.3
!
route-map blah permit 10
 match ip address 100
 set ip default next-hop 10.10.10.1
!
end

Verificar os Casos Práticos 3

Quando a única rota ao destino é a rota padrão — não há nenhuma rota específica para esse destino no conto do roteamento — o pacote é política distribuído.

R1# show ip route 200.200.200.4
% Network not in table


R1# show ip route 0.0.0.0 
Routing entry for 0.0.0.0/0, supernet
Known via "static", distance 1, metric 0, candidate default path
Routing Descriptor Blocks:
* 20.20.20.2
Route metric is 0, traffic share count is 1

R1# 
*Dec  4 12:58:55.191: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec  4 12:58:55.191: IP: route map blah, item 10, permit
*Dec  4 12:58:55.191: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0), len 100, policy routed
*Dec  4 12:58:55.191: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec  4 12:58:55.291: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec  4 12:58:55.291: IP: route map blah, item 10, permit
*Dec  4 12:58:55.291: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0), len 100, policy routed
*Dec  4 12:58:55.291: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec  4 12:58:55.391: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec  4 12:58:55.391: IP: route map blah, item 10, permit
*Dec  4 12:58:55.391: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0), len 100, policy routed
*Dec  4 12:58:55.391: IP: Ethernet0/0 to Serial1/0 10.10.10.2

R2# show ip route 100.100.100.3
% Network not in table

R2# show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "static", distance 1, metric 0, candidate default path
Routing Descriptor Blocks:
* 20.20.20.1
Route metric is 0, traffic share count is 1

R2#
*Dec  4 12:58:20.819: %SYS-5-CONFIG_I: Configured from console by console
*Dec  4 12:58:55.611: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec  4 12:58:55.611: IP: route map blah, item 10, permit
*Dec  4 12:58:55.611: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial1/0), len 100, policy routed
*Dec  4 12:58:55.611: IP: Ethernet0/0 to Serial1/0 10.10.10.1
*Dec  4 12:58:55.739: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec  4 12:58:55.739: IP: route map blah, item 10, permit
*Dec  4 12:58:55.739: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial1/0), len 100, policy routed
*Dec  4 12:58:55.739: IP: Ethernet0/0 to Serial1/0 10.10.10.1
*Dec  4 12:58:55.799: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3, len 100, policy match
*Dec  4 12:58:55.799: IP: route map blah, item 10, permit
*Dec  4 12:58:55.799: IP: s=200.200.200.4 (Ethernet0/0), d=100.100.100.3 (Serial1/0), len 100, policy routed
*Dec  4 12:58:55.799: IP: Ethernet0/0 to Serial1/0 10.10.10.1

Quando a rota padrão não existe porque 2/0 Serial foi desativada, o pacote é roteado por uma política.

R1# show ip route 0.0.0.0
% Network not in table
R1#
*Dec 5 13:02:31.283: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:02:31.283: IP: route map blah, item 10, permit
*Dec 5 13:02:31.283: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:02:31.283: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 5 13:02:31.375: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:02:31.375: IP: route map blah, item 10, permit
*Dec 5 13:02:31.375: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:02:31.375: IP: Ethernet0/0 to Serial1/0 10.10.10.2
*Dec 5 13:02:31.435: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 13:02:31.435: IP: route map blah, item 10, permit
*Dec 5 13:02:31.435: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial1/0),len 100, policy routed
*Dec 5 13:02:31.435: IP: Ethernet0/0 to Serial1/0 10.10.10.2

Na situação onde o Serial2/0 é ascendente e o Serial1/0 vai para baixo, nós afrouxamos o salto seguinte e o pacote segue a transmissão normal (tabela de roteamento) - política rejeitada.

R1# debug ip policy 
Policy routing debugging is on
R1#
*Dec 5 12:46:49.543: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 12:46:49.543: IP: route map blah, item 10, permit
*Dec 5 12:46:49.543: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0),len 100, policy rejected -- normal forwarding
*Dec 5 12:46:49.623: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 12:46:49.623: IP: route map blah, item 10, permit
*Dec 5 12:46:49.623: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0),len 100, policy rejected -- normal forwarding
*Dec 5 12:46:49.691: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4, len 100, policy match
*Dec 5 12:46:49.691: IP: route map blah, item 10, permit
*Dec 5 12:46:49.691: IP: s=100.100.100.3 (Ethernet0/0), d=200.200.200.4 (Serial2/0),len 100, policy rejected -- normal forwarding

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 47121