Serviços de rede de aplicativos : Cisco LocalDirector 400 Series

Configurando o redirecionamento HTTP no LocalDirector durante a verificação de disponibilidade do servidor

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Cisco anunciou a fim--venda para o Cisco LocalDirector. Para mais informação, refira o fim da vida útil do 400 Series de LocalDirector e as observações e os boletins de produto da Fim--venda.


Índice


Introdução

Este documento descreve como configurar o redirecionamento do Hypertext Transfer Protocol (HTTP) que permite verificar a disponibilidade de servidores no Cisco LocalDirector. O redirecionamento de HTTP também requer que endereços IP adicionais para endereços IP diretos (DIP) permitam navegação/chamada direta.

Esta configuração foi desenvolvida e testada utilizando as versões de software e hardware abaixo.

  • LocalDirector 416 em um ambiente de laboratório com configurações esclarecidas.
  • Versão do software LocalDirector 4.2.1
  • Microsoft Internet Explorer 5.5
  • Netscape Communicator 4.7

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede viva, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Diagrama de Rede

Como configurar o redirecionamento de HTTP para verificar a disponibilidade do servidor

Execute as seguintes etapas para configurar seu LocalDirector:

  1. Crie um registro “A” para o seguinte:
    test.testdomain.com <-> 172.18.124.209 VIP
    ns-ms1-dip.testdomain.com <-> 172.18.124.212 DIP 
    ns-ms2-dip.testdomain.com <-> 172.18.124.211 DIP
    ns-ms1.cisco.com <-> 172.18.124.207 REAL 
    ns-ms2.cisco.com <-> 172.18.124.206 REAL
    172.18.124.211 DIP virtual for 172.18.124.206 REAL (aka s2)
    172.18.124.212 DIP virtual for 172.18.124.207 REAL (aka s1)
    

    Nota: É necessário ter IP Virtual (VIP) vinculado a porta, DIP e endereços reais, mas você também precisa ter dois endereços IP para cada endereço real para conexões de saída com o servidor real para ainda ter permissão. Isto permite VIP seguros com uma restauração enviada para portas ruins. Também permite que outras chamadas para os DIPs cheguem diretamente através do endereço verdadeiro, enquanto usa endereços IP alternativos para o endereço virtual do DIP.

  2. Crie um endereço VIP (ligado à porta). Deve haver uma entrada de registro “A” no Domain Name System (DNS).
    virtual 172.18.124.209:80:0:tcp is 
    
  3. Crie um MERGULHO para cada “servidor real” que estará aceitando atendimentos para este endereço VIP. Use "extra IP number" na primeira parte da instrução.
    direct-ip 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp is
    direct-ip 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp is
    
    O sistema criará o seguinte:
    real 172.18.124.207:80:0:tcp is
    real 172.18.124.206:80:0:tcp is
    bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
    bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
    
  4. Crie um redirecionamento de URL para cada servidor real. Isto é o lugar onde o cliente será reorientado quando batem o VIP.
    url s2 http://ns-ms2-dip.testdomain.com/%p 302
    url s1 http://ns-ms1-dip.testdomain.com/%p 302
    

    Nota: A %p denota a página.

  5. Crie um comando de backup para cada DIP no VIP comum. Isto resolve o problema de marcação. Se um cliente marcar um URL de um DIP e se esse DIP (servidor real) não estiver disponível (aparecer como FAILED), ele usará o comando de backup para que o cliente chame o VIP novamente.
    backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
    backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
    

    Nota: O redirecionamento de HTTPS usa o backup de forma diferente.

  6. Vincule o VIP a cada comando URL.

    bind 172.18.124.209:80:0:tcp s2
    bind 172.18.124.209:80:0:tcp s1
    
  7. Crie um comando de enlace para cada URL na primeira parte do DIP. Isso cria uma associação entre DIP e os URLs associados a esse apelido (por exemplo, s1). O comando de enlace verifica se um DIP falhou. Em seguida, o LocalDirector não redirecionará clientes para a URL que chamaria esse DIP que falhou (que é mapeado um a um com um endereço IP real).
    link s2 172.18.124.211:80:0:tcp
    link s1 172.18.124.212:80:0:tcp
    

Comandos show e exemplo de saída

Comando show version

O comando show version exibe a versão do software que está sendo executada no LocalDirector.

localdirector# show version
LocalDirector 416 Version 4.2.1

Comando show configuration

O comando show configuration exibe a configuração que está sendo executada no LocalDirector.

localdirector# show configuration
: Saved
: LocalDirector 416 Version 4.2.1
syslog output 20.7
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
multiring all
no secure  0
no secure  1
no secure  2
ping-allow 0
ping-allow 1
no ping-allow 2
ip address 172.18.124.210 255.255.255.0
route 0.0.0.0 0.0.0.0 172.18.124.1 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
telnet 172.18.124.0 255.255.255.0
telnet 64.105.0.0 255.255.0.0
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location
virtual 172.18.124.209:80:0:tcp is
predictor 172.18.124.209:80:0:tcp roundrobin
real 172.18.124.207:80:0:tcp is
real 172.18.124.206:80:0:tcp is
direct-ip 172.18.124.211:80:0:tcp   172.18.124.206:80:0:tcp is
direct-ip 172.18.124.212:80:0:tcp   172.18.124.207:80:0:tcp is
url s2 http://ns-ms2-dip.testdomain.com/%p 302
url s1 http://ns-ms1-dip.testdomain.com/%p 302
backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
bind 172.18.124.209:80:0:tcp s2
bind 172.18.124.209:80:0:tcp s1
link s2 172.18.124.211:80:0:tcp
link s1 172.18.124.212:80:0:tcp

Comando show statistics

O comando show statistics exibe as estatísticas do servidor real e virtual.

localdirector(config)# show statistics
          Real Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.207:80:0:tcp           1092            8             2
(DIP) 172.18.124.206:80:0:tcp            960            7             1


       Virtual Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.211:80:0:tcp            960            7             1
(DIP) 172.18.124.212:80:0:tcp           1092            8             1
  172.18.124.209:80:0:tcp               3296           26             2
localdirector(config)#

Comando show url

O comando show url exibe informações de conexão com os URLs.

localdirector(config)# show url
Urls:

             Id  Connect    Rcode   State                     Url
             s2        1      302     IS http://ns-ms2-dip.testdomain.com/%p
             s1        0      302     IS http://ns-ms1-dip.testdomain.com/%p
localdirector(config)#

Comando show syslog

O comando show syslog exibe as informações de registro (como a data, o tempo, o nível e a saída):

<165> May 30 11:35:14 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:34 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'slowstart' to 'leastconns'
<162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'slowstart' to 'leastconns'
  

Verificar a configuração

Use os comandos seguintes verificar a configuração:

  • mostra real - Indica as estatísticas e os estados dos servidores reais.

  • show virtual - Exibe uma lista de servidores virtuais, seus estados, número de conexões e algoritmos de balanceamento de carga.

  • show statistics - Consulte acima.

Solucione os problemas de configuração

Comando syslog

O Syslog [IP de host | console | o comando da saída facility.level] pode ser usado debugando ou pesquisando defeitos.

Neste exemplo, http://test.testdomain.com é reorientado a http://ns-ms2-dip.testdomain.com/.

A amostra a seguir é uma saída do console syslog e da saída syslog 20.7:

localdirector(config)# syslog console
localdirector(config)# <162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp'
 from 'slowstart' to 'leastconns'
localdirector(config)# <162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp'
 from 'slowstart' to 'leastconns'


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas



Document ID: 46222