Rede de armazenamento : Switches multicamada Cisco MDS 9000 Series

Analisador e PERÍODO FC para o exemplo de configuração do Switches MDS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Similar à linha de produto do roteador Cisco debugar a capacidade, o Switches do armazenamento de Cisco MDS têm um analisador do Fibre Channel (FC) para examinar pacotes. O analisador FC examina pacotes a e das entidades que o interruptor fornece. O analisador FC pode debugar quadros que o interruptor é responsável para receber ou enviar a um dispositivo de armazenamento. Os quadros entre estações final não podem ser examinados pelo analisador FC.

Para examinar o fluxo da sessão, a funcionalidade do Switched Port Analyzer (SPAN) do Switches MDS deve ser usada. Bem como a função do PERÍODO em um Switch Ethernet de Cisco, o PERÍODO na linha de produto MDS replicates dados PARA MEDIR portas do destino, de modo que possa ser recolhido por um dispositivo de terceiros.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Interruptor de Cisco MDS9216

  • Interruptor de Cisco MDS9509

  • Ambos executam o sistema operacional do Storage Area Networking (SAN-OS) 1.2.1a.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Material de Suporte

Você deve saber quando usar a ferramenta do analisador FC e quando usar a característica do PERÍODO.

O analisador FC é uma ferramenta que recolha os quadros que são destinados a ou originam do supervisor MDS. o tráfego do Nó-à-interruptor ou do switch para switch pode ser considerado com esta ferramenta.

O PERÍODO é uma característica que permita os quadros que são transientes ao interruptor a ser copiado a uma segunda porta para a análise. O tráfego do nó para nó pode ser considerado com este método.

Refira este diagrama para uma ilustração:

/image/gif/paws/46220/analyze_span_1.gif

O tráfego da mostra das setas verde que pode ser seguido com a ferramenta do analisador FC, quando a seta cor-de-rosa mostrar o tráfego que pode ser capturado com o método do PERÍODO. O tráfego do host ao armazenamento não pode ser observado pelo analisador FC. Somente o tráfego do host ao interruptor ou do interruptor à direita puder ser considerado, quando você executar o analisador FC no interruptor à esquerda.

O PERÍODO pode ser usado para seguir o tráfego em (ingresso) e para fora (saída) de toda a porta no interruptor. O Remote SPAN (RSPAN), segundo as indicações do diagrama precedente, pode ser usado para recolher quadros dentro e fora da porta de host no interruptor esquerdo, com o analisador anexado ao interruptor do lado direito.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Configurando o analisador local FC

/image/gif/paws/46220/analyze_span_2.gif

Nota: A intenção é recolher os quadros FC de que origine, ou é destinada a, o supervisor 9612. Os quadros do host ao JBOD não são recolhidos com a ferramenta do analisador FC.

O local de analisador FC é executado do comando line interface(cli) através do acessório ou do telnet do console. Você pode executar um breve indicador para mostrar somente uma parcela pequena de cada quadro, ou você pode executar um traço detalhado para mostrar o quadro inteiro.

O traço for começado quando no modo de configuração, e é parado quando você pressiona o Ctrl-c. À revelia, somente 100 quadros são capturados. Para capturar mais de 100 quadros, adicionar a opção do comando limit-captured-frames ao comando que você se usa para começar o traço.

Você pode igualmente usar um filtro do indicador para limitar a saída do traço somente aos quadros específicos.


!--- VSAN 13 (0xd) is used here as example.

MDS9216# show fcdomain domain-list vsan 13
 
Number of domains: 2
Domain ID              WWN
---------    -----------------------
0x66(102)    20:0d:00:05:30:00:47:9f [Local] [Principal]
0x6b(107)    20:0d:00:05:30:00:51:1f

MDS9216# show fcns data vsan 13

VSAN 13:
--------------------------------------------------------------------------
FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x6600dc    NL    21:00:00:20:37:15:a2:49 (Seagate)       scsi-fcp:target
0x6600e0    NL    21:00:00:04:cf:6e:4a:8c (Seagate)       scsi-fcp:target
0x6600e1    NL    21:00:00:04:cf:6e:37:8b (Seagate)       scsi-fcp:target
0x660101    NL    10:00:00:01:73:00:81:82 (JNI)
0x660201    N     10:00:00:05:30:00:47:9f (Cisco)         ipfc
0x6b0001    N     10:00:00:05:30:00:51:23 (Cisco)         ipfc

Total number of entries = 6

!--- Configure FC analyzer for brief output.

MDS9216# config t

Enter configuration commands, one per line.  End with CNTL/Z.

MDS9216(config)# fcanalyzer local brief display-filter mdshdr.vsan==0xd

Capturing on eth2
  0.000000     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
  0.000095     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 18.721559     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 18.721879     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 19.970287     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 19.970368     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 38.941558     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 38.941849     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 39.940546     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 39.940628     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1

No exemplo seguinte, você tem os mesmos dados. Esta vez, contudo, a breve opção é omitida do comando, fornecer uma vista detalhada de cada pacote.

MDS9216(config)# fcanalyzer local display-filter mdshdr.vsan==0xd

Capturing on eth2
Frame 1 (100 bytes on wire, 100 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:18.310251000
    Time delta from previous packet: 0.000000000 seconds
    Time relative to first packet: 0.000000000 seconds
    Frame Number: 1
    Packet Length: 100 bytes
    Capture Length: 100 bytes
Ethernet II, Src: 00:00:00:00:00:0a, Dst: 00:00:00:00:ee:00
    Destination: 00:00:00:00:ee:00 (00:00:00:00:ee:00)
    Source: 00:00:00:00:00:0a (00:00:00:00:00:0a)
    Type: Unknown (0xfcfc)
Vegas (FC, SOFf/EOFn)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 70
        TTL: 255
        0111 .... = User Priority: 7
        .... 0000 0010 11.. = Dst Index: 0x000b
        .... ..00 1111 1111 = Src Index: 0x00ff
        Ctrl Bits: Index Directed frame (0x01)
        Timestamp: 42678
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 0
    Vegas Trailer
        EOF: EOFn (3)
        CRC: 4022250974
Fibre Channel
    R_CTL: 0x02
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: SW_ILS (0x22)
    F_CTL: 0x380000 (Exchange Originator, Seq Initiator, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Abort/MS, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1eb4
    RX_ID: 0xffff
    Parameter: 0x00000000
SW_ILS
    Cmd Code: HLO (0x14)
    FSPF Header
        Version: 0x02
        AR Number: 0x00
        Authentication Type: 0x00
        Originating Domain ID: 102
        Authentication: 0000000000000000
    Options: 00000000
    Hello Interval (secs): 20
    Dead Interval (secs): 80
    Recipient Domain ID: 107
    Originating Port Idx: 0x01000b

Frame 2 (60 bytes on wire, 60 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:18.310563000
    Time delta from previous packet: 0.000312000 seconds
    Time relative to first packet: 0.000312000 seconds
    Frame Number: 2
    Packet Length: 60 bytes
    Capture Length: 60 bytes
Ethernet II, Src: 00:00:00:00:00:00, Dst: 00:00:00:00:00:00
    Destination: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Source: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Type: Unknown (0x0000)
Vegas (FC, SOFf/EOFt)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 30
        TTL: 255
        0111 .... = User Priority: 7
        .... 0011 1111 11.. = Dst Index: 0x00ff
        .... ..00 0000 1011 = Src Index: 0x000b
        Ctrl Bits: 0 (0x00)
        Timestamp: 42679
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 241
    Vegas Trailer
        EOF: EOFt (1)
        CRC: 1019832848
Fibre Channel
    R_CTL: 0xc0(ACK1)
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: Unknown (0x00)
    F_CTL: 0xf80000 (Exchange Responder, Seq Recipient, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Cont, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1eb4
    RX_ID: 0x1e66
    Parameter: 0x00000001

Frame 3 (100 bytes on wire, 100 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:19.309559000
    Time delta from previous packet: 0.998996000 seconds
    Time relative to first packet: 0.999308000 seconds
    Frame Number: 3
    Packet Length: 100 bytes
    Capture Length: 100 bytes
Ethernet II, Src: 00:00:00:00:00:00, Dst: 00:00:00:00:00:00
    Destination: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Source: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Type: Unknown (0x0000)
Vegas (FC, SOFf/EOFn)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 70
        TTL: 255
        0111 .... = User Priority: 7
        .... 0011 1111 11.. = Dst Index: 0x00ff
        .... ..00 0000 1011 = Src Index: 0x000b
        Ctrl Bits: 0 (0x00)
        Timestamp: 42779
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 101
    Vegas Trailer
        EOF: EOFn (3)
        CRC: 4200187557
Fibre Channel
    R_CTL: 0x02
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: SW_ILS (0x22)
    F_CTL: 0x380000 (Exchange Originator, Seq Initiator, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Abort/MS, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1e67
    RX_ID: 0xffff
    Parameter: 0x00000000
SW_ILS
    Cmd Code: HLO (0x14)
    FSPF Header
        Version: 0x02
        AR Number: 0x00
        Authentication Type: 0x00
        Originating Domain ID: 107
        Authentication: 0000000000000000
    Options: 00000000
    Hello Interval (secs): 20
    Dead Interval (secs): 80
    Recipient Domain ID: 102
    Originating Port Idx: 0x01011c

Frame 4 (60 bytes on wire, 60 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:19.309646000
    Time delta from previous packet: 0.000087000 seconds
    Time relative to first packet: 0.999395000 seconds
    Frame Number: 4
    Packet Length: 60 bytes
    Capture Length: 60 bytes
Ethernet II, Src: 00:00:00:00:00:0a, Dst: 00:00:00:00:ee:00
    Destination: 00:00:00:00:ee:00 (00:00:00:00:ee:00)
    Source: 00:00:00:00:00:0a (00:00:00:00:00:0a)
    Type: Unknown (0xfcfc)
Vegas (FC, SOFf/EOFt)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 30
        TTL: 255
        0111 .... = User Priority: 7
        .... 0000 0010 11.. = Dst Index: 0x000b
        .... ..00 1111 1111 = Src Index: 0x00ff
        Ctrl Bits: Index Directed frame (0x01)
        Timestamp: 42778
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 0
    Vegas Trailer
        EOF: EOFt (1)
        CRC: 4022250974
Fibre Channel
    R_CTL: 0xc0(ACK1)
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: Unknown (0x00)
    F_CTL: 0xf80000 (Exchange Responder, Seq Recipient, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Cont, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1e67
    RX_ID: 0x1eb5
    Parameter: 0x00000001

Além disso, o breve traço é mostrado. Esta vez, contudo, o PC na porta 1/16 é desconectado e re-obstruído para forçar um início de uma sessão. Você vê quadros a e do outro interruptor FC, e a e do nó local anexado (o PC).

MDS9216(config)# fcanalyzer local brief display-filter mdshdr.vsan==0xd

Capturing on eth2
  0.000000     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
  0.000310     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
  0.999598     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
  0.999684     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 19.990040     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 19.990295     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 20.990602     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 20.990682     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 26.028780     ff.fc.66 -> ff.fc.6b     SW_ILS SW_RSCN
 26.029087     ff.fc.6b -> ff.fc.66     FC Link Ctl, ACK1
 26.029541     ff.fc.6b -> ff.fc.66     SW_ILS SW_ACC (SW_RSCN)
 26.029596     ff.fc.66 -> ff.fc.6b     FC Link Ctl, ACK1
 31.151197     00.00.01 -> ff.ff.fe     FC ELS FLOGI
 31.162809     ff.ff.fe -> 66.01.01     FC ELS ACC (FLOGI)
 31.162841     ff.ff.fe -> 66.01.01     FC ELS ACC (FLOGI)
 31.163139     66.01.01 -> ff.ff.fd     FC ELS SCR
 31.163583     ff.ff.fd -> 66.01.01     FC ELS ACC (SCR)
 31.163603     ff.ff.fd -> 66.01.01     FC ELS ACC (SCR)
 31.163835     66.01.01 -> ff.ff.fc     FC ELS PLOGI
 31.163965     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.163985     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.164186     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.164305     ff.fc.66 -> ff.fc.6b     SW_ILS SW_RSCN
 31.164479     ff.fc.6b -> ff.fc.66     FC Link Ctl, ACK1
 31.164628     ff.fc.6b -> ff.fc.66     SW_ILS SW_ACC (SW_RSCN)
 31.164670     ff.fc.66 -> ff.fc.6b     FC Link Ctl, ACK1
 31.165030     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165050     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165125     ff.fc.6b -> ff.fc.66     dNS GE_ID
 31.165193     ff.fc.66 -> ff.fc.6b     FC Link Ctl, ACK1
 31.165419     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.165577     ff.fc.66 -> ff.fc.6b     dNS ACC (GE_ID)
 31.165781     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165804     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165943     ff.fc.6b -> ff.fc.66     FC Link Ctl, ACK1
 31.166063     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.166870     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.166892     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.167268     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.167529     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.167549     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.168704     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.169272     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.169294     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.169568     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.170453     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.170473     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.170756     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.170975     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.170994     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.171400     66.01.01 -> 66.02.01     FC ELS PLOGI
 31.171562     66.02.01 -> 66.01.01     FC ELS ACC (PLOGI)
 31.171581     66.02.01 -> 66.01.01     FC ELS ACC (PLOGI)
 31.171752     66.01.01 -> 66.02.01     FC ELS PRLI
 31.171812     66.02.01 -> 66.01.01     FC ELS LS_RJT (PRLI)
 31.171832     66.02.01 -> 66.01.01     FC ELS LS_RJT (PRLI)
 31.173863     66.01.01 -> ff.ff.fc     FC ELS LOGO
 31.175020     ff.ff.fc -> 66.01.01     FC ELS ACC (LOGO)
 31.175047     ff.ff.fc -> 66.01.01     FC ELS ACC (LOGO)
 31.175182     66.01.01 -> ff.ff.fc     FC ELS PLOGI
 31.175290     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.175310     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.175632     66.01.01 -> ff.ff.fa     FC ELS PLOGI
 31.175753     ff.ff.fa -> 66.01.01     FC ELS ACC (PLOGI)
 31.175777     ff.ff.fa -> 66.01.01     FC ELS ACC (PLOGI)
 32.460020     ff.fc.66 -> 66.01.01     FC ELS PLOGI
 32.460050     ff.fc.66 -> 66.01.01     FC ELS PLOGI
 32.460207     66.01.01 -> ff.fc.66     FC ELS ACC (PLOGI)
 32.460246     66.01.01 -> ff.fc.66     FC ELS ACC (PLOGI)
 32.460340     ff.fc.66 -> 66.01.01     FC ELS PRLI
 32.460362     ff.fc.66 -> 66.01.01     FC ELS PRLI
 32.460492     66.01.01 -> ff.fc.66     FC ELS LS_RJT (PRLI)
 32.460525     66.01.01 -> ff.fc.66     FC ELS LS_RJT (PRLI)
 32.461839     ff.fc.66 -> 66.01.01     FC ELS LOGO
 32.461866     ff.fc.66 -> 66.01.01     FC ELS LOGO
 32.462046     66.01.01 -> ff.fc.66     FC ELS ACC (LOGO)
 32.462080     66.01.01 -> ff.fc.66     FC ELS ACC (LOGO)

MDS9216(config)# ^C

MDS9216(config)# exit

Configurar para o analisador remoto FC

/image/gif/paws/46220/analyze_span_3.gif

Nota: A intenção é recolher os quadros FC de que origine, ou é destinada a, o supervisor 9612. Os quadros do host ao JBOD não são recolhidos com a ferramenta do analisador FC.

O telecontrole do analisador FC é executado em um PC que esteja usando 0.9(9)leavingcisco.com etéreo ou mais atrasado e WinPcapleavingcisco.com . O endereço IP de Um ou Mais Servidores Cisco ICM NT do PC é especificado no comando que é emitido para começar o traço do analisador FC no MDS CLI. No PC, a obrigação etéreo seja começada igualmente da linha de comando, e o endereço IP de Um ou Mais Servidores Cisco ICM NT da interface de gerenciamento MDS deve ser especificado no comando.

  1. Para parar o traço do analisador MDS FC, você deve pressionar o Ctrl-c do CLI.

    MDS9216# config t
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    MDS9216(config)# fcanalyzer remote 64.102.58.114
    
    MDS9216(config)# ^C
    

    Não especifique a opção ativa no comando precedente, ou você precisará de adicionar opções adicionais à linha de comando em seu PC quando você começa etéreo. Adicionar a palavra-chave ativa significa geralmente que você tem que igualmente configurar o número de porta de TCP. Recomenda-se que você usa os padrões.

  2. No PC, verifique o endereço IP de Um ou Mais Servidores Cisco ICM NT, e comece o programa remoto etéreo da captação.

    d:\> ipconfig
    
    Windows 2000 IP Configuration
    
    Ethernet adapter wireless:
    
            Connection-specific DNS Suffix  . : cisco.com
            IP Address. . . . . . . . . . . . : 64.102.58.114
            Subnet Mask . . . . . . . . . . . : 255.255.255.128
            Default Gateway . . . . . . . . . : 64.102.58.1
    
    Ethernet adapter builtinE:
    
            Connection-specific DNS Suffix  . : cisco.com
            Autoconfiguration IP Address. . . : 169.254.219.141
            Subnet Mask . . . . . . . . . . . : 255.255.0.0
            Default Gateway . . . . . . . . . :
    
    d:\> cd ethereal099
    
    D:\Ethereal099> ethereal099 -i rpcap://172.18.172.56/eth2
    
  3. Uma vez os começos do programa, escolhem a captação e clicam então a APROVAÇÃO para iniciar a coleção de pacotes.

    /image/gif/paws/46220/analyze_span_4.gif

    Os pacotes FC que são recolhidos aparecem como outro no indicador sumário.

    /image/gif/paws/46220/analyze_span_5.gif

  4. Clique a parada para parar a coleção de pacotes e começar a parcela da opinião do traço do programa.

    /image/gif/paws/46220/analyze_span_6.gif

    Você pode usar filtros para limitar o indicador a um fluxo de tráfego específico.

  5. Se há um problema com a iniciação remota da captação, você pode ver uma tela do erro similar a essa na imagem seguinte. O analisador FC não é ativo no MDS, ou a palavra-chave ativa foi usada sem uma porta especificada.

    /image/gif/paws/46220/analyze_span_7.gif

Configurar para o SPAN local

/image/gif/paws/46220/analyze_span_8.gif

Nota: A intenção é recolher — com o analisador FC na porta 1/15 — quadros FC a e do host na porta 1/16 dos 9216.

Um analisador FC nas mostras da porta 1/15 pedidas ajusta-se, mas não os grupos pedidos que ocorrem no link que está sendo SPANed. O dispositivo do analisador FC pode ser um adaptador do analisador de porta (PAA) e um PC que seja ser executado etéreo, similar a um dispositivo de Finisar.

Configuração MDS9216

MDS9216# show run

vsan 13

vsan 13 interface fc1/16
vsan 13 interface fc2/16

boot system bootflash:/m9200-ek9-mzg.1.2.0.77.bin
boot kickstart bootflash:/m9200-ek9-kickstart-mzg.1.2.0.77.bin

 interface fc1/15
switchport mode SD
switchport speed 2000
no shutdown

 interface fc1/16
no shutdown

 interface mgmt0
ip address 172.18.172.56 255.255.255.0

span session 1
destination interface fc1/15
source interface fc1/16 rx

source interface fc1/16 tx

Indicadores MDS9216

MDS9216# show interface fc 1/15

fc1/15 is up
    Hardware is Fibre Channel
    Port WWN is 20:0f:00:05:30:00:47:9e
    Admin port mode is SD
    Port mode is SD
    Port vsan is 1
    Speed is 2 Gbps
    Beacon is turned off
    5 minutes input rate 73704 bits/sec, 9213 bytes/sec, 13 frames/sec
    5 minutes output rate 2275584 bits/sec, 284448 bytes/sec, 430 frames/sec
      2839098 frames input, 1883173240 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      3049460 frames output, 2038253240 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 0 loop inits
      0 output OLS, 0 LRR, 0 NOS, 0 loop inits

MDS9216# show interface fc 1/16 

fc1/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:10:00:05:30:00:47:9e
    Admin port mode is auto, trunk mode is on
    Port mode is FL, FCID is 0x660100
    Port vsan is 13
    Speed is 2 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 16
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 771568 bits/sec, 96446 bytes/sec, 171 frames/sec
    5 minutes output rate 1503144 bits/sec, 187893 bytes/sec, 258 frames/sec
      1238843 frames input, 691853044 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1864744 frames output, 1357707740 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 49 loop inits
      10 output OLS, 0 LRR, 10 NOS, 14 loop inits

MDS9216# show interface fc 2/16

fc2/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:50:00:05:30:00:47:9e
    Admin port mode is FX
    Port mode is FL, FCID is 0x660000
    Port vsan is 13
    Speed is 1 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 12
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 1647552 bits/sec, 205944 bytes/sec, 283 frames/sec
    5 minutes output rate 845624 bits/sec, 105703 bytes/sec, 188 frames/sec
      1867680 frames input, 1361393600 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1241179 frames output, 694505284 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 2 loop inits
      0 output OLS, 0 LRR, 0 NOS, 2 loop inits

MDS9216# show fcns data vsan 13

VSAN 13:
--------------------------------------------------------------------------
FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x6600dc    NL    21:00:00:20:37:15:a2:49 (Seagate)       scsi-fcp:target
0x6600e0    NL    21:00:00:04:cf:6e:4a:8c (Seagate)       scsi-fcp:target
0x6600e1    NL    21:00:00:04:cf:6e:37:8b (Seagate)       scsi-fcp:target
0x660101    NL    10:00:00:01:73:00:81:82 (JNI)

Total number of entries = 4

MDS9216# show span session brief

--------------------------------------------------------
 Session  Admin          Oper           Destination
          State          State          Interface
--------------------------------------------------------
 1        no suspend     active         fc1/15

MDS9216# show span session 1

Session 1 (active)
   Destination is fc1/15
   No session filters configured
   Ingress (rx) sources are
     fc1/16,
   Egress (tx) sources are
     fc1/16,

MDS9216# show span internal info session 1

====================================
Admin Configuration for session [1]
====================================
Name:
Destination port: [100e000] [fc1/15] Flags [1]
State: [0] not suspended
Session Flags: [0] <>
Session Filter rx:  none
Session Filter tx:  none
Source interface - rx: fc1/16
Source interface - tx: fc1/16
Source vsan (rx):  none
Session [1] is UNLOCKED txn[0] cfg[0] rid[80000000]
====================================
Runtime Data for session [1]
====================================
Status <active: 0 inactive 1> : [0] active
State reason:[0] Flags [6]rx_span_bit [0] tx_span_bit[1] ( 4s invalid)
oper configured PHYSICAL ports
fc1/16
PHYSICAL ports undergoing configuration
none
PHYSICAL ports in error state
none
PHYSICAL ports (incl. dest) link status
fc1/15, fc1/16

Configurar para o alcance remoto

/image/gif/paws/46220/analyze_span_9.gif

Nota: A intenção é recolher — com o analisador FC anexado aos 9509 — quadros FC a e do host nos 9216. A relação ST deve ter um gigabit interface converter (GBIC) instalado e a velocidade deve combinar a porta do destino do período (SD) nos 9509.

Antes que você tente configurar o RSPAN, assegure-se de que estes pontos estejam endereçados:

  • Todo o Switches deve executar o código 1.2 MDS ou mais atrasado.

  • Nenhum cabo deve ser anexado ao form fatora pequeno pluggable (SFP) na porta do terminal do período (ST).

  • Certifique-se de que o túnel FC está ACIMA antes que você comece a recolher quadros.

  • O analisador FC pode ser um PAA e um PC que seja ser executado etéreo, similar a um dispositivo de Finisar.

Se há qualquer Switches intermediário entre a fonte do PERÍODO e o switch de destino do PERÍODO, siga este procedimento:

  1. Crie uma relação ativa VSAN na mesma sub-rede como o origem e destino do túnel.

  2. Permita Roteamento IP.

  3. Permita o FC-Tunelamento.

  4. Use SAN-OS 1.2 ou mais atrasado.

Configuração MDS9216

MDS9216# show version

Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003 by Cisco Systems, Inc. All rights reserved.
The copyright for certain works contained herein are owned by
Andiamo Systems, Inc. and/or other third parties and are used and
distributed under license.

Software
  BIOS:      version 1.0.7
  loader:    version 1.0(3a)
  kickstart: version 1.2(1) [build 1.2(0.77)] [gdb]
  system:    version 1.2(1) [build 1.2(0.77)] [gdb]

  BIOS compile time:       03/20/03
  kickstart image file is: bootflash:/m9200-ek9-kickstart-mzg.1.2.0.77.bin
  kickstart compile time:  6/29/2003 0:00:00
  system image file is:    bootflash:/m9200-ek9-mzg.1.2.0.77.bin
  system compile time:     6/29/2003 0:00:00

Hardware
  RAM 963108 kB

  bootflash: 503808 blocks (block size 512b)
  slot0:          0 blocks (block size 512b)

  MDS9216 uptime is 0 days 21 hours 28 minute(s) 20 second(s)

  Last reset at 50030 usecs after Thu Jul  3 13:09:31 2003
    Reason: Reset Requested by CLI command reload
    System version: 1.2(0.45c)

MDS9216# show run

Building Configuration ...

 interface fc-tunnel 13
destination 10.0.0.2
source 10.0.0.1
no shutdown

vsan database
vsan 13

 interface vsan13
ip address 10.0.0.1 255.255.255.0
no shutdown

vsan 13 interface fc1/16
vsan 13 interface fc2/16

boot system bootflash:/m9200-ek9-mzg.1.2.0.77.bin
boot kickstart bootflash:/m9200-ek9-kickstart-mzg.1.2.0.77.bin
fc-tunnel enable

ip routing
zone default-zone permit vsan 13

 interface fc1/12
no shutdown

 interface fc1/15
switchport mode ST
switchport speed 1000
rspan-tunnel interface fc-tunnel 13
no shutdown

 interface fc1/16
no shutdown

 interface fc2/16
no shutdown

 interface mgmt0
ip address 172.18.172.56 255.255.255.0

span session 1
destination interface fc-tunnel 13
source interface fc1/16 rx

source interface fc1/16 tx

!--- Output suppressed.

Indicadores MDS9216

MDS9216# show interface fc 1/16

fc1/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:10:00:05:30:00:47:9e
    Admin port mode is auto, trunk mode is on
    Port mode is FL, FCID is 0x660100
    Port vsan is 13
    Speed is 2 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 16
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 1480080 bits/sec, 185010 bytes/sec, 331 frames/sec
    5 minutes output rate 2907712 bits/sec, 363464 bytes/sec, 498 frames/sec
      574444 frames input, 320246452 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      865170 frames output, 629303788 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 10 loop inits
      5 output OLS, 0 LRR, 5 NOS, 9 loop inits

MDS9216# show interface fc 2/16

fc2/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:50:00:05:30:00:47:9e
    Admin port mode is FX
    Port mode is FL, FCID is 0x660000
    Port vsan is 13
    Speed is 1 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 12
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 2905056 bits/sec, 363132 bytes/sec, 498 frames/sec
    5 minutes output rate 1480184 bits/sec, 185023 bytes/sec, 330 frames/sec
      867932 frames input, 632889576 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      576681 frames output, 322771132 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 2 loop inits
      0 output OLS, 0 LRR, 0 NOS, 2 loop inits

MDS9216# show interface fc 1/15

fc1/15 is up
    Hardware is Fibre Channel
    Port WWN is 20:0f:00:05:30:00:47:9e
    Admin port mode is ST
    Port mode is ST
    Port vsan is 1
    Speed is 1 Gbps
    Rspan tunnel is fc-tunnel 13
    Beacon is turned off
    5 minutes input rate 4391896 bits/sec, 548987 bytes/sec, 827 frames/sec
    5 minutes output rate 4391896 bits/sec, 548987 bytes/sec, 820 frames/sec
      1431232 frames input, 941079708 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1406853 frames output, 941079708 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 0 loop inits
      0 output OLS, 0 LRR, 0 NOS, 0 loop inits

MDS9216# show interface fc 1/12

fc1/12 is trunking
    Hardware is Fibre Channel
    Port WWN is 20:0c:00:05:30:00:47:9e
    Peer port WWN is 20:5d:00:05:30:00:51:1e
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    Port vsan is 1
    Speed is 2 Gbps
    Transmit B2B Credit is 12
    Receive B2B Credit is 255
    Receive data field Size is 2112
    Beacon is turned off
    Trunk vsans (admin allowed and active) (1-5,13,20,777)
    Trunk vsans (up)                       (1,13)
    Trunk vsans (isolated)                 (2-5,20,777)
    Trunk vsans (initializing)             ()
    5 minutes input rate 384 bits/sec, 48 bytes/sec, 0 frames/sec
    5 minutes output rate 4458296 bits/sec, 557287 bytes/sec, 827 frames/sec
      19865 frames input, 2220112 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1468709 frames output, 971064244 bytes
        0 discards, 0 errors
      0 input OLS, 2 LRR, 0 NOS, 0 loop inits
      2 output OLS, 2 LRR, 0 NOS, 2 loop inits

MDS9216# show interface fc-tunnel 13

fc-tunnel 13 is up
Dest   IP Addr: 10.0.0.2   Tunnel ID: 13
Source IP Addr: 10.0.0.1   LSP ID: 1
Explicit Path Name:
Outgoing interface: fc1/12
Outgoing Label(s) to Insert: 10005:0:1:ff'h
Record Routes:
10.0.0.2

MDS9216# show interface vsan 13

vsan13 is up, line protocol is up
    WWPN is 10:00:00:05:30:00:47:9f, FCID is 0x660201
    Internet address is 10.0.0.1/24
    MTU 1500 bytes, BW 1000000 Kbit
    2207 packets input, 170332 bytes, 0 errors, 0 multicast
    14952 packets output, 2225444 bytes, 0 errors, 0 dropped

MDS9216# show span session 1

Session 1 (active)
   Destination is fc-tunnel 13
   No session filters configured
   Ingress (rx) sources are
     fc1/16,
   Egress (tx) sources are
     fc1/16,

MDS9216# show fc-tunnel internal states

number of sessions : 1
Sess: 10.0.0.2 Tunnel-ID 13 Ext-Tunnel-ID 10.0.0.1

MDS9216# show fc-tunnel internal data

vsan interfaces:
  vsan 13: 10.0.0.1/255.255.255.0  [2]
  vsan 2: 15.0.0.4/255.255.255.0  [2]
next hop switch information:
  10.0.0.2 {vsan (13), 0x6b0001/8}: [4] fc1/12
layer 2 interfaces:
  fc1/12: Trunking, Up

Configuração MDS9509

RTP-9509-1# show run

Building Configuration ...
vsan database
vsan 13

 interface vsan13
ip address 10.0.0.2 255.255.255.0
no shutdown

vsan 13 interface fc2/16

boot system bootflash:/m9500-sf1ek9-mzg.1.2.0.77.bin sup-1
boot kickstart bootflash:/m9500-sf1ek9-kickstart-mzg.1.2.0.77.bin sup-1
boot system bootflash:/m9500-sf1ek9-mzg.1.2.0.77.bin sup-2
boot kickstart bootflash:/m9500-sf1ek9-kickstart-mzg.1.2.0.77.bin sup-2

fc-tunnel enable
fc-tunnel tunnel-id-map 13 interface fc2/6

ip routing

switchname RTP-9509-1

 interface fc2/6
switchport mode SD
switchport speed 1000
no shutdown

 interface fc2/29
switchport mode E
no shutdown

 interface mgmt0
ip address 172.18.172.57 255.255.255.0

Indicadores MDS9509

RTP-9509-1# show interface fc 2/29

fc2/29 is trunking
    Hardware is Fibre Channel
    Port WWN is 20:5d:00:05:30:00:51:1e
    Peer port WWN is 20:0c:00:05:30:00:47:9e
    Admin port mode is E, trunk mode is on
    Port mode is TE
    Port vsan is 501
    Speed is 2 Gbps
    Transmit B2B Credit is 255
    Receive B2B Credit is 12
    Receive data field Size is 2112
    Beacon is turned off
    Trunk vsans (admin allowed and active) (1,13,86,100,501)
    Trunk vsans (up)                       (1,13)
    Trunk vsans (isolated)                 (86,100,501)
    Trunk vsans (initializing)             ()
    5 minutes input rate 4497752 bits/sec, 562219 bytes/sec, 835 frames/sec
    5 minutes output rate 344 bits/sec, 43 bytes/sec, 0 frames/sec
      1934604 frames input, 1285716656 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      16903 frames output, 932076 bytes
        0 discards, 0 errors
      1 input OLS, 1 LRR, 2 NOS, 0 loop inits
      3 output OLS, 1 LRR, 2 NOS, 0 loop inits

RTP-9509-1# show interface fc 2/6

fc2/6 is up
    Hardware is Fibre Channel
    Port WWN is 20:46:00:05:30:00:51:1e
    Admin port mode is SD
    Port mode is SD
    Port vsan is 1
    Speed is 1 Gbps
    Beacon is turned off
    5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
    5 minutes output rate 4421448 bits/sec, 552681 bytes/sec, 835 frames/sec
      0 frames input, 0 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1912319 frames output, 1263982444 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 0 loop inits
      0 output OLS, 0 LRR, 0 NOS, 0 loop inits

RTP-9509-1# show interface fc-tunnel 13
                           ^
% invalid interface range detected at '^' marker.

!--- This is because the tunnel is not defined on the 9509.

RTP-9509-1# show interface vsan 13

vsan13 is up, line protocol is up
    WWPN is 10:00:00:05:30:00:51:23, FCID is 0x6b0001
    Internet address is 10.0.0.2/24
    MTU 1500 bytes, BW 1000000 Kbit
    15071 packets input, 2243728 bytes, 0 errors, 1 multicast
    2342 packets output, 185864 bytes, 0 errors, 0 dropped

RTP-9509-1# show fc-tunnel tunnel-id-map

tunnel id  egress interface
     13             fc2/6
     14

RTP-9509-1# show fc-tunnel internal states

number of sessions : 1
Sess: 10.0.0.2 Tunnel-ID 13 Ext-Tunnel-ID 10.0.0.1

RTP-9509-1# show fc-tunnel internal data

vsan interfaces:
  vsan 13: 10.0.0.2/255.255.255.0  [2]
next hop switch information:
layer 2 interfaces:
  fc2/6: Non-Trunking, Up

Notas para dispositivos do adaptador do analisador de porta

A porta Ethernet é de cobre, e tem auto-detecta velocidades do 1 Gbps ou do 100 Mbps. 0.9(9) Ou mais atrasado etéreo e WinPcap devem ser instalados no PC.

A porta FC exige um SFP e um cabo LC-à-LC para o acessório ao MDS.

Estas são configurações de switch no PAA:

  • As posições de switch são numeradas 1, 2,3, e 4 da esquerda para a direita.

  • Na lista seguinte, um 1 indica que o switch DIP está LIGADA ou LEVANTA-O. O A0 indica que o switch DIP está PARA BAIXO ou.

    0001 1G  NTM
    1001 1G  ETM
    0101 1G  STM
    0011 1G  DTM
    
    0000 2G  NTM
    1000 2G  ETM
    0100 2G  STM
    0010 2G  DTM
    
    1111 1G  MNM
    
    !--- Used for diagnostics only.
    
    
  • Comute 4 dita a velocidade (em = 1G, fora de = 2G). Modo truncado das ordens do Switches 1, 2, e 3. Todas as mudanças exigem um ciclo da potência.

Estes são os modos:

  • Nenhum modo truncado (NTM) — Os quadros FC são passados sem nenhumas alterações.

  • Os Ethernet truncam o modo (o ETM) — Reduz o tamanho de virulência de 528 linhas a 368 linhas, trunca o quadro FC a um máximo de 1496 bytes.

  • Modo truncado raso (STM) — Reduz o tamanho de virulência de 528 linhas a 58 linhas, trunca o quadro FC a um máximo dos bytes 256.

  • Modo profundamente truncado (DTM) — Reduz o tamanho de virulência de 528 linhas às linhas 10, trunca o quadro FC a um máximo de 64 bytes.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 46220