IP : IP Versão 6 (IPv6)

conexão 6bone usando os túneis 6to4 para o IPv6

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como um cliente do campus empresarial (por exemplo: uma instituição educacional, uma pequena empresa de softwares ou uma fábrica pequena) pode se conectar ao 6bone usando túneis 6to4. O 6bone é uma rede de teste da versão IP 6 (IPv6) concebida para auxiliar na evolução e na implementação do IPv6 na Internet.

Este documento é um de um grupo de documentos que o apoio e complementa a publicação das estratégias de distribuição do IPv6, que está disponível em Guias de Design do IPv6.

Você deve ler este documento junto com IPv6 Deployment Strategies (Estratégias de implementação de IPv6) para compreender melhor as atividades de pré-implementação de IPv6.

Pré-requisitos

Requisitos

Antes de implementar um túnel 6to4 no 6bone, execute as seguintes tarefas:

  • Identifique o roteador de borda no seu site o qual você irá configurar para executar uma pilha dupla. Este roteador de borda deve ter uma estática, globalmente endereço do IPv4 do roteável.

  • Uma licença dos dados é exigida para permitir todas as características do IPv6. A fim verificar que licença é permitida no roteador, use o comando license da mostra.

  • No ISP 6bone, obtenha o endereço IPv4 do roteador de transmissão 6a4 que você usará para o acesso 6bone.

    Nota: Quando você configura túneis para seus roteadores de borda corporativa, você deve usar globalmente endereços do IPv4 do roteável. Os endereços IPv4 utilizados nas configurações de exemplo neste documento não são globalmente roteáveis e são fornecidos para fins de ilustração apenas.

  • Assegure-se de que seu DNS esteja executando (ou tem as potencialidades equivalente de) a versão 9 do Berkeley Internet Name Domain (LIGAMENTO), que fornece uma aplicação dos componentes principais do DNS para o IPv6. A Configuração de DNS é além do alcance deste documento.

  • Reconheça que a aplicação atual da pilha dual no Cisco IOS Software permite uma solução de gerenciamento de rede provisória, que permita aplicativos tais como o TFTP, sibilo, telnet, e traceroute a ser sido executado sobre um IPv4 ou um transporte do IPv6.

  • Selecione um IPv6 Interior Routing Protocol, como RIPng, apropriado para sua configuração de rede. Para simplificar, a solução apresentada neste documento usa uma rota estática. O Ipv4 Exterior Routing Protocol relevante cuida do roteamento exterior.

  • Configurar todo seu Roteadores da pilha dual para usar o RASGO.

Consulte a biblioteca de configurações de IPv6 do Cisco IOS para obter mais informações sobre como configurar a rede para IPv6.

Componentes Utilizados

A informação neste documento é baseada em imagens IOS Cisco com apoio do IPv6.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

A figura a seguir mostra a topologia da rede IPv4 inicial para o cliente de campus corporativo. Esta rede usa diversos roteadores para fornecer conectividade de IP entre usuários locais. Uma conexão IPv4 permanente com um ISP (provedor de serviços de Internet) fornece conectividade externa

/image/gif/paws/45741/6bone_tc_1-01.gif

A tabela a seguir descreve os dispositivos usados nessa solução.

Dispositivo Roteador de borda corporativa Roteador ISP 6bone
Nome de Host 6bone-gw ipv6-router
Tipo de chassi Cisco 3660 Router Cisco 7206 Router
Interfaces físicas 2 série do Fast Ethernet 4 dos Ethernet 2 4 série do Fast Ethernet 4 dos Ethernet 2
Software carregado Cisco IOS Versão 12.2(4)T Cisco IOS Versão 12.2(4)T
Memória 64MV RAM; Flash do 16 MB 128 MB RAM; Flash do 20 MB
Endereços IP Ethernet0: IPv4 192.168.99.1 Tunnel2002: IPv6 2002:C0A8::1/128 Ethernet0/0: IPv4 192.168.33.1 Tunnel2002: IPv6 2002:C0A8:2102::1/128

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Como os Túneis 6to4 funcionam

Um túnel 6to4 é configurado em um roteador de borda de pilha dupla corporativo. Todo o tráfego de IPv6 empresarial destinado para o 6bone é roteado sobre o IPv4 por meio do túnel para o roteador de relay 6bone ISP 6to4. O tráfego do 6bone para um host empresarial é roteado via IPv4 pelo túnel até o roteador de borda de empilhamento dual empresarial e, em seguida, até o host de destino IPv6.

Os benefícios para a empresa com o uso de túneis 6to4 são os seguintes:

  • O software Cisco IOS suporta de 6 a 4 túneis.

  • A configuração de host do usuário final é simples—ele requer o mínimo de carga adicional de gerenciamento.

  • O túnel é automático; nenhuma configuração das específicas do empreendimento é exigida no local do relé 6to4. Túneis 6to4 são bem escaláveis.

  • Esta solução abrange endereços IP dinâmicos na empresa.

  • O túnel existe somente durante a sessão.

  • Um túnel 6to4 exige somente uma único configuração no ISP, que faz o relé 6to4 prestar serviços de manutenção simultaneamente a disponível a muitas empresas.

Limitações de túneis 6 para 4

O uso do túnel de 6 para 4 apresenta as seguintes limitações:

  • O NAT independentemente controlado não é permitido ao longo do trajeto do túnel.

  • Você não pode facilmente executar o hospedagem múltipla.

  • O mecanismo do túnel 6to4 fornece um bloco de endereço de /48; não mais endereço está disponível.

  • Devido ao fato de túneis 6to4 serem configurados como muitos-para-um e de o tráfego de túnel poder se originar de múltiplos pontos finais, os túneis 6to4 podem oferecer somente informações gerais sobre tráfego no ISP.

  • O endereço subjacente do IPv4 determina o prefixo de endereço do IPv6 da empresa 6to4, assim que a migração ao IPv6 nativo exige renumbering a rede.

  • Essa solução é limitada para roteamento estático ou BGP4+.

Um cenário em túnel

Uma pequena empresa de software (considerada um ambiente típico de campus corporativo) com uma rede IPv4 está discutindo uma fusão com outra empresa que executa IPv6 na rede. Para avaliar o impacto da conectividade que a fusão teria nas empresas, o cliente deseja ampliar seus conhecimentos do IPv6 conectando-se ao 6bone. Os objetivos comerciais do cliente do campus empresarial discutidos neste documento são estes:

  • Ganhe a experiência do IPv6 em um backbone estabelecido do IPv6 usando sua topologia existente do IPv4, com um investimento mínimo.

  • Teste os procedimentos transicionais e operacionais em um ambiente IPv6 real antes de distribuir o IPv6.

    Procedimentos transitórios são aqueles que são necessários para migrar de IPv4 para IPv6. Estes procedimentos incluem configurar os roteadores de pilha dupla e sistemas finais, mecanismos de tunelamento, servidores de Domain Name System (DNS) e, no futuro, o teste de Network Address Translation-Protocol Translation (NAT-PT).

    Os procedimentos operacionais são relacionados ao Gerenciamento de redes, o gerenciamento de elemento de anfitriões da pilha dual e os sistemas finais, e outras funções similares.

  • Teste aplicativos e aplicações do IPv6 em estações de trabalho local.

  • Minimize o overhead de gerenciamento associado a uma conexão 6bone.

    Nota: Embora o 6bone englobe muitos tipos de organizações (por exemplo, organizações acadêmicas e governamentais, fornecedores de hardware e software e provedores de serviço), este documento usa o termo 6bone ISP ao se referir à organização que está no lado 6bone do túnel.

Configurar

O endereço do IPv4 de seu roteador de borda é 192.168.99.1. Derive seu prefixo de 6 a 4 a partir do endereço IPv4 convertendo os componentes decimais desse endereço em componentes hexadecimais e, em seguida, prefixando “2002” aos números hexadecimais resultantes. Então, o prefixo 6to4 para os nós IPv6 em sua rede é 2002:C0A8:6301::/128.

O C0A8:6301 o endereço precedente do IPv6 é formado parte de do endereço do IPv4 convertendo cada octeto do dotted decimal notation a seu equivalente hexadecimal, segundo as indicações da tabela 6.

Decimal Hexadecimal
192 C0
168 A8
99 63
1 01

Esta seção apresenta as informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

Essa figura mostra a topologia de um túnel 6to4 comum para o 6bone.

/image/gif/paws/45741/6bone_tc_1-02.gif

Configurações

Seu 6bone ISP forneceu-lhe o endereço do IPv4 seu roteador de borda 6bone: 192.168.33.1. Utilize as informações de endereço anteriores para configurar um túnel 6to4 em seu roteador de borda de pilha dupla identificado inserindo os seguintes comandos:

Enterprise Router
ipv6 unicast-routing

interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0

interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4


!--- In some cases, a user will require a data license 
!-- in order to issue the tunnel mode ipv6ip command.

 ipv6 route 2002::/16 Tunnel2002
 ipv6 route ::/0 2002:C0A8:2101::1

O 2002:C0A8:2101::1 no segundo comando ipv6 route é o endereço IPv6 do roteador de retransmissão ISP 6to4 que fornece acesso ao 6bone. A parte do endereço C0A8:2101 é derivada do endereço IPv4 (192.168.33.1) do roteador de transmissão 6a4, de maneira semelhante à tabela 6.

Na outra extremidade do túnel, o roteador de bordo no seu 6bone ISP teria uma configuração como o exemplo de IPv6 Unicast Routing a seguir:

Roteador de Relay 6to4 ISP
ipv6 unicast-routing

interface ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0

interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

Enterprise Router 6bon2-gw
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname 6bone-gw
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router domain name
!
ip domain-name EnterpriseDomain.com
!
! Configure DNS name servers
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description connection to Lab interface router
 ip address 192.168.99.40 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:100::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet2/0
 description connection to core router
 ip address 192.168.99.41 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:200::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet3/0
 description connection to IPv4-only core router
 ip address 192.168.99.42 255.255.255.0
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
end
 end

Roteador 6bone IPv6 ISP
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname ipv6-router
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!
logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router's domain name
!
ip domain-name 6boneISP.com
!
! Configure DNS name servers
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 description connection to ISP-core-A
 ip address 192.168.34.10 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::6/64
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description connection to ISP-core-B
 ip address 192.168.35.22 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::8/64
 duplex auto
 speed auto
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
!
end

Verificar

Essa tarefa opcional explica como confirmar se o túnel está configurado e funcionando corretamente. Os comandos contidos nos passos da tarefa podem ser usados em qualquer seqüência e talvez precisem ser repetidos

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • enable

  • show interfaces tunnel número [contabilização]

  • destino do [protocol] do sibilo

  • show ip route [address [mask]]

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 45741