Switches : Switches Cisco Catalyst 3750 Series

Configurando o Roteamento Inter-Vlan com Catalyst 3750 Series Switch

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o roteamento Inter-VLAN usando dois Catalyst 3750s Series Switches empilhados juntos executando o software de Interferência Eletromagnética em um cenário de rede típico. O documento usa um Catalyst 2950 Series Switch e um Catalyst 2948G Switch como os switches de gabinete da Camada 2 (L2) que se conectam à pilha do Catalyst 3750s. A pilha do Catalyst 3750s também é configurada para uma rota padrão para todo o tráfego que vai para a Internet com o próximo ponto de salto para um Cisco 7200VXR Router, que pode ser substituído por um firewall ou por outros roteadores. Configurar o roteamento inter-VLAN em um único 3750 é o mesmo que configurar esta característica em um Catalyst 3550 Series Switch. Para obter informações sobre a configuração de roteamento inter-VLAN em um único Catalyst 3750 Series Switch, consulte Configuração de Roteamento Inter-VLAN em Catalyst 3550 Series Switches.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Antes de tentar utilizar esta configuração, verifique se os seguintes pré-requisitos são atendidos:

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Dois Switches do catalizador 3750G-24T que executam o software release 12.1(14)EA1 EMI empilhado junto

  • Catalyst 2950G-48 executando a versão do software 12.1(12c)EA1 EI

  • Catalyst 2948G executando o 6.3(10) Software Release

Nota: A configuração do Cisco 7200VXR não é relevante e, portanto, não é mostrada neste documento.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

Em uma rede comutada, os VLANs separam os dispositivos em domínios de colisão diferentes e em sub-redes de camada 3 (L3). Dispositivos com uma VLAN podem se comunicar entre eles sem necessidade de roteamento. Ao contrário, dispositivos em VLANs separadas requerem um dispositivo de roteamento para a comunicação entre eles.

Somente o Switches L2 exige um dispositivo de roteamento L3 (externo ao interruptor ou em um outro módulo no mesmo chassi). Uma raça nova do Switches, contudo, (por exemplo, 3550 e 3750) potencialidade de roteamento incorporada dentro do interruptor. O interruptor recebe um pacote, determina que pertence a um outro VLAN, e envia o pacote à porta apropriada no outro VLAN.

Um projeto de rede típico segmenta a rede com base no grupo ou na função ao qual o dispositivo pertence. Por exemplo, a VLAN do departamento de engenharia teria apenas dispositivos associados ao departamento de engenharia, quanto à VLAN de finanças teria apenas dispositivos relacionados a finanças. Se o roteamento estiver ativado, os dispositivos de cada VLAN poderão se comunicar sem que todos estejam no mesmo domínio de transmissão. Esse design de VLAN também possui o benefício adicional de permitir que o administrador restrinja a comunicação entre VLANs utilizando listas de acesso. Em nosso exemplo, a VLAN da engenharia poderia ser impedida (usando listas de acesso) de acessar dispositivos na VLAN do financeiro.

IP Routing em uma Pilha de 3750s

Em uma pilha de Catalyst 3750 Switch, o software que é executado no mestre determina as capacidades da pilha do todo. Se o switch mestre está executando uma imagem de EMI, a pilha do todo apoiará a definição completa de protocolos de roteamento apoiados (tais como o Open Shortest Path First (OSPF), o Enhanced Interior Gateway Routing Protocol (EIGRP), e os tais) mesmo se os outros membros de pilha apenas estão executando uma imagem de SMI. Entretanto, é aconselhável ter o mesmo software em execução nos membros de pilha diferentes. Se o mestre da pilha falhar, você perderá as capacidades de roteamento ampliadas caso os outros membros executem uma imagem do SMI oposta à imagem do EMI do mestre anterior.

Uma pilha de Catalyst 3750 Switch aparece à rede como um roteador único, independente a qual dos Stack Switch o routing peer é conectado. Um roteador criará uma única adjacência com uma pilha de 3750 Router.

O mestre de empilhamento executa as seguintes tarefas:

  • Iniciação e configuração dos protocolos de roteamento

  • Geração de mensagens de protocolo de roteamento

  • Processamento de mensagens recebidas do Routing Protocol

  • Geração e distribuição do banco de dados dCEF (Distributed Cisco Express Forwarding) aos diferentes membros da pilha

  • O endereço MAC do mestre é utilizado como o MAC de origem de pacotes roteados

  • Pacotes que requerem switching de processo são manejados pela CPU ou pelo mestre

Os membros da pilha executam as seguintes tarefas:

  • Atuam como a distribuição do Switches à espera que podem tomar sobre quando o mestre da pilha falha

  • Programação das rotas no base de dados dCEF no hardware

Quando o mestre falha, os membros da pilha (exceto por uma interrupção momentânea) continuarão a encaminhar os pacotes em hardware enquanto nenhum protocolo estiver ativo.

Depois que um mestre novo foi selecionado depois de uma falha mestra, o mestre recentemente eleito começará enviar ARP gratuitos com seu próprio MAC address a fim atualizar os dispositivos na rede com o MAC address novo que será usado para reescrever os pacotes roteado.

Para obter mais informações sobre do comportamento e da configuração da pilha do 3750 Switch, refira controlando a documentação das pilhas do interruptor.

Produtos Relacionados

Esta configuração também pode ser utilizada com as seguintes versões de hardware e software.

  • Algum Catalyst 3750 Switch que executa o software EMI ou a versão de SMI 12.1(14)EA1 e mais tarde.

  • Alguns Catalyst 2900XL/3500XL/2950/3550 ou Catalyst OS switch para o switch de camada de acesso.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/45002/intervlan3750_45002a.gif

O diagrama acima mostra um exemplo de rede pequeno com a pilha do catalizador 3750s que fornece o Roteamento Inter-Vlan entre os vários segmentos.

A seguir há três VLANs definidas pelo usuário.

  • VLAN 2 - VLAN de usuário

  • VLAN 3 - servidor VLAN

  • VLAN 10 – VLAN de gerenciamento

O gateway padrão configurado em cada server e dispositivo host deve ser o endereço IP de Um ou Mais Servidores Cisco ICM NT da interface VLAN correspondente na pilha de 3750s. Por exemplo, para servidores, o gateway padrão é 10.1.3.1. O Catalyst 2950 é em tronco ao Catalyst 3750 Switch superior (mestre da pilha) e o catalizador 2848G é em tronco ao Catalyst 3750 Switch inferior (membro de pilha).

A rota padrão para o empilhamento está apontando para o roteador Cisco 7200VXR. A pilha de 3750s usa essa rota padrão para rotear o tráfego destinado para a Internet. Consequentemente, o tráfego para que o 3750s não tem uma entrada de tabela de roteamento é enviada ao 7200VXR para processar.

Dicas práticas

  • Nesse diagrama, a VLAN de gerenciamento está separada da VLAN do usuário ou servidor. Esse VLAN é diferente do VLAN do usuário ou do servidor. Isto é feito para impedir que o Gerenciamento do Switches esteja afetado pela transmissão/tempestades de pacote de informação potenciais no usuário ou no vlan do servidor.

  • O VLAN 1 não é usado para gerenciamento. Todas as portas no padrão dos Catalyst Switches ao VLAN1, e todos os dispositivos conectados às portas NON-configuradas estarão no VLAN1. Isto pode causar problemas potenciais para o Gerenciamento do Switches, como explicado acima.

  • Uma porta de Camada 3 (L3) (roteada) é utilizada para conectar à porta padrão do gateway. Neste diagrama, um Cisco 7200VXR Router poderá ser facilmente substituído por um firewall que se conecte ao roteador do gateway da Internet.

  • Um Routing Protocol não é executado entre a pilha do Catalyst 3750s e o Internet Gateway Router. Em lugar de, uma rota padrão estática é configurada nos 3750. Esta instalação é preferida se há somente uma rota ao Internet. Verifique se configurou as rotas estáticas (de preferência resumidas) no roteador gateway (7200VXR) para as sub-redes que podem ser acessadas pelos Catalyst 3750s. Essa etapa é muito importante, pois os protocolos de roteamento não estão sendo usados.

  • Se você precisar de largura de banda adicional para as portas do uplink, poderá configurar o EtherChannel. Configurar o EtherChannel também fornece redundância de enlace em caso de uma falha de enlace.

Configurações

Este documento utiliza as configurações mostradas abaixo.

Como você pode ver abaixo, embora haja dois Catalyst 3750 Switch empilhados junto, são configurados apenas como se tiveram somente um interruptor. Ambo o Switches tem twenty-four 10/100/1000 das relações e na configuração aparece como os Ethernet 1/0/1 do gigabit até o gigabit 1/0/24 para o primeiro interruptor, e o gigabit 2/0/1 até o gigabit 2/0/24 para segundo. Assim olhando a configuração, parece como se há apenas um interruptor com dois módulos esse que cada um tem 24 portas.

Estendendo este exercício a 3, 4, 5, e assim por diante, Switches em uma pilha pareceriam similares, mas para cada interruptor que é adicionado à pilha, aparece na configuração como se um módulo é adicionado ao interruptor.

Cat3750 (Cisco catalyst 3750G-24T)
C3750G-24T#show run 
Building configuration... 
Current configuration : 2744 bytes 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname C3750G-24T 
! 
! 
ip subnet-zero 
ip routing 
! 
no ip domain-lookup 
! 
spanning-tree mode pvst 
no spanning-tree optimize bpdu transmission 
spanning-tree extend system-id 
! 
! 
! 
interface GigabitEthernet1/0/1 
 description To 2950 
 switchport trunk encapsulation dot1q 
! 

!--- Dot1q trunking (with negotiation) is configured on the L2 switch. 
!--- If DTP is not supported on the far switch, issue the  
!--- switchport mode trunk command  
!--- to force the switch port to trunk mode.


!--- Note: The default trunking mode is dynamic auto. If a trunk link 
!--- is established using default trunking mode, it does not appear
!--- in the configuration even though a trunk has been established on 
!--- the interface. Use the show interfaces trunk command to verify the 
!--- trunk has been established.

! 
interface GigabitEthernet1/0/2 
!

!--- Output suppressed.

! 
interface GigabitEthernet1/0/5 
 description to SERVER_1 

!--- Configure the server port to be in the server VLAN (VLAN 3).
 
 switchport access vlan 3 

!--- Configure the port to be an access port to  
!--- prevent trunk negotiation delays.

 switchport mode access 

!--- Configure port-fast for initial STP delay.  
!--- Refer to Using PortFast and Other Commands to Fix Workstation
!--- Startup Connectivity Delays for more information.
 
spanning-tree portfast 
! 
interface GigabitEthernet1/0/6 
! 

!--- Output suppressed.
 
!  
interface GigabitEthernet1/0/10 
 description To Internet_Router 

!--- Port connected to router is converted into a routed (L3) port.
 
 no switchport 

!--- IP address is configured on this port.
  
 ip address 200.1.1.1 255.255.255.252 
! 
interface GigabitEthernet1/0/21 
! 

!--- Output suppressed.
 
! 
interface GigabitEthernet1/0/22 
! 
interface GigabitEthernet1/0/23 
! 
interface GigabitEthernet1/0/24 
! 
interface GigabitEthernet2/0/1 
 description To 2948G 
 switchport trunk encapsulation dot1q 
! 

!--- Output suppressed.

! 
interface GigabitEthernet2/0/23 
! 
interface GigabitEthernet2/0/24 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 
interface Vlan2 
 description USER_VLAN 

!--- This IP address would be the default gateway for users.
 
 ip address 10.1.2.1 255.255.255.0 
! 
interface Vlan3 
 description SERVER_VLAN 

!--- This IP address would be the default gateway for servers.

 ip address 10.1.3.1 255.255.255.0 
!  
interface Vlan10 
 description MANAGEMENT_VLAN 

!--- This IP address would be the default gateway for other L2 switches
 
 ip address 10.1.10.1 255.255.255.0 
!  
ip classless 

!--- This route statement will allow the 3550 to send Internet traffic to  
!--- its default router (in this case, 7200VXR Fe 0/0 interface).
   

ip route 0.0.0.0 0.0.0.0 200.1.1.2 
ip http server 
!  
!  
line con 0 
 exec-timeout 0 0 
line vty 0 4 
 exec-timeout 0 0 
 login  
line vty 5 15 
 login  
!  
end  

C3750G-24T# 

Nota: Desde que os 3750 são configurados como um server do protocolo VLAN Trunk (VTP), a configuração de VTP não é indicada pelo interruptor. Este é um comportamento padrão. Os comandos abaixo são usados neste interruptor para criar um servidor VTP com os três VLAN definidos pelo utilizador do modo de configuração global.

C3750G-24T(config)#vtp domain cisco
C3750G-24T(config)#vtp mode server
C3750G-24T(config)#vlan 2
C3750G-24T(config-vlan)#name USER_VLAN
C3750G-24T(config-vlan)#exit
C3750G-24T(config)#vlan 3
C3750G-24T(config-vlan)#name SERVER_VLAN
C3750G-24T(config-vlan)#exit
C3750G-24T(config)#vlan 10
C3750G-24T(config-vlan)#name MANAGEMENT
Cat2950 (Switch Cisco Catalyst 2950G-48)
Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/33
 description HOST_1

!--- Host_1 is configured to be the user VLAN (VLAN 2).

 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- IP address used to manage this switch.
 
ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Default gateway is configured so that the switch is reachable
!--- from other VLANs/sub-nets. Gateway points to VLAN 10 interface 
!--- on the 3750.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Nota: Desde que o Catalyst 2950 é configurado como um vtp client, a configuração de VTP não é indicada pelo interruptor. Este é um comportamento padrão. A 2950 adquire a informação de VLAN do servidor VTP (3750). Os comandos abaixo são usados neste interruptor para fazer-lhe um vtp client no VTP domain Cisco do modo de configuração global.

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
Cat2948G (Switch Cisco Catalyst 2948G)
Cat2948G> (enable) show config 

!--- This command shows non-default configurations only.
!--- Use the show config all command to show both 
!--- default and non-default configurations.


...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- VTP domain is configured to be that same as the 3550 (VTP server).

set vtp domain cisco

!--- VTP mode is chosen as client for this switch.

set vtp mode client
!
#ip

!--- The management IP address is configured in VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- The default route is defined so that the switch is reachable.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Host_2 and SERVER_3 ports are configured in respective VLANs.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Trunk is configured to 3750 with dot1q encapsulation.

set trunk 2/49 desirable dot1q 1-1005
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Catalyst 3750

  • interruptor da mostra - O comando show switch diz o que a pilha consiste e qual dos membros de pilha é o mestre.

    C3750G-24T#show switch
                                                   Current
            Switch#  Role      Mac Address     Priority     State 
            --------------------------------------------------------
            *1       Master    000c.30ae.6280     15        Ready               
             2       Slave     000c.30ae.2a80     1         Ready
  • show vtp status

    C3750G-24T#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xA2 0xF4 0x9D 0xE9 0xE9 0x1A 0xE3 0x77 
    Configuration last modified by 200.1.1.1 at 3-1-93 03:15:42
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
    C3750G-24T#
  • show interfaces trunk

    C3750G-24T#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi1/0/1     desirable    802.1q         trunking      1
    Gi2/0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi1/0/1     1-4094
    Gi2/0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi1/0/1     1-3,10
    Gi2/0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi1/0/1     1-3,10
    Gi2/0/1     1-3,10
    
  • show ip route

    C3750G-24T#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, GigabitEthernet1/0/10
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Procedimento de Troubleshooting

Siga as instruções abaixo para fazer troubleshooting com sua configuração.

  1. Se você não pode sibilar dispositivos dentro do mesmo VLAN, você deve verificar a atribuição de VLAN das portas de origem e de destino emitindo o comando show port mod/port para ver se há Cactos e o comando show interface status para o software do ½ do ¿  de Cisco IOSïÂ, certificar-se dos estão no mesmo VLAN. Se não estão no mesmo interruptor, certifique-se de que o entroncamento está configurado corretamente emitindo o comando show trunk para Cactos e o comando show interfaces trunk para o Cisco IOS Software, e de que o VLAN nativo está combinando de cada lado. Verifique se a máscara de sub-rede compara o dispositivo de origem com o de destino.

  2. Se você não conseguir fazer ping para os dispositivos em VLANs diferentes, verifique se consegue fazer para o gateway padrão (consulte a etapa 1 acima). Além disso, certifique-se de que o gateway padrão do dispositivo esteja apontando para o endereço IP correto da interface de VLAN e de que a máscara de sub-rede seja compatível.

  3. Se conseguir alcançar a Internet, certifique-se de que a rota padrão no 3750 aponta para o endereço IP correto e que o endereço da sub-rede corresponde ao roteador do gateway de Internet, emitindo os comandos show ip interface id-da-interface e show ip route. Verifique se o roteador do gateway de Internet tem rotas para a Internet e as redes internas.


Informações Relacionadas


Document ID: 45002