IP : Open Shortest Path First (OSPF)

Projetando redes de discagem do provedor de serviços da larga escala com OSPF

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Para projetar uma rede de discagem é umas tarefas desafiadora para os provedores de serviço da Internet (ISP). Cada ISP usa um método exclusivo para projetar redes de discagem. Contudo, todos os ISP compartilham das mesmas áreas de preocupação quando projetam redes de discagem, como alistadas aqui:

  • Como devem as rotas do pool ser propagadas no núcleo ISP?

  • Que protocolo de roteamento deve ser usado para levar aquelas rotas no núcleo?

  • Devem aquelas rotas do tratamento por imagens ser resumidas antes de enviar no núcleo?

  • Que deve ser levado em consideração quando as associações são distribuídas?

  • O que acontece se os conjuntos são estáticos?

Este documento aborda a maioria das questões acima e lida com as práticas de design relacionadas ao uso de OSPF IGP (recurso Open Shortest Path First – Abrir Primeiro o Caminho Mais Curto, utilizando o Interior Gateway Protocol - Protocolo de Gateway Interno), em um ambiente de discagem ISP. O OSPF é geralmente usado na rede central dos ISPs. Neste documento, nós evitamos introduzir um protocolo separado para levar as rotas do pool do seletor — nós usamos o OSPF para propagar as rotas do pool do seletor no núcleo.

Topologia de rede

A topologia mostrada aqui é uma topologia de rede de discagem típica ISP. ISPs que fornecem serviços de discagem em geral têm uma série de Network Access Servers (NAS) que são tipicamente o AS5300 ou o AS5800. Os server são responsáveis para a disposição do endereço IP de Um ou Mais Servidores Cisco ICM NT a todos os usuários que discam no ISP e querem usar serviços de Internet. Os servidores NAS são conectados então a um dispositivo de agregação, que seja tipicamente um Cisco 6500 Router. O roteador 6500 propaga as rotas dialup para o núcleo, o que permite que os roteadores centrais forneçam serviços de Internet aos usuários finais. Figura 1 mostra uma encenação típica do Point of Presence (POP).

Figura 1 – Um Cenário típico de POP

ispdial.jpg

Conjuntos de dialup ISP

Um ISP trata tipicamente os dois tipos de endereços IP de Um ou Mais Servidores Cisco ICM NT do pool:

  • Estático

  • Central

Conjunto estático

Com associações estáticas, os ISP têm um grupo específico de endereços IP de Um ou Mais Servidores Cisco ICM NT dedicados a cada servidor NAS. Um usuário que encontre um NAS recebe um dos endereços IP de Um ou Mais Servidores Cisco ICM NT dedicados do pool. Por exemplo, se a escala de endereço do conjunto NAS1 estática é 192.168.0.0/22, há aproximadamente 1023 endereços IP de Um ou Mais Servidores Cisco ICM NT. Um usuário que encontre o NAS1 recebe um dos endereços na escala de 192.168.0.0 a 192.168.3.254.

Conjunto central

Com eleições centrais, ISPs têm uma faixa mais ampla de endereços IP distribuídos ao longo de todos os NASs em um único POP. Um usuário que encontre um NAS recebe um endereço IP de Um ou Mais Servidores Cisco ICM NT do pool central, que seja escala muito grande. Por exemplo, se o intervalo de endereço de pool central for 192.168.0.0/18 e forem distribuídos entre os 14 servidores NAS, há aproximadamente 14000 endereços IP.

Projeto do Dialup com um pool estático

Os pools estáticos são mais fáceis de serem administrados a partir de uma perspectiva de roteamento. Quando um pool estático é definido em um NAS, o pool precisa de ser propagado ao núcleo para propósitos de roteamento.

Use estes métodos para propagar rotas do tratamento por imagens de um NAS:

  • Crie uma rota estática ao intervalo de endereço IP do pool, apontando ao null0, com o endereço do conjunto redistribuído no NAS.

  • Atribua o endereço IP de Um ou Mais Servidores Cisco ICM NT do pool em um laço de retorno, no NAS com o tipo de rede Point-to-Point OSPF, incluindo o laço de retorno em uma área do OSPF.

  • Configurar uma rota estática em um roteador de borda de área (ABR) para o endereço IP de Um ou Mais Servidores Cisco ICM NT do pool que aponta para o roteador de limite de sistema autônomo NAS (ASBR) — isto é um método preferido porque a sumarização pode ser executada no ABR.

Crie uma rota estática à escala de endereço do conjunto que aponta ao null0

Se você usa este método, uma rota estática deve ser criada para cada NAS. Essa rota estática deve cobrir o endereço estático exato da escala do pool que aponta ao null0. por exemplo, se o endereço do conjunto estático é 192.168.0.0/22, a configuração da rota estática no NAS é:

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

O endereço do conjunto é redistribuído no OSPF, que propaga esta informação no núcleo no tipo formulário do anúncio de estado de link externo 5 (LSA).

Atribua o endereço do conjunto em um laço de retorno em um NAS com o tipo de rede Point-to-Point OSPF

Se você usar esse método, nenhuma rota estática será necessária. O endereço do pool está atribuído a uma sub-rede em uma interface de loopback. O tipo de rede padrão na interface de loopback é o LAÇO DE RETORNO, que, de acordo com o RFC 2328leavingcisco.com deve ser anunciado no OSPF como /32 — eis porque você deve mudar o tipo de rede no laço de retorno a ponto a ponto. O tipo de rede Point-to-Point força o OSPF para anunciar o endereço de sub-rede do laço de retorno, que é neste caso 192.168.0.0/22. Está aqui a configuração:

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

Esta configuração cria um link do stub do roteador no LSA de roteador e é propagada como uma rota OSPF interna um pouco do que uma rota de OSPF externo.

Configurar a rota estática no ABR para o endereço do conjunto, apontando ao NAS (o ASBR)

Se você usar esse método, não precisará executar nenhuma configuração em um NAS. Toda a configuração ocorre no ABR ou no dispositivo de agregação. Os conjuntos de endereços são estáticos. Consequentemente, a rota estática é gerada facilmente e o roteador pode apontar o salto seguinte para o NAS respectivo, o roteador de limite de sistema autônomo (ASBR). Essas rotas estáticas precisam ser redistribuídas em OSPF através das sub-redes estáticas de redistribuição em OSPF. Por exemplo:

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- and so on for the remaining 12 NAS boxes.

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

Esse é o método preferido porque o resumo pode ser executado no ABR. A sumarização pode igualmente ocorrer nos primeiros dois métodos, mas as configurações de sumarização são necessárias em cada NAS em relação a este método, onde uma configuração de sumarização é necessária somente neste roteador.

Se as associações estáticas estão no bloco contínuo, a sumarização pode ser executada no ABR porque todas as rotas estáticas estão no ABR. Por exemplo:

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Projeto do Dialup com a atribuição do IP dinâmico de um conjunto de endereços central

Para este projeto do tratamento por imagens, supõe que o pool central do endereço IP de Um ou Mais Servidores Cisco ICM NT está configurado no server do Remote Authentication Dial-In User Service (RADIUS). Cada POP tem um serviço de informações de número discado (DNIS) e o servidor RADIUS tem pools de endereços IP separados para cada DNIS. Além, todos os NAS que terminam atendimentos para um DNIS estão na mesma área e falam ao mesmo roteador de agregação.

As associações centrais do endereço IP de Um ou Mais Servidores Cisco ICM NT trazem alguma complexidade no projeto do protocolo de roteamento. Quando você disca um número DNIS para um POP, não há nenhuma garantia sobre o NAS a que você conecta e o endereço IP de Um ou Mais Servidores Cisco ICM NT que lhe será atribuído do pool central do endereço IP de Um ou Mais Servidores Cisco ICM NT para esse DNIS. Em consequência, a sumarização em cada NAS é impossível para os endereços atribuídos fora do pool DNIS. A sub-rede conectada redistribuída é necessária em cada NAS assim que pode propagar toda a informação ao ABR ou ao dispositivo de agregação. Lá é um problema com este projeto — porque o LSAs externo pode somente ser resumido no ASBR e neste projeto, os ASBR são os servidores NAS, como o ABR executarão a sumarização para as rotas externas que vêm dos NAS?

A fim resolver este problema de design, Cisco recomenda que a área a que os servidores NAS pertencem esteja configurada em um Not So Stubby Area (NSSA) (veja figura 2):

Figura 2 – Configuração em um Not So Stubby Area

/image/gif/paws/44944/ispdial2.jpg

Consulte OSPF Not-So-Stubby Area (NSSA) [&NSSA (Área de não muito stub) do OSPF] para obter mais informações sobre as NSSAs do OSPF.

Estão aqui os benefícios se você define uma área como o NSSA:

  • Todas as rotas NAS podem ser resumidas no ABR porque o ABR regenera/converte o LSA tipo 7 em LSA tipo 5.

  • Cada POP não carregará rotas pertencentes a outro POP, porque o NSSA não permite LSAs externos.

A configuração do redistribuído, sub-redes conectadas é necessária em todos os NAS porque as associações do endereço IP de Um ou Mais Servidores Cisco ICM NT através de todos os NAS não são estáticas — todo o NAS pode levar qualquer endereço IP de Um ou Mais Servidores Cisco ICM NT dentro desse intervalo de endereço IP central.

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

Se você executa esta configuração em todos os NAS, uma configuração de sumarização está executada no ABR porque todo o tipo 7s LSA é regenerado no ABR e traduzido no tipo 5s LSA. Porque o ABR gera um tipo completamente novo 5 LSA e o roteador de anúncio ID é o ID do roteador ABR, o ABR atua como o ASBR e permite a sumarização das rotas que eram previamente o tipo 7s LSA (originado pelos NAS).

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Observe que a área entre o ABR e o NAS é o NSSA, que pode ser configurado como segue:

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

Problemas de escalabilidade de área

Se você tem muitos servidores NAS em uma área, e cada NAS redistribui 1000 ou mais rotas na área, a pergunta elevara — quantos servidores NAS deve a cada área compreender? Se todos os servidores NAS estão na mesma área, a área pode tornar-se instável porque a área precisa de levar 1000 ou mais rotas de todos os servidores NAS. Neste exemplo de 14 servidores NAS, pode potencialmente redistribuir 14000 rotas, que é um número enorme. A fim trazer mais escalabilidade à área, Cisco recomenda que você divide a área em diversas subzonas, assegurar-se de que a cada área não afete outras áreas se alguma instabilidade ocorre em uma área (veja figura 3):

Figura 3 – Divida a área

ispdial3.jpg

A fim determinar o número de servidores NAS manter-se em uma área, você deve verificar o número de rotas que cada NAS injeta. Três servidores NAS em uma área podem ser bastante se cada NAS injeta 3000 ou mais rotas. Não põe demasiado poucos servidores NAS na cada área porque, se você tem áreas demais, o ABR pode se transformar sobrecarregado devido à criação das sumarizações na cada área. Contudo, você pode resolver este problema se você faz todas as áreas NSSA totalmente atarracado, que não permite a redistribução de nenhuma rotas sumárias na área. Esta ação reduz a quantidade de informação que cada NAS leva além do que seus próprios 1000 ou mais rotas, e reduz a quantidade de carga o ABR leva com a redistribução dos LSA sumário na cada área. Adicionar a palavra-chave do nenhum-sumário no ABR para executar a configuração, como mostrado aqui:

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

O link entre os servidores ABR e NAS não precisa sair de cada área, portanto, o ABR não precisa criar resumos em cada área dessas rotas conectadas. A maior vantagem do NSSA é que todas as 3000 ou mais rotas em uma área não vazam para outras áreas, desde que o NSSA não carregue LSAs externos. Quando o ABR traduz todos os NSSA LSA tipo 7s e uma área 0, ele não envia nenhum LSA tipo 5s para outras áreas devido às características do NSSA.

Conclusão

Projetar a rede de discagem ISP pode ser umas tarefas desafiadora, mas com algumas considerações pode ser melhorado e fornecido mais solução escalável. A incorporação do NSSA pode ser efetiva no gerenciamento de escalabilidade, pois permite uma redução significativa na quantidade de rotas que cada NAS deve carregar em comparação a uma situação na qual o NSSA não é usado. O resumo também ajuda a reduzir o tamanho da tabela de roteamento, especialmente no caso do Central IP Address Pool, porque o comando redistribute connected configuration é necessário nos servidores NAS. A atribuição de blocos contíguos de endereço IP em cada NAS também ajuda durante o resumo porque cada POP pode ser resumido em um grande bloco e o centro não precisa transportar rotas em excesso.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 44944