Voz : Media Gateway Control Protocol (MGCP)

MGCP com CAS Digital e exemplo da configuração do CallManager da Cisco

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica como usar o Media Gateway Control Protocol (MGCP) entre um gateway do ½ do ¿  de Cisco IOSï (por exemplo, VG200, 2600, 3600, IAD2400) e um Media Convergence Server do CallManager da Cisco 3.x (MCS). Cobre a configuração de uma conexão da sinalização associada a canal (CAS) T1 à rede telefônica pública comutada (PSTN). O local remoto é um gateway de H.323. A conectividade de VoIP aos Telefones IP do Cisco 7960 é mostrada igualmente. Quando esta configuração estiver concluída, será possível fazer chamadas entre todos os telefones usados nesta configuração. Além, será possível distribuir atendimentos sobre o PSTN de alguns dos telefones usados nesta configuração.

Este documento supõe que o leitor é já familiar com como configurar Telefones IP de Cisco no CallManager da Cisco. Igualmente supõe que há pelo menos um telefone IP já ativo no servidor do CallManager da Cisco.

Sintomas:

Esta é uma lista de sintomas possíveis que você pôde encontrar com gateways MGCP e que a verificar para ver se há:

  • De partida ou chamadas externas não estão trabalhando. Assegure-se de que você ligue a interface de origem correta MGCP para media e sinalização.

  • As chamadas externas recebem rapidamente ocupado depois que o dígito último é discado. Assegure-se de que você ligue a interface de origem correta MGCP para media e sinalização.

  • O gateway MGCP não se registra com CallManager da Cisco. Se você usa um Domain Name no gateway MGCP, assegure-se de que combine o Domain Name no CallManager da Cisco sob a configuração de gateway.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Um Cisco IOS gateway que executa um Cisco IOS Software Release que apoie o MGCP com CallManager da Cisco.

  • Este documento é criado usando um Cisco 2611.

Nota: Há outros trens de Cisco IOS Software Release que apoiam o MGCP em roteadores Cisco. O Cisco IOS Software Release 12.1XM é um exemplo.

cuidado Cuidado: A sintaxe para alguns dos comandos mgcp é diferente em outros Cisco IOS Software Release. Refira a documentação para sua configuração para determinar a sintaxe exigida.

Componentes Utilizados

Esta configuração foi testada com CallManager da Cisco 3.3(2) e uma imagem do Cisco IOS Software Release 12.2(13). Os screen shots e a configuração do IOS foram capturados usando o software, o hardware e o outro equipamento aqui.

  • Cisco 2600/1 MFT-T1/1 FastEthernet 10/100 de porta com Cisco IOS Software Release 12.2(13)

  • CallManager da Cisco 3.3(2) que é executado em um MCS7835

  • Aparelho de telefone analógico

  • Telefone IP do Cisco 7960

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Diagrama de Rede

O diagrama da rede abaixo descreve a instalação usada para a configuração e os propósitos de Troubleshooting desta documento.

/image/gif/paws/43802/mgcp_12_2_xn5.gif

Para versões de software recomendadas da compatibilidade entre o CallManager da Cisco e o Cisco IOS gateway, refira a matriz de compatibilidade do CallManager da Ciscoleavingcisco.com .

Nota: O Cisco IOS Software Release 12.2(11)T ou Mais Recente é recomendado com base nos realces do comando ccm-manager. O comando ccm-manager exige o Cisco IOS Software Release 12.1(5)XM ou mais tarde todos os roteadores Cisco (2600, 3600) e o VG200.

Apoio MGCP dos Cisco 2600 e 3600 Router se estão executando o Cisco IOS Software Release 12.1(3)T ou Mais Recente. A liberação e a versão que você exige são baseadas nas características que você precisa de permitir. O servidor do CallManager da Cisco deve executar a versão 3.0(5)a ou mais recente. A configuração de roteador é a mesma para todos os tipos de Roteadores. A configuração do CallManager da Cisco é igualmente a mesma para todos os tipos de Roteadores.

O Cisco IOS Software Release 12.1(5)XM1 e Mais Recente apoia o VG200. A liberação e a versão que você exige são baseadas nas características que você precisa de permitir. Embora o VG200 seja apoiado nas versões anterior do CallManager da Cisco, a versão 3.0(5)a ou mais recente é recomendada.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar o gateway MGCP do Cisco IOS

Este documento guia-o com uma configuração simples do Media Gateway Control Protocol (MGCP). Somente os comandos mínimos são exigidos para construir uma configuração em funcionamento para um roteador com um T1.

Nota: A configuração neste documento trabalha para um Cisco VG200, 2600, ou 3600 Series Router que executa o Software Release 12.1(5)T ou Mais Recente do ½ do ¿  de Cisco IOSïÂ. Para outros gateways de IOS MGCP, verifique a documentação de IOS para ver se há versões suportadas.

Instruções passo a passo

Siga este procedimento para configurar o gateway MGCP do Cisco IOS.

Nota: O restante deste documento refere o Cisco 2600. Os começos do Cisco 2600 com uma configuração padrão (como ela vem enviado).

  1. Configurar um endereço IP de Um ou Mais Servidores Cisco ICM NT na interface Ethernet de Cisco 2600's e permita a relação.

    router(config)#interface fastether 0/0               
    router(config-if)#ip address 172.16.13.35 255.255.255.224 
    router(config-if)#no shut
    
  2. Atribua um nome exclusivo ao Cisco 2600 de modo que o servidor do CallManager da Cisco possa o identificar.

     router(config)#hostname 2611-4
    
    !--- This is how Cisco CallManager keeps track of the MGCP network
    !--- devices it is communicating with. This name  must be unique.
    
    
  3. Configurar o Cisco 2600 para executar o MGCP como um protocolo de sinalização.

    2611-7 (config)#mgcp
    
  4. Configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT (ou o nome de DNS) para o servidor do CallManager da Cisco.

    2611-7 (config)#mgcp call-agent 171.69.85.171
    

    Nota: Para configurar CallManagers redundantes de Cisco no Cluster do CallManager use estes comandos.

    2611-7 (config)#ccm-manager redundant-host [ip address |
      DNS-name] [ip-address | DNS-name]
    2611-7 (config)#ccm-manager switchback {graceful|imm[ediate]
      |sch[edule-time] hh:mmm|uptime[-delay] minutes}
  5. Selecione o tipo de codec e a função de relay do Dual-Tone Multifrequency (DTMF).

    VG200A(config)#mgcp dtmf-relay voip codec all mode out-of-band
    
  6. Para permitir o apoio para o CallManager da Cisco dentro do MGCP, incorpore este comando.

    VG200A(config)#ccm-manager mgcp
    
  7. Ligue o aplicativo de MGCP às portas de voz.

    Nota: Use o comando show voice port determinar o tipo de portas que o Cisco 2611 tem e a ordem são instalados.

    dial-peer voice 999101 pots
     application mgcpapp
     port 1/0:1
    /* T1 digital port */

    Nota: Em alguns Cisco IOS Software Release, o comando application MGCPAPP é diferenciando maiúsculas e minúsculas. A menos que você souber que sua versão não é diferenciando maiúsculas e minúsculas, incorpore sempre este comando ao upper-case. Você pode verificar se sua versão seja diferenciando maiúsculas e minúsculas depois que você configura este comando quando você olha a saída do comando show running-config. O Cisco IOS Software Release 12.1(5)T não é diferenciando maiúsculas e minúsculas.

  8. Assegure que as portas de voz estejam permitidas.

    Nota: Os comandos shutdown and no shutdown afetam ambas as portas em uma placa de interface de voz (VIC). É somente necessário incorporar o comando em uma destas portas.

  9. Permita a conectividade IP.

    Se alguns dos dispositivos voip que o Cisco 2600 se comunica com são ficados situados em subnets/VLANS diferente, permita Roteamento IP e crie um Gateway of Last Resort (rede padrão). Esta etapa explica como executar ambas as tarefas.

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 
    <ip_address_of_gateway>

    Nota: Nos Cisco IOS gateway (que são essencialmente Roteadores com interfaces de voz), você pode configurar um protocolo de roteamento em vez das rotas estáticas. A edição importante é assegurar a conectividade IP entre dispositivos voip.

    Nota: Para o VG200, quando você permite Roteamento IP, o comando ip routing não aparece na configuração porque é normalmente sobre à revelia e os comandos default não aparecem geralmente em uma configuração de roteador Cisco. As imagens IOS Cisco VG200 cancelam o comportamento padrão de ter Roteamento IP permitido pela codificação dura o comando no ip routing na configuração inicial. A configuração inicial é criada quando a imagem é carreg em uma plataforma que tenha sua configuração cancelada pelo comando write erase ou quando é carreg acima de um VG200 que esteja nunca.

    O comando do <ip_address_of_gateway> de 0.0.0.0 0.0.0.0 da rota IP feito com que o VG200 instale um Gateway of Last Resort em sua tabela de roteamento. O comando show ip route confirma este. No exemplo abaixo, o endereço IP de Um ou Mais Servidores Cisco ICM NT do gateway é 172.16.13.35.

    Nota: O comando ip classless é exigido igualmente para que este Gateway of Last Resort seja eficaz. O comando ip classless é permitido à revelia. É um de poucos comandos default do Cisco IOS que aparece em uma configuração quando é permitido e igualmente aparece “não” no formulário quando é desabilitado. Se sua configuração tem a linha nenhum IP sem classe, inscreva o comando ip classless permitir o IP sem classe.

    cuidado Cuidado: Todos os elementos de configuração relacionada do Plano de discagem são controlados pelo CallManager da Cisco e não devem ser configurados no gateway MGCP para valores-limite MGCP-controlados (aqueles com o comando application MGCPAPP em sua indicação do dial-peer). Você não deve configurar qualqueras um funções:

    • Sob dial peer:

      • destination-pattern
      • session-target
    • Sob portas de voz:

      • connection { plar | tie line | trunk }

    O Cisco 2600 está agora pronto para comunicar-se com o servidor do CallManager da Cisco. Manda periodicamente mensagens na tentativa de estabelecer uma conexão. Quando a configuração do servidor do CallManager da Cisco está completa, a conexão deve automaticamente estabelecer-se. Você não deve ter que fazer para promover mudanças no Cisco 2600.

    Nota: É uma boa prática restaurar as portas de gateway depois que você termina a configuração, segundo as indicações deste exemplo.

    router(config)#voice-port 1/0:1
    router(config-voiceport)#shutdown
    router(config-voiceport)#no shutdown
    

Configuração

2611-4#show run

Building configuration...
Current configuration : 1480 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 2611-4
enable secret 5 $1$Mg6h$ewJl8p0VQlKWg0zYasUh91
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
!
isdn switch-type primary-ni
!
ccm-manager mgcp
mta receive maximum-recipients 0
!
controller T1 1/0
 framing sf
 linecode b8zs
 no yellow generation
 no yellow detection
 ds0-group 1 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.35 255.255.255.224
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
no ip http server
!
call rsvp-sync
!
voice-port 1/0:0
!
mgcp
mgcp call-agent 171.69.85.171 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple

!--- This binds the correct MGCP source interface.

mgcp bind control source-interface Ethernet0/0
mgcp bind media source-interface Ethernet0/0
mgcp profile default
!
dial-peer cor custom
dial-peer voice 99 pots
 application mgcpapp
 incoming called-number .
 port 1/0:1
!
dial-peer voice 88 voip
 destination-pattern 1010
 session target ipv4:172.16.13.42
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
 login
!

Verifique o gateway MGCP do Cisco IOS

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostra ccm — Fornece o status de registro do CallManager da Cisco.

  • mostre o valor-limite do mgcp — Fornece o status de porta.

mgcp-t1-cas-ccm-a.gif

2611-4#show mgcp endpoint 

Interface T1 1/0

             ENDPOINT-NAME    V-PORT   SIG-TYPE   ADMIN
         S1/ds1-0/1@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/2@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/3@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/4@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/5@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/6@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/7@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/8@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/9@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/10@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/11@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/12@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/13@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/14@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/15@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/16@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/17@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/18@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/19@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/20@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/21@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/22@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/23@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/24@2611-4    1/0:0    e&m-wnk    up    

Configuração do Cisco CallManager

Esta seção discute em detalhe a configuração do CallManager da Cisco na interação com o gateway MGCP e na relação de CAS ao PSTN.

Tarefa 1: Crie um Gateway MGCP

Nesta tarefa, um gateway MGCP de Cisco 2611-based é criado. O material nesta seção igualmente aplica ao outro Cisco IOS roteadores MGCP. A única diferença é a plataforma que você seleciona em etapa 3.

  1. Selecione o dispositivo > o gateway para usar o wizard de dispositivo para criar um gateway MGCP.

    mgcp-t1-cas-ccm-2.gif

  2. Clique o Add a New Gateway.

    mgcp-t1-cas-ccm-3.gif

  3. Selecione o tipo de gateway (neste caso, é Cisco26xx).

    Nota: No campo do protocolo de dispositivo, observe que a única opção “não está exigida para o MGCP.” Isto significa que nenhum protocolo precisa de ser selecionado se o gateway é um gateway MGCP.

    Nota: Se você está usando um outro roteador do Cisco IOS, selecione o tipo de gateway apropriado (tal como o Cisco 26XX ou o 36xx). Esta é a única etapa que é diferente. As tarefas remanescente aplicam-se ao Cisco VG200 assim como aos Cisco 2600 ou 3600 Series Router.

  4. Clique em Next.

  5. Para o Domain Name MGCP, use o nome de host real que você atribuiu ao Cisco 2600 (neste caso, 2611-4) e especifique o módulo portador que os 2600 instalaram (neste caso, é um NM-HDV).

    Nota: Os módulos portador da Voz para o IAD2400 são diferentes do que aqueles do Cisco VG200, 2600 e 3600.

    Nota: O parâmetro do Domain Name MGCP é diferenciando maiúsculas e minúsculas.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-4.gif

  6. Clique em Insert.

    Nota: Se o Cisco IOS Router/Gateway é configurado com uma palavra do Domain Name do Domain Name IP, o campo do Domain Name MGCP precisa de inclui-la. Por exemplo, 2600.company.com.

    Continue encarregar 2: Configurar as portas MFT-T1.

Tarefa 2: Configurar as portas MFT-T1

Nesta tarefa, as portas MFT-T1 são configuradas. Estas são as portas que conectam ao PSTN. Neste procedimento, você determina o tipo de porta e atribui o número de diretório assistente (DN).

  1. Identifique os módulos da placa de interface de voz (VIC) instalados nas posições 0 e 1. do slot1 neste caso que estão em 1 T1 da porta.

  2. Atualização do clique para ativar as mudanças.

    As portas T1 aparecem no direita inferior da tela seguinte. Estes são referidos igualmente como identificadores de ponto finais.

    mgcp-t1-cas-ccm-5.gif

  3. Selecione a porta T1 etiquetada 1/0/0.

  4. Selecione o tipo correto de porta T1.

    mgcp-t1-cas-ccm-6.gif

  5. Configurar seus parâmetros nesta tela de configuração do membro MGCP como necessário e clique a inserção.

    Nota: Procure o nome S1/DS1-0@2611-4 na imagem acima para determinar o dispositivo que MGCP você está configurando (2611-4) assim como o entalhe 1 Port0 da porta S1/DS1-0=.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-7.gif

  6. Clique a opção e configurar cada porta como segue:

    Clique sobre Add uma porta nova e configurar estes ajustes.

    CallManager da Cisco 3.3(2):

    • Tipo de porta: Somente o E&M é apoiado no CallManager da Cisco 3.3(2).

    • Número de porta de começo: A primeira porta configurada.

    • Terminando o número de porta: A última porta configurada.

    • Sentido da porta: Ambas as maneiras para dois atendimentos. De entrada para chamadas recebidas. De partida para chamadas feitas.

    • Sinalizando Type*: Somente dois tipos de sinalização são apoiados com CallManager da Cisco 3.3(2). São discagem de retardo e permissão de início.

    mgcp-t1-cas-ccm-8.gif

  7. Clique a inserção e configurar os parâmetros específicos da porta segundo as indicações dos passos restantes.

  8. Clique a porta, configurar os parâmetros, e clique a atualização.

    mgcp-t1-cas-ccm-9.gif

    Continue encarregar 4: Teste os telefones para a conectividade local.

Tarefa 4: Teste os telefones quanto à conectividade local

Se você tem terminado já as tarefas configurar o Cisco 2600, tem enviado mensagens de MGCP ao servidor do CallManager da Cisco que tenta estabelecer uma relação de MGCP. Se as tarefas 1 a 4 são um sucesso, o servidor do CallManager da Cisco e o Cisco 2600 estão agora prontos para distribuir chamadas local entre todos os Telefones IP registrados ao servidor do CallManager da Cisco e PSTN.

Você deve igualmente poder discar os Telefones IP que é configurado assim como para chamar os telefones analógicos dos Telefones IP. Tente terminar atendimentos a e de todos os telefones em sua configuração.

Nota: Se alguns de seus telefones não podem colocar ou receber atendimentos, olhar em sua separação, Calling Search Space (CSS), pool de dispositivos, e configurações do local. Você pode ter uma configuração que não permita que todos os telefones locais se chamem. Se este é o caso, temporariamente coloque um telefone IP e um telefone analógico (porta FXS) na mesmos separação, pool de dispositivos, lugar, e CSS e tente o teste outra vez.

Nota: Se você encontra edições com o registro ou a operação de gateway do Cisco IOS gateway, tente restaurar as portas de voz do gateway, segundo as indicações deste exemplo.

router(config)#voice-port 1/0:1
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

Nota: Se você continua a ter problemas, referir o monitor, a restauração, e os gateways MGCP da supressão para o CallManager da Cisco e a verificar o gateway MGCP para tarefas do Troubleshooting adicional.

Continue encarregar 5: Configurar uma rota padrão.

Tarefa 5: Configurar um padrão de rota

Nesta tarefa uma rota padrão simples é criada para permitir os telefones de fazer atendimentos através do PSTN. O teste padrão padrão do North American Numbering Plan (NANP) de "9.@" é usado.

  1. Selecione o plano de rota > padrão de rota do menu principal do CallManager da Cisco.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-10.gif

    Além do que os padrões, estes parâmetros foram configurados:

    Nome do campo Valor Significado
    Rota padrão 9.@ Rota padrão padrão para Planos de discagem usando o NANP. Esta rota padrão é configurada para fornecer o tom de discagem (ou à revelia).
    Lista do gateway router S1/DS1-0@2611-4 T1 1/0:1 em 2611-4
    Rejeite dígitos PreDot Gota tudo até e incluindo “.” na rota padrão.

    Nota: A rota padrão "9.@" é usada frequentemente para as instalações fora do Estados Unidos que não pode usar o NANP.

    /image/gif/paws/43802/mgcp-t1-cas-ccm-11.gif

  2. Clique a inserção e continue encarregar 6: Chamadas de teste sobre o PSTN.

Tarefa 6: Teste chamadas por PSTN

Você deve agora poder distribuir atendimentos sobre o PSTN de todo o telefone no sistema quando você disca 9, e disca então o número chamado depois que o tom de discagem volta. Nos traços abaixo, um atendimento é feito de um telefone IP e captura os traços do pacote de MGCP.

Nota: Se você tem quaisquer problemas, refira o monitor, a restauração, e os gateways MGCP da supressão para o CallManager da Cisco e verifique e pesquise defeitos o gateway MGCP do Cisco IOS para obter mais informações sobre das tarefas de Troubleshooting. Para todo o CAS que pesquisa defeitos, veja por favor para configurar e pesquisar defeitos a sinalização do T1 CAS.

Mar  9 06:34:21.523: NTFY 27862 *@2611-4 MGCP 0.1
X: 0
O: 
<---
*Mar  9 06:34:21.567: MGCP Packet received from 171.69.85.171-
200 27862 
*Mar  9 06:34:23.110: MGCP Packet received from 171.69.85.171-

!--- Keepalives sent to and received from the Cisco CallManager.

CRCX 122 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
X: 0
L: p:20, a:PCMU, s:off
M: recvonly
R: DT/oc
S: DT/sup(addr(1,0,1,0))
Q: process,loop

!--- CRCX: CreateConnection 
!--- C: CallId
!--- L: LocalCXOptions   p: packetize period(ms)   a: Compression Algo.
!--- M: Mode
!--- X: RequestIdentifier for the notification request
!--- R: RequestEvents
!--- I: ConnectionId

*Mar  9 06:34:23.146: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:23.146: 200 122 OK
I: 6
v=0
 c=IN IP4 172.16.13.35
m=audio 18546 RTP/AVP 0 100
 a=rtpmap:100 X-NSE/8000
 a=fmtp:100 192-194,200-202
 a=X-sqn:0
 a=X-cap: 1 audio RTP/AVP 100
 a=X-cpar: a=rtpmap:100 X-NSE/8000
 a=X-cpar: a=fmtp:100 192-194,200-202
 a=X-cap: 2 image udptl t38
<---
*Mar  9 06:34:24.885: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:24.885: NTFY 27863 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/oc(dt/sup)
<---
*Mar  9 06:34:24.925: MGCP Packet received from 171.69.85.171-
200 27863 
*Mar  9 06:34:26.271: MGCP Packet received from 171.69.85.171-
MDCX 123 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
I: 6
X: 0
L: p:20, a:PCMU, s:off
M: sendrecv
S: 
v=0
o=- 6 0 IN EPN S1/DS1-0/1@2611-4
s=Cisco SDP 0
t=0 0
c=IN IP4 172.16.240.41
m=audio 32112 RTP/AVP 0

!---  MDCX= ModifyConnection
!--- C: CallId
!--- I: ConnectionId 
!--- M: Mode

*Mar  9 06:34:26.287: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:26.287: 200 123 OK
<---
*Mar  9 06:34:34.340: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:34.340: NTFY 27864 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/ans
<---
*Mar  9 06:34:34.368: MGCP Packet received from 171.69.85.171-
200 27864 
*Mar  9 06:34:34.597: MGCP Packet received from 171.69.85.171-
RQNT 124 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S: 
Q: process,loop
*Mar  9 06:34:34.609: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:34.609: 200 124 OK
<---
*Mar  9 06:34:42.954: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:42.954: NTFY 27865 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/sus
<---
*Mar  9 06:34:42.958: MGCP Packet received from 171.69.85.171-
200 27865 
*Mar  9 06:34:42.962: MGCP Packet received from 171.69.85.171-
DLCX 125 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
I: 6
X: 0
R: DT/rlc
S: DT/rel
Q: process,loop
*Mar  9 06:34:42.970: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:42.974: 250 125 OK
P: PS=833, OS=133280, PR=875, OR=140000, PL=0, JI=24, LA=0
<---
*Mar  9 06:34:43.395: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->

Verificar

Veja a verificação a seção do gateway MGCP do Cisco IOS.

Troubleshooting

Consulte para verificar e pesquisar defeitos o gateway MGCP do Cisco IOS para a informação adicional de Troubleshooting.


Informações Relacionadas


Document ID: 43802